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5
Relacionar Datos

Ejercicio 5-1 Concepto: Manipulando Arrays

Objetivo
Manipular arrays con varias funciones de LabVIEW.

Descripción
Recibe un VI y debe mejorarlo para varios fines. Para cada parte de este 
ejercicio, empiece con el Array Investigation.vi situado en el 
directorio <Exercises>\LabVIEW Core 1\Manipulating Arrays. 
El panel frontal de este VI aparece en la figura 5-1. 

Figura 5-1.  Panel frontal del VI Array Investigation

La figura 5-2 muestra el diagrama de bloques de este VI.

Figura 5-2.  Diagrama de bloques del VI Array Investigation

Este ejercicio se divide en tres partes. Recibirá primero el escenario de cada 
parte. Consulte el final de este ejercicio para ver instrucciones detalladas de 
implementación de cada parte.
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Parte 1: Iterar, modificar y graficar el array
Modifique el VI Array Investigation para que, después de crear el array, éste 
se indexe dentro de bucles For donde multiplique cada elemento del array 
por 100 y convierta cada elemento en el número entero más cercano. 
Grafique el array 2D resultante en un gráfico tipo “intensity graph”.

Parte 2: Iterar, modificar y graficar el array
Modifique el VI Array Investigation o la solución de la parte 1 para 
conseguir los mismos objetivos sin usar los bucles For anidados.

Parte 3: Crear Arrays Subset
Modifique el VI Array Investigation para que el VI cree un nuevo array que 
albergue el contenido de la tercera fila, y otro array nuevo que albergue el 
contenido de la segunda columna.

Parte 1: Implementación
Modifique el VI Array Investigation para que, después de crear el array, éste 
se indexe dentro de bucles For donde multiplique cada elemento del array 
por 100 y convierta cada elemento en el número entero más cercano. 
Grafique el array 2D resultante en un gráfico tipo “intensity graph”.

1. Abra el Array Investigation.vi situado en el directorio 
<Exercises>\LabVIEW Core 1\Manipulating Arrays.

2. Guarde el VI como Array Investigation Part 1.vi.

3. Añada un gráfico tipo “intensity graph” al panel frontal del VI y 
autoescale los ejes X e Y, como en la figura 5-3. Para comprobar que la 
autoescala está habilitada para los ejes, haga clic con el botón derecho 
en el gráfico tipo “intensity graph” y seleccione X Scale»AutoScale X 
y Y Scale»AutoScale Y y asegúrese de que están marcados estos 
elementos.
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Figura 5-3.  Panel frontal del VI Array Investigation Part 1

4. Abra el diagrama de bloques del VI.

Siga las instrucciones inferiores para crear un diagrama de bloques similar 
al de la figura 5-4.

Figura 5-4.  Diagrama de bloques del VI Array Investigation Part 1

5. Itere el array.

❑ Añada un bucle For a la derecha del código existente. 

❑ Añada un segundo bucle For en el primer bucle For. M
ue
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❑ Cablee el terminal del indicador de Array con el borde del bucle For 
interior. Esto crea un túnel de entrada autoindexado en ambos bucles 
For. 

6. Multiplique cada elemento del array por 100. 

❑ Añada una función Multiply al bucle For interior. 

❑ Cablee el túnel de entrada indexado a la entrada x de la función 
Multiply. 

❑ Haga clic derecho en la entrada y y seleccione Create»Constant en 
el menú contextual. 

❑ Escriba 100 en la constante. 

7. Redondee cada elemento al número entero más cercano. 

❑ Add a Round To Nearest function to the right of the Multiply 
function.

❑ Cablee la salida de la función Multiply a la entrada de la función 
Round To Nearest.

8. Cree un array 2D en la salida de los bucles For para volver a crear el 
array modificado. 

❑ Cablee la salida de la función Round To Nearest con el bucle For 
externo. Esto crea un túnel de salida autoindexado en ambos bucles 
For. 

9. Cablee el array de salida con el indicador Intensity Graph. 

10. Cambie al panel frontal.

11. Guarde el VI.

12. Escriba valores para Rows y Columns.

13. Ejecute el VI.

Parte 2: Implementación
Modifique la parte 1 para conseguir los mismos objetivos sin usar los bucles 
For anidados.

1. Abra el Array Investigation Part 1.vi si aún no está abierto. 

2. Guarde el VI como Array Investigation Part 2.vi.
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3. Abra el diagrama de bloques.

4. Haga clic con el botón derecho en el borde del bucle For interior, que 
contiene la función Multiply y la función Round to Nearest, y seleccione 
Remove For Loop. 

5. Haga clic con el botón derecho en el borde del bucle For restante y 
seleccione Remove For Loop del menú contextual. Su diagrama de 
bloques debe parecerse al de la figura 5-5.

Figura 5-5.  Diagrama de bloques del VI Array Investigation Part 2

6. Guarde el VI. 

7. Cambie al panel frontal.

8. Escriba valores para Rows y Columns.

9. Ejecute el VI.

Observe que el VI se comporta del mismo modo que la solución de la 
parte 1. Esto se debe a que las funciones matemáticas son polimórficas. Por 
ejemplo, como la entrada x de la función Multiply es un array bidimensional 
y la entrada y es un escalar, la función Multiply multiplica cada elemento 
del array por el escalar, y produce un array de la misma dimensión que la 
entrada x.

Parte 3: Implementación
Modifique el VI Array Investigation para que el VI cree un nuevo array que 
albergue el contenido de la tercera fila, y otro array nuevo que albergue el 
contenido de la segunda columna.

1. Abra el Array Investigation.vi situado en el directorio 
<Exercises>\LabVIEW Core 1\Manipulating Arrays.

2. Guarde el VI como Array Investigation Part 3.vi. 

3. Abra el diagrama de bloques del VI.
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En los siguientes pasos creará un diagrama de bloques similar al de la 
figura 5-6.

Figura 5-6.  Diagrama de bloques del VI Array Investigation Part 3

4. Recupere la tercera fila de datos de Array utilizando la función Index 
Array.

❑ Añada una función Index Array al diagrama de bloques.

❑ Cablee Array a la entrada array de la función Index Array.

Consejo La función Index Array acepta un array n-dimensional. Tras cablear el array de 
entrada a la función Index Array, los nombres del terminal de entrada y salida cambian 
para coincidir con la dimensión del array cableado. Por lo tanto, cablee el array de 
entrada a la función Index Array antes de cablear cualquier otro terminal.

❑ Haga clic con el botón derecho en la entrada index(row) de la 
función Index Array y seleccione Create»Constant en el menú 
contextual.

❑ Escriba 2 en la constante para recuperar la tercera fila. Recuerde que 
el índice empieza por cero. 

❑ Haga clic con el botón derecho en la entrada subarray de la función 
Index Array y seleccione Create»Indicator en el menú contextual.

❑ Llame al indicador Third Row.

5. Recupere la segunda columna de datos de Array utilizando la función 
Index Array. 

❑ Añada otra función Index Array al diagrama de bloques. 

❑ Cablee Array a la entrada array de la función Index Array. 
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❑ Haga clic con el botón derecho en la entrada disabled index(col) de 
la función Index Array y seleccione Create»Constant. 

❑ Escriba 1 en la constante para recuperar la segunda columna dado 
que el índice empieza por cero. 

❑ Haga clic con el botón derecho en la entrada subarray de la función 
Index Array y seleccione Create»Indicator.

❑ Llame al indicador Second Column.

6. Guarde el VI. 

7. Cambie al panel frontal.

8. Escriba valores para Rows y Columns.

9. Ejecute el VI. 

10. Cierre el VI.

Fin del ejercicio 5-1

M
ue

str
a



Lección 5 Relacionar Datos

Manual de Ejercicios LabVIEW Core 1 5-8 ni.com

Ejercicio 5-2 Concepto: Clusters

Objetivo
Cree clusters en la ventana del panel frontal, reordene clusters y use las 
funciones de clusters para ensamblar y desensamblar clusters.

Descripción
En este ejercicio, siga las instrucciones para experimentar con clusters, 
orden del cluster y funciones del cluster. El VI que cree no tiene aplicaciones 
prácticas, pero resulta útil para entender los conceptos del cluster.

1. Abra un VI en blanco.

2. Guarde el VI como Cluster Experiment.vi en el directorio 
<Exercises>\LabVIEW Core 1\Clusters.

Siga las instrucciones inferiores para crear un panel frontal similar al de la 
figura 5-7.

Figura 5-7.  Panel frontal del VI Cluster Experiment

3. Añada un botón de parada (Stop) a la ventana del panel frontal. 

4. Añada un numeric indicator a la ventana del panel frontal. 

5. Añada un LED redondo al panel frontal. 

6. Llame al LED Boolean 2.
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7. Cree un cluster llamado Cluster, que contenga un valor numérico, dos 
interruptores y un control deslizante.

❑ Añada una estructura cluster al panel frontal.

❑ Añada un control numérico al cluster.

❑ Añada dos interruptores verticales al cluster.

❑ Llame a los interruptores Boolean Boolean 1 y Boolean 2.

❑ Añada una barra horizontal de deslizamiento de tipo rellenado al 
cluster.

8. Cree Modified Cluster, que alberga los mismos contenidos que 
Cluster, pero indicadores en lugar de controles.

❑ Cree una copia de Cluster. 

❑ Llame a la copia Modified Cluster.

❑ Haga clic con el botón derecho en la estructura Modified Cluster y 
seleccione Change to Indicator en el menú contextual.

9. Cree Small Cluster, que contiene un indicador booleano y otro 
numérico.

❑ Cree una copia de Modified Cluster. 

❑ Llame a la copia Small Cluster. 

❑ Elimine el segundo interruptor basculante. 

❑ Elimine el indicador del selector de relleno horizontal. 

❑ Haga clic con el botón derecho en Small Cluster y seleccione 
Autosizing»Size to Fit.

❑ Vuelva a etiquetar el indicador numérico como Slide value. 

❑ Cambie el tamaño del cluster si es necesario.

10. Compruebe el orden de los elementos de Cluster, Modified Cluster y 
Small Cluster. 

❑ Haga clic con el botón derecho en el límite de Cluster y seleccione 
Reorder Controls in Cluster en el menú contextual. 

❑ Confirme el orden de clusters que aparece en la figura 5-8.
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❑ Haga clic en el botón Confirm en la barra de herramientas para 
configurar el orden del cluster y salir del modo de edición del orden 
del cluster.

❑ Haga clic con el botón derecho en el límite de Modified Cluster y 
seleccione Reorder Controls in Cluster en el menú contextual. 

❑ Confirme el orden de los clusters que aparece en la figura 5-8. 
Modified Cluster debe tener el mismo orden de cluster que Cluster.

❑ Haga clic en el botón Confirm en la barra de herramientas para 
configurar el orden del cluster y salir del modo de edición del orden 
del cluster.

❑ Haga clic con el botón derecho en el límite de Small Cluster y 
seleccione Reorder Controls in Cluster en el menú contextual. 

❑ Haga clic en el botón Confirm en la barra de herramientas para 
configurar el orden del cluster y salir del modo de edición del orden 
del cluster.

❑ Confirme el orden de los clusters que aparece en la figura 5-8.

Figura 5-8.  Orden de clustersM
ue
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En los siguientes pasos, cree el diagrama de bloques de la figura 5-9.

Figura 5-9.  Diagrama de bloques del VI Cluster Experiment

11. Añada un bucle While desde la paleta Structures al diagrama de 
bloques. 

12. Desensamble Cluster.

❑ Añada una función Unbundle al diagrama de bloques. 

❑ Cablee Cluster a la entrada de la función Unbundle para cambiar 
automáticamente el tamaño de la función.

13. Ensamble Small Cluster.

❑ Añada una función Bundle al diagrama de bloques. 

❑ Cablee la función Bundle como en la figura 5-9.

14. Ensamble Modified Cluster.

❑ Añada una función Unbundle by Name al diagrama de bloques. 

❑ Cablee el Cluster a la función Unbundle by Name.

❑ Cambie el tamaño de la función Unbundle by Name para tener dos 
terminales de salida. 

❑ Seleccione Numeric en el primer nodo y Boolean 1 en el segundo 
nodo. Si el nombre de la etiqueta no es correcto, use la herramienta 
de operaciones para seleccionar el elemento correcto.

❑ Añada una función Increment al diagrama de bloques. 
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❑ Cablee la salida Numeric de la función Unbundle By Name en la 
entrada de la función Increment. Esta función suma 1 al valor de 
Numeric.

❑ Añada una función Not al diagrama de bloques. 

❑ Cablee la salida Boolean 1 de la función Unbundle By Name en la 
entrada x de la función Not. Esta función devuelve la lógica opuesta 
del valor de Boolean.

❑ Añada una función Bundle by Name al diagrama de bloques.

❑ Cablee Cluster a la entrada input cluster.

❑ Cambie el tamaño de esta función para tener dos terminales de 
entrada. 

❑ Seleccione Numeric en el primer nodo y Boolean 1 en el segundo 
nodo. Si el nombre de la etiqueta no es correcto, use la herramienta 
de operaciones para seleccionar el elemento correcto.

❑ Cablee la salida de la función Increment a Numeric. 

❑ Cablee la salida de la función Not a Boolean 1. 

❑ Cablee la salida de la función Bundle By Name al indicador 
Modified Cluster.

15. Añada una función de espera para facilitar al procesador el tiempo para 
completar otras tareas.

❑ Añada una función Wait Until Next ms Multiple al diagrama de 
bloques.

❑ Haga clic con el botón derecho en el terminal millisecond multiple 
de la función Wait Until Next ms Multiple.

❑ Seleccione Create»Constant en el menú contextual.

❑ Escriba 100 en la constante.

16. Complete el diagrama de bloques y cablee los objetos como en la 
figura 5-9.

17. Guarde el VI.

18. Abra el panel frontal.

19. Ejecute el VI.
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20. Escriba distintos valores en Cluster y observe cómo los valores 
introducidos en Cluster afectan a los indicadores Modified Cluster y 
Small Cluster. ¿Es el comportamiento que esperaba?

21. Haga clic en el botón Stop cuando esté listo.

22. Cambie el orden de clusters de Modified Cluster. Ejecute el VI. ¿Cómo 
afectó el cambio de orden al comportamiento?

23. Cierre el VI. No guarde los cambios.

Fin del ejercicio 5-2

M
ue

str
a



Lección 5 Relacionar Datos

Manual de Ejercicios LabVIEW Core 1 5-14 ni.com

Ejercicio 5-3 Concepto: Definiciones tipo

Objetivo
Explore las diferencias entre una definición tipo y una definición tipo 
estricta.

Descripción
1. Abra un VI en blanco. 

2. Cree un control personalizado con un estado de definición tipo estricta.

❑ Añada un control numérico a la ventana del panel frontal y llámelo 
Strict Type Def Numeric.

❑ Haga clic con el botón derecho en el control y seleccione 
Advanced»Customize en el menú contextual para abrir el Editor de 
Controles. 

❑ Seleccione Strict Type Def. en el menú desplegable Control Type. 

❑ Haga clic con el botón derecho en el control numérico y seleccione 
Representation»Unsigned Long en el menú contextual. 

❑ Seleccione File»Save. 

❑ Llame al control Strict Type Def Numeric.ctl en el 
directorio <Exercises>\LabVIEW Core 1\Type Definition. 

❑ Cierre la ventana Control Editor. 

❑ Haga clic en Yes cuando se le pregunte si desea sustituir el control 
original.

3. Explore el valor numérico personalizado definido estrictamente. 

❑ Haga clic con el botón derecho en el control Strict Type Def 
Numeric y seleccione Properties en el menú contextual. Observe 
que las únicas opciones disponibles son Appearance, 
Documentation y Key Navigation. La definición tipo estricta 
define el resto de propiedades. 

❑ Haga clic en Cancel para salir del cuadro de diálogo Properties. 

❑ Haga clic derecho en el control Strict Type Def Numeric de nuevo. 
Observe que la representación no está disponible en el menú 
contextual. Observe también que puede abrir la definición tipo o 
desconectarse de la definición tipo. 
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4. Modifique el control strict type def.

❑ Haga clic con el botón derecho en el control Strict Type Def 
Numeric y seleccione Open Type Def. en el menú contextual.

❑ Haga clic con el botón derecho en el control numérico y seleccione 
Representation»DBL en el menú contextual en la ventana Control 
Editor.

❑ Seleccione File»Save.

❑ Cierre la ventana Control Editor.

❑ Seleccione Help»Show Context Help para abrir la ventana Context 
Help.

❑ Mueva el ratón sobre el control del VI y observe que cambió de un 
tipo de datos numérico U32 a un tipo de datos numérico DBL.

❑ Haga clic con el botón derecho en el control Strict Type Def 
Numeric y seleccione Open Type Def. en el menú contextual.

❑ Cambie el aspecto físico del control numérico redimensionándolo en 
la ventana Control Editor.

❑ Seleccione File»Save.

❑ Cierre la ventana Control Editor.

❑ Observe que si modifica el control strict type def, actualizará el 
tamaño del control numérico del panel frontal del VI.

5. Cree un control personalizado con un estado de definición tipo.

❑ Añada otro control numérico a la ventana del panel frontal y llámelo 
Type Def Numeric. 

❑ Haga clic con el botón derecho en el control y seleccione 
Advanced»Customize en el menú contextual para abrir el Editor de 
Controles. 

❑ Seleccione Type Def. en el menú desplegable Control Type. 

❑ Haga clic con el botón derecho en el control numérico y seleccione 
Representation»Unsigned Long en el menú contextual. 

❑ Seleccione File»Save. 
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❑ Llame al control Type Def Numeric.ctl en el directorio 
<Exercises>\LabVIEW Core 1\Type Definition. 

❑ Cierre la ventana Control Editor. 

❑ Haga clic en Yes cuando se le pregunte si desea sustituir el control 
original.

6. Explore el valor numérico personalizado con definición de tipo. 

❑ Haga clic con el botón derecho en el control Strict Type Def 
Numeric y seleccione Properties en el menú contextual. Observe 
que existen más elementos disponibles, como Data Entry y Display 
Format. 

❑ Haga clic en Cancel para salir del cuadro de diálogo Properties. 

❑ Haga clic derecho en el control Type Def Numeric de nuevo. 
Observe que Representation está atenuado en el menú contextual 
porque la definición tipo define el tipo de dato. Observe también que 
puede elegir actualizar automáticamente con la definición tipo. 

7. Modifique el control type def.

❑ Haga clic con el botón derecho en el control Type Def Numeric y 
seleccione Open Type Def. en el menú contextual.

❑ Haga clic con el botón derecho en el control Type Def Numeric y 
seleccione Representation»DBL en el menú contextual en la 
ventana Control Editor.

❑ Seleccione File»Save.

❑ Cierre la ventana Control Editor.

❑ Seleccione Help»Show Context Help para abrir la ventana Context 
Help.

❑ Mueva el ratón sobre el control Type Def Numeric del VI y observe 
que cambió de un tipo de datos numérico U32 a un tipo de datos 
numérico DBL.

❑ Haga clic con el botón derecho en el control Type Def Numeric y 
seleccione Open Type Def. en el menú contextual.

❑ Cambie el aspecto físico del control numérico redimensionándolo en 
la ventana Control Editor.
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❑ Seleccione File»Save.

❑ Cierre la ventana Control Editor.

❑ Observe que al redimensionar el control type def en el Editor de 
Controles, no actualizó el tamaño del control Type Def Numeric del 
panel frontal del VI. Las copias de un control type def sólo se 
actualizarán cuando cambie el tipo de datos de la definición del tipo.

8. Añada otra copia del control personalizado a la ventana del panel frontal 
y desconéctela de la definición tipo. 

❑ Elija Select a Control en la Paleta de Controles. 

❑ Seleccione Type Def Numeric.ctl en el directorio 
<Exercises>\LabVIEW Core 1\Type Definition. 

❑ Haga clic en OK.

❑ Haga clic con el botón derecho en el nuevo control y seleccione 
Disconnect from Type Def. en el menú contextual.

❑ Haga clic en OK.

❑ Haga clic con el botón derecho en el control de nuevo y observe que 
ahora puede cambiar la Representation porque el valor numérico ya 
no está vinculado a la definición tipo.

9. Cierre el VI tras terminar. No necesita guardar el VI.

Fin del ejercicio 5-3
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Notas
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