
Getting Started with the 
LabVIEW  PDA Module for 
Windows Mobile
Version 8.5

The LabVIEW PDA Module extends the LabVIEW graphical development 
environment to PDA devices so you can create PDA applications that run 
on Pocket PC and Windows Mobile devices. Use the PDA Module to build 
applications that run in the smaller memory space common to PDA devices. 
You can create portable solutions for a wide spectrum of applications, such 
as field test systems, remote control and monitoring systems, and portable 
data acquisition systems.

This manual contains new features for version 8.5, system requirements, 
installation instructions, and a tutorial that shows you how to create a 
LabVIEW project and build, run, deploy, and debug a PDA application.
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What’s New in the LabVIEW 8.5 PDA Module
The LabVIEW 8.5 PDA Module features and changes include support for 
front panel data binding as well as expanded support for front panel 
controls and indicators.

Refer to the LabVIEW Upgrade Notes, available by selecting Start»
All Programs»National Instruments»LabVIEW 8.5»Manuals and 
opening LV_Upgrade_Notes.pdf for more information about new 
features in LabVIEW 8.5.

Refer to the PDA Module book on the Contents tab of the LabVIEW Help, 
available by selecting Help»Search the LabVIEW Help in LabVIEW, for 
more information specific to the PDA Module and PDA applications.

Refer to the PDA Module Readme file, available by selecting Start»
All Programs»National Instruments»LabVIEW 8.5»Readme and 
opening readme_PDA.html for known issues with version 8.5 of the PDA 
Module.

General
The LabVIEW 8.5 PDA Module includes the following enhancements and 
new features:

• Reading and writing front panel data using data binding—You
can use data binding to read or write front panel data for 
network-published shared variables. You can use data binding with 
any front panel control or indicator that the PDA Module supports. 

Note When you use front panel data binding in a PDA subVI, LabVIEW closes data 
binding connections when the subVI finishes execution.
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(PDA Emulators) The PDA Module does not support reading or writing 
shared variable values on x86 emulators. Prior to reading or writing 
shared variable values on ARM emulators, cradle the emulator and 
configure the IP address for the emulator. You must install support for 
shared variables after you cradle the emulator. Refer to the Shared 
Variable Support section for more information about installing shared 
variable support. Refer to the National Instruments Developer Zone at 
ni.com/info and enter the info code pdasvem for the most recent 
information about using shared variables with PDA emulators.

For more information about data binding, refer to the Reading and 
Writing Front Panel Data Using Data Binding topic in the LabVIEW 
Help. Select Help»Search the LabVIEW Help in LabVIEW to 
display the LabVIEW Help. For more information about using shared 
variables in PDA VIs, refer to the Using Shared Variables in PDA and 
Touch Panel VIs topic in the LabVIEW Help. Refer to the Shared 
Variable Intro - Pocket PC.lvproj in the labview\
examples\PDA\shared variable directory for an example of 
using front panel data binding.

• LabVIEW Aliases File Editor—In previous versions of the PDA 
Module, you changed the IP address of the shared variable host in the 
aliases file and manually downloaded the aliases file to the same 
directory as the corresponding application on the PDA target. You now 
can use the LabVIEW Aliases File Editor to edit the aliases file on the 
target. 

Tap Start»Programs»LabVIEW Aliases File Editor to launch the 
LabVIEW Aliases File Editor on the target. Tap the browse button to 
browse to and open an aliases file.

• Large application optimizations—For large applications with 
numerous front panel controls and indicators, the time it takes to build 
applications is significantly less than in previous versions. The PDA 
Module also generates significantly less C code for large applications.

• Call by Reference Node supports local references—You now can 
use a local reference with the Call by Reference Node. Select the 
Source Files category of the PDA Build Specification Properties 
dialog box to include any VIs that the Call by Reference Node calls 
locally in the project.

• Expression folding—Expression folding optimizes performance by 
collapsing groups of nodes into single expressions in the generated 
code that are easily recognized by C compilers. Place a checkmark in 
the Expression folding checkbox on the Application Information 
page of the PDA Build Specification Properties dialog box to
enable expression folding. You cannot debug a PDA VI while using 
expression folding because expression folding eliminates some wires 
on the block diagram.

http://www.ni.com/info
http://www.ni.com/info


Getting Started with the LabVIEW PDA Module 4 ni.com

• Expression Node supports clusters and arrays—You now can use 
arrays or clusters as inputs to an Expression Node.

• New VISA examples—The PDA Module includes new VISA 
examples, which are located in the labview\examples\PDA\
comm\VISA directory.

Front Panel Controls and Indicators
• Blinking Boolean controls and indicators—The PDA Module 

supports blinking for all Boolean controls and indicators except system 
controls. Use a Property Node with the Blinking property to enable 
blinking.

• Boolean mechanical action—The PDA Module now supports the six 
types of mechanical action for Boolean controls, which include Switch 
when pressed, Switch when released, Switch until released, Latch 
when pressed, Latch when released, and Latch until released.

• Control labels inside arrays—Labels on front panel controls and 
indicators that you place inside arrays are now visible in PDA 
applications. Right-click the control or indicator and select Visible 
Items»Label from the shortcut menu to display the label.

• Resizing and changing the color of increment and decrement 
buttons—You now can resize and change the color of the increment 
and decrement buttons for numeric controls, enumerated type controls, 
and time stamp controls.

• Scroll bar control—The PDA Module supports scroll bar controls, 
which include vertical and horizontal scroll bars that you can add to 
any front panel control or indicator with scrollable data. Use a Property 
Node to associate a scroll bar control with a front panel control or 
indicator.

• Text justification and underlining text for controls and 
indicators—You now can set the justification of text and underline 
text for buttons; enumerated type controls; and string, time stamp, and 
numeric controls and indicators.

Select the Limit to Single Line option from the shortcut menu for the 
string control to disable justification.

• Events and overlapping controls—When controls overlap each 
other, the control with the higher tabbing order number no longer 
receives the event. The topmost control now receives the event.

• Free labels and decorations inside cluster controls and 
indicators—You now can use free labels and decorations inside 
cluster controls and indicators.
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• Decorations inside tab controls—Decorations on one page of a tab 
control no longer appear on all the pages of the tab control.

• Decimal values in ring controls—You now can use decimal values 
for items in a ring control. 

Newly Supported VIs and Functions
• Get Special Folder Path—You can use the Get Special Folder Path 

VI to return the path to the application or directories that applications 
frequently use.

• Inline C Node—You can use the Inline C Node to add inline C code 
to the block diagram. The Inline C Node is similar to the Formula Node 
with additional support and functionality for low-level programming 
and header files without the overhead of a function call. Use the Inline 
C Node for short blocks of code that you cannot easily implement
in VIs.

• PDA Picture to Pixmap—You can use the PDA Picture to Pixmap VI 
to convert a picture to a cluster of image data that you can use to 
perform certain tasks with the image, such as writing customized 
pictures to file.

• Run Application—You can use the Run Application VI to run a 
specified PDA application.

• Show Hide Input Panel—You can use the Show Hide Input Panel VI 
to display or hide the input panel for PDA devices.

• Static VI Reference —You can use the Static VI Reference function 
to maintain a static reference to a VI. You can configure the Static VI 
Reference function to output a generic or strictly typed VI reference. 
After you place the Static VI Reference function on a block diagram, 
double-click the function to display a file dialog box in which you can 
select a VI.

• XML functions—The PDA Module now includes the Escape XML, 
Flatten To XML, Read From XML File, Unescape XML, Unflatten 
From XML, and Write to XML File VIs and functions. You can use 
these VIs and functions to manipulate LabVIEW data in XML format.

Newly Supported Properties
• Cluster properties—The PDA Module includes the following new 

cluster properties that you can use with cluster controls: Cluster Size, 
Cluster Size:Height, Cluster Size:Width, and Controls[]. You can use 
a Property Node with these properties to set the size of cluster controls 
and get references to cluster elements. 

The PDA Module also includes the following new cluster properties 
that you can use with radio buttons controls: Cluster Size, Cluster 
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Size:Height, Cluster Size:Width, and Color. You can use a Property 
Node with these properties to set the size and color of radio buttons 
controls.

• Data binding properties—The PDA Module includes the following 
new data binding properties: Data Binding:Binding Type, Data 
Binding:LED Visible, Data Binding:Mode, Data Binding:Path,
and Data Binding:Status. You can use a Property Node with these 
properties to return information about the data connection, configure 
the mode of the data connection, and show or hide the data binding 
indicator.

• Text property—You can use the Text property to read from or write to 
a string control or indicator.

• Waveform graph cursor properties—You can use the Allow Drag 
and Cursor Legend Visible properties with waveform graphs. Use a 
Property Node with the Allow Drag property to allow users to move 
the cursor in the plot area. Use a Property Node with the Cursor 
Legend Visible property to display the cursor legend for the waveform 
graph.

System Requirements
The PDA Module has the following requirements:

• A desktop computer with Windows Vista/XP or Windows 2000 with 
Service Pack 4.0 or later.

• LabVIEW 8.5 Base, Full, or Professional Edition.

• 2.5 GB available disk space.

• A PDA device running Pocket PC 2003 or Windows Mobile 5.0.

Note For more information about PDA software requirements and supported devices, 
refer to KnowledgeBase 3ANADAKN: LabVIEW PDA Module Software Requirements and 
Supported Devices at ni.com.

Refer to the LabVIEW Release Notes, available by selecting Start»
All Programs»National Instruments»LabVIEW 8.5»LabVIEW 
Manuals and opening LV_Release_Notes.pdf, for standard LabVIEW 
development system requirements.

http://digital.ni.com/express.nsf/express?openagent&code=exb3jd
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Installing the PDA Module
Complete the following steps to install the PDA Module.

1. On Windows Vista/XP/2000, log in as an administrator or as a user 
with administrator privileges.

2. Install LabVIEW 8.5, if not already installed. Refer to the LabVIEW 
Release Notes for standard LabVIEW installation instructions.

3. Install the PDA Module.

The PDA Module includes Microsoft tools, such as Microsoft 
ActiveSync on Windows XP/2000 and ARM Windows Mobile 
emulators. Some of these Microsoft tools might interfere with any 
existing installations of Visual Studio, Windows Embedded, or 
Windows CE toolkits.

Note (Windows XP/2000) The PDA Module installs ActiveSync 4.2 if you do not already 
have ActiveSync 4.2 or later installed. The PDA Module works with ActiveSync 4.2 or 
later.

4. Activate the PDA Module.

You must activate the PDA Module before you can build PDA VIs into 
PDA applications. The PDA Module runs in evaluation mode if you do 
not activate it. In evaluation mode, you can create PDA VIs, but any 
PDA applications you build run only for five minutes. You have the 
option of activating the PDA Module at the end of the installation. You 
also can use the NI License Manager, available by selecting Start»All 
Programs»National Instruments»NI License Manager, to activate 
National Instruments products. Refer to the National Instruments 
License Manager Help, available by selecting Help»Contents in the 
National Instruments License Manager, for more information about 
activating NI products.

5. Restart the computer when the installer completes.

6. (Windows Vista) You must install Windows Mobile Device Center
to use the PDA Module. Refer to the Microsoft Web site at 
www.microsoft.com to download Windows Mobile Device Center.

7. Install the additional tools you need. Refer to the Installing Additional 
Tools section for more information about the additional tools.

http://www.microsoft.com
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Uninstalling the PDA Module
In addition to uninstalling the PDA Module, you also must uninstall the 
following:

• (Windows XP/2000) Microsoft ActiveSync

• Microsoft Device Emulator version 1.0 – ENU

• Microsoft Visual C++ 2005 Redistributable

Installing Additional Tools
You must install additional tools on the target depending on the 
functionality you need.

Shared Variable Support
To use front panel data binding and Shared Variable nodes in your PDA 
applications, you must install the latest version of shared variable support 
on the PDA target.

Complete the following steps to install or uninstall support for shared 
variables on a PDA target.

1. Connect the PDA device to ActiveSync on the host computer.

2. Navigate to and run labview\PDA\Utilities\Variables\
PocketPC\Setup.exe.

Tip You also can right-click the PDA target in the Project Explorer window and select 
Install»Support for Shared Variables from the shortcut menu.

(PDA Emulators) You also must install the Virtual Machine Network Driver 
on host computers with Windows XP/2000 or install Virtual PC 2007 on 
host computers with Windows Vista. Download the appropriate installer 
from the Microsoft Download Center at www.microsoft.com/
downloads.

http://www.microsoft.com/downloads
http://www.microsoft.com/downloads
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PNG Image Support
You must install support for PNG images on the PDA target if the PDA VI 
contains PNG images on the user interface.

Complete the following steps to install or uninstall support for PNG images 
on a PDA target.

1. Connect the PDA device to ActiveSync on the host computer.

2. Navigate to and run labview\PDA\Utilities\LVPNG\
PocketPC\Setup.exe.

Tip You also can right-click the PDA target in the Project Explorer window and select 
Install»Support for PNG Images from the shortcut menu.

NI-VISA Support
You must install NI-VISA on the PDA target to use VISA in your 
applications. Select Start»All Programs»National Instruments»
VISA»Windows Mobile Driver Installation to install NI-VISA. 

Tip You also can right-click the PDA target in the Project Explorer window and select 
Install»Support for NI-VISA from the shortcut menu.

WIDCOMM Bluetooth DLLs
You can use the WIDCOMM Bluetooth DLLs on a PDA device to run PDA 
applications that use Bluetooth communication if you do not have the 
Microsoft Bluetooth driver. 

Note The PDA Module supports the WIDCOMM BTW-CE 1.4 or later driver. 

Do not install the WIDCOMM Bluetooth DLLs if you are using the Microsoft Bluetooth 
driver or you receive an error when you use the Bluetooth VIs and functions. If your device 
uses the Broadcom Bluetooth driver, install the LabVIEW WIDCOMM Bluetooth driver 
by manually copying LVBtw.dll from the labview\PDA\Utilities\Bluetooth
directory to the Windows directory. Do not run Setup.exe and do not copy 
BtCoreIf.dll or BtSdkCE30.dll if they already exist on the device.

Complete the following steps to install the WIDCOMM Bluetooth DLLs.

1. Connect to ActiveSync on the host computer.

2. On the host computer, run labview\PDA\Utilities\Bluetooth\
Setup.exe to install the DLLs on the PDA device.

Refer to readme.txt, located in the labview\PDA\Utilities\
Bluetooth directory, for more information about manually installing the 
WIDCOMM Bluetooth DLLs.
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LabVIEW SMS Client
You must install and run the LabVIEW SMS Client, which is located in 
labview\PDA\Utilities\SMS\Setup.exe, on the host computer to 
receive Short Message Service (SMS) messages or to use the Request 
Make Call VI. The LabVIEW SMS Client notifies the PDA application if 
there is an incoming SMS message and stores the incoming message in 
LVSMSClient.dat, which is located in the \Program Files\
National Instruments\labview\SMS directory on the PDA target.

Complete the following steps to install or uninstall the 
LabVIEW SMS Client on a PDA target.

1. Perform a soft reset on the PDA target. Refer to your PDA device 
documentation for information about performing soft resets.

2. Connect the PDA target to ActiveSync on the host computer.

3. Run Setup.exe on the host computer to install or uninstall the 
required DLLs.

You also can right-click the PDA target in the Project Explorer window 
and select Install»Support for SMS Client from the shortcut menu.

PDA Emulators
Emulators are tools you can use during development to quickly run and test 
PDA VIs without having to download the PDA application to the PDA 
device.

ARM Emulators
(Windows XP/2000) If you are using ARM-based emulators, which are the 
emulators the PDA Module installs, you must install the Virtual Machine 
Network Driver. Download the installer from the Microsoft Download 
Center at www.microsoft.com/downloads.

(Windows Vista) If you are using ARM-based emulators, you must install 
Virtual PC 2007. Download the installer from the Microsoft Download 
Center at www.microsoft.com/downloads.

(Windows Vista) If you want to use emulators with the PDA Module on host 
computers that use Windows Vista, you must download the Microsoft 
Device Emulator 2.0. Download the installer from the Microsoft Download 
Center at www.microsoft.com/downloads.

http://www.microsoft.com/downloads
http://www.microsoft.com/downloads
http://www.microsoft.com/downloads
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x86 Emulators
On host computers with Windows XP/2000, the PDA Module installs 
ARM Pocket PC and Windows Mobile targets, including the emulators. If 
you need x86 emulator targets, install the following Microsoft eMbedded 
Visual Tools:

• Microsoft eMbedded Visual C++ 4.0

• Microsoft eMbedded Visual C++ SP 4 or later

• SDK for Windows Mobile 2003-based Pocket PCs

Refer to the National Instruments KnowledgeBase at ni.com/info
and enter the info code pdaevc for the most recent information about 
downloading and installing the Microsoft eMbedded Visual Tools.

Tutorial
Use this tutorial to learn how to use the PDA Project Wizard to create a 
LabVIEW project and build, run, and debug a PDA application.

The VI in this tutorial simulates a sine wave with configurable offset and 
frequency and displays the result in a graph.

Creating the LabVIEW Project
Use LabVIEW projects to group together LabVIEW files and 
non-LabVIEW files, create build specifications for building a PDA VI into 
a PDA application, and deploy the PDA application to a PDA device or 
emulator. You must use a project to build a PDA VI into a PDA application.

Using the PDA Project Wizard complete the following steps to create a 
LabVIEW project, add a PDA target, and add an existing PDA VI to the 
project.

1. Launch LabVIEW. In the Getting Started window, select PDA 
Project under the Targets pull-down menu. Click the Go button to 
launch the PDA Project Wizard.

2. Define the project information as shown in Figure 1.

a. Select New Pocket PC project, import VI from the Project type 
pull-down menu to create the LabVIEW project using an existing 
VI.

Tip The blank VI project type creates a project with a new PDA template VI rather than 
importing an existing VI.

http://www.ni.com/info
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b. Specify a project name and the location where you want to save 
the project and the VI in the Project location text box. Save the 
project to a location other than the default location so you do not 
overwrite the shipping example with your changes. The default 
project name is Untitled project.lvproj. For this tutorial, 
name the project PDA Tutorial - Pocket PC.lvproj in the 
Project location text box.

c. Click the Browse button next to the VI path text box and navigate 
to labview\examples\PDA\tutorial\PDA Tutorial - 
Pocket PC.vi to select the VI to import. Click the OK button to 
add the VI to the project you are creating.

Figure 1.  Defining the Project Information

3. Click the Next button.

4. Select the Windows Mobile 5.0 Pocket PC Emulator from the 
Device type pull-down menu as shown in Figure 2.
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Figure 2.  Selecting the PDA Device Type

Note You might see additional Pocket PC and/or Windows Mobile targets if you configure 
additional devices through the Microsoft Device Emulator Manager.

5. Click the Next button.

6. The System preview page, shown in Figure 3, shows a preview of the 
project the wizard creates when you click the Finish button. Notice
the checkmark in the Create a build specification checkbox.
This checkmark indicates you want to create a build specification 
immediately after you create the project. Refer to the Creating the 
PDA Build Specification section for more information about creating a 
build specification.
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Figure 3.  Previewing the Project

Because the Create a build specification checkbox contains a checkmark 
as shown in Figure 3, the PDA Build Specification dialog box opens when 
you click the Finish button.

Creating the PDA Build Specification
Build specifications contain the build settings and code generation options 
to use when you build a PDA VI into a PDA application. You can create 
the build specification when you create a project or wait until you are ready 
to build the PDA VI into a PDA application. You must create a build 
specification before you can build a PDA VI into a PDA application.

You can have multiple build specifications for the same target. For example, 
you might want one build specification that generates debugging 
information and another build specification that does not generate this extra 
information.

Note This tutorial creates the build specification through the PDA Project Wizard. You 
also can create a build specification at any time by right-clicking Build Specifications in 
the Project Explorer window and selecting New»Application (EXE) from the shortcut 
menu.



© National Instruments Corporation 15 Getting Started with the LabVIEW PDA Module

Complete the following steps to create a PDA build specification. 

1. Define the settings for the PDA application as shown in Figure 4.

a. Enter a name for the build specification in the Build specification 
name text box. This is the name that appears under Build 
Specifications in the Project Explorer window. 

b. (Optional) By default, the name of the PDA application is the 
same as the top-level PDA VI. If you do not want to use the 
top-level PDA VI name for the PDA application name, remove the 
checkmark from the Same as top-level VI checkbox and enter a 
name in the Target filename text box.

c. Browse to and select the destination directory for the PDA 
application on the host computer, which is where LabVIEW saves 
the .exe, in the Destination directory text box.

d. Enter the destination directory for the PDA application on the 
PDA target in the Remote path for target application text box.

Figure 4.  Defining the PDA Application Information
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Note Although it is common to use the same name for the PDA VI, application, and build 
specification, you are not required to do so.

2. Click the Help button to open the LabVIEW Help and read a 
description of each build setting.

3. Select the Device Information category to view which target and 
processor this build specification applies to.

4. Select the Source Files category to select the source files to include 
when you build the PDA VI into a PDA application. When you use
the PDA Project Wizard to create a build specification, LabVIEW 
automatically uses the VI you import as the top-level VI. When you 
create build specifications outside of the wizard, you must manually 
select the top-level VI and click the blue arrow button, shown at left, 
to move the VI to the Top-level VI text box as shown in Figure 5. PDA 
applications can have only one top-level VI.

Figure 5.  Selecting the Source Files

Note The Machine Aliases category is not used in this tutorial. You use the Machine 
Aliases category to overwrite the default IP address of a target hosting shared variables so 
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you can move the shared variables to a different host without rebuilding the application. 
Refer to the Using Shared Variables in PDA and Touch Panel VIs topic in the LabVIEW 
Help for more information about using shared variables.

5. Select the Generated Files category to view the filenames and paths 
to the files the PDA Module will generate when you build the PDA VI 
into a PDA application.

6. Click the OK button. The build specification you just created appears 
in the Project Explorer window under the PDA target as shown in 
Figure 6.

Figure 6.  Project Explorer Window

7. Select File»Save Project in the Project Explorer window to save the 
project. LabVIEW saves build specifications with the project.

Building the PDA VI into a PDA Application and Deploying
After you develop the PDA VI on the host computer, you build the PDA VI 
into an executable PDA application that you can run on a PDA target. Pick 
one of the options in the Using the Shortcut Menu section or the Using the 
Run Button section to build, run, and deploy a PDA application.

Note ARM PDA emulators require a few minutes to load the OS before you see the PDA 
application running on the emulator target.
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Using the Shortcut Menu
Right-click the build specification and select one of the following from the 
shortcut menu:

• Deploy—Builds the PDA VI into a PDA application, if necessary,
and deploys the application to the PDA target. This option does not 
automatically run the PDA application.

• Run—Builds the PDA VI into a PDA application, if necessary; 
deploys the application to the PDA target, and automatically runs
the PDA application.

• Build—Builds the PDA VI into a PDA application. This option does 
not deploy or automatically run the PDA application.

Using the Run Button
When you run a PDA VI under a PDA target in the Project Explorer 
window, the Run button behaves differently from when you run a VI under 
My Computer in the Project Explorer window:

• If you want to build, deploy, and run—Click the Run button in a 
PDA VI to build the PDA VI into a PDA application, deploy the PDA 
application to the PDA target, and run the PDA application on the PDA 
target. LabVIEW prompts you to create a build specification if you do 
not have an existing build specification for the PDA VI. If you have 
multiple build specifications, LabVIEW prompts you to select a
build specification in the Select a Build Specification dialog box. 
Alternatively, you can specify a default build specification by 
right-clicking a build specification in the Project Explorer window 
and selecting Set as Default from the shortcut menu. The PDA 
Module uses the default build specification, which the PDA Module 
indicates with a green square around the PDA build specification glyph 
in the Project Explorer window.

• If you want to build without deploying or running—Press the 
<Ctrl> key while you click the Run button in a PDA VI to build the 
PDA VI into a PDA application without deploying or running the PDA 
application. LabVIEW prompts you to create a build specification if 
you do not have an existing build specification for the PDA VI. If you 
have multiple build specifications, LabVIEW prompts you to select a 
build specification in the Select a Build Specification dialog box. 
Alternatively, you can specify a default build specification by 
right-clicking a build specification in the Project Explorer window 
and selecting Set as Default from the shortcut menu. The 
PDA Module uses the default build specification, which the 
PDA Module indicates with a green square around the PDA build 
specification glyph in the Project Explorer window.
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Closing the PDA Application
Click the Exit button in the PDA application on the PDA target to close the 
PDA application.

Debugging the PDA Application
You must create a build specification that enables debugging before
you can debug a PDA application. Enabling debugging generates extra 
debugging information and can significantly increase the size of the PDA 
application.

When LabVIEW on the host computer connects to the PDA target, the PDA 
application runs on the PDA target. The front panel is fully functional on 
the PDA target. However, the front panel controls have no effect on the 
PDA application, and the indicators of the PDA VI on the host computer do 
not reflect the execution of the PDA application on the PDA target.

The block diagram acts as a conduit between the PDA application running 
on the PDA target and the PDA VI running on the host computer, where you 
can probe signals, set breakpoints, and step through code as you do in any 
other VI.

Tip You can modify an existing build specification by double-clicking the build 
specification in the Project Explorer window or right-clicking the build specification
and selecting Properties from the shortcut menu. This tutorial creates a second build 
specification for debugging.

Creating a Debugging Build Specification
Complete the following steps to create a debugging build specification.

1. Right-click Build Specifications under the PDA target and select 
New»Application (EXE) from the shortcut menu.

2. Enter (Debug) PDA Tutorial - Pocket PC in the Build 
specification name text box.

3. Remove the checkmark from the Same as top-level VI checkbox so 
you can change the PDA application name.

4. Enter (Debug) PDA Tutorial - Pocket PC.exe in the 
Target filename text box.
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5. Place a checkmark in the Enable debugging checkbox to generate 
debugging information when you build the PDA VI into a PDA 
application as shown in Figure 7.

Figure 7.  Creating the Debugging Build Specification

6. Select Source Files from the Category list and select 
PDA Tutorial - Pocket PC.vi in the source files list. Click the blue 
right arrow button, shown at left, to move the VI from the source files 
list to the Top-level VI text box.
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7. Click the OK button. The build specification you just created appears 
in the Project Explorer window as shown in Figure 8.

Figure 8.  Two PDA Build Specifications in the Project Explorer Window

Adding a Probe to the PDA VI
Probes display information about the data that passes through a wire. As 
you interact with the PDA application on the PDA device, you can see the 
data passing through the wire in the PDA VI on the host computer.

Complete the following steps to add a probe to the PDA VI.

1. Select Window»Show Block Diagram in the VI to open the block 
diagram if it is not visible.

Note Double-click the VI in the Project Explorer window to open the VI if the VI is not 
already open.

The block diagram acts as a conduit between the PDA application 
running on the PDA target and the PDA VI running on the host 
computer.

2. Right-click the wire flowing from the Frequency control to the For 
Loop and select Probe from the shortcut menu.
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A floating Probe window appears after you create a probe. LabVIEW 
numbers the Probe windows automatically and displays the same 
number in a glyph on the wire you probe as shown in Figure 9.

Figure 9.  Adding a Probe to the Block Diagram

Deploying and Debugging a PDA Application
You must use the debugging build specification to deploy the PDA VI, 
which contains debugging information, to the PDA device before the probe 
in the PDA VI on the host computer can update the values passing through 
the wire.

Complete the following steps to deploy and debug the PDA application.

1. Right-click the build specification for the PDA VI you want to build 
and deploy, which is (Debug) PDA Tutorial - Pocket PC in Figure 8, 
and select Debug from the shortcut menu. Save any VIs if prompted.
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The PDA Module builds the PDA VI into a PDA application, deploys 
the PDA application to the PDA target, and runs the PDA application 
on the PDA target as shown in Figure 10.

Tip You also can start a debugging session by clicking the Step Over or Step Into buttons 
or by clicking the Pause button and then clicking the Run button on the block diagram 
toolbar.

Figure 10.  Running the PDA Application on the PDA Emulator

2. Click the Run button in the PDA application.
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3. Move the Frequency slider in the PDA application running on the 
PDA target and click the Run button again. The value in the Probe 
window on the block diagram updates as you move the slider in the 
PDA application.

Note Any changes you make on the front panel of the PDA VI on the host computer have 
no effect on the PDA application running on the PDA target.

4. Click the Exit button in the PDA application on the PDA target to stop 
the PDA application and end the debugging session.

Related Documentation
LabVIEW includes extensive online and print documentation for new
and experienced LabVIEW users. The following documents contain 
information that you might find helpful as you use the PDA Module:

• LabVIEW Help—Refer to the LabVIEW Help, available by selecting 
Help»Search the LabVIEW Help in LabVIEW, for information 
about LabVIEW programming concepts, step-by-step instructions for 
using LabVIEW, and reference information about LabVIEW VIs, 
functions, palettes, menus, and tools. Refer to the PDA Module book 
on the Contents tab of the LabVIEW Help for information specific to 
the PDA Module and PDA applications. LabVIEW Help uses (PDA) in 
the index to indicate PDA-specific topics.

• PDA Module Readme—Refer to the PDA Module Readme file, 
available by selecting Start»All Programs»National Instruments»
LabVIEW 8.5»Readme and opening readme_PDA.html, for 
last-minute information and known issues with version 8.5.

• Documentation for the PDA target you use.

• LabVIEW PDFs—In addition to this document, the Getting Started 
with LabVIEW manual, LabVIEW Quick Reference Card, LabVIEW 
Fundamentals manual, LabVIEW Release Notes, and LabVIEW 
Upgrade Notes are available as PDFs by selecting Start»All 
Programs»National Instruments»LabVIEW 8.5»LabVIEW 
Manuals.

Note You must have Adobe Reader with Search and Accessibility 5.0.5 or later installed 
to view the PDFs. You must have Adobe Reader with Search and Accessibility 6.x or
later installed to search PDF versions of these manuals. Refer to the Adobe Systems 
Incorporated Web site at www.adobe.com to download Adobe Reader. Refer to the 
National Instruments Product Manuals Library at ni.com/manuals for updated 
documentation resources.

http://www.adobe.com
http://www.ni.com/manuals
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Where to Go for Support
The National Instruments Web site is your complete resource for technical 
support. At ni.com/support you have access to everything from 
troubleshooting and application development self-help resources to email 
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 
11500 North Mopac Expressway, Austin, Texas, 78759-3504. 
National Instruments also has offices located around the world to help 
address your support needs. For telephone support in the United States, 
create your service request at ni.com/support and follow the calling 
instructions or dial 512 795 8248. For telephone support outside the United 
States, contact your local branch office: 

Australia 1800 300 800, Austria 43 662 457990-0, 
Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599, 
Canada 800 433 3488, China 86 21 5050 9800, 
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 
Finland 385 (0) 9 725 72511, France 01 57 66 24 24, 
Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737, 
Italy 39 02 413091, Japan 81 3 5472 2970, Korea 82 02 3451 3400, 
Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710, 
Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466, 
New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60, 
Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851, 
Singapore 1800 226 5886, Slovenia 386 3 425 42 00, 
South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 
Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151, 
Taiwan 886 02 2377 2222, Thailand 662 278 6777, 
Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545

http://www.ni.com/support
http://www.ni.com/support
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