
NI 9930 Motion Control Accessories User Guide
Note If you are a new user of LabVIEW or are unfamiliar with LabVIEW, refer to the Getting 
Started with LabVIEW manual for information about LabVIEW and LabVIEW terminology.

This document explains how to use the NI 9930 motion control accessories with the NI 9512 C Series 
drive interface module and selected position command servo drives. 
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NI 9930M Motion Control Accessory for Mitsubishi Servo Drives
The NI 9930M motion control accessory allows easy connection between the NI 9512 C Series drive 
interface module and the Mitsubishi MR-J2 or Mitsubishi MR-J3 servo drive.

What You Need to Get Started
You need the following items to get started.

Hardware
❑ NI 9930M Motion Control Accessory and NI 951x Y-cable.

(NI part number 781824-01)

❑ NI 9512 C Series stepper drive interface module.
(NI part number 779944-01)

❑ NI real-time controller and chassis that support the RIO Scan Interface.

Tip To determine if your controller and chassis support the RIO Scan Interface go to ni.com/
info and enter rdsoftwareversion.

❑ 24 V power supply (such as the NI PS-15) for the CompactRIO controller.
(NI part number 781093-01)

Note Refer to the controller operating instructions for power supply requirements.
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❑ 24 V power supply (such as the NI PS-15) for the NI 9930M. This supply also powers the NI 9512 
and any drive I/O.
(NI part number 781093-01)

Note Refer to the NI 9512 Operating Instructions and Specifications and the drive manual to verify 
that the selected power supply meets the system requirements.

❑ Ethernet connection and cable for the CompactRIO controller.

❑ 50- or 20-pin MDR cables to connect the accessory to the drive.

– One 50-pin MDR cable for MR-J3 drives
(NI part number 194604-02)

– Two 20-pin MDR cables for MR-J2 drive
(NI part number 194466-02)

❑ Mitsubishi MR-J2 or MR-J3 position-command servo drive.

❑ Servo motor, encoder, power supply, and associated cables to connect the motor and encoder to the 
drive.

Software
❑ LabVIEW 2009 SP1 or later

❑ LabVIEW 2009 SP1 Real-Time Module or later

❑ LabVIEW 2009 SP1 NI SoftMotion Module or later

❑ NI-RIO 3.4.0 or later

Figure 1 shows a simplified connection diagram.

Figure 1.  NI 9930M Connection Accessory with to MR-J2 Drive Connections
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Figure 2.  NI 9930M Connection Accessory with to MR-J3 Drive Connections
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Figure 3 shows an overview of the connectors on the NI 9930M connection accessory.

Figure 3.  NI 9930M Connection Accessory Connectors

1 J1, J5, J7: User I/O Screw Terminal Connectors
2 DS1: +5 V Power LED (from NI 9512)
3 DS2: +24 V Power LED
4 J8: + 24 V Power Supply Connector

5 J6: CN1B Connector (for MR-J2 Drive)
6 J4: NI 9512 Connector
7 J2: CN1A Connector (for MR-J2 Drive)
8 J3: CN1 Connector (for MR-J3 Drive)
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Hardware Installation and Configuration

Step 1: Set Up the CompactRIO System
Complete the following steps to set up the CompactRIO hardware.

1. Install the real-time CompactRIO controller on the chassis if you are not using an integrated 
controller and chassis. 

Note Write down the controller serial number before installing the controller onto the chassis. 
You will be unable to read the serial number after you install the controller.

a. Make sure that no power is connected to the controller or the chassis.

b. Align the controller with the chassis as shown in Figure 4. 

Figure 4.  Installing the Controller on the Chassis (Eight-Slot Chassis Shown)
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c. Slide the controller onto the controller slot on the chassis. Press firmly to ensure the chassis 
connector and the controller connector are mated. 

d. Using a number 2 Phillips screwdriver, tighten the two captive screws on the front of the 
controller.

2. Connect the controller to a power supply and an Ethernet network on the same subnet as the 
development computer. Refer to the controller operating instructions for information about wiring 
the controller to the power supply and Ethernet network.

Note Do not plug in or turn on any power to the system until after you complete Step 3: Configure 
the Drive and Connect the Motor and Encoder to the Drive.

3. Install the NI 9512 module in slot 1, 2, 3, or 4 of the chassis.

Step 2: Connect the NI 9930M Connection Accessory
The NI 9930M connection accessory contains connections for the NI 9512 C Series module, the 
Mitsubishi MR-J2 or MR-J3 servo drive, and a 24 V power supply for NI 9512 module and drive I/O.

1. Connect the NI 9512 module to the NI 9930M J4 connector using the NI 951x Y cable.

2. Connect the NI 9930M to the drive.

• Mitsubishi MR-J2—Connect the J2 connector to the CN1A connector on the drive, and the 
J6 connector to the CN1B connector on the drive using two 20-pin MDR cables.

• Mitsubishi MR-J3—Connect the J3 connector to the CN1 connector on the drive using one 
50-pin MDR cable.

3. Connect a 24 V power supply to the Vsup and COM terminals on the NI 9930M accessory J8 
connector. Figure 3 shows the location of the power supply input.

4. Connect pin 2 (EMG - emergency stop input signal) and pin 1 (COM) to an emergency stop switch. 
Refer to the drive manual for more information about emergency stop switch requirements.

Note If the emergency stop functionality is not required, connect the EMG input directly to COM 
to bypass any external safety circuitry.

Note You cannot enable the drive if you do not connect the EMG input to an emergency stop switch 
or directly to COM.

5. Connect pin 15 (LSP - forward rotation stroke end/forward limit) and pin 14 (LSN - reverse rotation 
stroke end/reverse limit) to pin 13 (COM), or configure the drive to ignore limit inputs. 

Note These configuration settings disable limits for initial setup and testing purposes. National 
Instruments recommends connecting and enabling limits in your final application. Refer to the drive 
documentation for limit input requirements.

6. Connect pin 9 (COM) to pin 10 (LG - control common).

Note Not connecting pin 9 and pin 10 will result in unpredictable behavior.

7. Connect any additional I/O, such as limits, DIO, position compare outputs, position capture inputs, 
and so on, using the NI 9930M screw terminal connectors. The J1 and J5 connectors allow 
connection to the drive I/O signals, and the J7 connector provides connection to the NI 9512 I/O 
signals. Refer to the drive or the NI 9512 module documentation for specific signal connection 
requirements.



© National Instruments Corporation 7 NI 9930 Motion Control Accessories User Guide

Figure 5 shows the screw terminal connector pinouts.

Figure 5.  NI 9930M I/O Connectors
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Step 3: Configure the Drive and Connect the Motor and Encoder to the Drive
This section covers the minimum drive settings and connections to allow the motor to move. Refer to 
the drive manual for additional information about drive parameters and signal information.

1. Power on the drive and configure the drive for position control mode. These parameters differ 
depending on the drive. Refer to the drive manual for information about how to set drive 
parameters.

• Mitsubishi MR-J2—Set parameter P 21 to 1 (signed pulse train).

• Mitsubishi MR-J3—Set parameter PA 01 to 0 (position control) and PA 13 to 1 (step and 
direction). You may also need to set parameter PA 05 (pulses per rev) to the appropriate setting 
for your encoder. 

2. Ensure that the drive encoder output pulses and electronic gear parameters are set to the default 
values:

Mitsubishi MR-J2

a. Set parameter P 27 to 4000 pulses per rev. If you change this from the default value, you must 
also change the value specified for the encoder Counts per rev in Step 3: Configure the 
NI 9512 C Series Module of the Software Installation and Configuration section.

b. Set parameter 3 and parameter 4 to 1. This disables any electronic gearing settings.

Mitsubishi MR-J3

a. Set parameter PA 15 to 4000 pulses per rev. If you change this from the default value, you must 
also change the value specified for the encoder Counts per rev in Step 3: Configure the 
NI 9512 C Series Module of the Software Installation and Configuration section.

b. Set parameter PA 05 to 0. This disables the number of command input pulses per servo motor 
revolution parameter.

c. Set parameter PA 06 and parameter PA 07 to 1. This disables any electronic gearing setting.

3. Connect the motor and encoder to the drive. Refer to the documentation specific to your drive for 
motor and encoder connection information.

Tip An incorrectly connected encoder may cause NI SoftMotion to return error -77076 
(NIMCDM_driveReadyNotActiveError). Verify the encoder connections if you see this error.

4. Connect the drive power. Refer to the drive documentation for power connections and 
specifications.

5. Apply power to all the hardware once all connections are made and continue to the next section.

Software Installation and Configuration
This section covers installing and configuring the software for the NI 9512 C Series drive interface 
module. It assumes that all required software from the What You Need to Get Started section is installed.

Step 1: Install Software on and Configure the NI RT Controller
Complete the following steps to configure the controller and install software on it.

Note The Measurement & Automation Explorer (MAX) user interface may not match these steps 
exactly depending on which version of MAX you are using. 

1. Launch MAX on the development computer by clicking the MAX icon on the desktop, or by 
selecting Start»All Programs»National Instruments»Measurement & Automation.

2. Select the controller under Remote Systems in the Configuration pane. If you do not see the 
controller, you may need to disable the firewall on the development computer. Go to 
ni.com/info and enter RIOMAXTroubleshoot for more information.
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3. Verify that the Serial Number in the General Settings section matches the serial number on the 
device.

4. If you do not want to format the disk on the controller, eliminating all installed software and files, 
skip to step 14.

5. Set the Safe Mode switch on the controller to the On position.

6. Power on the controller. If it is already powered on, press the Reset button on the controller to 
reboot it.

7. Right-click the controller under Remote Systems in the Configuration pane in MAX and select 
Format Disk. 

8. (Optional) Enable the Keep Network Settings checkbox if you want to retain the same target name 
and IP address. 

9. Click Format to start formatting the disk.

10. When MAX finishes formatting the disk, set the Safe Mode switch to the Off position and click 
OK.

11. Select the System Settings tab and type a descriptive name for the system in the Hostname field.

12. (Optional) Complete this step only if the target has an empty IP address (0.0.0.0). Select the 
Network Settings tab and select DHCP or Link Local from the Configure IPv4 Address list to 
assign an IP address or select the Static to specify a static IP address in the IPv4 Address section.

13. Click Save on the toolbar and let MAX reboot the system.

14. When the new system name appears under Remote Systems, expand the controller item in the tree, 
right-click Software, and select Add/Remove Software.

15. Select a recommended software set that includes NI-RIO 3.4.0 or later. 

Note If you are using the NI SoftMotion Module 2010 SP1 or earlier, also select LabVIEW 
NI SoftMotion Module Scan Engine Support from the list.

16. Click Next.

17. Select LabVIEW NI SoftMotion Module from the add-ons list.

18. Click Next to install the selected software on the controller. Click Help if you need information 
about installing recommended software sets.

19. When the software installation completes, click Finish to reboot the controller.

20. Close MAX.

Step 2: Creating a Project and Adding an NI SoftMotion Axis
Complete the following steps to create a LabVIEW project. 

1. Launch LabVIEW by selecting Start»All Programs»National Instruments»LabVIEW.

2. Click the Empty Project link in the Getting Started window to display the Project Explorer 
window. You can also select File»New Project to display the Project Explorer window.

3. Select Help and make sure that Show Context Help is checked. You can refer to the context help 
throughout the tutorial for information about items on the block diagram.
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4. Right-click the top-level project item in the Project Explorer window and select New»Targets 
and Devices from the shortcut menu to display the Add Targets and Devices dialog box. Refer to 
Figure 6 for more information.

Figure 6.  Adding a New Target

5. Make sure that the Existing target or device radio button is selected.

6. Expand Real-Time CompactRIO.

7. Select the CompactRIO controller to add to the project and click OK.

8. If you have LabVIEW FPGA installed, the Select Programming Mode dialog box appears. Select 
Scan Interface to put the system into Scan Interface mode, then click Continue.

Tip Use the CompactRIO Chassis Properties dialog box to change the programming mode in an 
existing project. Right-click the CompactRIO chassis in the Project Explorer window and select 
Properties from the shortcut menu to display this dialog box.

9. Click Discover in the Discover C Series Modules? dialog box if it appears.

10. Click Continue. 
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11. Right-click the controller item in the Project Explorer window and select Properties from the 
shortcut menu to display the RT Target Properties dialog box. Select Scan Engine from the 
Category list to display the Scan Engine page. 

12. Set the Scan Period to 10 ms or lower, then click OK to close the RT Target Properties dialog 
box.

13. If you did not reformat the CompactRIO device in Step 1: Install Software on and Configure the 
NI RT Controller, expand the real-time target. If an axis already exists on the target, right-click the 
axis and select Remove from Project, or temporarily associate it with different hardware using the 
Axis Manager dialog box. You cannot associate two axes with the same hardware device. Refer to 
Figure 8 to view a project with an axis on the target.

14. Right-click the controller item in the Project Explorer window and select New»NI SoftMotion 
Axis from the shortcut menu to open the Axis Manager dialog box, shown in Figure 7.

15. Click Add New Axis to create an NI SoftMotion axis associated with the NI 9512 module. Axes 
are automatically bound to an available module. You can double-click the axis name to rename the 
axis and give it a descriptive name.

Figure 7.  Axis Manager Dialog Box
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16. Click OK to close the Axis Manager dialog box. The new axis is added to the Project Explorer 
window. 

Note You cannot associate more than one axis with the same C Series module.

When you have finished these steps your LabVIEW project should look similar to the image in 
Figure 8.

Figure 8.  Project Explorer Window with Modules in Scan Interface Mode

Step 3: Configure the NI 9512 C Series Module
Complete the following steps to configure the axis I/O settings for use with the Mitsubishi MR-J2 or 
MR-J3 servo drive.

1. Right-click the axis in the Project Explorer window and select Properties from the shortcut menu 
to open the Axis Configuration dialog box.
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Figure 9 shows the parts of the Axis Configuration dialog box for NI 9512 C Series module. 

Figure 9.  Axis Configuration Dialog Box

Note The Axis Configuration dialog box user interface may not match this image exactly 
depending on which version of the LabVIEW NI SoftMotion Module you are using. 

2. On the General Settings page set the Loop Mode to Closed-Loop.

3. Click the Encoder button and configure the Units and Counts Per Unit.

a. Make the following changes in the Active State section:

• Set the Line State for A to High.

• Set the Line State for B to Low.

• Set the Line State for Index to High. 

b. In the Index Reference Criteria section set the Line State for A and B to Inactive.

c. Type rev in the Units text box.

d. Set the Counts per rev to 4000. This assumes the default drive setting for encoder pulses per 
rev. Refer to Step 3: Configure the Drive and Connect the Motor and Encoder to the Drive in 
the Hardware Installation and Configuration section for more information.
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When you are finished the Encoder Settings page will look similar to Figure 10.

Figure 10.  Axis Configuration Encoder Page

4. Click the Stepper button to open the Stepper page. Configure the stepper output and steps per rev 
settings:

a. Set Output Mode to Step and Direction.

b. Set Output Type to Differential.

c. Set Active State to Low.

d. Set Steps Per rev depending on the encoder resolution. For example, if you are using an 
encoder with 131,072 pulses per revolution, set Steps Per rev to 131,072. 

When you are finished the Stepper Settings page will look similar to Figure 11.

Figure 11.  Axis Configuration Stepper Page
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e. In the Position Error section, change the Position Error Limit to an acceptable value for 
your system. Exceeding the specified position error limit causes NI SoftMotion to disable the 
drive and turn off the Drive Enable signal.

5. Click the Digital I/O button to open the Digital I/O page and map the following status inputs.

a. Map DI 1 to Servo/Drive Ready. This signal is active when the drive is enabled.

1) Double-click the text in the Mapping column and select Servo/Drive Ready from the 
dropdown list. 

2) Ensure that the DI 1 settings match the following:

• Input Type—Sourcing

• Active State—On

• Digital Filter—50 µs

b. Map DI 2 to In-Position. The In-Position signal from the drive is active when the current 
position is within a user-specified distance from the target position. This is a drive setting.

1) Double-click the text in the Mapping column and select In-Position from the dropdown 
list. 

2) Ensure that the DI 2 settings match the following:

• Input Type—Sourcing

• Active State—On

• Digital Filter—50 µs

c. Map DI 3 to Drive Fault/Alarm. When the Drive Fault/Alarm signal is active, the module 
does not generate command signals.

1) Double-click the text in the Mapping column and select Drive Fault/Alarm from the 
dropdown list. 

2) Ensure that the DI 3 settings match the following:

• Input Type—Sourcing

• Active State—Off

• Digital Filter—50 µs

d. (Optional) Configure a digital output to use for the Alarm Clear signal, if required. Position 
command drives often require an Alarm Clear signal from the module to the drive. This signal 
clears the alarm or fault outputs on the drive. This functionality is not available using a 
mappable digital output. However, you can use a digital output to implement this functionality 
in your code. Complete the following steps to use a digital output as an Alarm Clear output: 

1) Determine the required pulse time and active state for the Alarm Clear signal. This 
information is in the specifications for the position command drive. 

2) Select an available digital output. 

3) Configure the digital output Active State, Safe State, and Output Type as required by 
the drive. 

4) In your application VI add code to pulse the digital output line for the appropriate amount 
of time to clear the alarm output. Do not clear the alarm on the drive until the alarm 
condition is resolved.

Note If you are configuring a digital output to use as the Alarm Clear signal, you must connect the 
configured output from the J7 screw terminal connector to the drive Clear signal on the J1 screw 
terminal connector.
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When you are finished the Digital I/O Settings page will look similar to Figure 12.

Figure 12.  Axis Configuration Digital I/O Page

6. Open the Trajectory page and enable the In-Position checkbox. This allows the In-Position input 
to be used as a criteria for move complete. When this signal is included in the move complete 
criteria, the move is only complete if the In-Position signal is active. 

7. Click the Drive Enable button and configure the Drive Enable output settings.

a. Place a checkmark in the Enable checkbox.

b. Set Output Type to Sinking.

c. Set Active State to On.

d. Set Safe State to Off.

8. Complete the following additional steps if you do not have limits and home connected at this time:

a. Open the Limits & Home page.

b. In the Forward Limit and Reverse Limit sections ensure that the settings match the 
following:

Note These configuration settings disable limits for initial setup and testing purposes. National 
Instruments recommends connecting and enabling limits in your final application.

• Clear the Enable checkbox from both Forward Limit and Reverse Limit. 

• Set the Active State for both Forward Limit and Reverse Limit to Off. This prevents 
a limit warning even though limits are turned off.

c. Open the Home section and clear the Enable checkbox.

9. Configure any additional I/O settings according to your system requirements, such as position 
compare or position capture signals.

10. Click OK to close the Axis Configuration dialog box.

11. Right-click the controller item in the Project Explorer window and select Deploy All to deploy 
the axis information.

12. Click Apply in the Conflict Resolution dialog box when it appears. The NI Scan Engine must be 
in Active mode to move the axis. 

13. Select File»Save Project to save the project.
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Step 4: Enable and Test the Drive Using LabVIEW
Use the Interactive Test Panel to test and debug your motion system and configuration settings on the 
selected axis. With the Interactive Test Panel you can perform a simple straight-line move and monitor 
feedback position and position error information, move and I/O status information, change move 
constraints, get information about software errors and faults, and view position or velocity plots of the 
move. 

Complete the following steps to test your setup after configuring the axis using the Axis Configuration 
dialog box.

1. Right-click the axis in the Project Explorer window and select Interactive Test Panel from the 
shortcut menu. 

2. On the Move tab set Target Position to 25 revolutions.

3. On the Move Constraints tab set Velocity to 1 revolution/sec. Using the encoder counts per 
revolution and stepper steps per revolution values specified in this tutorial the motor will move 
25 revolutions at 60 RPM. Click the Help button for detailed information about the items available 
in this dialog box.

4. Click the Enable button to enable the drive.

5. Click the Start button on the bottom of the dialog box to start the move with the configured options.

6. Use the Status and Plots tabs to monitor the move while it is in progress.

Finalize your motion system setup by connecting and configuring additional I/O such as limits as 
required by your system using the screw terminal connectors on the NI 9930M accessory. 
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NI 9930P Motion Control Accessory for Panasonic Servo Drives
The NI 9930P motion control accessory allows easy connection between the NI 9512 C Series drive 
interface module and the Panasonic Minas A or Minas A5 servo drive.

What You Need to Get Started
You need the following items to get started.

Hardware
❑ NI 9930P Motion Control Accessory and NI 951x Y-cable.

(NI part number 781823-01)

❑ NI 9512 C Series stepper drive interface module.
(NI part number 779944-01)

❑ NI real-time controller and chassis that support the RIO Scan Interface.

Tip To determine if your controller and chassis support the RIO Scan Interface go to ni.com/
info and enter rdsoftwareversion.

❑ 24 V power supply (such as the NI PS-15) for the CompactRIO controller.
(NI part number 781093-01)

Note Refer to the controller operating instructions for power supply requirements.

❑ 24 V power supply (such as the NI PS-15) for the NI 9930P. This supply also powers the NI 9512 
and any drive I/O.
(NI part number 781093-01)

Note Refer to the NI 9512 Operating Instructions and Specifications and the drive manual to verify 
that the selected power supply meets the system requirements.

❑ Ethernet connection and cable for the CompactRIO controller.

❑ 50-pin MDR cable to connect the accessory to the drive.
(NI part number 194604-02)

❑ Panasonic Minas A or Minas A5 position-command servo drive.

Note The Panasonic Minas A drive product numbers start with MxDA, and the Panasonic Minas A5 
drive product numbers start with MxDH.

❑ Servo motor, encoder, power supply, and associated cables to connect the motor and encoder to the 
drive.

Software
❑ LabVIEW 2009 SP1 or later

❑ LabVIEW 2009 SP1 Real-Time Module or later

❑ LabVIEW 2009 SP1 NI SoftMotion Module or later

❑ NI-RIO 3.4.0 or later
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Figure 13 shows a simplified connection diagram.

Figure 13.  NI 9930P Connection Accessory Connections
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Figure 14 shows an overview of the connectors on the NI 9930P connection accessory.

Figure 14.  NI 9930P Connection Accessory Connectors

1 J1, J4, and J5: User I/O Screw Terminal Connectors
2 DS1: +5 V Power LED (from NI 9512)
3 DS2: +24 V Power LED
4 J6: + 24 V Power Supply Connector

5 J3: NI 9512 Connector
6 J2: Minas A or Minas A5 Connector
7 W1, W2, W3, and W4: Step and Direction Input Jumpers
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Hardware Installation and Configuration

Step 1: Set Up the CompactRIO System
Complete the following steps to set up the CompactRIO hardware.

1. Install the real-time CompactRIO controller on the chassis if you are not using an integrated 
controller and chassis. 

Note Write down the controller serial number before installing the controller onto the chassis. 
You will be unable to read the serial number after you install the controller.

a. Make sure that no power is connected to the controller or the chassis.

b. Align the controller with the chassis as shown in Figure 15. 

Figure 15.  Installing the Controller on the Chassis (Eight-Slot Chassis Shown)

c. Slide the controller onto the controller slot on the chassis. Press firmly to ensure the chassis 
connector and the controller connector are mated. 

d. Using a number 2 Phillips screwdriver, tighten the two captive screws on the front of the 
controller.

1 Controller
2 Captive Screws
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5
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3
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2. Connect the controller to a power supply and an Ethernet network on the same subnet as the 
development computer. Refer to the controller operating instructions for information about wiring 
the controller to the power supply and Ethernet network.

Note Do not plug in or turn on any power to the system until after you complete Step 3: Configure 
the Drive and Connect the Motor and Encoder to the Drive.

3. Install the NI 9512 module in slot 1, 2, 3, or 4 of the chassis.

Step 2: Connect the NI 9930P Connection Accessory
The NI 9930P connection accessory contains connections for the NI 9512 C Series module, the 
Panasonic Minas A or Minas A5 servo drive, and a 24 V power supply for NI 9512 module and drive I/O.

1. Connect the NI 9512 module to the NI 9930P J3 connector using the NI 951x Y cable.

2. Connect the NI 9930P J2 connector to the drive I/F (Minas A) or X4 (Minas A5) connector using 
the 50-pin MDR cable.

3. Configure the Step and Direction Input jumpers. The default setting, shown in Figure 16, 
configures the step and direction inputs as low-speed 500K inputs. This setting is compatible with 
either the Minas A or Minas A5 drive. 

Figure 16.  NI 9930P Step and Direction Input Jumper Default Configuration

The Minas A5 drive also supports high-speed 4M RS-422 step and direction inputs. To use these 
inputs, move the jumpers to the bottom position.

Caution The Minas A drive does not support high-speed RS-422 step and direction inputs. Do not 
change the jumper setting when using the NI 9930P with a Minas A drive.

4. Connect a 24 V power supply to the Vsup and COM terminals on the NI 9930P accessory J6 
connector. Figure 14 shows the location of the power supply input.

5. Connect any additional I/O, such as limits, DIO, position compare outputs, position capture inputs, 
and so on, using the NI 9930P screw terminal connectors. The J1 and J4 connectors allow 
connection to the drive I/O signals, and the J5 connector provides connection to the NI 9512 I/O 
signals. Refer to the drive or the NI 9512 module documentation for specific signal connection 
requirements.

W1 W4W3W2
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Figure 17 shows the screw terminal connector pinouts.

Figure 17.  NI 9930P I/O Connectors

Step 3: Configure the Drive and Connect the Motor and Encoder to the Drive
This section covers the minimum drive settings and connections to allow the motor to move. Refer to
the drive manual for additional information about drive parameters and signal information.

1. Power on the drive and configure the drive for position control mode. These parameters differ 
depending on the drive. Refer to the drive manual for information about how to set drive 
parameters.

• Panasonic Minas A—Set parameter PA_r02 to 0 (position control) and parameter 
PA_r42 to 3 (step and direction).

• Panasonic Minas A5—Set parameter PR0.07 to 3 (pulse train + signal).
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2. Ensure that the drive encoder output pulses and electronic gear parameters are set to the default 
values: 

Panasonic Minas A

a. Set parameter PA_r44 to 2500 pulses per rev. If you change this from the default value, you 
must also change the value specified for the encoder counts per rev in Step 3: Configure the 
NI 9512 C Series Module of the Software Installation and Configuration section.

b. Set parameters PA_r46, PA_r47, and PA_r4B to 10000 and parameter PA_r4A to 0. This sets 
any electronic gearing to a 1:1 ratio.

Panasonic Minas A5

a. Set parameter PR0.08 to 10000. This specifies the number of command pulses for one motor 
revolution. If you change this from the default value, you must also change the value specified 
for Steps per rev in Step 3: Configure the NI 9512 C Series Module of the Software 
Installation and Configuration section.

b. Set parameter PR0.11 to 2500 pulses per rev. This specifies the number of encoder pulses per 
revolution. If you change this from the default value, you must also change the value specified 
for the encoder Counts per rev in Step 3: Configure the NI 9512 C Series Module of the 
Software Installation and Configuration section by multiplying the specified value by four.

3. Connect the motor and encoder to the drive. Refer to the documentation specific to your drive for 
motor and encoder connection information.

Tip An incorrectly connected encoder may cause NI SoftMotion to return error -77076 
(NIMCDM_driveReadyNotActiveError). Verify the encoder connections if you see this error.

4. Connect the drive power. Refer to the drive documentation for power connections and 
specifications.

5. Apply power to all the hardware once all connections are made and continue to the next section.

Software Installation and Configuration
This section covers installing and configuring the software for the NI 9512 C Series drive interface 
module. It assumes that all required software from the What You Need to Get Started section is installed.

Step 1: Install Software on and Configure the NI RT Controller
Complete the following steps to configure the controller and install software on it.

Note The Measurement & Automation Explorer (MAX) user interface may not match these steps 
exactly depending on which version of MAX you are using. 

1. Launch MAX on the development computer by clicking the MAX icon on the desktop, or by 
selecting Start»All Programs»National Instruments»Measurement & Automation.

2. Select the controller under Remote Systems in the Configuration pane. If you do not see the 
controller, you may need to disable the firewall on the development computer. Go to 
ni.com/info and enter RIOMAXTroubleshoot for more information.

3. Verify that the Serial Number in the General Settings section matches the serial number on the 
device.

4. If you do not want to format the disk on the controller, eliminating all installed software and files, 
skip to step 14.

5. Set the Safe Mode switch on the controller to the On position.
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6. Power on the controller. If it is already powered on, press the Reset button on the controller to 
reboot it.

7. Right-click the controller under Remote Systems in the Configuration pane in MAX and select 
Format Disk. 

8. (Optional) Enable the Keep Network Settings checkbox if you want to retain the same target name 
and IP address. 

9. Click Format to start formatting the disk.

10. When MAX finishes formatting the disk, set the Safe Mode switch to the Off position and click 
OK.

11. Select the System Settings tab and type a descriptive name for the system in the Hostname field.

12. (Optional) Complete this step only if the target has an empty IP address (0.0.0.0). Select the 
Network Settings tab and select DHCP or Link Local from the Configure IPv4 Address list to 
assign an IP address or select the Static to specify a static IP address in the IPv4 Address section.

13. Click Save on the toolbar and let MAX reboot the system.

14. When the new system name appears under Remote Systems, expand the controller item in the tree, 
right-click Software, and select Add/Remove Software.

15. Select a recommended software set that includes NI-RIO 3.4.0 or later. 

Note If you are using the NI SoftMotion Module 2010 SP1 or earlier, also select LabVIEW 
NI SoftMotion Module Scan Engine Support from the list.

16. Click Next.

17. Select LabVIEW NI SoftMotion Module from the add-ons list.

18. Click Next to install the selected software on the controller. Click Help if you need information 
about installing recommended software sets.

19. When the software installation completes, click Finish to reboot the controller.

20. Close MAX.

Step 2: Creating a Project and Adding an NI SoftMotion Axis
Complete the following steps to create a LabVIEW project. 

1. Launch LabVIEW by selecting Start»All Programs»National Instruments»LabVIEW.

2. Click the Empty Project link in the Getting Started window to display the Project Explorer 
window. You can also select File»New Project to display the Project Explorer window.

3. Select Help and make sure that Show Context Help is checked. You can refer to the context help 
throughout the tutorial for information about items on the block diagram.
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4. Right-click the top-level project item in the Project Explorer window and select New»Targets 
and Devices from the shortcut menu to display the Add Targets and Devices dialog box. Refer to 
Figure 18 for more information.

Figure 18.  Adding a New Target

5. Make sure that the Existing target or device radio button is selected.

6. Expand Real-Time CompactRIO.

7. Select the CompactRIO controller to add to the project and click OK.

8. If you have LabVIEW FPGA installed, the Select Programming Mode dialog box appears. Select 
Scan Interface to put the system into Scan Interface mode.

Tip Use the CompactRIO Chassis Properties dialog box to change the programming mode in an 
existing project. Right-click the CompactRIO chassis in the Project Explorer window and select 
Properties from the shortcut menu to display this dialog box.

9. Click Discover in the Discover C Series Modules? dialog box if it appears.

10. Click Continue. 

11. Right-click the controller item in the Project Explorer window and select Properties from the 
shortcut menu to display the RT Target Properties dialog box. Select Scan Engine from the 
Category list to display the Scan Engine page. 
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12. Set the Scan Period to 10 ms or lower, then click OK to close the RT Target Properties dialog 
box.

13. If you did not reformat the CompactRIO device in Step 1: Install Software on and Configure the 
NI RT Controller, expand the real-time target. If an axis already exists on the target, right-click the 
axis and select Remove from Project, or temporarily associate it with different hardware using the 
Axis Manager dialog box. You cannot associate two axes with the same hardware device. Refer to 
Figure 20 to view a project with an axis on the target.

14. Right-click the controller item in the Project Explorer window and select New»NI SoftMotion 
Axis from the shortcut menu to open the Axis Manager dialog box, shown in Figure 19.

15. Click Add New Axis to create an NI SoftMotion axis associated with the NI 9512 module. Axes 
are automatically bound to an available module. You can double-click the axis name to rename the 
axis and give it a descriptive name.

Figure 19.  Axis Manager Dialog Box
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16. Click OK to close the Axis Manager dialog box. The new axis is added to the Project Explorer 
window. 

Note You cannot associate more than one axis with the same C Series module.

When you have finished these steps your LabVIEW project should look similar to the image in 
Figure 20.

Figure 20.  Project Explorer Window with Modules in Scan Interface Mode
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Step 3: Configure the NI 9512 C Series Module
Complete the following steps to configure the axis I/O settings for use with the Panasonic Minas A or 
Minas A5 drive.

1. Right-click the axis in the Project Explorer window and select Properties from the shortcut menu 
to open the Axis Configuration dialog box.

Figure 21 shows the parts of the Axis Configuration dialog box for NI 9512 C Series module. 

Figure 21.  Axis Configuration Dialog Box

Note The Axis Configuration dialog box user interface may not match this image exactly 
depending on which version of the LabVIEW NI SoftMotion Module you are using. 

2. On the General Settings page set the Loop Mode to Closed-Loop.

3. Click the Encoder button and configure the Units and Counts Per Unit.

a. Make the following changes in the Active State section:

• Set the Line State for A to High.

• Set the Line State for B to Low.

• Set the Line State for Index to High.

b. In the Index Reference Criteria section set the Line State for A and B to Inactive.

c. Type rev in the Units text box.

d. Set the Counts per rev to the correct value based on your encoder resolution.

Note NI SoftMotion uses x4 encoding, so the encoder resolution needs to be converted to 
quadrature counts per revolution before entering the information into the Axis Configuration dialog 
box. If your encoder does not supply resolution in quadrature counts per revolution, determine 
quadrature counts per revolution by multiplying the encoder resolution in encoder lines or periods by 
four. Encoder counts per revolution is also referred to as counts per index. For example, a 500 line 
encoder has 2,000 quadrature counts per revolution. 
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When you are finished the Encoder Settings page will look similar to Figure 22.

Figure 22.  Axis Configuration Encoder Page

4. Click the Stepper button to open the Stepper page. Configure the stepper output and steps per rev 
settings:

a. Set Output Mode to Step and Direction.

b. Set Output Type to Differential.

c. Set Active State to Low.

d. Set Steps Per rev depending on the encoder resolution. For example, if you are using an 
encoder with 2500 pulses per revolution, set Steps Per rev to 2500. 

When you are finished the Stepper Settings page will look similar to Figure 23.

Figure 23.  Axis Configuration Stepper Page

e. In the Position Error section, change the Position Error Limit to an acceptable value for 
your system. Exceeding the specified position error limit causes NI SoftMotion to disable the 
drive and turn off the Drive Enable signal.
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5. Click the Digital I/O button to open the Digital I/O page and map the following status inputs.

a. Map DI 1 to Servo/Drive Ready. This signal is active when the drive is enabled.

1) Double-click the text in the Mapping column and select Servo/Drive Ready from the 
dropdown list. 

2) Ensure that the DI 1 settings match the following:

• Input Type—Sourcing

• Active State—On

• Digital Filter—50 µs

b. Map DI 2 to In-Position. The In-Position signal from the drive is active when the current 
position is within a user-specified distance from the target position. This is a drive setting.

1) Double-click the text in the Mapping column and select In-Position from the dropdown 
list. 

2) Ensure that the DI 2 settings match the following:

• Input Type—Sourcing

• Active State—On

• Digital Filter—50 µs

c. Map DI 3 to Drive Fault/Alarm. When the Drive Fault/Alarm signal is active, the module 
does not generate command signals.

1) Double-click the text in the Mapping column and select Drive Fault/Alarm from the 
dropdown list. 

2) Ensure that the DI 3 settings match the following:

• Input Type—Sourcing

• Active State—Off

• Digital Filter—50 µs

d. (Optional) Configure a digital output to use for the Alarm Clear signal, if required. Position 
command drives often require an Alarm Clear signal from the module to the drive. This signal 
clears the alarm or fault outputs on the drive. This functionality is not available using a 
mappable digital output. However, you can use a digital output to implement this functionality 
in your code. Complete the following steps to use a digital output as an Alarm Clear output: 

1) Determine the required pulse time and active state for the Alarm Clear signal. This 
information is in the specifications for the position command drive. 

2) Select an available digital output.

3) Configure the digital output Active State, Safe State, and Output Type as required by 
the drive. 

4) In your application VI add code to pulse the digital output line for the appropriate amount 
of time to clear the alarm output. Do not clear the alarm on the drive until the alarm 
condition is resolved.

Note If you are configuring a digital output to use as the Alarm Clear signal, you must connect the 
configured output from the J5 screw terminal connector to the drive Alarm Clear signal on the J4 
screw terminal connector.
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When you are finished the Digital I/O Settings page will look similar to Figure 24.

Figure 24.  Axis Configuration Digital I/O Page

6. Open the Trajectory page and enable the In-Position checkbox. This allows the In-Position input 
to be used as a criteria for move complete. When this signal is included in the move complete 
criteria, the move is only complete if the In-Position signal is active. 

7. Click the Drive Enable button and configure the Drive Enable output settings.

a. Place a checkmark in the Enable checkbox.

b. Set Output Type to Sinking.

c. Set Active State to On.

d. Set Safe State to Off.

8. Complete the following additional steps if you do not have limits and home connected at this time:

a. Open the Limits & Home page.

b. In the Forward Limit and Reverse Limit sections ensure that the settings match the 
following:

Note These configuration settings disable limits for initial setup and testing purposes. National 
Instruments recommends connecting and enabling limits in your final application.

• Clear the Enable checkbox from both Forward Limit and Reverse Limit. 

• Set the Active State for both Forward Limit and Reverse Limit to Off. This prevents 
a limit warning even though limits are turned off.

c. Open the Home section and clear the Enable checkbox.

9. Configure any additional I/O settings according to your system requirements, such as position 
compare or position capture signals.

10. Click OK to close the Axis Configuration dialog box.

11. Right-click the controller item in the Project Explorer window and select Deploy All to deploy 
the axis information.

12. Click Apply in the Conflict Resolution dialog box when it appears.

13. Select File»Save Project to save the project.
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Step 4: Enable and Test the Drive Using LabVIEW
Use the Interactive Test Panel to test and debug your motion system and configuration settings on the 
selected axis. With the Interactive Test Panel you can perform a simple straight-line move and monitor 
feedback position and position error information, move and I/O status information, change move 
constraints, get information about software errors and faults, and view position or velocity plots of the 
move. 

Complete the following steps to test your setup after configuring the axis using the Axis Configuration 
dialog box.

1. Right-click the axis in the Project Explorer window and select Interactive Test Panel from the 
shortcut menu. 

2. On the Move tab set Target Position to 25 revolutions.

3. On the Move Constraints tab set Velocity to 1 revolution/sec. Using the encoder counts per 
revolution and stepper steps per revolution values specified in this tutorial the motor will move 
25 revolutions at 60 RPM. Click the Help button for detailed information about the items available 
in this dialog box.

4. Click the Enable button to enable the drive.

5. Click the Start button on the bottom of the dialog box to start the move with the configured options.

6. Use the Status and Plots tabs to monitor the move while it is in progress.

Finalize your motion system setup by connecting and configuring additional I/O such as limits as 
required by your system using the screw terminal connectors on the NI 9930P accessory. 
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NI 9930Y Motion Control Accessory for Yaskawa Servo Drives
The NI 9930Y motion control accessory allows easy connection between the NI 9512 C Series drive 
interface module and the Yaskawa Sigma II and Sigma V servo drive.

What You Need to Get Started
You need the following items to get started.

Hardware
❑ NI 9930Y Motion Control Accessory and NI 951x Y-cable.

(NI part number 781822-01)

❑ NI 9512 C Series stepper drive interface module.
(NI part number 779944-01)

❑ NI real-time controller and chassis that support the RIO Scan Interface.

Tip To determine if your controller and chassis support the RIO Scan Interface go to ni.com/
info and enter rdsoftwareversion.

❑ 24 V power supply (such as the NI PS-15) for the CompactRIO controller.
(NI part number 781093-01)

Note Refer to the controller operating instructions for power supply requirements.

❑ 24 V power supply (such as the NI PS-15) for the NI 9930M. This supply also powers the NI 9512 
and any drive I/O.
(NI part number 781093-01)

Note Refer to the NI 9512 Operating Instructions and Specifications and the drive manual to verify 
that the selected power supply meets the system requirements.

❑ Ethernet connection and cable for the CompactRIO controller.

❑ 50-pin MDR cable to connect the accessory to the drive.
(NI part number 194604-02)

❑ Yaskawa Sigma-II or Sigma-V position-command servo drive.

Note The Yaskawa Sigma-II drive product numbers start with SGDH, and the Yaskawa Sigma-V 
drive product numbers start with SGDV.

❑ Servo motor, encoder, power supply, and associated cables to connect the motor and encoder to the 
drive.

Software
❑ LabVIEW 2009 SP1 or later

❑ LabVIEW 2009 SP1 Real-Time Module or later

❑ LabVIEW 2009 SP1 NI SoftMotion Module or later

❑ NI-RIO 3.4.0 or later
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Figure 25 shows a simplified connection diagram.

Figure 25.  NI 9930Y Connection Accessory Connections
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Figure 26 shows an overview of the connectors on the NI 9930Y connection accessory.

Figure 26.  NI 9930Y Connection Accessory Connectors

1 J1, J4, and J5: User I/O Screw Terminal Connectors
2 DS1: +5 V Power LED (from NI 9512)
3 DS2: +24 V Power LED

4 J6: + 24 V Power Supply Connector
5 J3: NI 9512 Connector
6 J2: Sigma-II and Sigma-V Connector

F
R
O
N
T

3612 24

251 13

COM

VSUP

FOR PATENTS: NI.COM/PATENTS

J4J1 J5

J3

DS1 DS2

J6J2

12345678910111213141516171819

202122232425262728293031323334353637

10 9 8 7 6 5 4 3 2 11120 19 18 17 16 15 14 13 1225 24 23 22 21

35 34 33 32 31 30 29 28 27 263645 44 43 42 41 40 39 38 3750 49 48 47 46

+5 V Out +24 V

1

3

4

2

5

6



© National Instruments Corporation 37 NI 9930 Motion Control Accessories User Guide

Hardware Installation and Configuration

Step 1: Set Up the CompactRIO System
Complete the following steps to set up the CompactRIO hardware.

1. Install the real-time CompactRIO controller on the chassis if you are not using an integrated 
controller and chassis. 

Note Write down the controller serial number before installing the controller onto the chassis. 
You will be unable to read the serial number after you install the controller.

a. Make sure that no power is connected to the controller or the chassis.

b. Align the controller with the chassis as shown in Figure 27. 

Figure 27.  Installing the Controller on the Chassis (Eight-Slot Chassis Shown)

c. Slide the controller onto the controller slot on the chassis. Press firmly to ensure the chassis 
connector and the controller connector are mated. 

d. Using a number 2 Phillips screwdriver, tighten the two captive screws on the front of the 
controller.

1 Controller
2 Captive Screws
3 Controller Slot

4 Reconfigurable Embedded Chassis
5 Grounding Screw

4

5

1

3
2
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2. Connect the controller to a power supply and an Ethernet network on the same subnet as the 
development computer. Refer to the controller operating instructions for information about wiring 
the controller to the power supply and Ethernet network.

Note Do not plug in or turn on any power to the system until after you complete Step 3: Configure 
the Drive and Connect the Motor and Encoder to the Drive.

3. Install the NI 9512 module in slot 1, 2, 3, or 4 of the chassis.

Step 2: Connect the NI 9930Y Connection Accessory
The NI 9930Y connection accessory contains connections for the NI 9512 C Series module, the 
Yaskawa Sigma-II or Sigma-V servo drive, and a 24 V power supply for NI 9512 module and drive I/O.

1. Connect the NI 9512 module to the NI 9930Y J3 connector using the NI 951x Y cable.

2. Connect the NI 9930Y J2 connector to the drive CN1 connector using the 50-pin MDR cable.

3. Connect a 24 V power supply to the Vsup and COM terminals on the NI 9930Y accessory J6 
connector. Figure 26 shows the location of the power supply input.

4. Connect pin 15 (P-OT - Forward Drive Prohibit Input) and pin 14 (N-OT - Reverse Drive Prohibit 
Input) to pin 13 (COM).

Note These configuration settings disable limits for initial setup and testing purposes. National 
Instruments recommends connecting and enabling limits in your final application. Refer to the drive 
documentation for limit input requirements.

5. Connect any additional I/O, such as limits, DIO, position compare outputs, position capture inputs, 
and so on, using the NI 9930Y screw terminal connectors. The J1 and J4 connectors allow 
connection to the drive I/O signals, and the J5 connector provides connection to the NI 9512 I/O 
signals. Refer to the drive or the NI 9512 module documentation for specific signal connection 
requirements.
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Figure 28 shows the screw terminal connector pinouts.

Figure 28.  NI 9930Y I/O Connectors
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Step 3: Configure the Drive and Connect the Motor and Encoder to the Drive
This section covers the minimum drive settings and connections to allow the motor to move. Refer to
the drive manual for additional information about drive parameters and signal information.

1. Configure the drive for position control mode by setting parameter Pn000 to n.0010. This 
parameter is the same for the Sigma-II and Sigma-V drive.

2. Ensure that the drive encoder output pulses and electronic gear parameters are set to the default 
values:

Yaskawa Sigma-II

a. Set parameter Pn200 to n.0000. 

b. Set parameter Pn202 to 4 and parameter Pn203 to 1. This specifies a one to four ratio of steps 
to counts.

c. Set parameter Pn201 to 2048. This is the maximum allowable value for this parameter when 
you are using an incremental encoder. If you change this value, you must also change the value 
specified for the encoder Counts per rev in Step 3: Configure the NI 9512 C Series Module 
of the Software Installation and Configuration section by multiplying the value specified here 
by four.

Yaskawa Sigma-V

a. Set parameter Pn20E to 4 and parameter Pn210 to 1. This specifies a one to four ratio of steps 
to counts.

b. Set parameter Pn212 to 2048. If you change this value, you must also change the value 
specified for the encoder Counts per rev in Step 3: Configure the NI 9512 C Series Module 
of the Software Installation and Configuration section by multiplying the value specified here 
by four.

3. Connect the motor and encoder to the drive. Refer to the documentation specific to your drive for 
motor and encoder connection information.

Tip An incorrectly connected encoder may cause NI SoftMotion to return error -77076 
(NIMCDM_driveReadyNotActiveError). Verify the encoder connections if you see this error.

4. Connect the drive power. Refer to the drive documentation for power connections and 
specifications.

5. Plug in the hardware once all connections are made and continue to the next section.

Software Installation and Configuration
This section covers installing and configuring the software for the NI 9512 C Series drive interface 
module. It assumes that all required software from the What You Need to Get Started section is installed.

Step 1: Install Software on and Configure the NI RT Controller
Complete the following steps to configure the controller and install software on it.

Note The Measurement & Automation Explorer (MAX) user interface may not match these steps 
exactly depending on which version of MAX you are using. 

1. Launch MAX on the development computer by clicking the MAX icon on the desktop, or by 
selecting Start»All Programs»National Instruments»Measurement & Automation.

2. Select the controller under Remote Systems in the Configuration pane. If you do not see the 
controller, you may need to disable the firewall on the development computer. Go to 
ni.com/info and enter RIOMAXTroubleshoot for more information.
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3. Verify that the Serial Number in the General Settings section matches the serial number on the 
device.

4. If you do not want to format the disk on the controller, eliminating all installed software and files, 
skip to step 14.

5. Set the Safe Mode switch on the controller to the On position.

6. Power on the controller. If it is already powered on, press the Reset button on the controller to 
reboot it.

7. Right-click the controller under Remote Systems in the Configuration pane in MAX and select 
Format Disk. 

8. (Optional) Enable the Keep Network Settings checkbox if you want to retain the same target name 
and IP address. 

9. Click Format to start formatting the disk.

10. When MAX finishes formatting the disk, set the Safe Mode switch to the Off position and click 
OK.

11. Select the System Settings tab and type a descriptive name for the system in the Hostname field.

12. (Optional) Complete this step only if the target has an empty IP address (0.0.0.0). Select the 
Network Settings tab and select DHCP or Link Local from the Configure IPv4 Address list to 
assign an IP address or select the Static to specify a static IP address in the IPv4 Address section.

13. Click Save on the toolbar and let MAX reboot the system.

14. When the new system name appears under Remote Systems, expand the controller item in the tree, 
right-click Software, and select Add/Remove Software.

15. Select a recommended software set that includes NI-RIO 3.4.0 or later. 

Note If you are using the NI SoftMotion Module 2010 SP1 or earlier, also select LabVIEW 
NI SoftMotion Module Scan Engine Support from the list.

16. Click Next.

17. Select LabVIEW NI SoftMotion Module from the add-ons list.

18. Click Next to install the selected software on the controller. Click Help if you need information 
about installing recommended software sets.

19. When the software installation completes, click Finish to reboot the controller.

20. Close MAX.

Step 2: Creating a Project and Adding an NI SoftMotion Axis
Complete the following steps to create a LabVIEW project. 

1. Launch LabVIEW by selecting Start»All Programs»National Instruments»LabVIEW.

2. Click the Empty Project link in the Getting Started window to display the Project Explorer 
window. You can also select File»New Project to display the Project Explorer window.

3. Select Help and make sure that Show Context Help is checked. You can refer to the context help 
throughout the tutorial for information about items on the block diagram.
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4. Right-click the top-level project item in the Project Explorer window and select New»Targets 
and Devices from the shortcut menu to display the Add Targets and Devices dialog box. Refer to 
Figure 29 for more information.

Figure 29.  Adding a New Target

5. Make sure that the Existing target or device radio button is selected.

6. Expand Real-Time CompactRIO.

7. Select the CompactRIO controller to add to the project and click OK.

8. If you have LabVIEW FPGA installed, the Select Programming Mode dialog box appears. Select 
Scan Interface to put the system into Scan Interface mode.

Tip Use the CompactRIO Chassis Properties dialog box to change the programming mode in an 
existing project. Right-click the CompactRIO chassis in the Project Explorer window and select 
Properties from the shortcut menu to display this dialog box.

9. Click Discover in the Discover C Series Modules? dialog box if it appears.

10. Click Continue. 

11. Right-click the controller item in the Project Explorer window and select Properties from the 
shortcut menu to display the RT Target Properties dialog box. Select Scan Engine from the 
Category list to display the Scan Engine page. 
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12. Set the Scan Period to 10 ms or lower, then click OK to close the RT Target Properties dialog 
box.

13. If you did not reformat the CompactRIO device in Step 1: Install Software on and Configure the 
NI RT Controller, expand the real-time target. If an axis already exists on the target, right-click the 
axis and select Remove from Project, or temporarily associate it with different hardware using the 
Axis Manager dialog box. You cannot associate two axes with the same hardware device. Refer to 
Figure 31 to view a project with an axis on the target.

14. Right-click the controller item in the Project Explorer window and select New»NI SoftMotion 
Axis from the shortcut menu to open the Axis Manager dialog box, shown in Figure 30.

15. Click Add New Axis to create an NI SoftMotion axis associated with the NI 9512 module. Axes 
are automatically bound to an available module. You can double-click the axis name to rename the 
axis and give it a descriptive name.

Figure 30.  Axis Manager Dialog Box

16. Click OK to close the Axis Manager dialog box. The new axis is added to the Project Explorer 
window. 

Note You cannot associate more than one axis with the same C Series module.
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When you have finished these steps your LabVIEW project should look similar to the image in 
Figure 31.

Figure 31.  Project Explorer Window with Modules in Scan Interface Mode

Step 3: Configure the NI 9512 C Series Module
Complete the following steps to configure the axis I/O settings for use with the Yaskawa Sigma II or 
Sigma V drive.

1. Right-click the axis in the Project Explorer window and select Properties from the shortcut menu 
to open the Axis Configuration dialog box.

Figure 32 shows the parts of the Axis Configuration dialog box for NI 9512 C Series module. 

Figure 32.  Axis Configuration Dialog Box
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Note The Axis Configuration dialog box user interface may not match this image exactly 
depending on which version of the LabVIEW NI SoftMotion Module you are using. 

2. On the General Settings page set the Loop Mode to Closed-Loop.

3. Click the Encoder button and configure the Units and Counts Per Unit.

a. Make the following changes in the Active State section:

• Set the Line State for A to High.

• Set the Line State for B to High.

• Set the Line State for Index to High.

b. In the Index Reference Criteria section set the Line State for A and B to Inactive.

c. Type rev in the Units text box.

d. Set the Counts per rev to the correct value based on your encoder resolution.

Note NI SoftMotion uses x4 encoding, so the encoder resolution needs to be converted to 
quadrature counts per revolution before entering the information into the Axis Configuration dialog 
box. If your encoder does not supply resolution in quadrature counts per revolution, determine 
quadrature counts per revolution by multiplying the encoder resolution in encoder lines or periods by 
four. Encoder counts per revolution is also referred to as counts per index. For example, a 500 line 
encoder has 2,000 quadrature counts per revolution. 

When you are finished the Encoder Settings page will look similar to Figure 33.

Figure 33.  Axis Configuration Encoder Page

4. Click the Stepper button to open the Stepper page. Configure the stepper output and steps per rev 
settings:

a. Set Output Mode to Step and Direction.

b. Set Output Type to Differential.

c. Set Active State to Low.

d. Set Steps Per rev depending on the encoder resolution. For example, if you are using an 
encoder with 2048 pulses per revolution, set Steps Per rev to 2048. 
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When you are finished the Stepper Settings page will look similar to Figure 34.

Figure 34.  Axis Configuration Stepper Page

e. In the Position Error section, change the Position Error Limit to an acceptable value for 
your system. Exceeding the specified position error limit causes NI SoftMotion to disable the 
drive and turn off the Drive Enable signal.

5. Click the Digital I/O button to open the Digital I/O page and map the following status inputs.

a. Map DI 1 to Servo/Drive Ready. This signal is active when the drive is enabled.

1) Double-click the text in the Mapping column and select Servo/Drive Ready from the 
dropdown list. 

2) Ensure that the DI 1 settings match the following:

• Input Type—Sourcing

• Active State—On

• Digital Filter—50 µs

b. Map DI 2 to In-Position. The In-Position signal from the drive is active when the current 
position is within a user-specified distance from the target position. This is a drive setting.

1) Double-click the text in the Mapping column and select In-Position from the dropdown 
list. 

2) Ensure that the DI 2 settings match the following:

• Input Type—Sourcing

• Active State—On

• Digital Filter—50 µs

c. Map DI 3 to Drive Fault/Alarm. When the Drive Fault/Alarm signal is active, the module 
does not generate command signals.

1) Double-click the text in the Mapping column and select Drive Fault/Alarm from the 
dropdown list. 

2) Ensure that the DI 3 settings match the following:

• Input Type—Sourcing

• Active State—Off

• Digital Filter—50 µs
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d. (Optional) Configure a digital output to use for the Alarm Clear signal, if required. Position 
command drives often require an Alarm Clear signal from the module to the drive. This signal 
clears the alarm or fault outputs on the drive. This functionality is not available using a 
mappable digital output. However, you can use a digital output to implement this functionality 
in your code. Complete the following steps to use a digital output as an Alarm Clear output: 

1) Determine the required pulse time and active state for the Alarm Clear signal. This 
information is in the specifications for the position command drive. 

2) Select an available digital output.

3) Configure the digital output Active State, Safe State, and Output Type as required by 
the drive. 

4) In your application VI add code to pulse the digital output line for the appropriate amount 
of time to clear the alarm output. Do not clear the alarm on the drive until the alarm 
condition is resolved.

Note If you are configuring a digital output to use as the Alarm Clear signal, you must connect the 
configured output from the J5 screw terminal connector to the drive Alarm Clear signal on the J1 
screw terminal connector.

When you are finished the Digital I/O Settings page will look similar to Figure 35.

Figure 35.  Axis Configuration Digital I/O Page

6. Open the Trajectory page and enable the In-Position checkbox. This allows the In-Position input 
to be used as a criteria for move complete. When this signal is included in the move complete 
criteria, the move is only complete if the In-Position signal is active. 

7. Click the Drive Enable button and configure the Drive Enable output settings.

a. Place a checkmark in the Enable checkbox.

b. Set Output Type to Sinking.

c. Set Active State to On.

d. Set Safe State to Off.
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8. Complete the following additional steps if you do not have limits and home connected at this time:

a. Open the Limits & Home page.

b. In the Forward Limit and Reverse Limit sections ensure that the settings match the 
following:

Note These configuration settings disable limits for initial setup and testing purposes. National 
Instruments recommends connecting and enabling limits in your final application.

• Clear the Enable checkbox from both Forward Limit and Reverse Limit. 

• Set the Active State for both Forward Limit and Reverse Limit to Off. This prevents 
a limit warning even though limits are turned off.

c. Open the Home section and clear the Enable checkbox.

9. Configure any additional I/O settings according to your system requirements, such as position 
compare or position capture signals.

10. Click OK to close the Axis Configuration dialog box.

11. Right-click the controller item in the Project Explorer window and select Deploy All to deploy 
the axis information.

12. Click Apply in the Conflict Resolution dialog box when it appears.

13. Select File»Save Project to save the project.

Step 4: Enable and Test the Drive Using LabVIEW
Use the Interactive Test Panel to test and debug your motion system and configuration settings on the 
selected axis. With the Interactive Test Panel you can perform a simple straight-line move and monitor 
feedback position and position error information, move and I/O status information, change move 
constraints, get information about software errors and faults, and view position or velocity plots of the 
move. 

Complete the following steps to test your setup after configuring the axis using the Axis Configuration 
dialog box.

1. Right-click the axis in the Project Explorer window and select Interactive Test Panel from the 
shortcut menu. 

2. On the Move tab set Target Position to 25 revolutions.

3. On the Move Constraints tab set Velocity to 1 revolution/sec. Using the encoder counts per 
revolution and stepper steps per revolution values specified in this tutorial the motor will move 
25 revolutions at 60 RPM. Click the Help button for detailed information about the items available 
in this dialog box.

4. Click the Enable button to enable the drive.

5. Click the Start button on the bottom of the dialog box to start the move with the configured options.

6. Use the Status and Plots tabs to monitor the move while it is in progress.

Finalize your motion system setup by connecting and configuring additional I/O such as limits as 
required by your system using the screw terminal connectors on the NI 9930Y accessory. 
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Additional NI 9930 Accessories Connector Pinouts
This section contains pinouts for the 37-pin Dsub connector to the NI 9512 module and the MDR 
connectors to the drive for each NI 9930 accessory.

Figure 36.  NI 9930P I/O Connectors

Reverse Limit
Reserved
+24 V
Reserved
COM
Phase A+
Phase A–
Phase B+
Position Capture
Phase B–
Reserved
Reserved
COM
Enable (Servo On)
DI 3 (Drive Fault)
Dir–
DI 2 (In-Position)
Step–

Forward Limit
Home
COM
DI 0

COM
Index+
Index–

COM
+5 V Out

Position Compare
Reserved
reserved

DO 0
+24 V

DI 1 (Servo Ready)
Dir+

COM
Step+
DO 1

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37

J3 - NI 9512 Connector

10
9
8
7
6
5
4
3
2
1

11

20
19
18
17
16
15
14
13
12

25
24
23
22
21

35
34
33
32
31
30
29
28
27
26

36

45
44
43
42
41
40
39
38
37

50
49
48
47
46

J2 - Minas A or Minas A5
Connector

COM
Index–
Index+
Phase A–
Phase A+
NC
NC
Negative Direction Torque Limit Input (N-ATL)
COM
Positive Direction Torque Limit Input (P-ATL/TRQR)
COM
Analog Torque Command Input (SPR/TRQR/SPL)
COM
Zero Speed
Brake Off+
Brake Off–
Positive Direction Over Travel (POT)
Negative Direction Over Travel (NOT)
+24 V
SIGN2
SIGN1
PUSL2
PULS1
NC
NC

COM
Phase B–
Phase B+
SIGNH2*
SIGNH1*
PULSH2*
PUSLH1*

Speed Monitor Output (SP)
Torque Monitor Output (IM)

COM
Torque Limit Input (TLC)

DI 2 (In-Position)
COM

DI 3 (Drive Fault)
COM

DI 1 (Servo Ready)
COM

Inhibit Input
Control Mode Input (C-MODE)

Alarm Clear
Position Error Clear Input (CL)

Enable (Servo On)
Electronic Gear Switching Input 1 (DIV)

Gain Switching Input (GAIN)
Damping Control Switching Input 1 (VS-SEL1)

* High-speed 4M RS-422 Inputs Available on Minas A5 Drive Only

1S
T
E
P
 
&
 
D
I
R
E
C
T
I
O
N

1
0

3
4

2
2

2
3

1
1

F
O
R
 
P
A
T
E
N
T
S
:
 
N
I
.
C
O
M
/
P
A
T
E
N
T
S

J2J3

J4

J5

J1

W
1

W
2

W
3

W
4

J
6

FRONT

C
O
M

V
S
U
P

D
S
1

D
S
2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19

20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37

10
9
8
7
6
5
4
3
2
1

11

20
19
18
17
16
15
14
13
12

25
24
23
22
21

35
34
33
32
31
30
29
28
27
26

36

45
44
43
42
41
40
39
38
37

50
49
48
47
46

+
5 V

 O
ut

+
24 V



NI 9930 Motion Control Accessories User Guide 50 ni.com

Figure 37.  NI 9930M I/O Connectors
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Figure 38.  NI 9930Y I/O Connectors
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J2 - Sigma-II or Sigma-V Connector
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Related Documentation
The following documents contain additional information that you may find helpful. All referenced 
documents ship with the product and are available at ni.com/manuals.

• Operating instructions for the controller and C Series modules.

• Applicable drive manual.

• Getting Started with NI 951x C Series Modules and LabVIEW—Use this document to learn 
about using the NI 951x modules with LabVIEW, including information about the 
LabVIEW NI SoftMotion Module. To access this document, select Start»All Programs»
National Instruments»LabVIEW»LabVIEW Manuals»
Getting_Started_NI_951x_Modules_LabVIEW.pdf.

• LabVIEW NI SoftMotion Module Help—Use this help file to learn about using the NI SoftMotion 
Module in LabVIEW including information about function blocks and using the NI SoftMotion 
Module with the LabVIEW Project. To access this help file from LabVIEW, select Help»
LabVIEW Help, then expand the LabVIEW NI SoftMotion Module book on the Contents tab.

Worldwide Support and Services
The National Instruments Web site is your complete resource for technical support. At ni.com/
support you have access to everything from troubleshooting and application development self-help 
resources to email and phone assistance from NI Application Engineers.

Visit ni.com/services for NI Factory Installation Services, repairs, extended warranty, calibration, 
and other services. 

Visit ni.com/register to register your National Instruments product. Product registration facilitates 
technical support and ensures that you receive important information updates from NI. 

A Declaration of Conformity (DoC) is our claim of compliance with the Council of the European 
Communities using the manufacturer’s declaration of conformity. This system affords the user 
protection for electromagnetic compatibility (EMC) and product safety. You can obtain the DoC for 
your product by visiting ni.com/certification. If your product supports calibration, you can 
obtain the calibration certificate for your product at ni.com/calibration.

National Instruments corporate headquarters is located at 11500 North Mopac Expressway, Austin, 
Texas, 78759-3504. National Instruments also has offices located around the world to help address your 
support needs. For telephone support in the United States, create your service request at ni.com/
support and follow the calling instructions or dial 512 795 8248. For telephone support outside the 
United States, visit the Worldwide Offices section of ni.com/niglobal to access the branch office 
Web sites, which provide up-to-date contact information, support phone numbers, email addresses, and 
current events.
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