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NI VISION - SMART CAMERA

Este ejercicio le dara una introducciéon al diagrama de estados y a las heramientas del
Software Vision Builder Al En este ejercicio se contaran el nimero de cables conectados a
un plug, los cuales se encuentran en el disco de demostracién. Si un cable falta, entonces la
pieza falla y los resultados se podran observar en las salidas ISO o e ISO 1.

REQUERIMIENTOS

e Kit de demostracion de Smart Camera
e Disco demo con conectores
e National Instruments Vision Builder 2010

CONFIGURANDO LA DIRECCION IP

1. Haga click en Inicio>>Todos los Programas>>National Instruments>>
Vision Builder Al

2. En laventana de Bienvenida, en la casilla Select Network a Target to Run Vision
Builder AI seleccione ESI 192.168.0.5 Ready. En el campo Configure
Inspection seleccione New Inspection.
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ADQUISICION DE IMAGENES

Coloque el disco con los conectores en la plataforma de rotacién. Asegirese que el disco quede
correctamente ajustado en la plataforma. Siga las instrucciones para configurar la adquisicion
de imagenes para esta inspeccion.

Al finalizar los siguientes pasos La Smart Camera debera encender la iluminacion del anillo
y adquirir una imagen cada que se dé un trigger, el cual se observara con el led Rojo (TRIG)
ubicado en la base de la camara.



. . - . |
1. En la paleta Inspection Steps, seleccione la pestana Acquire Image.

2. Haga click en Aquire Image (Smart Camera) "'l La pagina de propiedad para
este pase se abrira

3. En el recuadro de Step Name, ingrese nombre Adquirir Imagen.
4. Ajuste el tiempo de exposicion (Exposure Time) en 0,504 ms.
5. Ajuste la ganancia (Gain) a 170.
> »
Step Name

Adquirr Imagen

Exposure Time (ms)
__ 0,504 &
U,Ol 0, 1 lU 100 2000

Gain

__ 170 &
0 100 200 300 400 511
Max Frame Rate (frames/s.) 60,00

Lok | [ concel |

6. En la pestafia Lighting haga click en el boton Configure Light, para abrir el cuadro
de dialogo de configuracion de la iluminacion.

7. Seleccione la opcion de luz National Instruments>>RL1424-660 (Ring Light,
Red), y de clic en OK.

. 2
E‘ Configure Light P9
(*) select Light (O Enter Light Protection Data
= Mational Instruments _A' Exceeding the maximum current or timing limits
@) BLO40401-660 (Back Light, Red) Bl ! specified by the manufacturer will damage the
@ LLS306-625 (Line Light, Red) | lighting device. Consult the documentation For the

lighting device to determine the correct limits and

v/ RL1424-660 (Ring Light, Red) enter them below.

% 5L2420-660 (Spot Light, Red)

= Advanced Ilumination
(V) ALOB4-BGW (Linear Array, 2" x 3", BLUE/GREEI
(/) ALOB4-R (Linear Array, 2" x 3", BLUE/GREEN]W

Maximum Continuous Current (ma) SO -

. Maximum Strobe Current (ma) 50 -
(v/) AL4424-BGW (Broad Area Linear Array, Blue/G
(v/) AL4424-RIR (Broad Area Linear Array, REDJIR] Maximum Strobe Duration (ms) 0,000
. .’T:"\ Al ACCA B IDvand Avas limaney Aevass ﬂ}(‘,}}l*. .
£ ] I | ) Maximum Strobe Duty Cycle (%) 0,00 ~
This File has been digitally signed by National
9 » Instruments. See Help for details,
| OK ll Cancel || Help I

8. Habilite la casilla Enable Direct Drive Lighting. Esto encendera la iluminacién
conectada a la Smart Camera.



9. Ajuste la opcion Direct Drive Lighting Mode a Strobed.

10. Ajuste la opcion Desired Current Level (mA) a 1000.

Main | Trigger  Lighting I Advanced |

> > Configure Light...

Enable Direct Drive Lighting
Direct Drive Lighting Mode  Strobed v

Desired Current Level (mA)

I I 1 I ] I, 1000 ¢
S0 200 400 600 800 1000
Actual Current Level: 1000 ma.

External Strobe Generation
[[] 5 v TTL Strobe

[[] 24 v strobe

[ OK ] [ Cancel ]

11. En la pestafia Trigger, habilite la casilla Triggered Acquisition, y ajuste Trigger
Polarity a Falling Edege.

» >

Triggered Acquisition
Trigger Polarity | Falling Edge v

Exposure Delay o =

Delay Unit milliseconds v
Timeout S000 (24 ms
Acquisition Mode
() Wait for Next Image
(® Immediate
I OK I l Cancel ]

12. Rote el disco y active el boton (Grab) > para iniciar la adquisicién. Observe que el

trigger de la camara se activa cuando alguno de los objetos pasa debajo de ella.
Inmediatamente aparece en el panel del software la siguiente imagen.




13. De clic en OK para iniciar la inspeccion.

INSPECCION

Complete las siguientes instrucciones para contar el nimero de cables conectados a los plugs
que se encuetran en la bandeja. Utilizara la herramienta de deteccion de bordes para
identificar si el nimero de cables es igual a 5, sino la sera etiquetada como pieza fallida.

1. En la paleta de Inspeccion, seleccione el boton Locate Features \i‘

A&

2. Haga click en el paso Find Edges A continuacion se abrird La ventana de
propiedades de la herramienta.
3. Enla casilla Step Name, ingrese Contar Cables.
van [ sowes | v | s D
Step Name
Contar Cables |

Reaion of Interest

Constent v
[ rReposition Region of Interest

Reference Coordinatz System

Step Status

weassll [k [Lconcel ]

4. Dibuje una linea horizontal debajo del conector, atravesando los cables.




5. En la pestana de Settings, ajuste la opcion Edge Polarity a Dark To Bright
Only, Adicional, deshabilite la opciéon Auto Setup, como se muestra en la Figura

Main  Settings | Advanced I Limits |
Look for All Edges v
Edge Polarity Dark to Bright Only |
Auto Setup

Minirmum Edae Strenatl

Edge Strength Profile

83—

50-
-SU-
-88-
Step Status
PASS. [ ok || cancel |

6. En la pestafia Limits, ajuste las opciones de Minimun Number of edges y
Maximun Number of Edgesa5.

Main | Settings | Advanced ' Limits l

Pass Inspection if...

Minimum Number of Edges 5
Maximum Number of Edges 5 @
Number of Edges Found: S
Step Results
Name Value Unit '~
- Edge #1 :
% Position 362,00 pix
¥ Position 234,66  pix
Distance 28,00 pix
Strength 79,73
SNR 19,04 dB
Rising False v
Step Status

_m l OK JlCanceI]




7. Haga click en OK para finalizar la configuracion de la herramienta.

RESULTADOS DE LA INSPECCION.

Una vez se ha determinado cuando un objeto pasa o no el test. Usted debera ajustar la variabe
de estado de la inspeccién Inspection Status, para ello debera seguir los siguientes pasos.

1.

2.
3.

4.

En la paleta de inspeccion, seleccione la herramienta %@ ‘Use Additional Tool.

2
Haga click en el boton B Set Inspection Status.
En el control de Inspection Status, seleccione la opcion Equals specified
measurement, y ajuste el valor a Count Wires - Step Status.

Main

Step Name
Set Inspection Status 1

Inspection Status
() FAILL if any previous step fails
() Equals specified measurement
Count Wires - Step Status v
) pass
() FALL

Inspection Status _

[¥] Update Number of Parts Inspected
Step Status

PASS | | OK ] I Cancel

De clic en OK para finalizar la configuracion.

CONFIGURANDO LAS LINEAS E/S

En la mayoria de las aplicaciones es necesaria la utilizaciébn de senales digitales para
discriminar las piezas malas de las buenas. Complete las siguientes instrucciones para
configurar la inspecciéon de tal forma que cuando la pieza este en correcto estado se encienda
el led ISO Output 0, y cuando la pieza falle se active la salida ISO 1.

1.

2.
3.

~

En la paleta de inspeccion, seleccione la pestaiia Communicate.

—TL

Haga click en el boton === ISmart Camera I/O Pulse step.

En la tabla Pulse Settings, seleccione ISO Out 1.

En el recuadro Pulse Properties, seleccione la opcion Generate Single Pulse.
Ajuste Delay a 0,001 y Width a 50.000. Esto configurara un ancho de pulso de 50ms.

En el control Single Pulse Settings, seleccione la opcion Pulse when this step
runs AND.

Ajuste la opcion Measurement para System Variable-Inspection Status is
Pass.

En la tabla Pulse Settings, seleccione ISO Out 2.

En el recuadro Pulse Properties, seleccione la opcion Generate Single Pulse.



9. Ajuste Delay a 0,001y Width a 50.000. Esto configurara un ancho de pulso de 50ms.

10. En el control Single Pulse Settings, seleccione la opcion Pulse when this step
runs AND.

11. Ajuste la opcién Measurement a System Variable — Inspection Status is Fail.

12. La tabla Pulse Setting se debe ver como se muestra a continuacion.

Skep Marme
Generate Pulse 1

Pulse Settings

Line Action Palarity Delay Widkh Trigger Source
i MI 1742 (img0) IS0 Ouk 0 i Single Pulse Drive High 0,001 m= 50 ms Count Wires - Step Status
MI 1742 {img0) IS0 Quk 1 Single Pulse Drrive High 0,001 ms S0 ms Count Yires - Step Status
Pulse Properties Single Pulse Settings
Action () Do not Update () Abways pulse when this skep runs
(3) Generate Single Pulse (®) Pulss when this step runs AND
C' Stark Pulse Generation Measurement
() Stop Pulse Generation Count YWires - Step Skatus w | is Pass | w
Polarity  |Drive High i :
Timebase Conkinuous Pulse Setkings Test Panel
Delay 0,001 & milliseconds w :
Irmmediake Pulse apply
tidth 50,000 o, Triggered Pulse
Comment Fulse Everytime
IS0 In0g Detects a  Rising Edge

13. Haga click en OK para adicionar un paso de inspeccion.

Complete las siguientes instrucciones para colocar un indicador Boolean en la imagen para
identificar si la pieza esta en buenas condiciones o no.

1. En la paleta Inspection Steps, Seleccione la pestana Additional Tools ‘% ‘

2. Haga click en el paso Custom Overlay @

3. En la casilla Step Name coloque Display Result.

4. En la Tabla Custom Overlay , haga click en Indicator Tool, y dibuje un rectdngulo
sobre la imagen de la pieza..

5. Seleccione Value>> System Variable - Inspection Status.

6. En el control True Text, Ingrese la palabra PASS.

7. En el control False Text, Ingrese la palabra FAIL.

8. Elindicador debe quedar como se muestra a continuacion.



PASS

9. Haga click en OK para colocar el paso de inspeccion
CREANDO UNA INTERFAZ PERSONALIZADA

Vision Builder AI 3.5 incorpora la habilidad para usar una plantilla para personalizar la
interfaz de inspeccion. Complete los siguientes pasos para personalizar la interfaz.

1. Seleccione Tools»Inspection Interface Configuration. Inmediatamente aparece
el cuadro de dialogo Configure Inspection Interface.

2. Enlatabla Inspection Interface, Seleccione Create New Custom Interface
from.

3. Seleccione Template Inspection Interface.
4. Seleccione Two Image Display Indicators.

5. Haga click en OK para cerrar el cuadro de dialogo Configure Inspection Interface.

ACTUALIZACION LAS IMAGENES CORRECTAS Y FALLIDAS

La inspeccion contiene dos imagenes en el display, usted puede actualizar cada display con
una imagen diferente. Siga los siguientes pasos para actualizar la imagen del conector.

Si la imagen del conector es correcta el indicador mostrara que paso el test. Y si la Imagen es
Fallida el indicador mostrara Failed.

£ q
1. Haga click en el botén Toggle Main Window View L2 len la barra de

herramientas. Esto le permite colocar el diagrama de estado en la ventana principal.
Observe el diagrama de inspeccion que aparece por defecto.




Start

Toggling the State Diagram

2. Haga click derecho sobre el diagrama de estado y seleccione Create New State, para
incluir otro paso de inspeccion.

En el control State Name, coloque Passed Part.
Haga click en OK.

Cree otro estado y nombrelo Failed Part.

o o » W

Usted puede arrastrar los items en el diagrama de estado para ubicarlos como desee.
Para reasignar el destino de una transicion (flechas), usted puede arrastrar la cabeza de
la flecha a un estado diferente. Organice el diagrama de estado como se muestra en la
siguiente imagen.

Start

7. Haga click derecho en el estado Inspect y seleccione Create New Transition.

8. Haga click en el estado Failed Part para crear una nueva transicion entre Inspect y
el estado Failed Part.



9. Haga doble click en Transition 1 para abrir el cuadro de dialogo Edit Transition,
Este cuadro le permite configurar la transicion entre los estados.

10. En el control Transition Name, coloque la palabra Failed.

11. En el cuadro de dialogo Edit Transition, modifique el control para transicién cuando
el System Variable - Inspection Status este en Fail.

Este procedimiento activa la transicion de falla siempre y cuando el control System
Variable - Inspection Status sea igual a Fail.

12. Haga click en OK para cerrar el cuadro de dialogo Edit Transition.

13. Haga click en el estado Passed Part en el diagrama de estado. Cualquier paso que
usted coloque adicional sera insertado en el estado Passed Part .

14. En la paleta Inspection Steps , seleccione la pestana Use Additional Tool %@ .

v
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15. Haga click en el paso Update Inspection Ul ="}

16. En la tabla Inspection Interface Indicators, seleccione Image 1.
17. En el control Operation, seleccione Set to Measurement.
18. En el control Images, seleccione Current Image.

19. Haga click en OK para incluir el paso de inspeccion.

20. Haga click en el estado Failed Part en el diagrama de estado.

21. En la paleta Inspection Steps, seleccione la table Use Additional Tools.

22. Haga click en el paso Update Inspection Ul .

23. En la tabla Inspection Interface Indicators, seleccione Image 2.
24. En el control Operation, seleccione Set to Measurement.

25. En el control Images, seleccione Current Image.

26. Haga click en OK para incluir un paso de inspeccién.

GUARDAR Y CORRER LA APLICACION

Siga las instrucciones para guardar la inspeccion y corra la interfaz de inspeccion.

H

1. Seleccione File»Save o haga click en el boton Save de la barra de herramientas.




2. Coloque Connector Inspection en el control Inspection Name.

3. Haga click en Save para guardar la inspeccion.

TIP: Seleccione File»Inspection Properties para incluir una descripcion corta o

comentario de la inspeccion.

4. Seleccione File»Switch to Inspection Interface. La ventana se cierra y se vuelve a

abrir en la interfaz de Inspeccion.

5. Haga click en el bot6n Start Inspection

b

y rote el disco que contiene los

conectores. Note que los LEDs de la Salida ISO 1y de la Salida ISO 2 parpadean cada
vez que pasa un conector bajo la Smarta Camera.

6. Haga click en el boton Stop Inspection
conectores.

para parar la inspeccion de los

7. Seleccione File»Switch to Configuration Interface para volver a la interfaz de

configuracion.



