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Agenda

Standard LabVIEW options

Built-in tools in LabVIEW and their modifications
Additional tools and their modifications
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Agenda

Standard LabVIEW options
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Getting Started \Window

[ LabVIEW = @ % |
File Operate Toocls Help

ElabVIEW (
@ Create Project ‘ (D Open. Existing ‘

Recert Project Templates | Al Recent Files - ]

Blank Project LabVIEW lvproj
Urtitled Project 1 Ivproj
Corfig File lvproj
LabWVIEW vi

Set Config.vi

LV Config Read vi

‘\_-i-‘ Find Drivers and Add-ons Pl Community and Support . ) Welcome to LabVIEW
Connect to devices and expand the " Participate in the discussion forums or " Leamto use LabVIEW and uparade
functionality of LabVIEW. request technical support. : from previous versions.

| I‘-:! LabVIEW News | [Point of VIEW] The Spirt of the Clumper Today

TDimirmd ~F WA COCAD | mmem % mvsmim sl COGZ A
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Getting Started \Window

@ Create Project

@ Open Existing |

Recent Project Templates - [ All Recent Files - ] *
+ B Continuous Measurement and Logging @ Acquisition lvpraj u
Gueued Message Handler @ Logging lvpraj
Blank Project @ TestBench1 Logger lvproj
Blank VI Untitled Project 5.1vproj
Untitled Project 4 lvproj
UIProgrammatic Manipulation Ivproj
Message CQueue lvproj ¥
v NATIONAL
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Getting Started \Window

LabVIEW
File

Operate  Tools Help

Recert Project Templat

Blank Proj

k| Find Drivers and Add-

*0aEn

@ =% ]
2 Create Project | CIRIS |
Choose a starting point for the project:
All Blank Project Templafes -
Templates I %..! Creates a blank project.
CompactRIO
Deskt
m?:RISp Blank VI Templates £
Robatics _',P‘ Creates a blank VI.
Sample Projects
CompactRIO Simple State Machine Templates
Desktop % Facilitates defining the execution sequence for sections of code. More Information
myRIO
MI-579
Real-Time Queuved Message Handler Templates
>0 Facilitates multiple sections of code running in parallel and sending data between therm. More
Information
Actor Framework Templates
Q} Creates an application that consists of multiple, independent tasks that communicate with each
other. This ternplate makes extensive use of LabVIEW classes, More Information
myRIO Project Templates
% Creates a new project for contrelling your myRIO. This template uses code written with the
LabVIEW rmyRIO Toolkit. More Information
myRIO Custom FPGA Project Templates
% Facilitates cust
LabVWIEW FPGH
bl Finite Measun
e Acquires a fini .
waae \nitepaper 14045
Continuous M
P — 'ﬁlﬂ Acquires mea
Additional Search Queued Messa
| Feadhark Fuannrati hi
Fnish | | Cancel || Help |

ni.com
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File Edit View Project Operate Tools

Window Help

(31 611555l 2 [peAvtontr - [ 6 [

serh ﬂ|?’;5'

Tools -> Options

Controls/Functions Palettes
Environment

Search

Pathz

Printing

Source Control

Menu Shortcuts
Revision History
Security

Shared Variable Engine
VI Server

Web Server

Math5cript

Statechart

FPGA Maodule

[] Labels locked by default

Default label position: controls

Classic |Z|

Default label position: indicators

Classic |Z|

[} Options = =
Categol | - Front Panel
Block Diagram CTmT e T pm—mmm——" -

Control Style for New Vs

@ Modern style
(7 Classic style

() System style
() Silver style

Front Panel Grid

Show front panel grid

Default panel grid size (pixels)
12 B

Contrast with panel background

0 25 50 75 100

0]4
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3 LabVIEW.vi Block Di

File Edit View Project Operate Tools

Window Help

:$1§| @LT_I_—I E@ L.QIIE’ % ; 15pt Application Font |~ ||2;v ”’-ﬁ;v :W]F’E |>/<;ar'h

Tools -> Options

.
2 Options E‘m
Category | - Block Diagram

Front Panel
Block Diagram) -
Controls/Functions Palettes General
Environment
Search [V] Place front panel terminals as icons
Paths Place structures with Auto Grow enabled
Printing
Source Control Cenfigure Express VIs immediately ;
Menu Shortcuts [¥] Auto-insert Feedback Node in cycles [file path (dialog if empty)|
Revision History
Security Tip Strips and Labeli
Shared Variable Engine p>trips )
W1 Server Show ti - -
p strips over terminals -
Web Server Murneric Control 2
MathScript Use control caption for subV tip strips
Statechart [ Use transparent free labels
FPGA Module

Use transparent name labels
[7] Labels locked by default Mumeric Control 3

Default label position: contrel terminals and constants ﬁp
Classic EI J

Default label position: indicators

Classic EI

Default label position: other

Classic EI

0K || Cancel || Help

‘7 NATIONAL
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3 LabVIEW.vi Block Di

File Edit View Project Operate Tools
:$1§| VQJEE@ L.QIIE’ < ilSptApplication Font '~ ||2;v ”’-ﬁ;v :W]F’E

Window Help

|>/<;ar'h

N

Tools -> Options

- =
¥ Options E‘Elg
Category | « Controls/Functions Palettes
Front Panel
Bleck Diagram -

Controls/Functions Palettes| Loading B

Environment

Search @ Load palettes in background

Paths () Load palettes when needed

Printing B

Source Control () Load palettes during launch

Menu Shortcuts

Revisi_on History Formatting

Security

Shared Variable Engine Mavigation Buttons

VI Server Label Selected Icons

Web Server E 3
MathScript Palette

Statechart Category (Icons and Text)

FPGA Module E

Use window titles in Functions palette™
[] Sort palette iterns

*Changes to marked options will take effect the next time you start LabVIEW.,

Customizing

To show or hide palette categories, click the Customize button on a pinned palette, select
Change Visible Palettes, and select the categories you want to show or hide.

LabVIEW expands the top-most visible categery on an unpinned palette, Te change the top-
maost visible category, right-click the categery bar on a pinned palette and select Move to Top

from the chartrit menn

| ok || Cancel || Help |

Functions

Q Search | 2, Customize~ |

T ———

ni.com 11
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|* Programming

EY1)2]

Structures Array
- L K
[~ [
Functions

1 GL Search
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File Edit View Project Operate Tools Window Help

[>[®| @[n]|[?](25]valm* .2 [15pt Application Font |~ | (3o |[7Ga~ | |6~ |[Fall

*] Search K

Tools -> Options

Controls/Functions Palettes
Search

Paths

Printing

Source Control

Menu Shortcuts
Revision History
Security

Shared Variable Engine
V1 Server

Web Server
Math5cript

Statechart

FPGA Module

-
£} Options @E‘g
Front Panel
Block Diagram -

Saving Vs

[] Treat read-only Vs as locked
Do not save automatic changes

Enable automatic saving for recovery

() Save before a VI runs

(@ Save before a VI runs and periodically

5 = | minutes

Fonts

Application Font ®

m

E| Use default font

Font Style...

[The quick brown fox jumps over the lazy dog.

*Changes to marked options will take effect the next time you start LabVIEW.

Colors

Use default colors

oK || cancel ||

Help

ni.com
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File Edit View Project Operate Tools Window Help

> |®| @[n|[?](25]valB® . [15pt Application Font |~ |[$o |[7Ga~ | |6~ |[Fall

Tools -> Options

Controls/Functions Palettes
Envirenment

Search

Paths

Printing

Source Control

Menu Shortcuts|

-
2 Options E‘M
Category | ~ Menu Shortcuts
Front Panel
Block Diagram

Menu Iterm™

Shortcut Default

- File

MNew...

MNew MNXT/EV3

- Robot Project...
Targeted VI

Revision History Open... Ctrl+0 Ctrl+ O
Security Target to NXT/EV3
Shared Variable Engine Close Ctrl+W Ctrl+W
VI Server Close All
Web Server Save Ctrl+5 Ctrl+5 ad
MathScript 11 | r
Statechart
EPGA Module Selected ltem | Restore All
| New VI

Shorteut (Press key cembination)

‘ Ctrl+M | Set |

Default Shortcut S

‘ Ctrl+M | Restore |

il *These menu items are applicable on VI windows (panel and diagram) only.
[ ok || cancel || Help

ni.com
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@le . v Computer » Local Disk (C:) » Program

LabVIEW.Ini

Organize - Mj Open = Print Burn Mev
- Favorites Name
Bl Deskt . applib Ty
wsktop CpP: The LabVIEW.ini holds your
4. Downloads , autotest
L Recent Places | CCodeGen customization preferences in a key /
| cintools . .
= Libraries | Database value COnflgurathn.
3 Documents , examples
@' Music . FPGA
k| Pictures . help
B videos | instr.lib
. manuals
1M Computer | menus
&L, Local Disk (C:) | project

'Ehj Metwork

. ProjectTemplates

, readme

| TESOUrCE

J TV

, Targets

. temnplates

J userlib

J vilib

, VIObjCache

WA
£} LabVIEW.exe
&k | LabVIEW.ini
| hvdscaini

|| readme htrml

14
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@le . v Computer » Local Disk (C:) » Program

Organize -

- Favorites
Bl Desktop
4. Downloads

=
= Recent Places

. Libraries
3 Docurments
,J'. Music
k| Pictures

E Videos

1M Computer
£, Local Disk (C)

'Ehj Metwork

j Open =

Print Burn

Mame

, applibs

. autotest

, CCodeGen

. cintools

. Databaze

, examples

. FPGA

. help

, instr.lib

. manuals

J FEenus

. project

. ProjectTemplates

, readme

J TESOUrCE

J TV

, Targets

. temnplates

J userlib

J vilib

, VIObjCache

| WWW
£} LabVIEW.exe
&k | LabVIEW.ini
| hvdscaini

|| readme htrml

Mev

LabVIEW.Ini

APl to read and write keys to

LabVIEW.Ini

Located at

LabVIEVWAresource\dialog\Lvconfig.llb

key

ISuperSec retCLAFeatures

i S

value

15

LY Config Write Boolean.vi

| Eerror out
= L e
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@’Cj | . v Computer » Local Disk (C:) » Program

Organize - j Open = Print Burn Mev
- Favorites Name
B Desktop | applibs
4. Downloads , autotest
| Recent Places . CCodeGen
. cintools
. Libraries | Database
@ Docurments , examples
@' Music . FPGA
[ Pictures | help
B videos | instr.lib
. manuals
1M Computer . menus
&L, Local Disk (C:) | project

?ﬂ Metwork

. ProjectTemplates
, readme
| TESOUrCE
J Vi
, Targets
. temnplates
J user.lib
J vilib
, VIObjCache
WA
£} LabVIEW.exe

| | LabVIEW.ini

| hvdscaini

|| readme htrml

LabVIEW.Ini

Undocumented INI| tokens:

1. QuickBold

2. BookmarkManager.ShowVILIB
3. BookmarkManager.ShowRESOURCE
4. Many more...

‘7 NATIONAL
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Agenda

Built-in tools in LabVIEW and their modifications
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File Edit View Project Operate Tools

Window Help

[5]®] @[11][3] (5] [wal® o [ 156t Appicetion Fort |~ | 3~ |[aa ][00~ |

[+ search

BN

-1 Functions
Programming

g Search l

k

5]

22|

EE
=
EaE

Structures Array Cluster, Clas
g ¢ ¢
[£=
Mumeric Boolean String
E} » [ » = b
& @ A
Compariscn Tirning Dialog & Use
» 3
n UL
File I/Q Waveform  Application
¥ r [E==h ¥
Jo L 3 |
'—-> Jg DS
Synchronizat.. Graphics & 5... Report Gener
B B
Desktop Exec...  VIAnalyzer  Unit Test Fra...
Measurement /O
Instrument I/ O

Mathematics

Signal Processing
Data Communication
Connectivity

Express

Addons

Select a VL.
Real-Time

FPGA Interface
Robotics

k

Functions

(=]

O\ Search | 2 Cu

Wiew This Palette As

4

[* Programming

b

&

[ EA Change Visible Palettes...

Structures Options...
k _IEI F abe] F
[
Murneric Boolean String
E;’ 3 ® 3 - b
[=- A
Compariscn Tirning Dialeg & Use
= k 2
Jun
File /'O Waveform  Application
3 b =it
o ¥
'—-> o =
Synchronizat... Graphics & 5... Report Gener
o W =
Desktop Exec...  VIAnalyzer  Unit Test Fra...

[ ¥ Measurement /0

[ » Instrument /0

[ »  Mathematics

[ » Signal Processing

[ » Data Communication

[ ¥ Connectivity

[ ¥ Express

I'» Addanc

Palettes

-
2 Change Visible Palettes

Available Palette Categories

You are modifying the Functions palette.

Programming
Measurement [/O
Instrument /O

[T Vision and Motion
Mathematics

Signal Processing
Data Communication
Connectivity

[7] Control & Simulation
[ SignalExpress
Express

Addons

[ Favorites

[] User Libraries

[7] Select a V...

»

|~ Select All
Deselect All

Restore Default

m

-

dialog box from the Controls palette,

To change the category visibility of the Controls palette, invoke this

[ ok

H Cancel ][ Help ]

Ld

NATIONAL
INSTRUMENTS"




Choose Environment b . ]
Measurement & Automation Explorer... h ”i‘él [' Search A “ ?
Instrumentation 4

e [Tools -> Advanced -> Edit Palette Set...
Create your own palettes.

Drop code instead of a VI.

Build Application (EXE) from VI...
Convert Build Script...

Source Control »
VI Analyzer »
LLB Manager... I
Import 4 e a re u u
Shared Vaniable 3

Distributed Systern Manager

Find VIs on Disk...

Prepare Example VIs for NI Example Finder...
Remote Panel Connection Manager...

Web Publishing Tool...

Actor Framework Message Maker...

Control and Simulation »
Create Data Link...

Find LabVIEW Add-ons...

MI VeriStand 4
MXT/EV3 Application Browser...

NXT/EV3 Preferences...

MXT/EV3 Terminal... Mass Compile...

Mavigate to Requirements Gateway.. Clear Compiled Object Cache...
Rebot Simulation Model Builder...

) Edit Error Codes...
Sipalbpe=s @ it Palette Set...
VI Package Manager...
Vision Assistant... Create or Edit Express V...

Export Strings...
Options... Impaort Strings...

‘7 NATIONAL
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File Edit View Project Operate Tools Window Help

> @[n][9][25]walm .2 [15pt Application Font |~ |[$~ |[Fa | (69~ |[#al]

lcon Editor

I Icon Editor (LabVIEW.vi)
File Edit Tools Layers Help

Templates | Icon Text | Glyphs | Layers ‘

Categol :
Filter templates by keyword
AII Templates ¢ v

F Library

Framewaorks
= VI

Framewarks L]

mo @
[ T I
M= 2
[l == ]

” Cancel H

ni.com
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3 LabVIEW.ui Block Diagr

File Edit View Project Operate Tools
§>@| :'J!l E;" !L%:! '#D“E’ -+ | 15pt Application Font |~ HEDVI::E;V |G~ Huﬁ

Window Help

lcon Editor

-
I Icon Editor (LabVIEW.vi)

Edit

Close

Tools Layers Help

Ctrl+W

=

=

Categc»ﬁ

Library

VI

Frameworks

Frameworks

Glyph

-

Filter templates by keyword

Ld
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Choose Environment

File Edit View Project Operate

v [® @]

Measurement & Automation Explorer...

Instrumentation » *| Search

e : Tools for LabVIE

Math5cript Window...

DSC Module »

Compare
Merge
Profile
Security

You can place your own tools here!
Just put your LabVIEW Vls here:

Convert Build Script...

v v v ow

| [LabVIEWXXXXN\Project

Distributed System Manager

Find VIs on Disk...

Prepare Example VIs for NI Example Finder...
Remote Panel Connection Manager...

Web Publishing Tool...

Actor Framework Message Maker...

Control and Simulation »
Create Data Link...

Find LabVIEW Add-ons...

NI Veristand »
MNXT/EV3 Application Browser...

MNXT/EV3 Preferences...

NXT/EV3 Terminal...

Mavigate to Requirements Gateway...

Robot Simulation Medel Builder...

Folders or VIs with underscore at the
beginning will not be named here.
ni.com 24 "ﬂ”SA'.I[II!?JNMAELNTS”



File Edit View Project Operate Tools Window Help

[>]®@ @[11][9][25][wal@® 2 [15pt Application Font |+ | [$er |[a~ | (60~ |[al)

[lsean ’ﬂl’f’?'

Quick Drop

3 Quick Drop

(Incomplete) Beta Function.vi [NL Grmath.kvlib] -
(Incomplete) Gamma Function.vi [NI_Gmath.vlib] |E|
(Riemann) feta Function. [NI_Gmath.hlib]

MET Object Te Vanant.vi

10 ANOVA i [NLAALPro.Ivlib]

1D Linear Evaluation PtByPt.vi [NI_PtbyPt.lvlib]

1D Polar to Rectangular PtByPtan [NI_PtbyPt.vlib]

10 Pelynomial Evaluation PtByPt.ovi [NI_PtbyPt.vlib]

1D Rational Pelynomial Evaluation.vi [MI_AALPro.lvlib -

Configure.., ] [ Help

ni.com

25
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Window Help

File Edit View Project Operate Tools

{3@] ’QEEWIF .+ | 15pt Application Font |~ | (3 ||%a~ | (6D~ W

TN ]

2 Quick Drop

Quick Drop

| B

(Incomplete) Beta Function.wvi [MI_Gmath.lvlib]
{(Incemplete) Gamma Function.wvi [MLGmath.lvlib]
(Riemann) Zeta Functicn.wvi [NI_Gmath.lvlik]

MET Object To Variant.vi

1D ANOVA i [NL_AALPro.vlib]

1D Linear Evaluation PtByPt.vi [NL_PthyPt.vlib]

1D Polar to Rectangular PtByPt.vi [NI_PthyPt.Ivlib]
1D Polynomial Evaluation PtByPt.vi [NL_PthyPt.lvlib]

m|

1D Rational Polynomial Evaluation.vi [NL_AALProulvlib =

’
{2 Quick Drop Configuration

Front Panel | Block Diagram

Add Shortcut
Diagram Shortcut

Diagram Shortcut Object

/|

Configure... Help

)

ni.com

Block Diagram Shertcuts

Ctrl-Key Shortcuts | Options ‘

Add

Shortcut

Object Mame

Remove Selected Shortcut(s)

Cancel l [

oK

Help l

26
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3 LabVIEW.vi Block Di

File Edit View Project Operate Tools

Window Help

$ @| @) II rg D L.q’l" < 3 15ptApphcahon Font |~ ||§g' ”-n.,v :WH?’E |>/<;ar'h r”?
2 Quick Drop
(Incomplete) Beta Function.wvi [MI_Gmath.lvlib] - [ . .
{(Incemplete) Gamma Function.wvi [MLGmath.lvlib] @ B Quick Lz A e u
(Riemann) Zeta Functicn.wvi [NI_Gmath.lvlik] - ] -
{NET Object To Variant.vi | Front Panel | Block Diagram | Ctrl-Key Shortcuts | Options |
1D .IDA.NOVA.VI [NITMLPI'O.W'II-}] : CtrI-Key Shortcut Mappir‘lgs
1D Linear Evaluation PtByPt.vi [NL_PthyPt.vlib] -
1D Polar to Rectangular PtByPt.vi [NI_PtbyPt.Iviib] Shorteut Plugin Name -
1D Polynomisl Exaluation PtByPti [NI_PtbyPEIVIib] 1 (default) et
1D Rational Polynomial Evaluation.vi [NL_AALProulvlib = T (default) Mowve Labels
Confiaure ] ’ i ] R (default) Remove and Rewire
ALe.- £ P (default) Replace
" ’ B (default) W1 Server Rename
D (default) Wire All Terminals
W (default) Wire Multiple Objects Together
Shortcut (Press Key)
Ctrl-1 Set
Selected Plugin Description
Inserts the object specified by name in the Quick Drop dialog box on the selected wire(s) on the B
diagram. If [Shift] is also pressed, and multiple wires were selected, a single instance of the object is
inserted on those wires,
Default Shortcut - [I]
Selected Plugin Path
C:\Program Files (x86)\Naticnal Instruments\LabVIEW 2014\ resourcehdialogh QuickDropi\plugins\Insert.vi
oK Cancel || Help |
ni.com 27 "INSTRUMENTS"



File Edit View Pro;(t Operate Tools Window Help . - 1.
[>|®] ®[n][5][25][wal o [15pt Application Font |~ |[2o |[Ta~ | (65~ |[#al) [+ Search A [?]

Quick Drop

2 Quick Drop

(Incomplete) Beta Function.vi [NI_Gmath.hvlib] B Sta N d a rd Q u I C k D rO p P | u g | N S

{(Incemplete) Gamma Function.wvi [ML_Gmath.lvlib] |E|
(Riemann) Zeta Functicn.vi [NI_Gmath.lvlik]

NET Object To Variant.vi S-t | | -t
10 AMOVAN [NLAALPro.Ivlib] rg + n S e r
1D Linear Evaluation PtByPt.vi [NL_PthyPt.vlib]
1D Polar to Rectangular PtByPt.vi [NI_PthyPt.Ivlib]

prommchmamsrniorin | Strg+T  Move labels
Strg+R Remove and rewire
Strg+P  Replace
Strg+B VI server rename
Strg+D  Wire all terminals

Strg+W  Wire multiple objects
together

Configure... ] ’ Help ]

VNATIONAI.
ni.com 28 ’ INSTRUMENTS'



File Edit View Project Operate Tools

Window Help

@ ] : Yo l" | 15pt Application Font |~ IQ;;‘ | e~ l» Search 4 I;‘
2 Quick Drop
e iere -1 | QUICK Drop Plugin Template:
{(Incemplete) Gamma Function.vi [ML_Gmath.lvlib]
(Riemann) Zeta Functicn.vi [NI_Gmath.lvlik] . .
LabVIEWXXXXI\ \dialog\Quick
10 ANOVAN [NL_AALPro.Ivlib] [ a reSOU rce Ia Og U IC
1D Linear Evaluation PtByPt.vi [NLPthyPt.vlib]
1D Polar to Rectangular PtByPt.vi [MI_PtbyPt.hulib] D
1D Polynomial Evaluation PtByPt.avi [MI_PtbyPt.lvlib] rO p
1D Rational Polynomial Evaluation.vi [NLAALPro.lvlib =
Configure... ] ’ Help ]
INSTRUCTIONS:
1. Save a copy of this VI with a descriptive name in [LabVIEW]\resource\dialog\QuickDrop\plugins or in [LabVIEW Data]\Quick Drop Plugins.
2. Edit the VI Description te include a description of your plugin and specify a default shortcut.
3. Write code to execute when you press Ctrl-[char] or Ctrl-Shift-[char] while Quick Drop is visible,
%‘t - Mﬂ Variant out

ni.com

QD Launch VI Ref

Reference to the VI from
which Quick Drop was
launched. You do not need
to close this reference
(Quick Drop will close it).

error in (no error)
Saok

Get the selection list from either the panel or
the diagram, depending on which one Quick
Drop was launched from.

See the diagram of this subVl
for a description of all data

passed in to the plugin by I
the Quick Drop framework

Y
| False 't

e

Undo Name

[Labck

Shift Pressed?
=

QD Combo Box Ref

VI

Drop window when this plugin finishes execution.
You will usually want to leave this value as TRUE

This is where you will write
your scripting code that
processes every object in the
selection list from the VI

M True 't

Transaction.Begin Undo

» MName m
=t
[If you did any scripting during this loop
iteration, set this value to TRUE.
7
,—

Transaction.End Undo

[If anything was created, end
the transaction. Otherwise,
[fail the transaction.

[Indicates whether 'Shift' was also pressed when Ctrl-[char] was pressed. ]

This value indicates if you want to close the Quick 2

- <-———{Reference to the Quick Drop Combo Box. Useful for determining the text currently typed and/or autocompleted in the QD window.]

MNote: Most Quick Drop Keyboard Shortcuts operate on the selection list. Also, you'll usually want to create an Undo transaction if you're doing any VI
scripting. The code above is intended for these use cases. However, this code is just a guide. Feel free to edit the contents of this diagram in any way you
wish...the only hard requirement for a Quick Drop Keybeard Shertcut plugin is that the connector pane of this VI not be modified.

29
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. - <. B
[} LabVIEW.vi Block Diagram * QE=RMoS

‘File Edit 8 Project Operate Tools Window Help - @
2 Co Is Palette ont |~ ||3nv e | |@v ”%| [“ Search “\ Ir@l
Functions Palette G

Tools Palette

Bookmark Manager

Breakpoint Manager

Probe Watch Window

Event Inspector Window

Error List Ctrl+L

Load and Sa

Warning List

VI Hierarchy
LabVIEW Class Hierarchy

Browse Relationships » s ——
Bookmark Manager 2 Bookmark Manager g

Thic VIin P

This VI in Pr

B Ctrl+Shift+B Main Application Instance El :?: erpbiEooknak
.NET Assemblies in Memory - Group by VI

ActiveX Control Property Browser Bookmarks Vis - -
Getting Started Window... = #myBookmark

Toolbars 2

IThats a great modification ;)

Create your own!

INSTRUMENTS'
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Agenda

Additional tools and their modifications
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[ LabVIEW.vi Block Diagram *

File

Edit View Project Operate

o= @]

3

ni.com

Choose Environment
Measurement & Automation Explorer...

Instrumentation »
Real-Time Module »
FPGA Module »
MathScript Window...

DSC Module »
Compare »
Merge »
Profile »
Security »
User Name...

Build Application (EXE) from VL.
Convert Build Script...

Source Control »
VI Analyzer »
LLE Manager...

Import »
Shared Variable »

Distributed System Manager

Find VIs on Disk...

Prepare Example VIs for NI Example Finder...
Remote Panel Connecticn Manager...

Web Publishing Tool...

Actor Framework Message Maker...

Control and Simulation

Create Data Link...

-

Find LabVIEW Add-ons...

NI Veristand »
MNXT/EV3 Application Browser...
NXT/EV3 Preferences...
NXT/EVZ Terminal...
Mavigate to Requirements Gateway...
Robot Simulation Model Builder...
SignalExpress »
VIPackage Manager...

ssisti

—

]

*| Search

[S=SEaRL X
1@ |‘§

Find LabVIEW Adad-ons...

- 250+ third-party add-ons
- Free and paid

32

TOOLS NETWORK

-

- WINEMAN
JechNaLaay
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2 LabVIEW.vi Block Diagram *

File

- - . Choose Environment
Edit View Project Operate i
Measurement & Automation Explorer...

= @ E Instrumentation 13
Real-Time Module »
FPGA Module »
MathScript Window...
DSC Module »
Compare »
Merge »
Profile »
Security »
User Name...

Build Application (EXE) from VL.
Convert Build Script...

Source Control »
VI Analyzer »
LLE Manager...

Import »
Shared Variable »

Distributed System Manager
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