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Hardware Configuration



Goal ¢ Connectyour NI CompactDAQ system to the PC

e Use Measurement & Automation Explorer to configure your hardware and verify signal
connections

e Create a simulated NI-DAQmx device (Optional)

Part Hardware Connection and Setup
A Estimated time.: 5 minutes

The hardware for this seminar includes many measurement modules to give you the best
possible understanding of the value of modular data acquisition platforms. Today, you can
explore analog voltage, digital input, accelerometer, strain and temperature measurement
as well as digital output and voltage generation. For more information about the modules
you see in the chassis or to learn more about NI CompactDAQ, check out
ni.com/compactdag.

1. Before beginning any of the following exercises, ensure that your chassis is
connected to your PC via the supplied USB cable and both the PC and the NI
CompactDAQ chassis have power. Both the green Power LED and amber Ready
LED should be lit before you begin configuring your chassis in software.

2. Take a moment to go over the connections in the demo box. Make sure that all
modules are securely seated in the chassis. Additionally, if any wires are loose or
something appears missing or broken, alert your instructor.

3. Once you have confirmed everything is connected and powered on, proceed to Part
B.

Part Software Configuration
B Estimated time.: 20 minutes

Similar to the Windows Device Manager, which manages all peripherals connected to a
Windows PC, MAX manages all NI hardware and software. This application is installed with
most NI software packages. In this exercise, you will look at the most used features of
MAX including Software and Devices and Interfaces.

Note: You can access two systems in MAX: the locally installed hardware and software,
which is listed under My System, and Remote Systems, which contains all the remote
targets you have detected on your network such as NI CompactRIO hardware or a real-time
PXI system. Today, you will only be working with the local PC and USB chassis, so
everything will be under My System.

1. Once your hardware is connected and powered on, open MAX by double clicking
the icon on the desktop or navigating to Start » All Programs » National Instruments
» Measurement & Automation Explorer.

2. After MAX launches, expand My System » Devices and Interfaces. You should be
able to see any hardware attached to your local machine:
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TR NI cDAQ-9178 "cDAQL" - Measurement & Automation Explorer

File Edit View Tools Help
« B Wy System
S Data Neighborhood
« & Devices and Interfaces
@= [ntegrated Webcam “cam(”
& ASRLI-INSTR "COM1™
= ASRL10ZIMNSTR "LPT1"
= 0y NI cDAQ-9178 "cDAQL”
@ 1: NI 5211 "cDAQIModL™
B 20 N19237 “cDAQIMod
I 3: NI 9472 “cDAQIModl”
O 4: NI9263 "cDAQIModd”
I 6: NI9234 "cDAQIModE™
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& Network Devices
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&1 Saftware
il V1 Drivers
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H

¥ Refresh |

Settings
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Status
Slot Details
Slot  Model

1 NIail
2 NIy
3 NI 9472
4 NI9263
6 NI823d
8  NI9215

+ Reset [th Self-Test

DAagQlL

MNatsonal Instruments
NI<DAQ-9178
016721EC

Present

Name Senal Number

cDAQIModl  01266CT6
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cDAQIModé  014A599E
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FAdd a € Series Module
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Figure 1. Expand the chassis drop-down menu to show attached modules.

Within MAX, you can ensure that your hardware is properly connected, check
external connections, rename your devices, and even simulate devices for
developing code without attached hardware.

In addition to hardware, you can see all the software installed on the machine by
expanding My System » Software. Here you can check the driver and software

versions:

| B N1 A1 78 “rDAG” - Measaement & Automation Fxploner

= 9 0 cOA-5178 "D

0 &:NI%251 e
0 6: NIS2H "¢
o B:NIS2:
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Figure 2. Make sure you have the right software and drivers installed by expanding
the Software section in MAX.
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Underneath the software section, you should notice that both LabVIEW and NI-
DAQmx are installed — NI-DAQmx is the driver that lets your PC communicate with
your hardware and LabVIEW is the graphical programming environment that we will
use to program during today's exercises.

Now that you have navigated through and understand the basics of MAX, you can
test the connectivity of the NI CompactDAQ chassis. Right-click the chassis under
the Devices and Interfaces section and select Self-Test.

TR I cDAQ-9178 “cDAQL" - Measurement & Automation Explorer
File Edit View Tools Help
5 Iy System ¥ 2 Refresh | % Reset B Sed-Test
@ Data Neighorhood
+ @ Devices and Interfaces
= [ntegrated Wabcam “cami® Settings

IMSTR “LAT1" Name <DAGL
Q9176 e 5 )
O 1 N1 8211 “Ter, B RESEL Vendor Mational Instruments
B 2 N1 9237 “Stralleh_SelfTest Model W cEG-E17E
B3 N1BAT2 D Rename
B 4N 525; j‘ Sarial Mumiar O16721EC

n 3
o B HEIR Status Present

[N
O & MN18215 “Voltage_in®

Figure 3. Self Test is a basic utility for checking connectivity with your hardware.

If your chassis is properly connected and able to communicate with your PC, then
you will see the following message:

EE NI cDAQ-9178 "cDAQ1" - Measurement & Automation Explorer

File Edit View Tools Help

4 B My System H 3 Refresh ‘ % Reset [£h Self-Test
> [@ Data Neighborhood _
4 @ Devices and Interfaces < E; The self test completed successfully. D 3]

@ Integrated Webcam "cam0”

@ ACDIALTRICTR "rAL AT

Self-testing the chassis is always a good first step after installing new hardware or
software.

To check the signal connections to the NI CompactDAQ chassis, you will use the
NI-DAQmx Test Panels. As an example, we will check the signal connectivity of the
NI 9211 thermocouple module.

a. Right click on the NI 9211 and select Test Panels...:



Ea 1: NI 9211 "¢DAQIMod1” - Measurement & Automation Explor

File Edit View Tools Help
4 B My System H
[l Data Neighborhaod
4 &g Devices and Interfaces (]
@ Integrated Webcam "cam0”
ASRLIzINSTR "COM1"
= ASRL10:INSTR "LPT1"
4 I NI cDAQ-9178 "cDAQL"
D 1: NI 9211 "cDAQ1Mod™™
0 2 NI9237 "cDAQIMod @ Reset
0 3: NI 9472 "cDAQIMod [ Self-Test
0 4: N[ 9263 "cDAQIMod {# Create Task...
0 6: NI 9234 "cDAQIMod & Configure TEDS...
0 8 NI9215 "cDAQIMod
4 Network Devices

(3 NI Switch Executive Virtual—
B Test Panels...
- B Historical Data Wiceeren
. ad Scales & Device Pinouts
&1 Software Help '
[ VI Drivers
F8 Remote Systems

Rename

Figure 4. Test Panels let you check your signal connections without writing any
code.

b. Selecting Test Panels brings up a simple utility to check the signals on each
of the channels of the module. When you press Start, you should see the
following screen for the NI 9211 test panel:

[ Test Panels : NI 9211: "cDAQ1Mod1" S

Analog Input

Amplitude vs, Samples Chart Auto-scale chart [/

Start ‘ M stop ‘

Figure 5. The NI 9211 test panel lets you read the signal on each of the channels of
the device. Scaling and CJC settings are built in to simplify testing.

c. Hold the tip of the thermocouple and notice that the temperature increases.
d. Take a moment to practice with the test panels for the other modules in the
chassis. Notice that test panels are slightly different, each providing the

inputs for measurements supported by the module.

e. When finished, close any open Test Panel window by selecting Close.
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6. For many applications, simply using the default assigned names is not sufficient.
Within MAX, you can very easily rename your modules to match the module type or
measurement.

a. Torename the module, right-click on the module and select Rename.

ﬁ 1: NI 9211 "cDAQ1Modl” - Measurement & Automation Explorer

File Edit View Tools Help

4 H My System H 7 Refresh | * Reset [£Self-Test [ Tesi
- [#@ Data Neighborhood
4 g Devices and Interfaces s The self test completed successfully.

@ Integrated Webcam "cam0Q”
ASRLIZINSTR "COM1"

= ASRL10:INSTR "LPT1" Settings
4 @ NI cDAQ-9178 "cDAQL"
I 1: NI 9211 "cDAQ1Mod1" Name cDAQIModl

0 2: NI 9237 "cDAQ1Mod2 © Reset

i 3: NI 9472 "cDAQ1Mod3 [ Self-Test

I 4: NI9263 "cDAQIMod4"| {nf Create Task.. viodel NI 9211

I 6: NI9234 "cDAQ1Modb"| Configure TEDS...

I 8 NI9215 "cDAQ1Mods
+ .4 Network Devices Rename lot Number 1
- [# NI Switch Executive Virtual D

endor National Instrume

erial Number 01266C76

8 Historical Data ] Test Panels... tatus Present
. 44 Scales Z& Device Pinouts
. &1 Software Help b
- [l IVI Drivers External Calibration

- B8 Remote Systems

Falilentine Masa P s =

Figure 6. Select Rename to add new descriptive names.
b. Rename each of the channel types to descriptive names.

c. Use the following descriptive names to identify your modules

4 B My System
- [ Data Neighborhood
4 g9 Devices and Interfaces
@ Integrated Webcam "cam0”
ASRLL:INSTR "COM1"
=w ASRL10:INSTR "LPT1"
4 @ NI cDAQ-9178 "cDAQL"
I 1: NI 9211 "Temperature”
0 2: NI9237 "Strain”
I 3: NI 9472 "Digital_out”
0 4: NI 9263 "Voltage_out”
I & NI 9234 "Sound_Vibration”
I 8 NI9215 "Voltage_in"
=+ Network Devices
» (@ NI Switch Executive Virtual Devices
. @ Historical Data
» 44 Scales
. & Software
» [ VI Drivers
- B3 Remote Systems




Part Creating a Simulated Device (Optional)

C Estimated time: 10 minutes
When developing your data acquisition application, oftentimes you may not have
immediate access to the hardware in the initial stages of writing the software. For
situations like this, you can create simulated devices in MAX.

1. To create a simulated device, right-click on Devices and Interfaces and select Create

New....
T3 Devicos and Inerfaces - Measurement & Automation Exploser Jsebiz) m
| File Edit View Tools Help
4 B8 My System 1 Create New.. 2

@ Data Neighborhood
& Devices and Interfaces,
8 Historical Data [ Creare

Devices and Interfaces

“d Scales Devices and Interfaces lists installed and detected CAN, DACL FieldPont Senal Controllers, GFIB, 11, Motion, Senal, VISA, Vision, and
&1 Software Xl hardware
i IV Drivers

& Remote Systems If you do not see your devices...

B You have not refreshed the configuration tree
# Your diace may not be Windews Plug and Play compatitle

What do you want to do?
2 Configure an enskng dewce

#2dd a non-Plug and Play device

For more infarmation abaut using your NI product in MAX, refer 1o your praduct-specific help, located on the Help»Halp Topics menu
item. You can also access NI product help from within A% help, which you can launch from the Hellp menu or by pressing <F1i=

@ Submit feedback on this topc.

|4 Help

Figure 1. Creating a simulated device enables you to experiment with a device
without having the actual hardware on-hand.

2. When the Create New... screen launches, select Simulated NI-DAQmx Device or
Modular Instrument and press Finish.

Choose the type of item you want to add.

(=& Devices and Interfaces
i NI Switch Executive Virtual Device
[ Virtual NIl Motion Devices
[ VME Device
&5 Network NF-DAQmx Devices
F%@ NI-DAQmsx SCXI Chassis
4@ NFDAQmx SCC Connactor Block
£ NI-DAQmx TEDS Interface
]
il NI-RTSI Cable
& Pon(Senal or Parallel)
a5 VISA TCP/IP Resource
W GPIB-ENET/100
W GPIB-ENET/1000
il PXI Chassis

e ]

Figure 2. Within MAX, you can simulate any NI-DAQmx device and many modular
instruments.
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3. For this exercise, select Nl cDAQ-9174. This is a 4-slot version of the NI
CompactDAQ chassis that you are using for exercises in this booklet. Press OK to
add the simulated device.

ﬁ Create Simulated NI-DAQmx Device |

MI-DAQmx Simulated Devices
----- X Series DAQ -
M Series DAQ
E Series DAQ
5 Series DAQ
SC Express
- B Series DAQ =
. USEDAQ
.. CompactDAQ Chassis
------- NI cDAQ-9132
------- MI cDAQ-9133
------- NI cDAQ-9134
------- MI cDAQ-9135
....... NI cDAQ-3136
------- NI cDAQ-3137
....... MI d:)AQ—9138
------- MI cDAQ-9139
------- MI cDAQ-9171
------- MI cDAQ-9172

e NI cDAQ-9178 =

PXI Chassis | 1

PXI Slot | 3

Figure 3. The NI cDAb-9174 is just one of many options for simulated devices.

The new simulated chassis will show up under Devices and Interfaces just like the

real devices connected to the system but will be colored yellow. Notice that
modules are not included. To add modules to the chassis, select Configure
Simulated cDAQ Chassis...

T NI cDAG-9174 "cDAQY" - Measurement & Automation Fxplorer

File Edit View Toals Heip
a B My System
(3 Data Neighborhood
+ @ Devices and Interfaces
= Integrated Webcam “cam{”
o ASRLIZINSTR "COM1™
= ASRLIO=INSTR "LPT1™
4 @ NI cDAQ-9178 "cDAQL™
0 1 N19211 "Temperature”
O 2: N19237 "Serain®
3 N19472 "Digital_out”
3 4: N19263 Voltage_out™
i 6: N19234 “Sound_Vibration™
i & N19215 “Voltage_in™
a1y NI cDAQ-9174 "cDAQZ"
4 Network Devices
&I NI Switch Executive Virtual Devices
8 Historical Data
“d Scales
& Software
W V] Drivers
B Remate Systems

H ¥ Refresh I (¥ Configure Simulated cDAQ cmssis.l * Reset [Eh Self-Test

Settings

MName eDAG2

Vender National Instruments
Model Nl cDAQ-9174
Status Simulated

I Settings M Device Routes ¥ Synchronization

=B R

[+ Hide Help

(BBack R -
NI CompactDAQ Chassis Basics
What do you ment to de?
Frest communicatien to the chassis
FRemove the chassis
kadd a C Series Module

FRun the NI-DAQmMX Test Panels

Figure 4. The simulated NI cDAQ-9174 shows up in Devices and Interfaces just like a real
device, but the emblem is yellow.
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5. For Slot 1, select the NI 9201 module — this is a 12 bit voltage input module that is
not included in your chassis. Press OK to add the module to the chassis.

T4 Simulated cDAQ Chassis Conti.. e

2 1N = s

NI 5201 (DSUE)

Nl 9203

NI 5205

NI 9205 (DSUE)

NI 9206

NI 9207 (DSUB)

NI 9208 (DSUE) b

Help | oK | concel

Figure 5. The NI 9201 is a basic voltage input module, but you can configure your
simulated chassis for any module that the NI cDAQ-9174 supports.

6. Once the module is added to the simulated chassis, you can perform actions just
like on a real device. To illustrate this, right click on the NI 9201 and select Test
Panels...

T% 1: NI 9201 "cDAQZMod]” - Measurement & Automation Explorer
[ File Edit View Tools Help
“ B My System W ¥ Refresh | = Reset [ThSelf-Test ) Test Panels.. | (% Create Task. & Dew

& Data Neighborhood
4 &P Devices and Interfaces

o [ntegrated Webcam “cam0” Settings
@ ASRL1:ZINSTR "COM1™
= ASRL10=IMSTR “LPT1" Name eDAQ2Mod]

+ # NI cDAQ-9178 "cDAQ1L"

O 1: N19211 “Temperature™

O 2 N19237 “Strain™ Model NI 9201
0 3: N19472 "[hgital_out”
B 4: N1 9263 "Voltage_out”
I 6: N19234 “Sound_Vibration® Status Simulated
D 8 NI19215 "Voltage_in”

A NI cDAQ-9174 “cDAQY
i3 1: N19201 “eDAQIMod"

Vendor National Instruments

Slat Number 1

Current Device Temperature  00"C

4 Netwark Devices B Feset

@ NI Switch Executive Virtua [ Self-Test External Calibration
8 Historical Data [# Create Task.
“d Scales & Configure TEDS... Calibration Date NJA
& Software
:. ™ D,:m Rename E;::rr::ﬂad Mext N/A

BE Remaote Systems X Delete e =
lettings M Device Routes
1 Test Panels.. |
- I: Device Pinouts —
Help »

Figure 6. Select Test Panels... to take measurements from your simulated device.

7. When the simulated device test panel appears, press Start to begin visualizing the
simulated data. Notice that the data is a simple sine wave. It is important to note
that this data set is built into the NI-DAQmx driver and does not actually constitute
real data; however, you can interact with it exactly the same way as interacting with
real data. For example, you could write code to analyze the maximum and
minimum values and write those values to a spreadsheet file.
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Test Panels : 1: NI 9201: "cDAQ2Mod1"

Analog Input

Amplitude vs. Samples Chart

Start

Auto-scale chart [

| M stop |

|

| Cloze

Fidure 7. The data displayed in the simulated device test panel is a simple sine

wave that is included in the NI-DAQmx driver.

8. Close any open Test Panel windows by selecting Close.

9. Delete the simulated device by right-clicking on the NI cDAQ-9174 and selecting

Delete from the context menu.

"; NI eDAQ-9174 “cDAQ2" - Measurement & Automation Explorer

File Edit View Tools Help
B My System H
& Data Neighborhood
+ @ Devices and Interfaces
= Integrated Webcam “cami”
& ASRL1-INSTR "COM1”
= ASRLI0:INSTR "LPT1"
- B N1 CDAG-9178 "cDAGL”

o4 tage_out”
0 & N19234 "Sound Vibration
i B:N19215 “Vaoltage_in®
4 P NLeDAQ-9174 "cDAQ2”
0 1:N19201 "cl = Reset
& Network Devices £ Self-Test

[ml NI Switch Execut Rename

= Refresh

Scttings
Name

Vendor
Model

Status

Slot Details

| Maodel

NI 9201

B Histerical Data |X Delete

4d Scales

& Software

il N Drivers
B8 Remote Systems

Help

b

[Ef Configure Simulated ¢DAQ Chassis.. *a Reset D Sell-Test

+ | [@Back 5]

cDAQ2
National Instruments
NI cDAQ-9174

Simulated

Name Serial Number

cDAGZMod]

& Configure Simulated cDAQ Chassis.. by empty slots

[
> Hide Help

NI CompactDAQ Chassis Basics

What do you wanl be deo?

Pt communication to the chassis
MRemove the chassis
badd a C Series Module

MRun the NI-DAQmx Test Panels

T Settings ¥ Device Routes ¥ Synchronization

Figure 8. Remove the simulated device from the system.

<End of Exercise>
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Goals e Become familiar with the NI-DAQmx examples
e Run a pre-built example program to acquire your first measurement

Part A Open LabVIEW and Explore the Example Finder

Estimated time: 10 minutes

Installed with NI-DAQmx, the NI-DAQmx examples provide you with a proven starting
point for creating data acquisition applications. By utilizing an example program, you can
eliminate several sources of errors and save time by utilizing existing code.

1. To access the examples, open LabVIEW by navigating to Start » All Programs »
National Instruments » LabVIEW <Year>. Upon launching, you will see the
following Getting Started screen:

I3 Labview =B

| File Operate Tools Help

2 | abVIEW (

a. || [:'[J Create Project b. [ D{, Open Existing

Show | Projects *

% | Find Drivers and Add-ons » Community and Support

b/ Welcome to LabVIEW
P ea W and

) LabVIEW News | fiou the LabVIEW Skis Guide Wi Improve Your Werk

Figure 1. The LabVIEW start-up screen provides several paths for learning,
support and development.

2. The opening screen provides paths for developing code, recalling previously
opened programs and finding support or help resources.

a. Create Project— Selecting Create Project will launch a screen with options
to create new code from existing templates and sample projects. Code
architectures like the State Machine and Actor Framework are included in
the templates and you can quickly get up and running by creating them
from this dialog box. The sample projects are ready-to-run code built using
best practices for scalable development. Using the templates and sample
projects, you should never have to start a LabVIEW application from
scratch.
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Choose a starting point for the project:

Al Blank Project Templztes -

Templates @ Creales a blank

Sample Projects

Blank VI plstes
ﬂ Creates a blank VI
Simple State Machine

@ Facilitates defining th

Queued Message Handler
41 Facilitates multiple se
Information

quence for sections of code. More Information

running in parallel and sending data between them. More

Actor Framework Tz
Cre: nt tasks that communicate with each other
This template ma es. More Information

Finite Measurem
Acq nite porting the measurement to disk. This sample
e. More Information

based on the

Continuous Measurement and Logging (NI-DAQmx) =
.ﬁ@ Implements a continuous data acquistion application using NI-DAQmx More Information

asuramant (MLNAOMY) S2mela Srnisrte

[ Fnish ][ Caned ]| Help ]

Figuré 2. Templates and Sample Projects can help you create scalable
applications faster with proven code and techniques.

b. Open Existing — As you work on programs today, you can quickly recall
projects that you have worked on within the Open Existing section or
press the Open Existing button to browse for your code.

c. Find Drivers and Add-ons — For most hardware connected to your PC, you
will need to use a hardware driver. Today, you will be using NI
CompactDAQ, which utilizes the NI-DAQmx driver. This same driver
works for hundreds of data acquisition devices, enabling you to reuse
code from device to device and application to application.

d. Community and Support— For those times when you get stuck, NI has a
vibrant community of LabVIEW developers and data acquisition experts.
The forums are a free support resource that is monitored by both NI
Applications Engineers and NI enthusiasts to ensure that you will get the
support you need. For more immediate support, you can call or email NI
Applications Engineers directly as one of the many benefits of the
LabVIEW Standard Service Program (SSP).

e. Welcome to LabVIEWW—- After today, you will be familiar with using the
LabVIEW environment. To move beyond simple programming tasks and
access more in-depth proficiency training, refer to the help and training
resources in the Welcome to LabVIEW link.

3. Today, we will be using several examples as starting points for our code. To open
the NI-DAQmx examples directory, select Help » Find Examples from the
LabVIEW Getting Started screen.

4. Once the NI Example Finder launches, navigate to Hardware Input and Output »
DAQmMx.
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5. Navigate the DAQmx directory and read some of the capabilities of the examples.
Each example has a descriptive name, but you can find out more capabilities of
the program by reading the descriptions in the Information section.

ﬁ NI Example Finder

= S |

Browse | Search

Double-click an example to open it.

Browse accerding to:

(@ Task

i rectory Structure

[ Distributing and Docurnenting Applications
) Favorites
4 Fundamentals
) Hardware Input and Output
5] DAz
3 Analog Input
Bridge - Centinucus Input.vi
Current - Continuous Input.vi

Information

Description: -
This example, while not
specifically written for the
LabVIEW Real-Time Module,

runs on RT targets.

This example demonstrates how
to continuously acquire voltage
measurement using a DAQmzx

m

device,
Current - SW-Timed Input.vi eviee

IEPE - Continuous Inputvi

Resistance - Continuous Input.vi
RTD or Thermistor - Continuous Input.vi [
Strain (Rosette) - SW-Timed Input.vi B

S AAAASA

For instructions on how to
connect your signals to the DAQ
device, refer to your device
documentation.

Strain - Centinueus Input.vi [
Thermocouple (with OTCD) - Continuod ), 8, il
Input.vi
Thermocouple - Continuous Input.vi E - Requirements
Thermoceuple - SW-Timed Inputwvi [ &4 The following devices can run this .
Voltage (with Events) - Continuous B, e example: =
Input.vi USE-93234
- Voltage - Continuous Input.vi Eﬂ. E:gii:i
e i ]
Visit ni.com Voltage FII‘IItE.IHFILItVI |:,' - USB4432
for more examples Voltage - SW-Timed Input.vi B # NI9232 DA
) Analog Output MI9233
Hardware ) Counter Input NI9234 -
Find hardware El () Counter Qutput >[4 +
[C] Limit results to hardware I Add to Favorites ] [ Setup... I [ Help ] [ Close ]

Figure 3. The NI Example Finder is a useful tool for navigating the installed NI
examples.

Each section of the directory includes examples for performing certain tasks. For
example, analog input includes examples for measuring simple voltage, current,
strain, and temperature, whereas the analog output section includes examples
for controlling either voltage or current.

Run a Pre-Built Example
Estimated time. 10 minutes

Now that you are familiar with the different measurement types provided by the NI-
DAQmx examples, you can open and run several that use some of the hardware in your
hands-on kit. We will start with a simple voltage measurement.

1. In the NI Example Finder, navigate to Hardware Input and Output » DAQmMx »
Analog Input and double click Voltage — Continuous Input.vi. This will launch a VI
to continuously measure a voltage channel.

2. When the VI launches, the front panel will be displayed. This is the user interface
and includes controls and indicators for interacting with your code. In this
particular example, notice the controls for selecting the channel, voltage input
ranges, timing parameters and logging location. Additionally, the front panel
includes a graph indicator for instantly viewing the data on the voltage channels.
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B Voltage - Continuous Input.vi [Voltage - Continuous Inputwi] Front Panel

File Edit View Project Operate Tools Window Help

OE‘EUDtAnnllcation Font '™ HED‘ ||TJE'”$" |'—Séar(h

Channel Settings Acquired Data
Physical Channel § Pom,
[ Devifain rTwJ
| 0.25-
Max Voltage Min Voltage
p . M ~ Pz
‘ : 0.15
Termingl Configuration |
(] )| = 01
= [defeuit J :
- 0.05
Timing Settings o
Sample Clock Source
[ 1 0.05-,
Fomboracos |2 \ . . . . !
| I OnboardClock J 0 0.02 0.04 0.05 0.08 o1 ||=
Ti
SampleRate  Achial Sample Rate me r \
1000 1000.00 | B s

Humber of Samples

o Trigger Settings

= = )| NoTr
Logging Settings loTrigger | Digital Start | AnalogStart |

Logging Mode

or 1 Ta canfigure and use  start rigger you must have the necessary tob
= selected above. Not all hardware supports triggering—refer to your device
TOMS Fi Path ) documentation for more info.
S

Fl 1 »

Figure 4. The front panel is the user interface and contains controls and indicators
for interacting with your LabVIEW code.

3. To view the code behind the scenes of this front panel, select Window » Show
Block Diagram or use the keyboard shortcut <Ctrl+E>.

4. Expand the block diagram window so that you can see more of the source code.

You will see a series of Vls used to program your DAQ device to acquire a
voltage signal. LabVIEW uses dataflow to pass information along wires to
sequential VIs. This programming paradigm enables you to better program like
you think.

S

=

Mamed Settings Timing Settings Logying Scttings Trigaer Settings s

Figure 5. LabVIEW uses a graphical programming language and passes data
through the code via wires that connect nodes.

5. The block diagram is organized into the following sections:
1. Channel Settings — In this section, the DAOmx Create Channel V/
configures the channel on the DAQ device that you intend to use. In this
example, you can configure the range of the device and terminal

configuration (single ended versus differential).

2. Timing Settings — In the Timing Settings section, the DAOmx Timing VIis
used to configure the sample clock on the DAQ device. Using this VI, you
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can configure the sample rate, the sample clock source, and the sampling
mode you intend you use. In this example, the default settings use the
on-board clock to sample continuously at 1000 Hz.

3. Logging Settings — The DAQmx Configure Logging V/is used to set the
location of the logged data file as well as the logging mode.

4. Triggering Setting - The DAQmx Trigger.vi is used to configure the task to
start acquiring or generating samples based on the triggering options

5. Acquire Data — In this section, the DAQOmx Read V//is called inside a While
Loop, allowing this code to continuously acquire data from the DAQ
device until the Stop button is pressed.

Most data acquisition applications will follow this flow —

=

Al Voltage ~ Analog 1D DEL _
1Chan NSamp
DA
Sample Clock |
Analog DBL _
. 1Chan 15amp
|_fL
Start

Analog Edge M

Figure 6. The most common Vls for each section are shown above.

6. Compare the example program block diagram to the Vls shown in Figure 6. If
you open other DAQmx example programs, notice that most follow this exact
flow.

7. For more information about the elements on your block diagram and front panel,
press <Ctrl+H> to bring up the Context Help window. By hovering over elements
in your code, you can see brief descriptions and the inputs and outputs of each
VI. Required input labels are shown as bold in the Context Help. For more
detailed descriptions, you can press the Detailed help link. Try hovering over a
few elements on your block diagram.
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Context Help (8]

DAQmx Create Channel (Al-Voltage-Basic).vi

input terminal configuration
minimum value

maximum value -

task in

physical channels

name to assign

units

error in

custom scale name

Creates channel(s) to measure voltage. If the measurement requires
the use of internal excitation or you need excitation to scale the
voltage, use the Al Custom Voltage with Excitation instance of this

Detailed help il

EREE ¢

Figure 7. Context Help can provide a quick description of the elements in your
front panel or block diagram.

8. Now that you are familiar with the parts of a basic program, you are ready to
acquire data using this example. To do this, switch back to the front panel by
selecting Window » Show Front Panel or by pressing <Ctrl+E>.

9. Change the Physical Channel to Voltage_in/ai0.

&8 Voltage - Continuous Input.vi Front Panel @Eﬂ
File Edit View Project Operate Tools Window Help m
[7] _[5[] [0 [0 Appeationnt 1+ B e 5] TN
Channel Settings Acquired Data
Physical Channel 5
J)
Strain/aif A 4
Strain/ail
Temperature/ai0 37
Temperature/ail
Temperature/ai2 2]
.  Temperature/ai3 L
[ Voltage_in/ai0 ,h 14
Voltage_in/ail B ]
Voltage_in/ai2 £
Vi in/ai e
oltage_in/2i3 - 5 -
Sample Rate Actual Sample Rate 4 1
[|1ooo \] | [1000.00 |
Samples per Loop 2]
[- 1000
-3
Logging Settings
Logging Mode =
| =1[os
5 | 1 1 i i (| | 1 | |
TDMS File Path i 0 01 02 03 04 05 056 0.7 08 09 1
[ ) e [
L — | Il stop
< B : - m - B : | b

Figure 8. Use the controls on the front panel to select the channel, timing
settings and logging settings.

10. Change the Sample Rate control to 10000 and press the Run arrow () to begin
acquiring data.
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Because your signal is connected to the light sensor in the box, you will see the
output of the light sensor. This signal will have some noise from sources in the
room but you should be able to see the effects of placing your hand over the
sensor. You are sampling the signal along with the noise in the room at 10 kHz -
what could be some sources of noise in the room around you? What could you
do to get a better idea of what is happening to the signal of interest?

r {3 voltage - Continuous Input.vi lilﬂ‘g
File Edit View Project Operate Tools Window Help |
Channel Settings [ Acquired Data
Ehyslca\ Channel 0.0022 -
[ Voltage._in/ai0 | m} 0.002-
Max Voltage Bﬂm Voltage 0.0018- M
B | ” 0.0016-
Terminal Canfiguration 0.0014-
([ defaute |} 0.0012-
= 0.001 -
Timing Settings 0.0008-
Pample Clock Source % 0.0006-
|I/D OnboeardClock |m] E 0.0004-] L
Sample Rate Actual Sample Rate = oo ]
[10000 || |[2000000 | o
Samples per Loop -0.0002-
[ooo ] -0.0004-
-0.0006 -
Logging Settings

-0.0008 -

Legging Mod
Logging Mode 0001

Blow ]
(=)) OF -0.0012- B

TDMS File Path 0 0.02 0.04 0.06 0.08 01
Time
= | ,
i ] =

] [ [ ] r

Fighure 9. With this program, you are sampling a channel at 10 kHz. Throughout
this seminar, you will modify and customize examples to perform many tasks.

11. Press Stop to stop acquiring data.

12. Exit the program without saving.
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Part C Experiment With Other Example Programs (Optional)

Estimated time.: 10 minutes

Try exploring other example programs. Examples that might be useful to look include
1. Analog Input / Thermocouple — Continuous Input.vi
Note:
e Be sure to select Temperature/ai0 from the Physical Channel control.

2. Analog Input / Strain — Continuous Input.vi
Note:
e Be sure to select Strain/ai0 from the Physical Channel control.
e Be sure to select Quarter Bridge | from the Strain Configuration control.
e Be sure to use 3.3 as the Voltage Excitation Value.

3. Digital Output / Digital — Continuous Output.vi
Note:
e Be sure to select Digital_out/port0/line0:7 from the Line(s) control.
e Be sure to select OnboardClock from the Sample Clock Source control.

4. Analog Output / Voltage (non-regeneration) — Continuous Qutput.vi
Note:
e Be sure to select Voltage_out/ao1 from the Physical Channel(s) control.
e Be sure to select 1.00 from the Waveform Settings Frequency control.
o Be sure to select 3.00 from the Waveform Settings Amplitude control.
e Be sure to change the Fan Speed Contro/hardware switch on the Sound
and Vibration Signal Simulatorin your demo box to BNC.

e |f the fan continues operating after stopping the example program,
navigate to MAX and reset the NI 9263 by right-clicking on the
Voltage_out module and choosing Reset Device.

ra NI cDAQ-9178 "cDAQL" - Measurement & Automation Explorer

File Edit View Tools Help
4 B3 My System H £ Refresh | + Reset [ Self-Test
» [@ Data Neighborhood
4 g8 Devices and Interfaces
=« Integrated Webcam “cam0” Settings

ASRLL:NSTR "COM1"

@ ASRL10:INSTR "LPT1" Name cDAQL
4 | NI cDAQ-9178 "cDAQL?

1 NI9211 "Tempera Vender National Instruments
1 2:NI19237 "Strain® | [£ Self-Test Model NI cDAQ-9178
1 3:NI19472 "Digital o Rename )
D 4 NI 9263 "Voltage Serial Number 016721EC
. ] »
D 6:NI19234 "Sound_vi | HEIP Status Present

I 8: NI 9215 "Voltage_in"
Figure 10. You can reset any hardware device to its default state in MAX.

<End of Exercise>
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The first goal is to quickly acquire a set of temperature data using the DAQ
Assistant

e The second goal is to perform analysis on that data and output a digital warning
signal if the temperature goes above an adjustable warning level.

Goals .

Part A

Part A gives you a chance to see what you'll complete in this exercise’s final application.
You'll also explore important elements of the LabVIEW environment.

1. If you have not already done so, launch LabVIEW. Click the LabVIEW application
after navigating to Start » All Programs » National Instruments » LabVIEW <Year>.
Once you launch LabVIEW, the Getting Started window appears:

I8 LabVIEW = | B |
File Operate Tools Help

El LabVIEW (

\: I:\/.;I Create Project

-
{

. I:\/.;I Open Existing

Show | Other

k| Find Drivers and Add-ons

Connect to devices and expand the
functionality of LabVIEW.

k| Community and Support

Participate in the discussion forums or
request technical support

k| Welcome to LabVIEW

Leam to use LabVIEW and upgrade
from previous versions

) LabVIEW News | What's New in LabVIEW?

Figure 1. The LabVIEW start-up screen provides several paths for learning, support and
development.

The LabVIEW Getting Started window appears each time you launch LabVIEW to assist
you in creating new applications or opening existing applications. Additionally you can use
links on the Getting Started window to find local and online help resources or open
example programs to aid in application design.
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Select the Open Existing button to open an existing project.

3. Navigate to C\Seminars\LV HO\Exercises\3 - Temperature and select the
Temperature.lvproj project. Once opened, the Project Explorer window will appear
and look like this:

§3 Temperature lvproj - Project Explorer E@é]

File Edit View Project Operate Tools Window Hel

el IECIERS

Items Files

= [l
5 B My Computer
A ) Exercises
@ [ Solutions
+_'-!:|_" Dependencies
“&_ Build Specifications

Figure 2. The LabVIEW Project is a great way to organize all the dependencies in an
application.

The Project Explorer provides a central location for you to include the different elements of
an application including LabVIEW code and other files like Microsoft Word and Excel
documents. You can include any file in a LabVIEW application. You can create folders and
sub-folders to organize the files in an application. Here, a few folders have been created as
part of the example.

4. Expand the Solutions folder in the Project Explorer and open the & - Wiite to File
(Solution).vi by double-clicking on it or right-clicking and selecting Open.
Every LabVIEW application is made of a front panel and a block diagram. The front
panel is the user interface, whereas the block diagram contains the code that
controls the functionality of your application. You can toggle between the two
windows by selecting Window » Show Block Diagram or Window » Show Front
Panel to see the other window. You can also switch between the windows by
pressing <Ctrl+E> on the keyboard or clicking either window if both are present on
your monitor.

3 5 - Write to File Solution)vi Front Panel on Temperature.vproj/M.. (= REce)
Fie Edit View Project Operste Tools Window Help {:I
[11] [15pt Application Font |~ |[§o= |[sa=] < [ 2] 2

EEr——

Temperature Data

26.76 -

66-] v !
6:00:00.000 PM 6:00:02.500 PM 6:00:05.000 PM
12/31/1903 12/31/1903 12/31/1903
Time

Alarm Level Alarm Qutput
STOP. -

[Temperature.lvproj/My Computer] <
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Figure 3. The application’s front panel is its user interface.

Hover the cursor over the different objects on the front panel. Notice that your cursor
turns into a pointer finger when above the Stop button, and turns into a text editor when
above a text field. By default, LabVIEW's Automatic Tool Selection will change the cursor
depending on what operations are possible. Also notice that as you move over any object,
resizing boxes appear on its edges. Try resizing a few objects’ sizes.

[ | | | | |
=l Stop =
- - - - . - - - .

5. Notice the menu bar at the top of the window. We will discuss many of its basic
items in future pages and exercises. For now, the most important button to review
is the Run button, found on the left edge of the menu bar.

i i
I3 5-Write to File (Solution)wi I3 5-Write to File {Solution)wi

File Edit View Project ! File Edit View Project |

)=|@n][s > )& ©n][15

Figure 4. A broken run arrow (left) indicates that there is an error compiling the application.

You must press the Run button to begin any LabVIEW application, and a broken run arrow
tells you that there are some unresolved errors in the code. Since LabVIEW is continually
compiling code throughout development, you can press the broken Run button at any time
and a list of current errors will appear.

6. Make sure that your NI CompactDAQ chassis is connected to your PC with a USB
cable and that the modules are plugged into the chassis. Now press the Run
button in the LabVIEW application and watch as the application begins to record
temperature data from the module plugged into the first slot of the CompactDAQ
chassis. Contact the instructor if your application isn’t running as described.

7. Hold the end of the thermocouple and watch the values on the graph rise and fall
accordingly. Change the “Alarm Level” control to different values and hold the
thermocouple so that it rises above and below the value you've entered on the
front panel.

As temperature rises and falls around the Alarm Level, look at the NI 9472 module in the
CompactDAQ chassis. One digital output line on this module has been programmed to
drive a 5 V signal whenever temperature is greater than the value of Alarm Level. The
module’s LEDs indicate the status of each digital line. These lines could be connected to
other hardware, like a light or buzzer, or other 5V device

8. Press the Stop button on the front panel once you are ready to move on.
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9. Navigate to the block diagram by selecting Window » Show Block Diagram.

13 5 - Write to File (Solution).vi Block Diagram on Temperature luproj/My Computer = | B o
File Edit View Project Operate Tools Window Help
= - =8
©[][@][o8] [wal ] 7 [ 4o Application Font |- B2 e~ 68~ [¥ad] [ seareh 2=
& | 2]
: 2] | ki 3
DAQ Assistant Comparison
data Operand 1 b )
= Alarm Level [} Operand2 DAQ Assistant2
1 v Result 3 data
Alarm Output
Temperature Dat
stop
o
Temperaturevproj/My Computer < i ’

Figure 5. The block diagram is the source code of an application.

LabVIEW's graphical programming uses dataflow to control the flow of an application. In

this case our application does the following:

1. Acquires temperature data with the DAQ Assistant and displays it on a chart.
2. Compares acquired data with Alarm Level.
3. Outputs 0V or 5V to the digital output module based on the comparison in #2.
4. Writes acquired data to file.

10. Distribute the front panel and block diagram windows so that both are visible in
your monitor. Navigate to Window » Tile Left and Right to tile the front panel and

block diagram on your monitor, or press <Ctrl+T>.

Notice that for every object on the front panel, there is a terminal with the same name on
the block diagram. The functions and wires on the block diagram connect the inputs
(“controls”) and outputs (“indicators”) on the front panel. As you add objects to the front
panel in future exercises you'll see that terminals are automatically created on the block

diagram.

Additional Steps

11. The LabVIEW help system is a great way to learn about LabVIEW and answer your
programming questions. Press <F1> on the keyboard to start the help system.
More assistance can be found from the LabVIEW » Help menu.

ni.com/daq
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12. Within the LabVIEW help system, expand Fundamentals » LabVIEW Environment
and explore the information available here. Feel free to explore and get a feel for
the depth of content and how it is organized.

% LabVIEW Help = [ B S
& S
Hide Locste Back Options

Conterts | Index | Search | Favortes| Organization of LabVIEW

= ([ Fundamentals ~ This topic describes the structure of the LabWIEW file system and the suggested # Oraganization of the

. . LabVIEW Directory
= () LabVIEW Envirorment lecations for saving files. Structure c
= %”EZ;TS Started ¥ Organization of the LabVIEW Directory Structure ¥ Suggested Location for
2 ing Started V Saving Fi
z Controls Palette This section describes the structure of the LabVIEW file system on Windows, Mac OS5 uine Hies

¥, and Linux. LabVIEW installs driver software for GPIB, DAQ, VISA, IVI, Motion Control, and IMAQ hardware

5 .
3 Functions Palette depending on platform availability.

2] Searching in Lab| =

z Navigating the C: The labview directory contains the following groupings after you complete the installation.

z Addons @ Note LabVIEW modules and toolkits you have installed might create additional directories within the

ﬂ Favortes labview directory.

[2] Tools Palette

[2] Menus and Toolt Libraries

z Context Help Wir * user.lib—Directory in which you can save controls and VIs you create. LabVIEW displays controls on User
E Project Explorer | Controls palettes and V1= on User Libraries palettes. This directory does not change if you upgrade or uninstall

LabVIEW.

vi.lib—Contains libraries of built-in WIs, which LabVIEW displays in related groups on the Functions palette.
Do not =ave files in the vi_ 1ib directory because LabVIEW overwrites these files when you upgrade or

E Navigation Wind
E Customizing “our
z Securing the Lab reinstall

7 i, .

% Controls Fal instr.lib—Contains instrument drivers used to control PXI, VXI, GPIB, serial, and computer-based

£| Userionirols Fa instruments. When you install National Instruments instrument drivers and place them in this directory,
0 How-To R LabVIEW adds them to the Instrument Drivers palette.

] 1l +

Structure and Support -

Figure 6. The LabVIEW help is an exhaustive resource for building applications.

13. Take a few minutes to explore other topics in the help system.

14. Click the Search tab and try searching on analysis functions for features you might
need in your applications.

Part B This exercise will review the LabVIEW environment basics you have learned so far. You
will create an application that simulates a signal inside of LabVIEW and display that signal
to a chart.

You should still have the 7Temperature project open and you will work out of this for the
next exercises.

1. Open a blank VI from the 7emperature Project Explorer by right-clicking the
Exercises folder and selecting New » VI.
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i3 Temperature.lvproj - Project Explorer E@ﬂ

File Edit View Project Operate Toels Window Hel

lhedl kb X||gw|E- ¢

Items | Files |

=3 ikgl, Project: Temperature.lvproj
= B My Computer
S
- [ Solutior
; ‘:qj Depend  Add R Virtual Folder
% Build 5p Control
Convert to Auto-populating Folder... onto
Library
Convert to Library Variable
Items incorrectly claimed by a library Class
Unit Tests » MEztel
Analyze Vis.. MI-DAQmx Task
MI-DAQmx Channel
Arrange By » MI-DAG M Scale
Remove from Project Bt
I — Test Vectors
Meee— | Rename... F2

—

Figure 1. You can create a new VI from directly within a Project.

2. Press <Ctrl+T> to tile the Block Diagram and Front Panel.

3 Untitied 1 Front Panel on Temperature.vprojf.. L= | & | 58 1) (B Unfitied 1 Block Diagram an Temperature.ivproj.. .= | =1 | EX_ |

ow

File Edit View Project Operate Tools Window % File Edit View Project Operate Tools Window Help
ST [ i [P e T T s

Temperature.lvproj/My Computer] < v Temperature vproj/ My Computer < v

Figure 2. It is often helpful to view user interface and source code side-by-side.

3. Save this VI in the \LV HO\Exercises\3 — Temperature\Exercises folder by selecting
File » Save and naming it 2 - Simulate Signal to Graph.vi.

4. Right-click any empty space on the block diagram to bring up the Functions palette,
and then navigate to Programming » Structures » While Loop. Left-click the While
Loop and it will be automatically placed on your cursor. Keep in mind your palette
may not look exactly like the one pictured below.
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<] Functions q Searchi
Programming L4
BI’ [FIT7 | E‘(‘:l
— 21 Structures
Structures While Loop
T | ]
Bl kd e
Numeric While Loop  Timed Struct...
B o
Comparison | Case Structure Event Struct... In Place Ele...
¥ GIEH
2 oo
File /O Flat Sequence  Stacked Seq...
| aC) [T
fo = B
-
Synchronizat.., Diagram Dis.. Conditicnal ... Formula Nede
el
g )
VI Analyzer | Shared Varia... Local Variable Global Varia...
Measurement I [ N
Instrument /O oo
Vision and Mot Decorations Feedback Mo...
Mathematics L4
Signal Processing L4
Data Communication 4
Connectivity L4
»

Express
Select a VI...

¥

Figure 3. The Functions palette is a hierarchical organization of LabVIEW functions.

Click and then drag diagonally to form the While Loop to the area you desire. You can
resize the While Loop by dragging any of the resizing boxes that appear when your cursor
hovers above the loop’s edges.

1.

You can also create a While Loop by pressing <Ctrl+Space> to bring up the Quick
Drop dialog. Begin typing “While Loop"” and it will appear in the list of possible
objects. Double-click its name and it will appear on your cursor for use on the block
diagram. Since you've already placed the While Loop, release the While Loop you
found using Quick Drop by right-clicking to cancel the operation.
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\While Loop ]

:

While Loop with Button

-

[ Configure.. ][ Help ]

Figure 4. If you know the name of what you're looking for, there is no faster way to
program than by using Quick Drop.

5. While Loops have two terminals in their bottom left and right corners.

@

Figure 5. Notice the two terminals on a standard LabVIEW While Loop.
The most important of the two is the loop condition. The conditional terminal is on the
lower right side and looks like a stop sign by default. Since While Loops run until told to
stop, we must provide a (Boolean) stop command so that the loop won't run indefinitely.

Notice the broken run arrow (IE) in the upper left corner of the screen. LabVIEW cannot
execute an application that contains a While Loop with an un-wired conditional terminal.

For our application, we need to create a Stop button that the user will press to halt the
While Loop and exit the program.

6. On the front panel, right-click on any empty space to bring up the Controls palette
and navigate to Silver » Boolean » Stop Button. Left-click on the Stop button and it
will be automatically placed on your cursor.
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Figure 6. LabVIEW contains dozens of engineering-specific user interface elements.

7. Left-click where you would like to place the button on the front panel. If you prefer,
enlarge the Stop button by moving your cursor to one of the button’s edges and
dragging the resizing boxes.

8. Look again at the block diagram. Notice that a terminal for the stop button has
appeared. This terminal acts as the connector from the front panel to the
functionality of the block diagram. Click the stop button terminal and drag it next to
the loop condition terminal () in the While Loop.

9. Move your cursor to the right edge of the stop button terminal and notice that the
edge of the terminal is blinking and the cursor now looks like a spool. This is the
wiring tool that lets you draw wires between different objects on the block
diagram.

10. Left-click on the right edge of the stop button terminal.

11. Left-click on the left edge of the While Loop’s condition terminal.

Stop Button

Figure 7. The wire carries data between the button and the conditional terminal.

With the While Loop now having a way to exit (the state of the stop button), the broken

Run arrow (E) is replaced with a Run arrow (). Your application is ready to run, but
you'll need to add more code to accomplish the tasks of this exercise.
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The other terminal in the While Loop, the loop iteration counter (m), outputs the number
of times the While Loop has iterated. That information may be useful depending on your
application, but we will not be using it today; it is not required that we do anything with it
in order to run our program.

12. Press <Ctrl+Space> to bring up the Quick Drop dialog and begin to type “Simulate
Signal.” Double-click Simulate Signal/ once you see it in the Quick Drop window
and the Simulate Signal Express V/ will automatically appear on your cursor.

3 Quick Drop uﬂléj
[Simulate 5ifE |
Simulate Signal -

Simulate Arbitrary Signal [NI_ExpressFull.lvlib]
2-5imulate Signal to Graph (Selution).vi [Solutions< My Compu

-

[ Shortcuts... ] [ Help ]

Figure 8. Quick DrE)p pre-indexes all LabVIEW functions for expedited search.

13. Left-click to place the Simulate Signal Express VI inside the While Loop and its
configuration dialog will automatically appear.

r ~
{3 Configure Simulate Signal [Simulate Signal] l" J
{ signal N\ /" Result Preview ~\
Signal type 1-
Sine [=]
0.5-
Frequency (Hz) Phase (deg) o
101 0 g .
i . a7
Amplitude Offset Duty cycle (36) E 1
1 0 50 05- 8
\__/ Add naise )
MNoise type 1) i
Uniform White Noise k 0 0099
u Ve A 5 - .
Time
Moise amplitude Seed number Trials Time Stamps
06 l 1
: @ Relative to start of measurement
Timing _ Absolute (date and time)
Samples per second (Hz)
1000 _ Simulate acquisition timing Reset Signal
Number of samples @ Run as fast as possible ! Reset phase, seed, and time stamps
100 [7] Automatic @) Use continuous generation
DInteger number of cycles Signal Name
Actual number of samples [] Use signal type name
100 -
Signal name
Actual frequency Simulated Signal
101
0K ] [ Cancel ] [ Help
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Figure 9. All LabVIEW Express Vls have easy-to-use configuration dialogs.

14. Try changing the Signal Type, Amplitude, Frequency, Offset, and Phase values in
the Signalportion of the dialog and see the changes in the Results Preview portion.

15. Deselect the Use signal type name box in the Signal Name section and enter
Simulated Signal as the name.

16. Once you have chosen the signal you want to display, press OK. The Simulate
Signal Express VI has now been customized based on the settings you provided.

17. Switch to the front panel and use <Ctrl+Space> to launch Quick Drop.
18. Type the word chart. Double-click on the Waveform Chart (Silver) control.
19. Place the Waveform Chart (Silver) on the front panel in any the location you prefer.

20. Return to the block diagram and move the chart’s icon into the While Loop (if it
isn't already) to the right of the Simulate Signal Express VI.

21. Use a wire to connect the output of the Simulate Signal Express VI (“Simulated
Signal”) to the input Waveform Chart terminal. Notice that the chart terminal
changed colors to reflect the data type it received.

.

* *

Simulate Signal wavweform Chart

Simulaked Signal *
=

Figure 10. The Simulated Signal will be displayed on the Waveform Chart during each
iteration of the While Loop.

22. Return to the front panel and Run the VI by pressing the Run arrow (). The
simulated signal you created in the Express VI is now displayed on the chart. Press
the Stop button when you are ready to move on.

23. Right-click on an empty space on the front panel to bring up the Controls palette,

find the knob control (Silver » Numeric » Knob (Silver)) and place it on the front
panel. Double-click on the knob's label and change it to Amplitude.
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24. Repeat step 23 to make another knob. Change its label to Frequency. Double-click
the maximum value on Frequency's scale (default = 10) and change it to 50.

Hﬂmnﬂun H | l

Figure 11. The front panel with controls for the signal’s amplitude and frequency.

25. On the block diagram, move the Amplitude and Frequency controls inside of the
While Loop.

26. Hover your cursor over the right side of each of the Amplitude and Frequency
terminals until the wiring tool appears on the cursor. Left-click and drag the
connection to the identically named input on the Simulate Signal Express VI. Your

block diagram should look like the image below.

Frequency
|@ ¥
L §
Amplltude "
e
i ¥
Simulate Signal Waveform Chart
Simulated Signa¥
7
Stop Button
o EFEe

Figure 12. You can now programmatically change the frequency and amplitude.

27. Press the Run arrow, manipulate Ampl/itude and Frequency knobs and notice that
the chart display changes accordingly. The Chart’s Y-axis auto-scales to maximize
the signal’s size on the display. To disable that feature, right-click the chart and

deselect AutoScale Y.
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Waveform Chart | Smuiated Sanal 17

Copy Data
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Description and Tip...
Visible rems »
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Clear Chart

N
I

AutoScale X
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e Update Mode » e
o Autosize Plot Legend
Ignore Attributes
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5 Export »
L} 1 ’5 s 1
ER /‘/.7.,\,7 15, ) /-7-,\,35 Stop Button
2- -8 10~ | -20 | Wl stop
e | L
1- \ ~9 5=\ ~15
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Figure 13. Sometimes you want to manually control the scale of a graph.

You can now change the upper and lower ranges of the Y-axis by clicking on the numbers
along the axis and typing in new values.

28. Stop the VI by pressing the Stop button.

Additional Steps

LabVIEW provides several tools that can help you develop your applications. The next few
steps will show how to use some of the most important programming assistance tools.

Block Diagram Cleanup

As you program, and especially as you learn how to program in LabVIEW, you are not

always thinking about layout and readability. This can result in a poorly organized block
diagram.

LabVIEW's Block Diagram Cleanup is a built-in tool that organizes your code, making it
easier for you and others to understand how your program functions.
29. Press the Block Diagram Cleanup icon found on the menu bar.

{8 2 - Simulate Signal to Graphwi Block Diagram cn Temperature lvproj/My Computer = | B e

File Edit View Project Operate Tools Window Help
o [ O@|Lbu|lﬁ’ . |14ptAppIication Font |« ||Em' ||'_|JEV||@‘9£”%| H
| S~ -

*| Search 4 |

Figure 14. Block Diagram Cleanup will automatically organize your code.

Your block diagram should now be organized, with cleaner wires and an even distribution
of code elements.
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Highlight Execution

30. Press the Highlight Execution button on the menu bar. Notice that the light bulb
icon now appears to be on.

=RREN X

{8 2 - Simulate Signal to Graphwi Block Diagram cn Temperature lvproj/My Computer

File Edit View Proj erate Tools Window Help

o & O _ |Lb|:||'E' . |14ptAppIication Font |+ ||$m'||‘_ﬂhu'||@b'”1’ﬁ|
N

*| Search J\ |

Figure 15. Highlight Execution slows your code to let you visualize dataflow.
31. Run your application with Highlight Execution turned on. Press the Run arrow and
watch as your code executes step-by-step. While not always necessary for simple

applications, the Highlight Execution tool is a powerful resource for troubleshooting
complex programs and determining if your code performs as expected.

Context Help

32. Press the Context Help button in the upper right portion of the block diagram.

=RNC X

{3 2 - simulate Signal to Graphwvi Block Diagram on Temperature.lvproj/My Computer

File Edit View Project Operate Tools Window Help

-,
o |2 O@|L.u|lﬁ’ . |14ptAppIication Font |« ||E;,—_|' ||7|:|E'||@,b'”1”d| |" Search { | E'K
N

-~

Figure 16. Context Help displays a context-based help dialog.

33. With Context Help active, hover your cursor over different objects on the block
diagram and front panel of Simulate Signal to Graph.vi. As you do so, the Context
Help Window provides details including descriptions and wiring diagrams.

Context Help @
Simulate Signal
Offset 1
Frequency Frequency T
[oni® Amplitude g
. ey re—— t
Amplitude |: Phase i . § BITOT O
o b error in (no error) ==t Slmulalze5|. nal )
E— I Reset Signal Simulated Signa e Simulsted Signal
[Simulale Signal Waveform Chart Simulates a sine wave, square wave, triangle wave, sawtooth wave, or
Simulated Signa s m— =] noise signal.
This Express Vlis configured as follows: ||
stop
m @ @I Signal Type: Sine
Frequency: 10.1 Hz
Amplitude: 1
Phase: 0
T &|?] ¢ 3

Figure 17. Context Help is a quick way to get a VI's overview, inputs, and outputs.

34. Right-click the block diagram and navigate around the palettes. Notice that the
Context Help window provides details on the objects while they are in the palettes.
Also notice that for some objects, the Context Help window provides a link for
Detailed Help. This link will open the LabVIEW Help and give you more information.
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35. Save Z - Simulate Signal to Graph.viand close.

Part C  The purpose of this exercise is to use LabVIEW and NI CompactDAQ to quickly set up a
program to acquire temperature data.

1. Right-click the Exercises folder and select New » VI. Once opened, save the VI in
the Exercises folder under the name 3 - Basic Measurement.vi.

2. Press <Ctrl+T> to tile front panel and block diagram windows.

3. Pull up the Functions Palette by right-clicking the white space on the LabVIEW
block diagram window.

4. Move your mouse over the Express » Input palette and click the DAQ Assistant
Express VI. Left-click the empty space to place it on the block diagram.

Control Design & Simulation b

SignalExpress L3

e %

Addons b o) Express

Favorites '
User Libraries 1 E wﬂ ﬁ ‘I H’l
Selecta VL. 4-] Input

Input 0

e @ e

Exec Control | DAQAssist  InstrAssist  Instr Drivers

Simulste Sig  Sirn Arb Sig  Acquire Sound

Read Meas File Prompt User File Dialog

Figure 1. The DAQ Assistant is a configuration-based way to acquire data from real or
simulated hardware.
5. The Create New... window then appears:

~
B Create New .. m

ymrmt
INSTRUMENTS"

-

{#  Acquire Signals

Salect the measurement type for the

task. Generate Signals

A task is a collection of one or more
virtual channels with timing, triggering.
and other properties.

To have multiple measurement types
within a single task, you must first create
the taslk with one measurement type.
After you create the task, click the Add
Channels button to add a new
measurement type to the task.

< Back Next > Finish
|
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Figure 2. NI-DAQmx tasks are a collection of channels with homogenous timing and
triggering properties.

6. To configure a temperature measurement application with a thermocouple, click
Acquire Signals » Analog Input » Temperature » Thermocouple.

7. Click the + sign next to the module named Temperature (NI 9213), highlight

channel ai0, and click Finish. This adds a physical channel to your measurement
task.

8. Within the DAQ Assistant configuration dialog, change the CJC Source to Built In
and Acquisition Mode to Continuous Samples.

9. Change the Samples to Readto 100.
10. Change the Rate (Hz)to 1k.

11. Click the Run button. You will see the temperature readings from the
thermocouple in test panel window.

{# DAQ Assistant ]

9 o e | + x
Undo Run Add Channels Remove Channels Show Help

[{aif Express Task |42 Connection Diagrem|
™
o 500m-|

2
-
< -500m-|

......

Time
Graph [+] visplay Type Autoscale Y-Axis

gering | Advanced Timing | Logoing |

Thermocouple Setup
Femedic § secings | B Device | 4, Calbraton |

Click the Add Charnels button buitin _[=]
(4] to 2dd more charnels to
the task.

Acquiition Mode Samples to Read Rate (H2)
Continuous Samples [=] 100 1k

Figure 3. You can configure and test your measurement from within the DAQ Assistant
window.

12. Click Stop and then click OK to close the Express block configuration window to
return to the LabVIEW block diagram.

13. LabVIEW automatically creates the code for this measurement task. Since we
select a Continuous Samples measurement, it makes sense for the code to be

39



placed within a While Loop, which LabVIEW informs us. Click Yes to automatically
create a While Loop.

Confirm Auto Loop Creation |

v _"-‘ fou have configured this task with a mede that typically requires you to
' place the DAQ Assistant Express VIin a loop. Would you like to
automatically create the loep now? You will not be prompted again for
this VI

Figure 4. LabVIEW notifies us that the code should likely be placed within a loop.

14. Right-click the data terminal output on the right side of the DAQ Assistant Express
VI and select Create » Graph Indicator.

:

: )

DAQ AssistantA

ia_l‘r}wsimakem; s

Help

Description and Tip..
Breakpoint 3

Select Input/Output »
Insert Input/Output

Remove Output

DAQmc - Data Acquisition Palette b
Signal Manipulation Palette »

Control
Replace » s
Graph Indicator
Open Front Panel Numeric Indicator

Size To Text

View As Icon

Convert to NI-DAQmx Task
Generate NI-DAQmx Code

Properties

Figure 5. You can automatically create a front panel object from the block diagram.

15. Rename the new Waveform Graph indicator from Datato Temperature.
16. Notice that a corresponding graph indicator is placed on the front panel.
17. Your block diagram should now look like the figure below. The While Loop

automatically adds a Stop button to your front panel that allows you to stop the
execution of the loop.

DAC Assistant Temperature
data = e

:

Figure 6. The fully-functional application that acquires temperature data.

18. Feel free to Run the VI to test its functionality. Press Stop when you are finished.
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19. Save the VI.

Additional Steps

Express VIs make creating basic applications very easy. Their configuration dialogs allow
you to set parameters and customize inputs and outputs based on your application
requirements. However, to optimize your DAQ application’s performance and allow for
greater control, you should use standard DAQmx driver VIs. The DAQ Assistant can
automatically generate standard DAQmx code; not all Express Vls have this functionality.

Before you generate standard DAQmx code from the DAQ Assistant, you need to remove
any unnecessary code that was automatically created by the Express VI.

20. Right-click the While Loop and select Remove While Loop. Then click the Stop
button and press the <Delete> key to remove the Stop button. Repeat these
actions for the Temperature Graph as well as any additional wires that may remain.
You can press <Ctrl+B> to remove all unconnected wires from a block diagram.

21. When you are left with only a DAQ Assistant, right-click on the DAQ Assistant
Express VI you created in this exercise and select Generate NI-DAQmx Code.

" L
" H
4
» o
DAQ Assiste—
data

=2

i Help

Visible ftems 3

Description and Tip...
Breakpoint 4

DAQmx - Data Acquisition Palette  »
Replace »

Open Front Panel

Size To Text
View AsIcon

t onvert to NI-DAQmx T
Generate NI-DAQmx Code

Top

Figure 7. Generate NI-DAQmx code from the DAQ Assistant’s configuration.

Your block diagram should now appear something like this:

number of samples
5
b E3

timeout (s} E
10

NChan NSamp

Analog 1D Wfm _ E-b status E ....... “

-
Figure 8. The lower-level DAQmx equivalent of the DAQ Assistant’s configuration.

The Express VI has been replaced by four ViIs. We'll examine their functionality in the
following steps.
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Part D
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22. Open Context Help by clicking the Context Help icon () on the upper-right
corner of the block diagram.

23. Hover your cursor over each VI and examine their descriptions and wiring diagram.

24. DAOmx Read.vireads data based on the parameters it receives from the Untitled
I/ on the far left.

25. Double-click the Untitled V/ and open that VlI's block diagram (code shown below).

emperature/ai
D on & = DAQmx Channel §
[errorin] 3 £ [ iy

ActiveChans
F_AlAutoZeroMode

Al Temp TC 7]

Temperature

[ |
Figure 9. The Untitled VI contains all of the channel configuration information including but

not limited to measurement type, scaling, and timing.

All the parameters that are wired as inputs to the different DAQmx setup Vls reflect the
settings you originally configured in the DAQ Assistant Express VI.

Note: By moving these parameter and setup VIs onto the block diagram, you could now
programmatically change their values without having to stop your application and open the
Express VI configuration dialog. This can save development time and possibly optimize
performance by eliminating unnecessary settings depending on your application.

26. Close the Untitled VI. \When prompted, do not save.
27. Close 3 - Basic Measurement.vi. When prompted, do not save.

The purpose of this exercise is to expand our application to include thresholding that will
trigger a user-defined alarm.

1. From within the Exercises folder of the open 7emperature project, open 4 —
Analysis and Output.vi. This VI is functionally equivalent to the VI we created in
the previous exercise, but already provides additional space on the block diagram
to add additional code.

2. Right-click the front panel to open the Controls palette and navigate to Controls »
Silver » Numeric. Select and place a Numeric Control on the front panel.
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Figure 1. Add a numeric control to the front panel for specifying the alarm threshold.

3. Double-click the numeric control’s label and rename the control Alarm Level.

4. Switch to the block diagram; if it isn't already, drag-and-drop the Alarm Level
control into the while loop.

[+ L

[+

»

3 L
DAQ Assistant

data i

i

Alarm Level

Temperature Data

@ e
Figure 2. The resized while loop allows us more space to add code.

5. Press <Ctrl+Space> to launch Quick Drop and type “Comparison” to find the
Comparison Express V.

6. Double-click Comparison in the Quick Drop results list and place it within the while
loop.
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Once placed on the block diagram, the Comparison Express VI's configuration dialog will
appear.

ﬂ Configure Comparison [Greater]

Items to Compare Input Signal

Data points E

Compare Condition
=G omparison Inputs
@ Second signal input

~7> Mot equal
Value
@) > Greater
0
L ater or equal

Amplitude

< Less

<= Less or equal
Equal within tolerance Tolerance 001 Result Preview

1

In range Minimum 0

Out of range Maximum 1

=
Ln
|

Result

o
|

Invert result

Amplitude

~ One result per data point

@ One result per channel

&
tn
|

Qne result for all channels

-

1 i ] !
-1 075 -05 -025 0

Result Name
/| Change Express VI name to name of function

| 0K | ‘ Cancel | | Help ‘

Figure 3. The configuration dialog of the Comparison Express VI.

7. Select > Greater in the Compare Condition section, Second signal input from the
Comparison Inputs section, and One result per channel from the Result section.

Click OK.

8. Hover over the data output of the DAQ Assistant until the spool icon appears on
your cursor, then left-click and drag your mouse to the Operand 1 input on the
Comparison Express VI. Perform the same hover, drag, and connect to wire the
Alarm Level control and the Operand 2 input on the Comparison Express VI.

9. Your block diagram should now look something like this:

@
:
v
r q | |
DAQ Assistant ERFRIEY
data Operand 1
P Operand2
Alarm Level Result H
¥
Temperature Data
"""""
stop
o G

Figure 4. Comparing the acquired data to a user-specified alarm level.

10. On the front panel, right-click and navigate to Controls » Silver » Boolean » LED
(Silver). Place the LED on the front panel and resize the LED so that it is easier to

See.

11. Rename the LED A/arm. Your front panel should look like this:
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34 Analysis and Outputvi Front Panel on Temperature.lvproj/My Com‘.‘ﬂléj
File Edit View Project Operate Tools Window Help {:I
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Temperature
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Time
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Figure 5. The Ul now contains mechanisms for user input and data display.

12. If it isn't already, drag-and-drop the Alarm indicator into the while loop.

13. On the block diagram, wire the output of the Comparison Express V/to the input of
the A/arm indicator’s terminal.

@
:
*
* d X ]
DAQ Assistant Greater
data Operand 1
P Operand 2 Alarm
Alarm Level Result H
3
Temperature Data
stop

0 TER @

Figure 6. At this point, the application will notify the user if the measurement exceeds a
specified threshold.

14. Press the Run button and change the Alarm Level control to some level above the
current acquired temperature signal. Hold the thermocouple until the temperature
exceeds the Alarm Level value. The Alarm LED turns on when the acquired
temperature signal goes above the level set on the front panel. Next, we will
update a digital line depending on this LED status.

15. Stop the VI using the Stop button on the front panel.
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16. Switch to the block diagram. Right-click to access the functions palette and select
the DAQ Assistant Express VI from Functions » Express » Output. Place the DAQ
Assistant on the block diagram within the while loop.
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Compasisan Timing maulm..
B &
FlelD Werdorn  Applcation

2 % s

Synchronizat... Graphics & 5... Report Gener...
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Wl Anshyzer  Urit Test Fra

Measurement 1'0 *
Instrument L'0 *
Viion and Motion »
Mathematics. *
Sagnal Prcseviing »
Dats Communication »
Connectivity 1 1 Express
m
Select 8 VL., L =
: i [
Toput Ggnalfealyis Cutput nﬂi‘g nl.yWn
S e
&l EW I@I IEI 1]
e Contrel  Asmh & Com._ wmeMulF- Dladem Rep... MS Ofe Repart

Figure 7. Adding another DAQ Assistant will allow us to control the digital module.

17. Within the Create New... dialog, select Generate Signals » Digital Output » Line
Output

r ™
B 7 Create New .. m

-

Select the measurement type for the Acquire Signals

task. = Generate Signals

A task is a collection of one or more
virtusl channals with timing, triggering, Analog Output

and other properties.
mree Counter Output
To have multiple measurement types

within a single task, you must first create = Dhgtal Output
the task with one measurament typa.

After you create the task, click the Add 7. Line Output
Channels button to add a new

measurament type to the task. S5 Port Output

< Back Next » Finish 4
Figure 8. A digital line output allows us to generate data to one single digital line.

18. Expand the + sign next to the Digital_out module in the following window and
select port0/line0, then click Finish.

19. Press OK in the DAQ Assistant window that appears, since all of its default
settings are correct for the application.

ni.com/daq 46



20. Create an additional wire that connects the Comparison Express VI's Result output
to the data input on the new DAQ Assistant? Express V.

A Convert from Dynamic Data function appears automatically. LabVIEW will always try to
coerce unlike data types when two nodes are wired together. In this case, the output of
the Comparison Express VI is a Dynamic Data type, and the input of the DAQ Assistant is
Boolean. LabVIEW placed the Convert from Dynamic Data node in between the two

nodes so they could be connected without a syntax error. Your block diagram should now
look like this:

3
i 3
i 4 id ¥ >
DAQ Assistant Greater b - N
data Operand 1 DAQ J:lsstlsta nt2
- #  Operand 2 i a
Alarm Level Result ¥
7l =
Temperature Data
--------
stop
| e

Figure 9. The threshold comparison result will be output to the digital module.
21. Press the Run button. Notice that the LED bank on the CompactDAQ 9472 module
turns on and off to match A/arm’s value on the front panel.

22. Save the VI.

Part E The purpose of this exercise is to save our acquired data to file for future processing,

which could include sharing with colleagues, turning into a report, running additional
analysis, or all of the above.

1. The 4 - Analysis and Outout.vi should still be open from the previous exercise. |If
not, open it now from the Exercises folder in the 7Temperature project.

2. Right-click the block diagram and select Functions » File I/O » Write to

Measurement File. Place the Express VI inside the While Loop on the block
diagram.
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Figure 1. LabVIEW includes dozens of options for reading and writing files.

3. Since this is an Express VI, a configuration window will appear. Configure the
window as shown below, but be sure to make a mental note of the file location in
the Filename field. When finished, click OK.

ﬂ Configure Write To Measurement File [Write To Measurement File] g

File Format

T Text (LVM)
@ Binary (TDMS)
—Rinary with XMi-Header (TDM)

Filename

Lock file for faster access
Action
@ Save to one file
[] Ask user to choose file
9 Ask only once

Ask each iteration

If a file already exists
(*) Rename existing file

) One column per chagnel

(@ One column only

e filename

@ Append to file

Delimiter
- @ Tabulator
() Save to series of files (multiple files) _
Comma
Settings...
File Description
[ OK l [ Cancel ] [ Help l

Figure 2. This configuration will save a binary file that is able to be post-pfocessed in
common software such as NI DIAdem or Microsoft Excel.

4. Wire the output of the DAQ Assistant Express V/to the input of the Wiite to
Measurement File Express V.

5. Your block diagram should now resemble the following figure.
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Figure 3. This completed application acquires temperature data, outputs a digital signal if
the temperature exceeds a threshold, and saves all of the data to file.

6. Run the VI momentarily and press Stop to stop the VI.

7. Your file will be created in the folder specified. If you can’t remember the location
of the file, double-click the Write to Measurement File Express VI.

8. Using Windows Explorer, navigate to the location of the data file on disk.

9. Right-click on the file in Windows Explorer and select Open With » Excel Importer

to open it with Microsoft Excel. Review the header a

nd temperature data saved in

the file. Note that they may be contained within different Excel worksheets (tabs).
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Figure 4. The resulting temperature data file that was saved from the completed

LabVIEW application.
10. Close the data file, if it is still open.
11. Close the LabVIEW VI, if it is still open.

12. Close the Temperature Project, if it is still open.
<End of Exercise>
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Combining Measurements from Light and Temperature
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Goals e In this exercise, you will acquire a light signal using NI-DAQmx
e In the second part of this exercise, you will modify the example to scale the data
and measure the ambient light in the Measurements Demo Box

Part A Open and Run Our Starting Point

Estimated time: 20 minutes

Today's exercises start with a pre-built single-channel measurement system that
measures temperature data from a thermocouple. We will expand this system to acquire
mixed-measurement data from two sensors (a thermocouple and a solar cell) using two
different modules and write data to a scalable file format.

1. If you have not done so already, launch NI LabVIEW by selecting Start » All
Programs » National Instruments » LabVIEW <Year> » LabVIEW.
2. Open the Light Sensor Project.
a. Inthe LabVIEW Getting Started Window, select Open Existing.
b. Navigate to C:\Seminars\LV HO\Exercises\ - Light.
c. Select and open Light Sensor Project.lvproj.
3. Open and run the starting point application.
a. Inthe LabVIEW Project, double-click to select Exercises » 1 — Write

Temperature to ASCII File (Original).vi.

b. Run the application by clicking the Run arrow () on the front panel as
shown in Figure 1.

c. While the application is running, use your finger to warm the thermocouple
attached to the Analog Input 0 (ai0) channel of the NI 9213 module.

d. Verify that the temperature signal on the LabVIEW front panel graph rises
and falls appropriately, and that the LED indicator turns on when the
temperature exceeds 26 °C. When the LED indicator turns on, the physical
LED on the NI 9472 digital output module should also light.

e. Stop the VI by selecting the Stop button on the LabVIEW front panel as
shown in Figure 1.
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Figure 1.
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4. Press <Ctrl+E> to view the Block Diagram.

Use the Run arrow to run the LabVIEW application.

This LabVIEW code uses the DAQ Assistant to acquire data - an Express VI with
built-in configuration steps, eliminating the need for many of the most common
device configurations. That said, the DAQ Assistant has some limitations when
you need more control of your DAQmx device, like synchronization or specific
device parameters that are outside the scope of this seminar. In the coming
exercises, you will learn the basics of using the standard (non-Express) NI-DAQmx
API. This lower-level programming method opens up the capabilities of the device
and in the long run, will make you a better user.

131 - write Temperature to ASCI File (Original).vi Block Diagram on Light Sensor Project.ivproj/My Computer
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Figure 2. Using a DAQ Assistant is an easy way to get up and running acquiring

5. Close the VI.

data.
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Part B Use the Low-Level NI-DAQmx AP

Estimated time: 20 minutes

Though the DAQ Assistant used in the last exercise got the job done, it isn't quite as

flexible or scalable for mixed-measurement applications. This exercise will replace the
DAQ Assistant and accomplish the equivalent measurements using the more flexible

lower-level NI-DAQmx Vls.

1. Open the exercise application.

a. Inthe LabVIEW Project, double-click to select Exercises » 2 — Use the NI-
DAQmx Vls (Original).vi.

2. Examine the lower-level NI-DAQmMx code.

a. Select Window » Show Block Diagram or press <Ctrl+E> to examine the
LabVIEW code.

b. Ifitis not already open, select Help » Show Context Help or press
<Ctrl+H> to turn on LabVIEW Context Help.

c. Navigate to the left-most section of code on the diagram, as shown in
Figure 3.
a e . proj/My Computer [E=icE =<

File Edt View Project Operate Tools Window Help

® 1| @] [25] 4o 5 .+ |[ 159t Application Fant |~ || 3o~ | o~ | [~ |2l B A [®

physical channel
[cDAQIMod1 /30 1
L

i) [

[Light Sensor Project vproj/ Ny Compu

Figure 3. The lower-level NI-DAQmx API follows a logical pattern.

d. One at a time, hover over the Vls on the block diagram and examine their
functionality as described in the Context Help window, as shown in Figure
4.

Context Help @

DAGmx Read (Analog 1D Wm NChan NSamp).vi {4833)

task/channels in [0]
number of samples per channel [7]
error in [L1] ==

[4] task out
&[] data
S [ 15] error out

Reads one ar maore waveforms from a task that contains ane ar more
analog input channels.

Detailed help
[=[E12] « '
Figure 4. The Context Help dialog gives you detailed information about every VI, as
well as its expected inputs and output values.
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Notice that the logical flow of the NI-DAQmx API begins by configuring an analog
input channel that corresponds to a physical channel of measurement.

Just before the while loop, the acquisition is started. Within the loop, samples are
read from the NI-DAQmx buffer repeatedly until the user stops the loop, at which
point the acquisition setup is cleared from memory.

3. Add Timing configuration to the lower-level NI-DAQmx code.

Right-click in the white space on the block diagram to access the functions
palette.

b. Navigate to Measurement I/O » NI-DAQmx and select DAQmx Timing.vi.

21 DAQmx - Data Acquisition

DAQmx Timing.vi

[ ] [ ]

Task Const

DIAG %

,
Ly

Timing Triggering

[1=<I] [[=]] [I[=]
(&5 | LZ ]
Channel Made Timing Mode  Triggering M. Read Node Write Made
» ¥ = ¥ ¥
. 1
4 [%: (e
DAQ Assist Real-Time Dev Canfig  Task Config/...  Advanced

Figure 5. The NI-DAQmXx palette houses all of the data acquisition functions built

into the LabVIEW environment by the NI-DAQmx driver.

Left-click to place the DAQmx Timing.vi between the DAOmx Create
Channel VIl and the Start Task V// as shown in Figure 6.

Right-click on the Sample Mode input terminal of the DAQmx Timing.vi and
select Create » Constant from the right-click context menu.

Instead of Finite Samples, change the Sample Mode input to Continuous
Samples.

Right-click on the Rateinput and select Create » Constant from the right-
click context menu. Leave the default rate value of 1000 Hz.

Right-click on the Samples per Channel/input and select Create » Constant.

Double-click the Samples per Channel constant and change the value to
100.

Click on the output of the Task Out output of the DAQOmx Create

Channel.vi, then click again on the Task/Channels In input of the DAOmx
Timing.vi. This will connect a wire between the two nodes.
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j.  Similarly, wire the Task Out output of the DAQmx Timing.vi to the
Task/Channels In input of the DAQmx Start Task.vi.

Cjc source

physical channel
' Temperature/ail |+|

E LS B = DAQmx Channel & 112
channel name y‘:r‘u—’m 5 -'lcQtr.'EChan: B
[Temperature} [a1TempTC ~] | f_ALAutoZeroMode Sample Clock ~
NChan NSamp
ActiveChan 1000
AutoZeroMode

Figure 6. Complete the configuration of the DAQmx Timing.vi as shown.

4. Run the VI.

a. Using the Run arrow (), run the VI and ensure that it behaves with the
lower-level NI-DAQmx Vls exactly as it did using the DAQ Assistant.

b. Stop the VI by selecting the Stop button on the LabVIEW front panel.
5. Select File » Save to save your changes.

6. Keep the VI open for the next exercise.

Use an NI-DAQmx Task

Estimated time: 20 minutes

The lower-level NI-DAQmx VIs offer the greatest flexibility in programming NI LabVIEW
data acquisition applications. With the lower-level Vls, you can programmatically control
the lowest level of details to create everything from simple acquisition or generation
applications to those with multiple simultaneous channels using complex timing and
triggering.

As a compromise between the DAQ Assistant (which offers maximum ease of use while
sacrificing some relative flexibility) and the lower-level NI-DAQmx VIs (which offer
maximum flexibility while sacrificing some relative ease of use), the NI-DAQmx Task
combines configuration-based setup with low-level control —a “best of both worlds”
approach that works well for scalable applications.

1. Re-save the VI for use in Exercise 3.

a. Ifitisn't already open, within the Light Sensor Project, double-click to select
Exercises » 2 — Use the NI-DAQmx VIs (Original).vi.

b. Select File » Save As...
c. Choose Substitute copy for original and select Continue...

d. Save the VI in the <Exercises> directory as 3 — Use a NI-DAQmx Task.vi.
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2. Ifitisn't already open, select Start » All Programs » National Instruments »
Measurement & Automation Explorer to open Measurement & Automation
Explorer.

3. Add a NI-DAQmx Task to your Data Neighborhood.

a. Underneath the My System tree, right-click on Data Neighborhood and
select Create New....

b. Choose NI-DAQmx Task and select Next.

& Data Neighborhood - Measurement & Automation Explorer

File Edit View Tools Help

4 B My System * Create New...

S Data Neinhhoarhnad
 Devices ) Creste New| -
& Historical Data Data Neighborhood

“ *4 Scales Data Neighborhood provides access
4 = NI-DAQmx Scales configured physical channels in your

“4 Solar Scale messages, NI-DAQvirtual channels

& Software
@ IVI Drivers What do you want to do?

B8 Remote Systems
ys 2 Create a new shortcut

& Test or remove a shortcut
2 \iew or change properties
For more information about using Da
to your product-specific help, located
can also access NI product help from
from the Help menu or by pressing <

E Submit feedback on this topic.

Figure 7. Use the Data Neighborhood section of the My System tree to create
descriptively named shortcuts to physical channel configurations.

4. Add and configure a thermocouple analog input channel.

a. Select Acquire Signals » Analog Input » Temperature » Thermocouple as
shown in Figure 8.
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I¢ VexThermistor i

Figure 8. NI-DAQmx makes it easy to correctly configure acquisition applications
since all configuration settings are grouped by acquisition type.

b. Choose Temperature (NI 9213) » ai0 and select Next to configure the
thermocouple input on analog input channel 0 of the NI 9213 C Series
thermocouple module.

c. Rename the NI-DAQmx Task to Measure Temperature and Light and select
Finish.
Notice that the built-in configuration entry dialog that appears is identical in
every way to the DAQ Assistant in LabVIEW. As a fully integrated driver,
the user experience will be seamless whether configuring NI-DAQmx from
LabVIEW, Measurement & Automation Explorer, or any other NI software.
This contributes to both easier application flexibility and scalability.

d. Instead of 1 Sample (On Demand), change the Acquisition Mode setting to
Continuous Samples.

e. Change the Samples to Read setting to 100.
f.  Change the Rate (Hz) setting to 1000.

5. Add a second channel to the task to measure light.

a. Within the Channel Settings section, use the Add Channel button () to
select Voltage as shown in Figure 9.
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Figure 9. Both acquisition channels can be a part of the same NI-DAQmx Task
since they both share the same timing and triggering settings.

a. Within the Aad Channels to Task dialog, choose Voltage_in (NI 9215) » ai0
and select OK to configure the voltage input on analog input channel 0 of
the NI 9215 C Series analog input module.

b. Right-click on the Voltage channel and select Rename...

c. Rename the Voltage channel to Solar Energy and select OK.

6. Setup a NI-DAQmx Custom Scale.

a. Underneath the My System tree, right-click on Scales and select Create

New...

b. Choose NI-DAQmx Scale and select Next.

c. Select Map Ranges as shown in Figure 10.
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Figt]re 10. There are several different scaling options for NI-DAQmx Scales.

d. Name the scale So/ar Scale and select Finish.

e. Configure the Map Ranges Scale dialog as shown in Figure 11.

Map Ranges Scale

30+

297
] Pre-Scaled values
26—
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Walts
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25

- Scaled Yalues
25

T axinnurm Tinirnum

Units
Pre-scaled

Valks [=]

Scaled

Figure 11. The NI-DAQmx Map Ranges scale maps one range of values to another
range of values.

f.  Save the changes to the NI-DAQmx Scale by selecting Save.
7. Apply the NI-DAQmx Scale to the Task.

a. Underneath the My System tree, select NI-DAQmx Tasks » Measure
Temperature and Light.
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Select the Solar Energy channel in the task.

Change the Custom Scaling setting to Solar Scale. If it does not appear in
the list, you did not save your scale in this exercise during Part C, Step 6F!

Change the Signal Input Range Min setting to 25.
Change the Signal Input Range Max setting to 30.

Save the Measure Temperature and Light task by selecting Save. The Solar
Energy channel should be configured as shown in Figure 12.

The specifications for the solar cell sensor dictate that it outputs a voltage
value between 0 Volts (no light present) and .5 Volts (full sunlight). Light in
the seminar room will output a tiny voltage value, so our scale will map it
onto larger voltage values. Though the thermocouple also outputs values in
this (small) voltage range, the thermocouple channel type in the task
automatically maps the thermocouple output values to a degrees Celsius
(°C) scale between 0 and 100.

Applying our custom scale to the solar measurements will map the solar
values into the same range of values being represented by the
thermocouple channel at approximately room temperature.

Configuration | Triggering | fdvanced Timing | Logging |

Channel Settings

Details | “ | Veltage Input Setup

Temperature ! et
Solar Emergy

Calibration

Signal Inpuk Range
Scaled Uniks

Walks E

Max

in 25

Terminal Configuration

Click tha Add Channels buttan == ~Z
(+1 fo add move channeals éo Custom Scaling
the task. Saolar Scale E| P )
- _p"'.'
e —
Timing Setkings
Acquisition Mode Samples ko Read Rate (Hz)
Conkinuaus Samples E| 100 1k

Figure 12. The Solar Energy channel uses its own scaling configuration but shares

timing and triggering settings with all other channels in the same task.

8. Use the NI-DAQmMx Task in the LabVIEW.
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a. Inthe 3 - Use a NI-DAQmx Task.vi within LabVIEW, click-and-drag to
highlight all VIs and input parameters to the left of the DAQOmx Start Task.vi
as shown in Figure 13.

13 3 - Use a NI-DAQmx Taskui Block Diagram on Light Sensor Project.vproj/My Computer

File Edit View Project Operate Tools Window Help
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Continuou

3 =% DAQmx Channel 3
22Chans
oMode

number of samples

""""

Analog 1D Wfm b
NChan N5amp

§ {Sample Clock -}

Figure 13. Delete all configuration Vls and input parameters to the left of the
DAQmx Start Task.vi.

b. Using your keyboard, press Delete to delete the code to the left of the
DAQmx Start Task.vi.

c. Press <Ctrl+B> to clear any broken wires resulting from the removal of the
configuration code.

d. Right-click in the white space on the block diagram to access the functions
palette.

e. Navigate to Measurement I/O » NI-DAQmx and select DAQmx Task Name
Constant.

3] DAQmx - Data Acquisition

Task Const J Channel Const Create Chan...

Timing Triggering
[1=T] [1=T] [1=1 ] [1=*T] [1=]]
&
Channel Made Timing Made Triggering N...  Read Node Write Made
¥ 3 5= M ¥
! |:§@: T %@
DAQ Assist Real-Time Dev Config  Task Config/..  Advanced
Figure 14. Select the DAQmx Task Name Constant from the DAQmx functions
palette.
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f. Left-click to place the DAQmx Task Name Constant to the left of the
DAQmx Start Task VI.

g. Using the drop-down, select the Measure Temperature and Light task that
you configured in Measurement & Automation Explorer.

h. Wire the task from the output of the DAQmx Task Name Constant to the
input of the Task / Channels In input of the DAQmx Start Task.vi as shown
in Figure 15.

DAOmx Task Mame
I?ﬁ Measure Ternperature and Light |v

number of

Figure 15. Replace the configuration ViIs and input parameters with the DAQmx
Task Name Constant.

i. Right-click on the wire exiting the Result output of the Comparison Express
VI.

j.  From the right-click context menu, select Insert » Signal Manipulation
Palette » Split Signals as shown in Figure 16.

v v
. L4
Comparison
(3
Operand 1 _ b ¥

m Level Operanclﬁf DAQ Assistant?
H Result L3 i r data
i \\\-‘.‘-—r_-' =
perature Alarm Output
1]

Figure 16. Insert the Split Signals node immediately after the Comparison Express
VI.

Due to the tight integration between LabVIEW, hardware, and the NI-DAQmx
driver, LabVIEW is aware of the creation or configuration of tasks or settings in
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Measurement & Automation Explorer. Any tasks created in Measurement &
Automation Explorer automatically populate within LabVIEW.

Because the Measure Temperature and Light task includes two channels, we must

split the signal coming out of the Comparison VI so that only the results of the
Temperature channel are output to the digital output DAQ Assistant.

9. Run the VI.
a. Using the Run arrow (), run the VI.

b. While the application is running, use your finger to warm the thermocouple
and verify that the temperature rises appropriately.

c. While the application is running, use your hand to shield the solar cell
sensor from light and verify that the voltage falls appropriately. Alternatively,
you can provide additional light by using an available cell phone and
verifying that the voltage rises appropriately. The solar cell should not react
as drastically as the thermocouple.

d. Stop the VI by selecting the Stop button on the LabVIEW front panel.

10. Save the VI.

11. Keep the VI open for the next exercise.

Save a Well-Documented File
Estimated time: 20 minutes

The project already writes to an ASCII file in the form of a LabVIEW Measurement (*.LVM)
file. ASCII files are reasonable choices for small, one-shot applications, but the ASCII file
format is not a viable data storage choice for applications that require scalability due to the
large amount of overheard required using ASCII format.
This exercise will replace the ASCII format with a more flexible, scalable file format — the
Technical Data Management Streaming (TDMS) file format — which will also yield future
benefits for data management and mining.

1. Re-save the VI for use in Exercise 4.

e. Ifitisn't already open, within the Light Sensor Project, double-click to select
Exercises » 3 — Use a NI-DAQmx Task.vi.

f.  Select File » Save As...
g. Choose Substitute copy for original and select Continue...
h. Save the VI in the <Exercises> directory as 4 — Save a Well Documented

File.
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2. Configure the Write to Measurement File format options.

On the block diagram, double-click the Write to Measurement File Express
l//to open its configuration dialog.

a.

b. Inthe File Format section, select Binary (TDMS).

c. Make a mental note of the directory in the Filename path directory.

Ef> ConﬁguWMeasumment File]
Filename File For
ChUsersy Administratar.Documents'. LabVIEW Data’, Text {
Test.tclms @ Bina
Binary
Locl
Action
Segmer
@ Savet fil
2 Save to one file © Oneh
[] Ask user to choase file
@ One h
@ Ask anly ance Mo he
Ask each iteration

Figure 17. The new TDMS data files should be saved in the LabVIEW Data directory.
d. Inthe /fa File Already Exists section, select Use Next Available Filename.

e. Provide an explanatory description of the file's purpose in the File
Description field.

f.  Ensure that the dialog is configured similar to the settings in Figure 18.
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FiguFe 18. The Write to Measurement File Express VI provides maximum eaée of

use but, like all Express Vls, sacrifices some flexibility.

3. Write custom, descriptive properties to the structure of the TDMS file.

In the Configure Write to Measurement File configuration dialog, select
Advanced....

On the TDM Properties tab, select Insert.

In the Hierarchy Level column, select Channel Group.

In the Data Type column, select STR (string).

In the Name column, replace the text Untitled_0 with the text Author.

In the Value column for the Author property, type your name (i.e. Jane
Smith).

Repeat steps 3B — 3F as desired to document more custom properties.
Feel free to experiment! With the TDMS file format, you can document an
unlimited number of properties, and the more you add, the more flexibility
you gain later when trying to search for or manage your data.

Some optional properties to include are Location, Test Type, and Serial
Number. You can populate these properties with made up values.
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43 Configure User Defined Properties &J
TDM Praperties | DAQmx Properties
Saurce Mame Value Data Type Hierarchy Level -
Value Author Jane Smith STR. Channel group
Value Lacation Austin, TX STR Channel group
m Serial_Mumber  C397-A STR. Channel group
[ 0K ] [ Cancel ] [ Help ]

Figure 19. With the TDMS format, you can easily add unlimited descriptive
information to the file. Feel free to experiment!

4. Add NI-DAQmx Properties to the TDMS file.
a. Inthe Configure User Defined Properties dialog, select the DAQmx
Properties tab.

b. Check the box for Analog Input.

{3 Configure User Defined Properties @

TDIM Properties | DAQmx Properties
MmechMenies Edit starage property name -

EX=]

- ® Analog Input
i [ Analog Outy
[ [ Digital Input
[ O Digital Output

B O Counter Input

[ [ Counter Output
[ [ General Properties

[ QK ][ Cancel ][ Help ]

Figure 26. With the NI-DAQmx driver, you can automatically log all ac;quisition
settings to TDMS properties for future reference.

c. Select OK to close the Configure User Defined Properties dialog box.
d. Select OK to close the Configure Write to Measurement File dialog box.
5. Connect the NI-DAQmx Task to the Write to Measurement File Express VI.

a. Wire the purple Task Out output of the DAQmx Read.vi to the DAQmx Task
input of the Write to Measurement File Express VI as shown in Figure 20.
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Figure 21. The purple DAQmx Task wire contains all data acquisition settings from
the Measure Temperature and Light task.

By configuring the Write to Measurement File Express VI to write all Analog Input
properties from the task, the NI-DAQmx driver automatically saves any Analog
Input properties utilized in the measurement with the data file. These properties
include descriptive settings such as custom scale information, measurement units,
or thermocouple type — all very helpful information to have automatically
documented!

6. Prompt the user for a test description.
a. Right-click in the white space on the block diagram to access the functions
palette.

b. Navigate to Programming » Dialog & User Interface and select the Prompt
User for Input Express VI.

c. Left-click to place the Prompt User for Input Express VI outside of the while
loop somewhere to the left of the while loop as shown in Figure 21.
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Figure 22. The Prompt User for Input Express VI is placed before the while loop
since it is the first thing we want to happen when the application runs.

d. Inthe Configure Prompt User for Input dialog that appears, type Please
Provide a Test Name: in the Message to Display field.

e. Inthe Inputs entry section, type Response in the Input Name column.

f. In the Inputs entry section, select Text Entry Box for the Input Data Type of
the Response entry.

g. Confirm that the dialog is configured to match Figure 22 and then select OK
to close the dialog.

ﬂ Configure Prompt User for Input [Prompt User for Input]  —. |
g P P P P
Message to Display Inputs
Please Provide a Test Name: - Input Mame [ Input Data Type
Respanse Text Entry Box El
Number -
Mumber -
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Mumber -
Fumber -
MNumber -
Mumber -
Number -
= Mumber -
Buttons to Display Edit Inputs
First button name Tnsert ] [ Delete
OK
Secand buttan name Window Title
Cancel [] Display secand button Prompt User for Input
[ 0K ] I Cancel ] I Help ]

Figure 23. The Prompt User for Input Express VI is a quick and easy way to get
feedback from the user.

h. Wire the pink Response output of the Prompt User for Input Express VI

through the while loop to the pink Comment input of the Write to
Measurement File Express VI as shown in Figure 23.
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i.  Wire the yellow Error Out output of the Prompt User for Input Express VI to
the Error In input terminal of the DAQmx Start Task.vi as shown in Figure

8 4 - Save 2 Well-Documented File (Solution).vi Block Diagram on Creating Scalable, Mixed Measurement Systems.lvproj/My Computer = | G S|
File Edit View Project Operate Tools Window Help
— o
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Input -
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Figure 24. The Write to Measurement File takes input from multiple sources.

By wiring the Error Out output of the Prompt User for Input Express VI to the Error
In input terminal of the DAQmx Start Task VI, we ensure that the acquisition is not
started until the user is finished responding to our prompt. By enforcing an order
of execution in this way, we are using a differentiating feature of LabVIEW called
dataflow — we literally get to control the flow and timing of data.

7. Run the VI.
a. Using the Run arrow (), run the VI.

b. Inthe Prompt User for Input dialog, type any unique name for the test such
as "Test 001-A."

c. While the application is running, use your finger to warm the thermocouple;
use your hand or cell phone to vary the amount of light reaching the solar
cell.

d. Stop the VI by selecting the Stop button on the LabVIEW front panel.

e. Repeat steps 7A — 7D as desired to create a few varying data sets. Some
options include:

i. During one test, interact only with the thermocouple.

ii. During one test, interact only with the solar cell.

iii.  During one test, interact with both sensors, starting at the same
time.

iv. During one test, interact with both sensors, starting at different
times.

8. Save the VI.
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9. Using Windows Explorer, navigate on disk to the location where the data was
saved. If you forgot where the data was saved, you can double-click the Write to
Measurement File Express VI on the block diagram and examine the Filename

control.

13.

Right-click on one of your data files in Windows Explorer and select Open With »

Excel Importer to open it with Microsoft Excel. Review the header information on
the first Excel sheet (tab) and notice all of your custom descriptive properties.

14. Review the properties that were added to the file by the DAQmx driver, such as

the name of the custom scale and the measurement type.
15. Switch to the second Excel sheet (tab) in the file and notice the time, temperature,
and solar energy data saved in the file.

”
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& = = Bookl - Microsoft Excel
g Home Insert Page Layout Formulas Data Review View D
= % Calibri 1 - F= ; =  Text - (B conditional Fo
J ErRd (B 1 U~ A A = - $ - % + [ FormatasTabl
aste d | H S A E i P %50 10 [ Cell Styles =
Clipboard Font Alignment Mumber Styles
AL - F | Time 4
A B C D E
1 [Time Time* Temperature Solar Energy
2 | 10/26/2012 04:27:44.532 AM 0 24.28739925 27.8872623
3 | 10/26/2012 04:27:44.533 AM 0.001 24.28739925 27.8872623
4 | 10/26/2012 04:27:44.534 AM 0.002 24.28739925 27.7598619
5 | 10/26/2012 04:27:44.535 AM 0.003 24.28739925  27.791712
6 | 10/26/2012 04:27:44.536 AM 0.004 24.28739925 27.9509625
7 | 10/26/2012 04:27:44.537 AM 0.005 24.28739925 28.0465128
8 | 10/26/2012 04:27:44.538 AM 0.006 24.28739925  28.110213

Figure 25. The fully documented file contains metadata and measurement data.

16. Close the data file, if it is still open.

17. Close the LabVIEW VI, if it is still

open.

18. Close the Light Sensor Project, if it is still open.

<End of Exercise>
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Strain Gage Measurement with User LED Feedback



Goals e In the first part of this exercise, you will write a program to acquire data from a
strain gage in a quarter bridge configuration.
e For the second part, you will add code to indicate approximate strain to a user with
LED indicators
o Key concepts include
0 Strain measurement
Using the NI-DAQmx API
Using SubVls
Combining measurement and control tasks
Writing to file when an event occurs

©O 00O

Part A Measuring Data From a Strain Gage

Estimated time. 40 minutes

Acquiring strain data is one of the most common tasks in any structural measurement
system. Strain is measured using a strain gage, which is a small resistive element that
changes resistance when deflected. Because the resistance changes proportionally with
deflection, you could excite the strain gage with a current and measure the voltage change
to calculate the change in resistance. However, because the change in resistance is so
small, a better solution is to use a Wheatstone bridge configuration to measure the small
changes in resistance.

Figure 1. A Wheatstone Bridge enables precise measurement of small resistance
changes.

In a Wheatstone Bridge, four resistors are used in the configuration seen in Figure 1 and
excited using a voltage source Ve. |f all four resistors are equal, the bridge is said to be
balanced and the voltage measured at V, will be equal to zero. When using a Wheatstone
bridge to measure strain, the strain gage will have a nominal resistance equal to the other
elements of the bridge, in the case of this exercise, 350 Ohms. As the strain gage flexes,
the resistance changes and, consequently, V.. Knowing this, we can derive the
proportional change (without getting into any details), arriving at the following equation:
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Vo GFs¢ 1

1 +GFet
=

Figure 2. In a quarter bridge configuration, we can calculate strain based on the voltage
change.

In this exercise, you will use a strain gage in the quarter bridge configuration, meaning that
only one of the gages is active.

Strain gages are particularly delicate. Before you start this exercise, confirm that the strain
gage is properly connected and you are able to acquire basic data from the channel
connected to the strain gage.

1. On the NI CompactDAQ chassis, ensure that the green Power and amber Ready
LEDs are lit to confirm that the chassis is connected over USB and powered on.

2. Examine the wiring into the NI 9237 module to confirm that the strain gage is
properly connected.

3. Ifitisn’t already open, launch Measurement & Automation Explorer by selecting
Start » All Programs » National Instruments » Measurement & Automation
Explorer.

4. Right-click on the NI 9237 and select Test Panels....

:.. 2 NT8237 "Strain” - Measurement & Automation Explorer | = (=] ﬁ
| Fite Edit view Tools Help |
4 W My System 3] #¥ Refresh | + Reset [ Self-Test [ Test Panels.. | {# Create Task.. - Device Pinouts @ Configure TEDS... 37 Hide Help

& Data Neighborhood - |cBack -
< @ Devices and Interfaces =
@ Integrated Webcam “cam” Settings NI-DAQmx Device Basics
® ASRLL:INSTR "COM1 what do you mant 1o dot
= ASHLLO:INSTR "LPTL” Mame Strain
4 B0 NI cDAQ-9178 “cDAQL . PRun the NI-DAQM Test Panels
_— . . Vendor Mational Instruments .
B 1:NI9211 "Temperature MRemove the device
02 NIE9237 "Strain® Model I}
D 3: NI9472 "oi:im-v Reset ‘_’;i;N“thr :1::;:0 | Wiew or change device: confiquration
D 4: NI9263 "Volti [ Self-Test 1
D 6 NI9234 "Sour [ Create Task.. Slot Numbser 2
™ & NE9215 Volt g Configure TEDS.. Status Present
4 Metwork Devices
0 NI Switch Executive Rename
B Historical Data
“d Scales = W External Calibration
& Software M Device Pinouts
il VI Drvers Help ' Cahbraton Date 2/13/2012 5:07:26 PM
& Remote Systems Recommended Next 213/2013 507:26 PM
Calibraticn

T Settings | Device Routes

Figure 3. Select Test Panels to open a simple utility for checking signal connectivity.
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5. When the test panel opens, change the Samples to Read input to 500 and the

6.

7.

10.

11.

12.

Mode input to Continuous.

Press Start. The test panel should look like Figure 3.

Test Panels : NI 9237 "Strain” X
Analog Input

Channel Name Rate (Hz) Amplitude vs, Samples Chart Auto-scale chart [/
Strain/ai0 =] 5000 -0,0040125
Mode Samples To Read -0.00401275
Continuous =] 500 -0.004013)
-0.00401325
Measurement Type -0.0040135
Bridge -0.00401375
-0.004014
Max InputLimit ~ MinInputLimit  Units 000401425
25m -25m | |vpv =] 2.0040145
Bridge Type Bridge Completion -0.00401475 |
Quarter Bridge =] 3% -0.004015 -
Vex Source Wex Value -0.00401525 |
Internal =] 33 -0.0040155 |

-0.00401575 -

T
114500

| | Start | Stop

‘ Close | | Help |

Figure 4. The test panel is used to confirm electrical connections.

Press down on the strain bar and ensure that the graph reacts to your input. If you
detect no noticeable change, please alert your instructor at this time.

Press the Stop button and close the Test Panel.

Every time you set up a new measurement or measurement system, it is a good
idea to confirm that the wiring is correct and that all software is installed and
working correctly. MAX provides the insight into your system and setup to help you
eliminate mistakes early in your development process.

Once you have confirmed that the strain gage is working, minimize MAX and select
Start » All Programs » National Instruments » LabVIEW <Year> » LabVIEW to open
LabVIEW.

From the LabVIEW Getting Started window, select Open Existing.

Navigate to C\Seminars\LV HO\Exercises\b — Strain.

Double-click Strain Gage Exploration.lvproj to open the strain gage project. You
should see the following screen:
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13 Strain Gage Exploration.lvproj - Project Explorer EIIEI

File Edit View Project Operate Tools Window Help

il=1: JIEN= IELT=RE

Ttems | Files |

=] ik_;]. Project: Strain Gage Exploration.lvproj
£ B My Computer
G [ Exercises
G- Solutions
& [@ Support Vis
- _4;_" Dependencies
"4_ Build Specifications

Figure 5. Use LabVIEW Projects to organize all your Vls.

With the LabVIEW Project you can easily organize and visualize all the files that are
important to your application. In this particular project, the folders like Exercises,
Solutions, and Support VIs have been set to auto-populate with the files within
them.

13. Expand the folders to view the files within them. You should see the following Vls:

13 Strain Gage Exploration.lvproj - Project Explorer EI@

File Edit View Project Operate Tools Window Help

hodl X b IEC Y=

Ttems | Files |

=] iﬁ; Project: Strain Gage Exploration.vproj

£ B My Computer
Bl [ Exercises
L[l Strain_w_User_Feedback_Exercise.vi
= [ Solutions
L.l Strain_w_User_Feedback_Solution.vi
= [ Support Vs
! L[wl LED Scaled_Output.i
& % Dependencies
"«5»_ Build Specifications

Figure 6. The VIs used in your project can be found in the auto-populating folders.
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14.

15.

16.

17.

Start by opening the solution. In the Project Explorer, expand My Computer »
Solutions and double-click Strain_w_User_Feedback_Solution.vi.

Click the Run arrow () and then delicately push down on the strain bar. Notice
that the LEDs signal the amount of strain experienced on the strain bar.

Close the VI. If prompted, do not save changes.

To start this exercise, use the Project Explorer to navigate to My Computer »
Exercises and double-click Strain_w_User_Feedback_Exercise.vi. The front panel
has already been created for you.

When starting a new program, beginning with a Front Panel design is a good way
to organize your thoughts around the inputs and outputs that you expect. Once
you understand how you want a user to interact with the code, then you can begin
writing the VI to support that functionality.

Throughout this exercise, you will complete this VI to acquire data from the strain
gage and light a series of LEDs to communicate the strain level to a user.

3 Strain_w_User_Feedback_Exercise.vi Front Panel on Strain Gage Exploration.vpraj/My Computer EI@
File Edit View Project Operate Tools Window Help %
P 5 5 el
E“‘d} OIEHlSptApphcatlon Font |~ Hﬁpvu-un' ”g'| *| Search ~ ”?| 3
Strain/ai0
Strain Chart | AT
0.001 -
0.0008 -
0.0006-
w
S 0.0004-
g 0.0002-
<
0-
-0.0002 -
-0.0004 - ;
6:00:00.000 PM 6:00:05.000 PM
12/31/1903 12/31/1903
Tirmne
LED Configuration Quarter Bridge Diagram Strain Configuration =
LED Channels LED Qut | DAGQmx Physical Channel
- < - ! [ P 1
’; Digital_out/ =] .I : | % Strain/ai0 =]
i C I ;
Range High | ?tram Sample Rate i
r ~ 1 )
£ [o.001 S ! |
Range Law . : E ?a:nple;PerChannel 1
— - \ h ' 151|000
. |2 1 ] ¢
Smh 'NI9236 Bridge Completion'
Number of LEDs Loy L e e
r ~ fo
SIE
f . Stop
Strain Gage Exploration.lvproj/My Computer| 4 1 3

Figure 7. The Front Panel is the user interface for your program and contains all the
controls and indicators to interact with your code.
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18.

i

Notice that the Run arrow in the top right corner is broken (I:). This is because
the code contains errors, or in this case, is not in a running state. LabVIEW
continuously compiles in the editing environment, so you will always know if your
code is able to run.

Pressing the run arrow when it is broken will show a list of errors. Try pressing the
run arrow to view some of the errors with our current code. If you double-click on
one of the errors, LabVIEW will even highlight the section of code containing the
error.

If your code compiles with no errors, the run arrow will no longer be broken ().

Close the Error Dialog and select Window » Show Block Diagram. The keyboard

shortcut for this is <Ctrl+E>. Use this shortcut to toggle back and forth between
the Front Panel and Block Diagram. When the Block Diagram opens, you will see
the following code:

3 fonaen e Fonci | 7 g e Eerfo- il
[Fe St Viem P Opete Teok Window Hep =
| - 0[] wo = o [150t Apphcation Fomt |+ | (3 |[da= | (B | al e — N
«
DG Fhysicsl Channd ¥ E|Q
Lo B o=
nidge mlaimaty on =
st Sralge 1 7 L5 Nl
..... o
i DO
burmber of LEDs el
u
St Buston L
m [ -

[Siale Gage lrglon

Figure 8. The Block Diagram does the work of your program. This is where you will
write the code to control the Front Panel.

Because the code has been started, this Block Diagram includes some basic
elements already. Each element on the Front Panel has a corresponding terminal
on the Block Diagram. To find the corresponding Front Panel element, you can
double-click the element on the block diagram to highlight it.

Try double-clicking on the Strain Chart icon. Then double-click on the same item on
the Front Panel. This is a convenient way to find items on either the Front Panel or
Block Diagram.

The light yellow boxes are annotations. You can create notes on the block diagram
simply by double-clicking in any blank space. It is always a good idea to properly
document your code so that you (if you come back a week later) or someone else
can understand what is going on.
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19. Now that you are familiar with the elements of the program, you can start building
the code to acquire strain data. To start, make sure that the Block Diagram is
visible.

20. For this exercise, a large part of the coding will come from the DAQmx palette. To
access this palette right-click on any white space on the Block Diagram and
navigate to Measurement I/O » NI-DAQmx, like in Figure 9.

21. Click on the pin to keep this palette visible (red arrow in Figure 9).

41 Functions Q Searchi}
Programming »
» »
B W 8
Structures Bsrwy Chuster, Clas.
» (T ="
B B B
Numaric Boolean Sering
B B
> O] B,
Comparson  Timing  Dialog & Use.
Cl ¥
B J
File VO Waveform  Application
o Y EShy
o] w55
Synchoonazat . Graphacs & S Report Gener
[ e b0 S—
Instrument L'0 [ =
Visson and Moton [l
Mathernatics [
Signal Processing [}
Data Communication (§ e -
Connectity : = = [
Contrel Design & Simulatien 1 Task Const  Channel Const Create Chan... write Wait
Signaliapress ' —rn o
- E @
Addors " Timing Triggering Step Clear
Favorites Ll =0
s Lo ' B & £
Selecta ¥ (WM Timing Node Triggering M.  Fead Node Write Node
=1 . N Cl o= »
& o] e ¥ ¥
DAQAssit  Feak-Time DevConfig TaskConfig/  Advanced
@)
System Cond.
%
-
MO Trace

Figure 9. The DAQmx palette includes all the required Vs for coommunicating with
your NI CompactDAQ chassis.

DAQmx - Data Acquisition (3]

4 | Q search | &, Customize~ | l

@

rase |-}

Task Const Channel Const Create Chan...

D0 Dy
Timing Triggering
[T=1]
B &
Channel Node Timing Node Triggering N... i
gl A M »
u‘:d d | 'ﬁ:v e b o
DAQ Assist Real-Time Dev Config  Task Config/..  Advanced
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Figure 10. Pinning a palette enables you 1o click elsewhere in your code with the
palette still visible.

22. To start, drag the NI-DAQmx Create Channel (red arrow in Figure 10) and place it in

the position shown in Figure 11.

[ TSrer—r——— : |
Pl [ Vew Dveec Dpmee Tk Weses Sy : - I
0] e e ppsmen et + | e (| e "‘E
= B
'
e JE

B, .
] = .

I;.. Tyt

| S

o e s o it S g, | [ e e e
bttreme, w51 s sesmgia .

gt g+ s e ot | [ oy e R e
i e et v s ey g gty | vt s o et e o
Fee s ety gt v | g, et i et

i oyt parse o e | |

e e

Pt | et

|
[T o :m.--n..“..“..-.m,—. e e et i |
I

e | ey - ———————
[E— | T —" - S —— . i |- u.-..l-_...
o o | ot 1t e 8 s s i 2 s i, Th | s T P, B0 58
[, | e g o i 5 g s | s st [ ——

S — rr
?la"r\q_ﬂnlwmﬂﬁlnl- Ik

A e e o e s itk | e e VRS By

Figure 11. The DAQmx Create Channel VI establlshes communication W|th your

DAQ device.

23. By default the VI is configured to create a simple analog input voltage. To
configure this for strain, click on the drop down arrow and select Analog Input »

Strain » Strain Gage.

P

v
J Volage

Analog Output  » Voltage RMS

Digital Input Temperature »

Digital Output Current

CounterInput  » Current RMS

Counter Output  p Resistance

(St b | SwinGage |

Force » | Rosette Strain Gage
Pressure >
Torque [
Frequency »
Position »
Acceleration »
Velocity [
Sound Pressure b
More »
TEDS »

Figure 12. The DAQmx Create Channel VI is called polymorphic because it changes
to adapt to the selected measurement type.

24. To find out more about this VI, bring up the Context Help by pressing <Ctrl+H>.
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The Context Help gives you a brief description of anything you hover over with your
cursor. Hover over the DAQOmx Create Channel V/to see the inputs and outputs of
the VI.

For a strain channel, we need to provide the channels you are measuring and the
strain gage information. To provide these inputs, wire up the VI as shown in Figure
13 by clicking on the outout of each block diagram node and then clicking again on
the target input terminal of the DAQmx Create Channel VI.

DAQmx Physical Channel

I/0

bridge information
Cuarter Bridge =
0
0

Internal =

Figure 13. Wire up the inputs to the DAQmx Create Channel VI.

25. Drag the following Vls from the DAQmx palette and place them as shown in Figure
14.
a) DAQmx Timing
b) DAQmx Start Task
c¢) DAQmx Read
d) DAQmx Stop Task
e) DAQmx Clear Task

Serain Samgle Rate Strain Chare
R DA Craste et DAQmx B DA oen
DAGr Physical Channel 2 i [EEE o ;:S-;\;k Resdvi =l 9] DAGex Stop DG Clear
= o - Tackvi Taskon .
bridge informaticn L] )
. m [T F_.;;
Arulog DAL s @ ]
1Chan 15smp
- PBange High
e [
B Range Low
i) e LED Qut
o3 Pumber of LEDs i)
LED Chanew ok
Shep Bubton
 [n 55 =0

Figure 14. The flow of DAQOmx code almost always follows the same pattern.

If you recall from the example programs you examined in the earlier exercises, the
DAQmx pattern almost always follows the same flow. A channel is created,
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26.

27.

28.

29.

30.

31.
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settings like timing and triggering are configured, the task is started, the channel is
read then the task is stopped and the channel is cleared.

The DACOmx Timing VI configures the sample rate, sample mode, and clock source
for your task. You are going to be sampling continuously, using the on-board clock
source. Wire the DAQmx Timing VI as follows:

Samples Per Channel

[Continuous Samples ~

Strain Sample Rate

Sample Clock =

Figure 15. The DAQmx Timing VI configures your clock parameters.

The DAOmx Start Task VI transitions the code to the running state. Once your code
is past this VI, you are ready to read or write data. To learn more about this VI,
make sure the Context Help is still visible <Ctrl+H> and hover over the DAQmx
Start VI.

After the task is started, the DAOmx Read VI pulls data off the DAQ device buffer.
Like the DAQmx Create Channel VI, the DAQmx Read VI is polymorphic. To
configure this VI to read a data from the strain gage, click the drop-down arrow and
select Analog » Single Channel » Multiple Samples » Waveform.

&

iLrus

ZSngesinpe v )
Digital » Multiple Channels » 1D DBL |
Counter » Unscaled » [7im|

More > |'

Figure 16. Select a single channel of waveform measurement to read from the
supplied strain gage.

Wire the output of the DAOmx Read V/to the Strain Chart. This will enable a user
to visualize the data on the front panel.

The DAOmx Stop VIand DAQOmx Clear V/ ensure that your program properly closes
communication and frees up the hardware before stopping the code. Again, to
learn more about these VIs, hover over them with the Context Help visible.

Wire the task and error wires through the code as shown in Figure 17. This will
pass the task values and any errors that may arise through the code.
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Figure 17. To finish the strain acquisition code, wire the task and error wires
through the code.

Because LabVIEW uses dataflow to enforce order of execution, you can visualize
the data traveling across each of the wires, from one VI to the next. Each VI will
only execute once all the wired inputs have been accounted for.

Wiring the error wire thought the code ensures that any errors in the code will pass
through the code and be reported to the user.

32. Wire the error wire from the DAQmx Read VI to the input of the Compound
Arithmetic VI. This VI will OR the inputs to stopping the While Loop from
executing. The code you just wrote will stop if an error occurs or a user stops
presses the stop button.

Stop Button

Figure 18. The Compound Arithmetic ORs the inputs, stopping the While Loop if
the code has an error or the user presses stop.

33. Once you wire the error wire to the Compound Arithmetic, your code should be
ready to run. Check to see that the Run Arrow is intact ().

34. Press <Ctrl+E> to toggle to the Front Panel.

35. Press the drop-down arrow on the DAQOmx Physical Channelto select the correct
channel. In this exercise, the strain gage should be attached to channel 0 of the NI

9236. If you correctly renamed your modules in an earlier exercise, select
Strain/ai0.
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Strain Configuration
DAQmx Physical Channel

J]

Sound_Vibration/ail
Sound_Vibration/ail
Sound_Vibration/ai2
Sound_Vibration/ai3
Strain/ail

Strain/ai2

Strain/ai3

Strain/aid =

R | Stop ]

Figure 19. Select the channel that your strain gage is attached to.

m

36. Set the Strain Sample Rate to 10000 Hz and the Samples Per Channe/to 1000, like
in Figure 20.

Strain Configuration
DAQmx Physical Channel

=
i

¥ Strain/aio |[=]

Strain Sample Rate

-

| BRI

| 10000 |

||
L

Samples Per Channel

| £ [2000 |
' Stop ]
Figure 20. A good rule of thumb is to set the number of samples to 1/10" of the
sample rate.

The sample rate dictates how fast your DAQ device samples the selected channel.
The Samples Per Channel dictates how much data is pulled from the DAQ buffer
each time the loop runs. In the example above, DAQmx Read will wait until there
are 1000 samples on the buffer before it pulls them from the DAQ device. This
translates to an update every 1/10™ of a second. If you change the Samples Per
Channel to 10000, your code will update once every second. If you get buffer
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37.

38.

39.

40.

41.

overflow errors, it usually means that your loop is not executing fast enough to pull
data off the DAQ device before the buffer is full. Try increasing the number of
Samples Per Channel if this is the case. In some cases, you may need to split your
code into parallel loops. For more information about this type of architecture,
search Producer Consumeron ni.com.

Press the Run arrow. Notice that when you gently press on the strain gage, you
can see the inflections on the waveform chart.

{3 Strain_w_User_Feedback_Exercise.vi EI@
File Edit View Project Operate Tools Window Help =
T .\_.,_;,
=] [@[n ..4
Strain/ai) |/
Strain Chart L reunval
0.0012
0.001 -
0.0008 -
& 0.0006-
2
E 0.0004 -
< 0.0002-
0]
-0.0002 -
-0.0004 -} ]
9:31:32.382 AM 9:31:37.382 AM
10/11/2012 10/11/2012
Tirmne
LED Configuration Quarter Bridge Diagram Strain Configuration =
LED Channels LED Qut DAQmix Physical Channel
- < - ! [ P 1
', Digital_out/ =] -"\.’:I : | % Strain/ai0 (=]
) ¢ ) 1 ;
Range High "gll | ?tram Sample Rate )
— _ I =
[=][0.001 @ ! |51/ 10000
) @) 1 I
Range Low /‘i:l ! : rSa_ranE;PErCharmEI §
(= I | i 1=/ |1000
e/t O i b
b Stuain 'N19236 Bridge Completion'
[\IumberofLEDs . !l WMH ________S____P____
(E— , |
. Stop
Strain Gage Exploration.lvproj/My Computer| < 11l 3

Figure 21. You have created a program to visualize strain gage data. This data can
be analyzed, saved to file or used to control an output.

Press Stop. Save this VI, as you will use it in the next part of the exercise.

To finish out this portion of the exercise, open the LabVIEW Example Finder by
selecting Help » Find Examples.

Navigate to Hardware Input and Output » DAQmx » Analog Input » Strain —
Continuous Input.vi.

Change the Physical Channelto Strain/ai0 (or the channel your strain gage is

connected to), the Strain Configuration to Quarter Bridge | and the Vo/tage
Excitation Value to 3.3. See Figure 22 for reference.
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Figure 22. The DAQmx examples are built to give you a solid starting point for your
programs. Use them as a starting point.

42. Press the run button. The graph should react to you gently pressing on the strain
bar just like in your code. Press Stop.

43. Press <Ctrl+E> to open the block diagram. This code includes many more settings
specific to strain gage measurements than the code you have just built, but it still
follows the same exact DAQmx flow. Additionally, this code includes logging and
triggering functionality. These could easily be added you your code by adding the
appropriate Vls.

44. Close this example VI. When prompted, do not save your changes.

Part B Controlling the Colored LEDs for User Feedback

Estimated time. 30 minutes
For this part of the exercise, you will add to the code built in Part A.

Oftentimes, users need immediate feedback from a measurement system and a computer
monitor may not be practical for applications like embedded measurement systems,
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industrial monitoring or process control. A common way to alert an operator to the
condition of the test is to use signal LEDs. For this next part of the exercise you will use
your code to alert a user to the strain level on the aluminum bar.

Before you start this exercise, confirm that the LEDs are properly connected and you are
able control them in Measurement & Automation Explorer.

1. Begin by opening MAX (Start » All Programs » National Instruments »
Measurement & Automation Explorer).

T% 319472 “Digital_out” - Measurement & Automation Expiorer [T
File Edit View Tools Help
4 B My Systern H ¥ Retresh | = Reset EhSeit-Test T Test Panels._ | [3 Create Task.. = Device Pinouts 4 Hide Help |
& Data MNeightorhood 1
Back a
+ & Devices and Interfaces = €] |
ted Webcam “camg) Settings

NI-DAQmx Device Basics

PT1” Name: Digital_out
- 8 N] cDAG-9178 "cDAQ] ¥Run the NI-DAQmx Test Panals
T s Vendor National nstruments h
B 1 NI9211 Temperature e i
8 2 Ni 9237 “Strain” Model NI 9472 : .
T R e Piew or change device configuration
s | Reset Serial Mumber 01314313

3 4: NI 9263 ¥
O & NI9734 " Bl Self-Test Siot Number 3
5 8 NE9215 v (8 Create Task.

Status Present
& Metwork Dewge:

0 NI Switch Execut

9 Histerical Data | TamPaneis. |
. :

Seales § Device Pincuts
& Software Hel ¥
0 V1 Drivess =

& Remote Systems

Renasmu

T Sentings M Device Routes

Figure 22. Starting with Test Panels ensures that your sensors are working and you
will not have hardware problems.

2. Right click on the NI 9472 and select Test Panels. The following panel will open:

Digital 1/0 | Counter 1O

1. Select Port 2. Select Direction
Port Name PortiLine Direction .
portd portd/ine0:7 :
= Input (1) All Input
& Output (0) =

portd Direction
00000000
7 0

3. Select State

PortjLine State

7 portd/fline0:7

Lo EEEEmEEE e
Lo

Iy 5 : AllLow
portd State
00000000
7 0

Figure 23. With the NI 9472 Test Panel, you can control the digital output channels
to ensure they are operating properly.

3. Press Start.

4. Select the All High button as a quick test of all the digital outputs. You should see
all the LEDs on your demo box light up. Notice that the LEDs on the NI 9472 also

ni.com/daq 86



light up. You can control each LED individually, but for testing operability, it is not
essential.

5. Press Stop and close the Test Panel.
6. Open your copy of Strain_w_User_Feedback_Exercise.vi.
7. Press <Ctrl+E> to open the Block Diagram.

In this part of the exercise, you will add code to control the LEDs proportionally to
the strain experienced by the aluminum bar. To add this code, you will perform
many of the same steps used in the strain acquisition, but this time, you are writing
data, rather than reading. You should notice some overlap in the steps performed.

8. Like in Part A, a large part of the coding will come from the DAQmx palette. To
access this palette right click on any white space on the Block Diagram and
navigate to Measurement I/O » NI-DAQmx.

{1 Functions Q searenf
Programming »

v - »
Edl Bl e

Structures Amsy  Chuster, Clas

" " [ ¥

% ] 2] &E|

Nurnenc Boolean String

; q
Comparson Timing  Dislog & Use

B &

File V0 Wavelorm  Application .

: e
Bg] * =3

Symchromazat_.. Graphics & S Report Gener.

Measurement VO
Instrument L0
Visson and Motion =
Mathermatics [} I""’ gl |
Signal Processing ' & DAGm - Data Acquisition
M-DAQms
Duta Communication '
Sy { =2 = G B B B
S e 1 TaskConst  Channel Const Create Chan Rasd Wrte Wt
Signaliapress [ v
Eagees I w! i ") @ B
Addorm L] Timing Trggerng Seant Step Clear
Favortes ' -
e e | B B B B
Select a1 Channel Node  Timing Node TrggerngN.. ReadNede  Write Node
e — H " =] »
@ o e @
DAQAmit  Real-Time DevConfig TaskConfig/~  Advances
"
iC) T

System Cont.
e M

=
=

MVO Trace

Figure 24. The DAQmx palette includes all the required Vis for communicating with
your NI CompactDAQ chassis.

9. Click on the pin to keep this palette visible (red arrow in Figure 24).
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DAQmx - Data Acquisition

@ [ Q search | & Customizer | 1

[T

Task Const Channel Const Create Chan...
ona,

Stop

Timing Triggering
=0 [A=1] =]
Bl B B B

Channel Node Timing Node Triggering N... Read Node Write Node

@ o L

DAQ Assist Real-Time Dev Config Task Config/...  Advanced

Figure 25. Pinning a palette enables you to click elsewhere in your code with the
palette still visible.

10. To start, drag the NI-DAQmx Create Channel (red arrow in Figure 25) and place it in
the position shown in Figure 26.

Suwn Chaa
_— " DAL e DA e e Chiar
DA Physical Chasn D30 Crate - Y [ﬂ] T T
= o I e .
gt Anaiog Wim |
Al Strams Gas han,

LED Charseh

-

21 Vehage =]

——
frivmat: W

o e

Figure 26. The digital output code will run parallel to the strain task.

11. Use the drop-down menu under the VI to change the DAQmx Create Channel VI to
Digital Output.

*
—t
A

J Analog Input ¥
Analog Output  #
Digital Input
Counterlnput  p
Counter Output b

Figure 27. Choose Digital Output for controlling the signal LEDs.

12. Wire the LED Channel control to the Lines input of the VI. Press <Ctrl+H> and
hover over the VI if you need a reminder where this input is.

13. Drag the following VlIs from the DAQmx palette and place them as shown in Figure
28.
a) DAQmx Start Task
b) DAQmx Write
c) DAQmx Stop Task
d) DAQmx Clear Task
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Figure 28. These VlIs should look familiar — nearly all DAQ programs will follow this
pattern.

14. Change the new DAQmx Write VI to Digital » Single Channel » Single Sample » 1D
Boolean (N lines).

D
Writevi

|/ Analog b | _
[ Dgtsl b [ SngieChamel b [ SngieSample _» RSO RY
Counter b | Multiple Channels » | Multiple Samples  »

Mare ¥ I U3 (port format)
U16 (port format)
U32 (port format)
Waveform

Figure 29. You can write an array to the digital lines on the NI 9472 using the
DAQmx Write VI.

15. Wire the task and error wires through each of the DAQmx Vs like in Figure 30.

Sarsps Pas Chsre |
St Somghs et 1} o e @ g g Qe Clani
DéGomu Ppnical Charmel Do Creste (75 ) . Py 32 Ted | Teke
Barene - o
' G -
M.Z“H— —ﬁ[ eI |Fa 2l HET 2 ..
: it [l firam Giage =] arriple Clock l-tl::g Wtm |
E g
1|
Rarsge b
————m o
B — oo
: Faoi]
E]| Y. ]
& DG [
Bl pemem o o oo B
e e vl &2
Dol Ot =] (Dol 1D Bessd
‘ | 10han 1iammg
isp Butten 5
o on a8

Figure 30. Wiring the task and error wires through dictates the flow of your code.
16. To properly handle the errors, you will need to ensure that the while loop stops if

your digital code has an error. To do this, start by expanding the Compound
Arithmetic. Hover over the VI and drag the handle up to expose another input.
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Figure 31. Expanding the Compound Arithmetic ORs all the inputs.

17. Wire the error wire from the output of the DAQmx Write to the new Compound
Arithmetic input.

DA Mx
Writewi

LA

Digital 10 Bool _
1Chan 15amp

Stop Button

.......................................... :'U' .....

Figure 32. The Compound OR now accounts for all the errors inside the While
Loop.

18. At the end of your code, you will need to combine all the error wires, alerting the

user of any errors in the code. To do this, expand the Merge Errors function to
expose a new input.

DA Clear DA Clear
Tash i Taskw

Figure 33. Combine all the error wires in your code with the Combine Errors VI.

19. Wire the error wire from the output of the bottomm DAQmx Clear Task VI into the

new input of the Merge Errors function. Your code should look like Figure 34.

DAQmx Stop  DAQmx Clear
Task.vi Task.wvi

DA mx DAQmx
Stop Car
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Figure 34. All your error wires are combines so the Simple Error Handler can
display the errors to the user.

20. Now that you have the code for writing the data to the digital outputs, you will
need to create the code to translate the analog data from the strain gage to a digital
level. Luckily, that code has already been created for you as a subVI. To add the
subVI, right click on some white space on the Block Diagram and click on Select a

VI...
51 Functions Q, Search|
Programming »
G ¥
B | el
Structures Array Chstes, Clas...
Tl B &
]
Numeric Boolean Stiing
i » ¥
0] B
Comparison Timing  Dislog & Use...
m— | ¥
H &
File VO Waveform  Application ...
C - et
bo] < &3
Synchronizat.. Graphics & S.. Report Gener...
Measurement 10 L4
Instrument 'O »
Vision and Motion »
Mathematics L3
Signal Processing »
Data Communication »
Connectivity ¥
Control Design & Simulation »
SignalExpress LS
Express »
Addons L4
Favorites )
User Libraries L2

Figure 35. Press Select a VI... to find a subVI that isn't visible on your palettes.
21. Navigate to b — Strain\Support VIs and select LED_Scaled_Output.vi.

22. Place the VI as shown in Figure 36.

DAGMm: Strain Chart

Read.vif

LB ]
vy

Analog Wfm

1Chan M5amp

Range High
[DBLY

Range Low
LED Ou

oot l@] ETF]

MNumber of LEDs
DAQH

Write.vi

I ¥ |
Digital 1D Bool _
1Chan 15amp

: [ |
- oo bR
Figure 36. The LED_Scaled_Output VI is a subVI to scale the strain input to an LED
output.
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An alternate way to place the subVI on your Block Diagram is to navigate to it in the
Project Explorer and drag it onto the Block Diagram, like in Figure 37.

B arain_ User_Faediback | 0 s oemputer Sl @

e
SR s e T T o ra—

Stran Chart
DAQx Create DaQmw Dagmx o [15] D&Qma Stop  DAQmE Chear
P Mol Shanns v.‘q.ucmm S Tk [ —— 2 Tak  Tekd
gt infoermation <, | 108 e o = - "
justerBndgel ¥} [AiGirainGd | Fle Eda View Project Openate Techs Help [ Anstog Wim _|
M ¥ . T T {1Chan NSamg
hel= 1< HIEe) B W R
irterral 7] Mems | Files
= = M Project: Strain Gage Exploration hprej Range High
stri gage infommation & § by Compuer [
5 Exercises i P
[ Strain.w_ User Fredback Exercisei (i) F ﬁu
B Salutions Number
MAGmx
Virtual © ol Stoain_w User Feedback Soltionss |4 o= DA
LED Chamnets S8 Suppon Vh wadl Wit i
- il

4% Dependencics
héulvm:\n [ B Digaal 10 ool
= Specications et ]
o 180

Stop Button
o] [no)

[Configare Channel Sctiings [T [ResdiWirite Data top. Ciear and Handle Errors
i o e, o o | of| [t the sk st i the ummmdwwmm rtaract o read o |Oncs you bave complted your ks,
channel settings for the type nbe fihe coo DAQ devi
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configuring the themocouple
levpe setting
fihe optamurn gain in the DAQ device. lbunt cal, offset uling, etc, of sdvsnced

[Siram Goge omputer ¢

Figure 37. You can drag any Vls from your project onto the Block Dlagram

23. Organizing your code into subVls a way to make your code more manageable and
scalable. To examine the contents of the subVI, just double-click the icon to open
the subVl's front panel. Take a minute to examine the contents of the subV!I.

24. Close the subVI.

25. Wire the call to the subVI like in Figure 38.

Strain Chart
DAGMmx
Read.vi

o 1
RELY

Analog Wfm
1Chan M5amp

Range High
[5y

Range Low
e

MNumber of LEDs

Digital 1D Bool _
1Chan 15amp

Stop Button
m ......................

- |
Figure 38. This subVI outputs a Boolean array that can then be output by the
DAQmMx Write.
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26. Your code is ready to run. Switch to the Front Panel and press the Run button. You
should notice that the LEDs light proportionally to the amount of force applied to
the strain gage.

If the scaling seems off. Press on the bar and take note of the highest and lowest
values on the graph. Stop the VI, adjust the Range High and Range Low values to
match the range of the strain. Restart the VI and you should see the LEDs reacting
to pressure on the strain bar.

27. If you watch the front panel and the LEDs, they should be reversed in how they are
displayed. The physical LEDs and the front panel indicator can be matched in code
easily. To swap the order of the front panel indicator, start by deleting the wire
between the LED subVI and the LED indicator on the block diagram. Click once on
the wire shown in Figure 39 and press delete.

Range High
k
Range Low PLED ot LED Out

Mumber of LEDs
-—‘ DA mx

Write.vi

ey
Digital 1D Bool
1Chan 15amp

Figure 39. Delete the wire between the LED subVI and the LED indicator.

28. To switch the order of a 1D array, use the Reverse 1D Array function. Right click on
white space on the block diagram. Select Programming » Array » Reverse 1D
Array.
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Figure 40. The Array palette includes many useful Vls for array manipulation.

29. Place the VI in between the LED out subVI and the LED out indicator and wire it up
like in Figure 41.

Range High

=
Range Low LED nur LED Out
@ l E E—rE ETF]

Mumber of LED=
-—I DAQmx

Writewvi

LA

Digital 10 Bool _
1Chan 15amp

Figure 41. Use Reverse 1D Array to swap the order that the Boolean array is
displayed.

<End of Exercise>
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Exercise 1: Acquire Audio Signal

Note: This exercise assumes that you have already installed all required software and configured all
hardware as outlined in earlier sections. If you have not, please refer back to the appropriate section to
do so.

GO&'S e The first goal is to continuously acquire 40000 data point arrays from the audio
source connected to the NI 9215 (or similar Analog Input) module

e The second goal is to add data logging to the DAQmx task

Part A 1. Launch LabVIEW by navigating to Start » All Programs » National Instruments »
LabVIEW <Year> » LabVIEW.

2. Create a new LabVIEW Project by selecting the Create Project button from the Getting
Started Window.

3. Select Blank Project and then select Finish to create a project file to hold all files and
references for the application.

5
ﬂ Create Project G X"
Choose a starting point for your project:
All Blank Pro_lem &
Templates _1 Creates a new blank project

Sample Projects

Blank VI
ﬂ Creates a new blank VI

Continuous Measurement
'ﬁlﬂ Streams continuous measurement data to a file. More Information

m

Feedback Evaporative Cooler (Actor Framework)
Tl EET NOTE: This starte ctis functionally co T[f\:‘t:‘ but still has roug dges: icons are unfinished,
cumentation is incomple ic. We appreciate i back on the app, ulthu|»|5 no need to... More Information

Instrument Driver Project
B The Instrument Driver Project Wizard helps you
instrument driver templates or from an existing

e winstrument driver. You can create a new driver from
‘-'15!\ La IEW Plug and Play instrument driver.

Many Independent Tasks In One Application (Actor Framework)
Use e Actor Framework to implement a basic application with a main VI to handle the user interface and two
independently running Vls that handle other ongoing tasks (such as hardware... More Information

Queued Message Handler
450 Implements an event-driven user interface. More Information

N Single Shot Measurement
nnnnnn = Logs single-shot measurement values to a file. More Information

Rtandard State Marhina -

Finish Cancel Help

4. In the newly opened LabVIEW Project Explorer, navigate to File » Save As... and save
your project as cDAQ Hands On.lvproj within the C:\Seminars\LV HO\Exercises\6 —
Audio Equalizer folder.

5. Within the LabVIEW project window, right-click My Computer and select New » VI to
create a new LabVIEW Virtual Instrument (VI) to acquire data.
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43 <DAQ Hands On.lvpraj - Project Explorer EIEI&J

File Edit View Project Operate Tools Window Help

=11 IETTER RS

Items | Files |

E |T_:2, Project: cDAQ Hands On.lvproj ”

" Mo
- = Depende I NI
'4,‘ Build Spe Eport N Virtual Folder
Import » Control
Liby
Add o
Variable
Find Project ltems... Class
ey N XControl
Expand All NI-DAQmx Task
Collapse All NI-DAQmx Channel

NI-DAQmx Scale
NI-XMET Session
Unit Test

Test Vectors

Help...

Properties

New...

6. Select File » Save to save the newly created VI. Name the VI "Exercise 1a” and save
the VI within the same folder as your LabVIEW Project.

7. Navigate to the Block Diagram window of Exercise 7a.vi. If you are on the Front Panel,
press <Ctrl+E> to toggle between Block Diagram and Front Panel.

8. Right-click on empty white space in the window to bring up the Functions Palette and
navigate to Functions » Measurement I/O » NI-DAQmx. This is the DAQmx Functions
Palette.

a. Now select the first function, DAQmx Create Virtual Channel. Left-click to
select the function, and then left-click to place it onto the Block Diagram. This
function opens a reference to and reserves a DAQ hardware device.

b. Once placed, left-click the white polymorphic selection box and navigate to
Analog Input » Voltage. Although we are acquiring a sound signal, we will still
use a voltage because this is what the MP3 player outputs.

Al Voltage ~|

c. Turn on Context Help by pressing <Ctrl+H> and then hover over the Create
Channel VIto see all of the inputs and outputs.
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Context Help @

DAQmx Create Channel (Al-Voltage-Basic).vi

input terminal configuration
minirmum value

maximum value

task in task out

physical channels -
name to assign
units

ETOr in

custom scale name

error out

Creates channel(s) to measure voltage, If the measurement requires
the use of internal excitation or you need excitation to scale the
voltage, use the Al Custom Voltage with Excitation instance of this
VL

Detailed help i
Sl r

d. Hover over the upper-left corner of the Create Channel VI and notice that the
cursor changes to the wiring tool automatically and the tip-strip displays for the
terminal over which your mouse is located.

[physical channels|

e. Right-click the terminal for Physical Channels — the second terminal from the top
— and select Create » Constant. This constant will only be visible on the Block
Diagram, and there is no corresponding control or indicator on the Front Panel.

f.  Left-click the arrow on the Physical Channels constant and browse to the
channel of interest, Voltage_in/ai1.

g. Right=click the Input terminal configuration terminal and select Create »
Constant. Set this constant value to Differential.

h. The next image displays is a common sensor setup diagram. In this example, a
thermocouple is connected to an NI CompactDAQ device.
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Thermo- Noise Induced

couple

DAQ Device

Noise and other signals can enter into the signal through the wires between the
sensor and the DAQ device, as wires act like antennas. Shielding and other
technigues can help to reduce this affect.

The terminal input configuration is the easiest way to eliminate a lot of the effect
of noise. Single-ended measurements (RSE and NRSE) only take the positive
sensor signal (ai+) and then they reference this to the system or chassis ground
(GND). The chassis ground typically does not have any noise on it, and is
represented by the solid black line below. The signal line does typically have
noise on it.

With Single-ended measurements, the noise will still be seen because the
acquired data will be the difference between the noisy signal line, and the clean
GND line.

W arg
B ai-
GND

Differential configuration means that the ADC will take the difference between
the ai1+ and ail- pins on the DAQ device, which is the most accurate way to
measure from a sensor as it eliminates noise that is common on both the
positive and negative wires.

Always use this configuration if available for sensor acquisition. The resulting
Block Diagram should appear as follows.
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Differential

9. Right-click the Create Channel VI and navigate to DAQmx — Data Acquisition Palette »
DAQmx Timing. This is a shortcut to quickly place another function from the same
palette, NI-DAQmMXx.

a.

b.

Click to place the DAQmx Timing V/to the right of the Create Channel VI.

To align any functions on the Block Diagram, select by holding <Shift> and
left-clicking the functions. Then select the Align Objects button on the
toolbar and choose Align Top Edges.

e |15ptﬁkpplication Font |+ ||E;|' ||7]E'| b~ "Ziﬂ

(@ | fom Nom

50| [=
o &
] E

—
-

Differential

— Sample Clock =
AlVoltage =

Now wire the Task Out and Error Out of the Create Channel VI to the Task In
and Error In of the Timing VI, respectively.

If you diagram is cluttered or messy, press the Clean Up Diagram button  (

) in the toolbar or simply press <Ctrl+U> to have LabVIEW automatically
arrange the Block Diagram.

Create a constant for the Sample mode input terminal and select Continuous
Samples, which means that you will continuously acquire data until the task
is cleared.

Create a constant for the Rate input terminal and enter 40k for the value.

LabVIEW can interpret metric abbreviations for units such a 'k’ for thousand,
and ‘m’ for milli.
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g. Create a constant for the Source input and select OnboardClock. This means
that the task will use the Analog Input internal timing engine on the 9215
module to acquire data at a rate of 40k Samples per second.

h. Create a constant for Samples per channel input terminal and set the value
to 4k. This means you will acquire 4k Samples every time the DAOmx Read
I//is called corresponding to one second of data. This will configure the
buffer for the transfer of data from the DAQ device to the System Memory.

i. A good benchmark is to acquire 1/10th of the number of samples as the
sample rate. This is not required, but you can do this programmatically using
a Divide function in LabVIEW. This function is located in the Programming »
Numeric palette.

samples per channel 4000

sample mode [Continuous Samples ¥|———

rate (40000

source [% OnboardClock [r}

Differential =

[% Voltage _in/ail [~

|J'1'-I‘-f|:||tage "’" |Samp|e Clock '"

10. Place a NI-DAQmx Start Task VI to the right of the NI-DAQmx Timing VI and wire the
error and task wires together from each VI. This function will begin the acquisition of
data from the device and begin to store data in the on-board FIFO memory of the
device.

samples per channel [4000

sample mede [Continuous Samples v——

rate | 40000

source |5 OnboardClock [»f-

Dhifferential «

[% Voltage_in/ail [

g

|.ﬂl‘-.|‘|:|ltage "" |Samp|e Clock ""

11. Place a NI-DAQmx Read VI to the right of the Start Task VI and wire the task and error
terminals together from each VI.
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Differential =

IS
pk:d iy
Al Voltage |Samp|e Clock ‘ﬂ Analog DEL

1Chan 15amp

40000

a. The VI's polymorphic instance is by default set to Analog » Single Channel »
Single Sample » DBL. Because we will be reading 4k samples at a time, we
will need to change this to Analog » Single Channel » Multiple Samples »
Waveform.

b. Right-click the data output terminal of the DAQmx Read VI and create an
indicator.

4000

|Continuous Samples ~

L OnboardClock |+

data

Differential |

% Voltage_in/ail |«

s
Al

fnh {5

|AI Voltage "'“ |Samp|e Clock "" Analog Wfm
1Chan M5amp

40000

c. Locate the indicator on the Front Panel. This is a waveform indicator, which
is the proper indicator for the data type, but it would be better to visualize
the results on a graph.

d. Right-click the waveform indicator on the Front Panel and choose Replace »
Silver » Graph » Waveform Graph. A waveform graph will display an entire
waveform of data, and will redraw the graph each time it receives new
waveform data.

= -
Waveform Graph L 2l |N J

10- |

w
1

=

Amplitude
o
i
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e. On the block diagram, wire the Samples per Channel constant of the DAQmMx
Timing VI to the Number of Samples per Channel input of the DAQmx Read
VI.

12. Return to the Block Diagram and place a NI-DAQmx Clear Task VI to the right of the
Read VI and wire the Error and Task wires. This will clear and dispose of all references
to the hardware.

13. Place a Simple Error Handler to the right of the Clear Task VI. This is located in the
Programming » Dialog and User Interface palette, but you can also use the search
button of the Functions Palette.

a. Wire the Error Out terminal to the Error In terminal of the Simple Error
Handler VI.

b. Because you have wired all of the error terminals together, the errors will be
passed from one VI to the next, and then handled at the end. Once handled,
the error message will be displayed, if there is an error detected.

4000

Continuous Samples =
% OnboardClock |]

data

Differential |

. . -
GO 34
.................... {5 iy
AlVoltage = Sample Clock ~ Analog Wfm
1Chan N5amp

40000

14. To acquire continuously, you will need to use an execution structure to repeat code
continuously until a condition is met; this is called a While Loop.

a. On the Block Diagram, open the Functions Palette and navigate to
Programming » Structures » While Loop. This will turn your mouse cursor
into a while loop cursor.

b. Left-click-and-drag around everything that needs to run continuously in the
VI, which is the DAQOmx Read Function. Release the mouse button to
complete the drawing of the loop.

Analog Wfm
1Chan N5amp
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c. Notice the solid boxes that are created on the edges of the While Loop
border; these are called tunnels and are used to pass data from outside the
loop into the loop before it begins, and then from inside the loop outside the
loop after the condition is met and the loop is exited.

d. Try to run the VI by pressing the run arrow — notice that the run arrow is

broken (E), but go ahead and click on it. The VI will not run, but it will list
the errors that need to be resolved before you are able to run. The Error list
window will appear, and you can click on Show Error and LabVIEW will take
you to the error source.

r N
3 Ervor list =R

Iterns with errors

Exercise 1c Solution.vi

-

1 errors and warnings Show Warnings O

# Block Diagram Errors -

While Loop: Conditional terminal is not wired

Details

The conditional terminal is not wired to anything and must be wired to a boolean  »
data source such as a button or the result of a comparison.

[ Close ] [ Show Error J[ Help ]

15. You now need to wire a Boolean (True/False) control into the Conditional
Terminal () of the loop (which looks like a stop sign). Right-click the input and select
Create » Control to create an interactive control — a stop button on the Front Panel.

! e I
,Wﬂge'" ’Wﬂ Analog Wfm
1Chan NSamp
40000 |
Stop Button
o E=E

16. To ensure that the DAQmx Read VI receives the Task and Error values are passed from
one iteration to the next, you will need to use shift registers to pass data.
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a. Right-click the output tunnel of the purple DAQmx Task wire and select
Replace with Shift Register. This will change the output tunnel to a shift
register, and then allow you to select the proper input terminal. Left-click the
input tunnel for the DAQmx Task wire.

H 60
LN
Analog Wfm

1Chan MSamp

Stop Button

[

b. Repeat for error wire tunnels.

17. To ensure that the VI exits the loop in the event that an error is generated within the
loop, it is necessary to unbundle the error cluster which contains an error status
Boolean, an error code numeric, and an error source string.

Error Qut

ry

status  code
I ~..| d
@ [

SOUrce

a. Select the While Loop on the Block Diagram and expand it vertically
downward, and then move the conditional terminal and stop button to the
bottom again to make room for more functions within the loop.

b. On the Functions Palette, navigate to Programming » Cluster, Class, &
Variant » Unbundle by Name and place this function in the empty space you
just created.

c. Wire from the Error output wire of the DAQmx Read to the input of the
Unbundle by Name function. This will automatically populate the names of
all of the elements of the Error cluster, and you can left-click to select the
element that you wish to unbundle. Select Status.
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H.69
DO

Analog Wfm
1Chan M5amp

[

d. Now place a Compound Arithmetic function with the Boolean functionality of
OR with multiple inputs. This is located in the Functions Palette under
Programming » Boolean. This will create a multi-input OR function that will
report a Boolean True if any one of the inputs is True, which stops the While
Loop execution. Note: you can use a basic Boolean OR function for this
example, but the compound is used as it will enable you to grow the
application in a later exercise.

e. Wire the output of the Compound OR function into the Conditional Terminal
of the While loop.

ey

ey »
Analog Wfm

1Chan MSamp

Stop Button

==

18. Save your VI by pressing <Ctrl+S>.

19. Navigate to the Front Panel and press the run button or simply press <Ctrl+R> to run
the VI. Ensure that your audio source is playing a song — for example, from your cell
phone, or from the audio output jack of the laptop you are working on.

a. You should see a sound signal in the waveform graph indicator similar to the
image below.
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Part B
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Amplitude

Time

Stop Button

'l stop

The following section will explain how to log data using the TDMS format. This format
allows for easy organization of data, high streaming rates to disk, and other great qualities
for engineering data storage. NI offers a program dedicated to opening and manipulating
data in TDMS format, NI DIAdem. If you have more than 30K samples in your log, you are
approaching Microsoft Excel’s limitations and DIAdem is the right tool for you.

1. To log the acquired data to the previous example, only one (1) function needs to be
added to the chain of DAQmx code. Fortunately, there is already an example built
by the DAOmx R&D team at National Instruments that has this function added.

a. Within the LabVIEW environment, navigate to Help » Find Examples....
Once the NI Example Finder is loaded, browse to Hardware Input and Output

» DAQmx » Analog Input » Voltage — Continuous Input.vi. Double-click to
open this example.
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B NI Example Finder = 2|
Browse | Search Double-click an example to open it.

() Building User Interfaces - | |Description: ~

Browse according to: (33 Communicating with External Applications This example. while not
@) Task 3 Control and Simulation spedifically written for the
LabVIEW Real-Time Module,
o (1 Distributing and Documenting Applications o on R,‘::rg;': .
) Directory Structure ) Favorites
J Fundsmentals This example demonstrates how
23 Hardware Input and Output - | to continuously acquire voltage
25 DAGmx measurement using a DAQMX
device.

3 Analog Input

Bridge - Continuous Input.vi For instructions on how to
connect your signals to the DAQ
device, refer to your device
documentation.

Current - Continuous Input.vi
Current - SW-Timed Input.i
IEPE - Continuous Input.vi

AAA AAAAAAAAA

Resistance - Continuous Input.vi
RTD or Thermistor - Continuous Input.vi
Strain (Rosette) - SW-Timed Inputvi )

Strain - Continuous Input.vi E Requirements
Thermocouple (with OTCD) - Continuot E The following devices can run this .
Inputi example: 3
Thermocouple - Continuous Inputvi [} USB-9234
Thermocouple - SW-Timed Inputvi B S:gjji
Visit ni.com Voltage (with Events) - Continuous B} UsE4432
Inputvi
ki T atage- Conmmuous o5 e
Hardware Voltage - Finite Input.vi B, ¥, MI9234 -
Find hardware [=] Voltage - SW-Timed Input.i B ||« ,
[ Limit results to hardware [ AddtoFavorites | [ Setup.. | [ Help | [ Close |

b. Explore the Front Panel. This was made entirely using LabVIEW Front Panel
controls, indicators, and decorations.

2. Press <Ctrl+E> to open the Block Diagram. Observe the code. If you still have the
solution to Exercise 1a open, compare your Block Diagram code to this code. There
are a few differences in this Block Diagram in comparison to your Block Diagram.

a. For the Create Channel VI, all of the inputs are set to be controls rather than
indicators. This allows the operator to easily change things directly from the
front panel, instead of having to go to the block diagram. Also, the Max and
Min Voltage input terminals have controls. This allows you to specify the
range of the input signal. There are limits for this range, and you should refer
to the specifications document for these limits.

Terminal Configuration

Min Voltage
b

Max Voltage
b

Physical Channel

L7 0L s

Al Voltage *

Channel Settings

b. For the Timing VI, again, controls are used instead of constants. There is
also an advanced function used, called a Property Node. Turn on context
help <Ctrl+H> and mouse over the property node to learn more. This
property node is used to read out the ‘actual’ rate of the sample clock.
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Some timers can only sample at certain rates; if you do not specify one of
those rates, it will be coerced into that rate.

Sample Mode

|Continuous Samples +

Sample Rate
r

Sarnple Clock Source
/0

E-GDAmeTiming ﬂ
J b
Sample Clock =

Actual Sample Rate
r

Timing Settings

c. Hereis abrand new VI, DAOmx Configure Logging (TDMS).vi. This enables
you to automatically stream (log) the data acquired to your DAQ device
directly to disk using the Technical Data Management (TDM) format. If you
are using a sensor such as an accelerometer or thermocouple that has
custom scaling, it will log in the scaled engineering units.

Operation
IGpen or Create vI—

TOMS File Path

Legging Mode
E——

d. Explore the remaining functions of the VI to notice a few more changes such
as the Read and Boolean OR functions.

3. To explore the functionality of the data logging, return to the Front Panel. Locate
the Logging Settings section on the Front Panel.

a. Mouse over the right folder section of the TDMS File Path and left-click to
browse to the proper file path. This allows you to browse to the file location,
but you must also enter the name of the file to be created before selecting
OK in the Open Dialog Window. Enter “Exercise 1b Data” for the file name
and place the file within the project folder and then proceed.
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Logging Settings
Logging Mode
E: | Log and Read H

TDMS File Path
[, C:\Seminars\LV HO\6 - Audio Equalizer |]

L o

b. Change the controls on the Front Panel so that they match the image below:

r =

Channel Settings
Physical Channel
|1/0 Voltage_in/ail |m]

Max Voltage Min Voltage
5 -5
Terminal Configuration

[ E: | Differential |]

Timing Settings

Sample Clock Source

|I/D OnbeoardClock |m]
?ample Rate Actual Sample Rate
40000 ” [1000.00 |

Samples per Loop

Logging Settings
I:ogging Mode
E: Log and Read
TDMS File Path
|q,, C\Seminars\LV HOVG - Audio Equalizer |]

c. Run the VI for a few seconds, and then press the Stop button on the Front
Panel to end the acquisition. Assuming that no errors were encountered, the
data should now be logged to file.

4. |f you have Excel installed, you should be able to locate and double-click the file to
open it directly in Excel. If not, you can try to first open Excel, and then choose to
open the file from the Excel environment.

a. After you open the file in Excel, the root tab is the default open tab. This tab

contains high level information about the file, but does not actually have the
data points.
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b. To see the data, navigate the _unnamedTask<1> tab. This tab has every
single data point that was acquired, and the top row has the physical channel
name.

A B C
Voltage_in/ail
0.030820487
0.030820487
0.030820487
0.031136481
0.031452475
0.030820487
0.030820487
0.030820487
0.030820487
11 0.030820487
0.031136481

B @ |~ ook w e

c. You can choose to graph and manipulate the data however you please from
this point.

5. Close the DAOmx Example VI, but keep your Exercise VI open for the next step.

<Exercise Continued on Next Page>
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Exercise 2: Filtering and FFT

Goals e Add a Fast Fourier Transform (FFT) to the audio signal to view the signal in the
frequency spectrum

e Add a low-pass filter to remove the high-frequencies from the audio signal

e Add a band-pass and high-pass filter to split the signal into Bass, Mid-tone, and
Treble, attenuate signals, and mix back together
e Create a subVI to contain all of the signal processing

Part A 1. Before placing the signal processing functions, first create empty space within the
while loop for these functions.

a. While holding <Ctrl>, left-click-and-drag to place blank white space on the
block diagram within the while loop

b. Try this a few times to get used to how it works. If you do not like the
result, press <Ctrl+Z> to undo your last action.

c. Hereis an example on how this functionality works.

Analog Wfm
Analog Wfm g
1Chan NSamp 1Chan NSamp E status|
Stop Button
m = =0}

2. Open the Functions Palette and navigate to Signal Processing » Waveform
Measurements » Power Spectrum and PSD and place this VI to the right and below
the DAQmx Read VI.

a. Wire the DAQmx Read data output into the Time signal input of the Power
Spectrum.

b. This function will compute a fast Fourier transformation and output a Power
Spectrum, which displays the power of each signal for each frequency band.

ni.com/daq 112



c. Create a waveform Graph on the Front Panel and wire the Power Spectrum /
PSD output into the input of this graph.

d. Wire the Error out of the DAQmx Read into the Error In of the Il Filter, and
then connect the Error Output into the Shift Register and the Unbundle by
Name function.

- G
DA
Analog Wfm _ frequency T
1Chan NSamp . lpeer | oot | status |
PsiPsO)

Stop Button
O

3. Save the VI.

4. Run the VI to observe the Frequency spectrum of the audio signal

Errbsindy | Plot0 [V

e

0.0001 -

8E-5-

6E-5-

Amplitude

4E-5-

Amplitude

2E-5

0- (-
1 I 1 1 I 1 1 1 I

0 002 004 006 008 01 0 5000 10000 15000 20000

Tirmne Frequency

Part B 1. Open the Functions Palette and navigate to Signal Processing » Waveform
Conditioning » Digital IIR Filter and place the VI in-between the DAQmx Read and
Power Spectrum VI so that the signal is filtered before it is transformed to the
frequency spectrum. Wire accordingly for error and signal wires. Expand the while

loop if you need more space.
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a.

data

§ DA
1R, e

Analog Wfm L*@ﬂ E frequency
1Chan M5amp =) =] =
PsfPED

Stop Button

Create a constant for the IIR filter specifications input to the filter. Thisis a
cluster of data that contains many items. Mouse over each with Context
Help on to find out what each represents.

Context Help (=]

IR filter specifications

Mo description available,

IR filter specifications (cluster of 7 elements)

8 Topology (unsigned word [16-bit integer (0 to 65535)] enum [Off, Butterworth, |
] Type (unsigned word [16-bit integer (0 to 65535]] enum {Lowpass, Highpass, Ba
[ Order (long [32-bit integer (-2147483648 to 2147483647)])

Lower Fc (double [64-bit real (~15 digit precision]])

Upper Fc (double [64-bit real (~15 digit precision]])

PB Ripple (double [64-bit real (~15 digit precision)])

5B Attenuation (double [64-bit real (~15 digit precision)])

Detailed help i
EREEE m | b

b. Make the following entries into the constants

C.
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i. Topology = Butterworth
ii. Type = Lowpass
iii. Order =10
iv. Lower Fc =600
Right-click the border to the cluster and select View Cluster as Icon to
minimize its space on the block diagram.

-

¢ Butterworth |

¢ Lowpass ¥

TR
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d. Move the cluster constant below and to the left of the filter. Your Block
Diagram should appear as follows.

g DG |
TRy by
Analog Wfm L@

- T E frequency
1Chan MSamp E =T Th==t]|

(L]

pfpsD

[1d
Stop Button |
m = -Hvl-@l

2. To visualize the effect of the filter and to find out the ideal cutoff frequency for the
filter, it would be better to be able to control the frequency cutoff while the program is
running. With LabVIEW, this is possible!

a. You will need to modify the Lower Fc component of the IIR Filter
Specifications. Place a Bundle by Name function below and to the left of
the IIR filter function.

b. Wire the cluster output into the input cluster input on the top of the Bundle
by Name function.

data

N DL |
1R !
Analog Wfm - L.:

1Chan MSamp =
(]

PEfPED

c. Wire the output of the Bundle by Name function into the IIR Filter
Specifications input of the IIR Filter function

d. Create a control for the Lower Fc input of the Bundle by Name function
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By
Ty
Analog Wfm =
1Chan M3amp -Ht S
IR frequency
......... T ] El-u .
Lower Fc : |
g PS/PS0
@ Stop Button |
m B “Hv]-®

e. Navigate to the Front Panel to locate the Numeric Control and replace the
control with a Silver » Horizontal Numeric Pointer Slide. Double-click the
minimum value and change it to 1 and double-click the maximum value and
change it to 20k.

f. The minimum frequency must always be greater than zero, and the
maximum frequency must always be less than or equal to the Nyquist
Frequency, which is the %2 of the Sampling Frequency, 40kHz in this
example.

Plot0 [~/

Frequency
0.012-

0.01-

Amplitude
o o o
AR

0- 1 [ [ [
0 5000 10000 15000 20000
Frequency

Lowpass Frequency

=

I
1 5000 10000 15000

3. Save the VI.
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4. Run the VI and modify the cutoff frequency while it is running. Can you see the effect
on the frequency?

m Exercise 2b Solution.vi =RR=N X
File Edit View Project Operate Tools Window Help J
W by gl
i [2|@n i
" 9215/ai0 " Ploto
data L fab | Frequency L N/

0.1+ 7E-5-
BE-5-]
u o 5E-5-
2 2 4E5-
E E 3E-5-
2E-5-

1E5-] =

0- ‘I_" S 1 1
0 5000 10000 15000 20000
Frequency
Lowpass Frequency 8591 .64
B s R L
- 1 1 1 1 1
L1 5000 10000 15000 20000
SLIDE = = =
<W> Server: localhost | < 1 b

You are now aware of the effect of the filter. For this reason, you no longer need to
have the control on the Front Panel.

Part C 1.

a. Delete the Lowpass Frequency control and remove the Bundle by Name
function from the Block Diagram.

b. Change the Lower Fc value to 600 within the cluster

c. Wire the cluster output back into the IIR Filter Specifications input of the IIR
filter function.

2. Addin 2 more Digital IIR filters, one bandpass filter for the mid-range frequencies, and
one high-pass filter for treble frequencies. You will need to add more space to the

While Loop to place two more filters.

a. Select the entire filter setup by clicking and dragging to select, and then hold
<Ctrl> and click-drag-and-drop to copy the functions for the additional filters
to save time. You can also select multiple items by holding <Shift> while

selecting items.

b. Wire the error out of the Lowpass into the error in of the Bandpass Filter.
Wire the error out of the Bandpass into the error in of the highpass. Wire
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the error out of the highpass into the error in of the Power Spectrum
function. You will need to adjust the Block Diagram spacing again.

)
D

=) Q
Analog Wfm Lq@” frequency

1Chan MNSamp I.:L_J.._] =]

=Ey

Stop Button

................... Hvl]-{®i

c. The bandpass Lower Fc must always be greater than zero and less than the
Upper Fc of the bandpass filter. Open the cluster by double clicking on it
and then set Lower Fc to 800 and Upper Fc to 3000. Change the type to
Bandpass.

d. Contrary to intuition, the high-pass filter uses the Lower Fc for the frequency
limit, not the Upper Fc terminal. Set this to 5000. Change the type to
Highpass.

e. The filters are now cascaded in series for the error wires, which is
acceptable. However, we do not want to run the filtering in series; the
filtering must be in parallel to allow each filter to view the original sound
signal. Branch off of the data output from the DAQmx Read VI and wire this
to the signal in terminal of each filter.
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data

3]

ey
ity

¥ :
Analog Wfm E

1Chan N5amp

nL

frequency

Stop Button

@

3. With the above setup, only the lowpass filtered signal will be displayed. However, the
goal of an audio equalizer is to mix the signals back together after filtering them out
and attenuating them.

To attenuate the signals, you need to operate on the array of numeric data
within the waveform rather than the entire waveform. Use a Get Waveform
Components for each of the three waveform clusters to unbundle the Y
array of data.

This is located in Programming » Waveform on the Functions Palette. Place
3 of these down and wire the waveform output from each filter into the
function.

Place a multiply function for each array from the Programming » Numeric
Functions Palette and connect each one of the three arrays to the top input
of the function.

On the Front panel, create 3 Silver Numeric Vertical Pointer controls, one for
Bass, one for Mid-tone, and one for Treble, titled respectively.

Set the input range at 0 to 1.0 for each
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1- 1- 1-
08- 08- 08-
06- 0.6- 06-
0.4- 0.4- 0.4-
0.2- 0.2- 0.2-

0- 0- 0-

f.  Place each control inside of the while loop and connect to the respective
Multiply functions.

data

&5
Ly

E.I -
Analog Wim Lj TR LE Bass

1Chan NSamp @

e

LLHR Mid-tﬁ,_">
IIE»

Treble

.................... | o=

4. To add the arrays back together, use a Compound Arithmetic function as you did to
add the Boolean functions together for the Conditional terminal.

a. You can copy and paste from the Compound OR function and change the
mode, or place it from the Programming » Numeric Functions Palette.

b. Expand for three inputs, and wire the arrays into it accordingly.
c. To build the arrays back into a waveform, use a Build Waveform function and
branch off of the previous waveform to use as a reference for the input

cluster input on the top of the function.

d. Wire the output of the Compound Arithmetic into the Y terminal of the Build
Waveform.

e. Wire the resulting waveform into the Power Spectrum VI. The Block
Diagram code within the While Loop should appear as follows.
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data

&
] iy

Analog Wfm
1Chan NSamp

4
LM

Treble

©

5. Save the VI.

6. Run the VI and set the level of attenuation of the signals on the Front Panel to visualize
the effect of the filters.

_

At this point, the Block Diagram is getting pretty messy, and it would be in your best
interest to try to clean it up. In LabVIEW it is possible to make a subVI, which is a
function that you create and use within a larger VI. In this example, we will make a
subVI for all of the signal processing.

Part D

2. To prepare the Block Diagram for creating a subVI, you need to align the Controls
(Inputs) to the left side and the indicators (outputs) to the right. Everything that you
wish to conceal within the subVI should be in the center. Here is an example.

o

The blue section will be contained within the subVI, and the wires that are enveloped
in the red section will be inputs and outputs to the subVI function.

3. To create the subVI, left-click and drag a selection around the entire blue section from
the prior image.
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a. After you have selected the items, navigate to Edit » Create subVI.

b. This will put all the enclosed items within a new subVI and automatically
create controls and indicators

data
P

=}
E'lmj“'é'bﬁ
] AL
Analog Wim |
1Chan NSamp
Bass

=
M\drtfl'\a
==

Treble

e

o

4. You can now proceed by editing the icon for the subVI and changing the wiring if
required. Double-click on the subVI icon to begin this process. This will bring up
the Front Panel of the subVI.

a. Inthe upper right hand corner of the subVI Front Panel, you will find the icon
and terminal editor of the subVI.

(=] |g
e

b. Double-click the default icon to open the icon editor.
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c. Browse around the environment and edit the icon as you desire. It is best to
add in text and choose an icon to indicate the functionality of the subVI. You

can drag-and-drop glyphs from the library and also copy and paste in images
from the internet.

13 Icon Editor (Untitied 1 (SubVI)

File Edit Tools Layers Help

Templates | IconText | Giyphs | Layers |

Catedo " Filter glyphs by keyword /
Acquiring and Generating Dat 7
Actions & & (@] ¥ O m
Attributes N B o
Communication (@]
Data Types 4 o vx I ¥ 1 e
Editing Operations & T
File Operations
File Structures g o o ci “ ® & I
File Types et
Hardware
Image Manipulation v © o * o
LVOOP Classes and Objects > /’%
Mathematics
Product Namesldentifiers a 1 Te rrp e?
Programmin g fu & S
Signal Processing [
Signals - = O ad 2 i
State Charts i RO %0
Things 3 [N G0 Y0

— . S o0 g0 Ok [ Cancel |[ Help ]

d. Here is an example of an icon that you could use, but feel free to create your
own. Select OK once you are satisfied.

=G HAaL
FFROC

e. Now let's change the terminal pattern and wiring. It is best to keep the
inputs on the left and outputs on the right. The top and bottom are typically
used for specifications and optional inputs. This means that we need to

have 5 inputs on the left and move the Treble control terminal to the left-
hand side.

f.  Right-click the terminal editor and select Patterns » and then select the
pattern with 5 inputs, 5 outputs, and 3 top and 3 bottom terminals.
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Remove Terminal

ET— ) T
Flip Horizontal

HIEJEFATHHES
Disconnect All Terminals E:I E % E @:I ED
Disconne ct This Terminal

mecomeins AP EETH
el a=

mn

g. You now need to change the terminals that are mapped to controls. Right-
click the lower orange input which corresponds to mid-tone and select
Disconnect This Terminal.

h. No you will need to reconnect the Mid-tone control to the middle input
terminal. Left-click the middle input. Notice that it changes the mouse
pointer to the wiring tool.

i. You will now need to left-click on the control that you wish to be mapped to
this terminal, Mid-tone.

i You can left-click any terminal that is already assigned to a control and it will
highlight the associate control.

k. Repeat this process to map the Treble control to the input terminal just
above the error input and just below the mid-tone input.

|.  Return to the Block Diagram and right-click on the waveform wire that is
input to the Power Spectrum function and create an indicator. Map this
indicator to the middle output terminal.

output waveform

m. Here is the how all of the controls and indicators should be mapped.
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error in (no error)

| status  code

n. Save the VI as Signal Processing subVI within the folder on your desktop.

0. Close the subVI.

5. Open the Block Diagram of your main code and notice that the subVI is now greyed-
out. This is because you need to re-link to the subVI after changing the input

terminals.

—
I HAL
FROC

a. Right-click the subVI and select Relink to subVI.

b. Verify that all connections are now correct. Clean up the Block Diagram and
condense the size of the while loop. Here is the resulting Block Diagram
after cleaning it up.

data

|
%] |
E _—3 ;
Analog Wfm - Bassl@ >
1Chan NSamp Mid-tone:@ r Stop Btton

Treblel@ ]

frequency

@

6. Save the VI. Run the VI to verify that it still functions correctly.
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<Exercise Continued on Next Page>
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Exercise 3: Output Processed Signal

Goals e Create an Analog Output Task to play a simple tone
o Modify code to continually generate and output a new waveform
e Add this code into the Analog Input code and then output the filtered Audio Signal
¢ Modify code to allow for two analog inputs and two analog outputs because it is a
stereo signal with Right and Left audio signals

Part A 1. Create a new VL.
2. On the block diagram of your new VI, create an Analog Output Voltage DAQmx Virtual
Channel by placing a DAQmx Create Virtual Channel and then selecting the type to be
Analog Output » Voltage.

a. Set the input to be Voltage_out/ao0
b. Set the input terminal configuration to be default

3. Create a DAQmx Timing VI

a. Set the rate to be 40k
b. Set the sample mode to be Continuous

|Continuous Samples =

Default ~ 20000

% Voltage_out/ac0 |+ 3

—F
nnn

AO Voltage Sample Clock *

4. By default, Analog Voltage output tasks are setup to have a waveform pre-loaded into
the output buffer before starting, and then continuously regenerate the waveform until
the DAQmx Task is cleared. So you now need to create a waveform.

a. Navigate to the Functions Palette and browse to Programming » Waveform
» Analog Waveform » Waveform Generation » Basic Function Generator and
place it above the Sample Clock Timing VI.

b. Browse the inputs using Context Help <Ctrl+H>

c. Place a constant for frequency, amplitude, signal type, and sampling info.

d. Enter 800 for frequency, 0.005 for amplitude, and Sine Wave for signal type.
For the sampling info, enter 40k for the Sample Rate (Fs) and 40k for
Number of Samples (#s). You can mouse over the items in a cluster to view

their label in context help, but in this case it does not matter as they are the
same value.
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e. This function will now generate a one second long 800 Hz tone that is
sampled at 40kHz.

frequency |800

amplitude {0,005
sampling infe {40000 E
40000

5. Create a DAQOmx Write VI and place to the right of the Sample Clock VI
a. Connect the Task and Error wires accordingly form the Sample Clock VI

b. On top of the VI there is a terminal, Auto-start, which will start the task
automatically after the buffer is loaded. Create a constant for this input and
select F to prevent it from auto-starting.

c. Wire the signal out from the Basic Function Generator VI to the data input of
the DAQmx Write VI

6. Place a DAQmx Start Task after the DAQmMx Write

7. Create a small while loop to the right of the Start Task VI and pass the task and error
wire through to make tunnels.

a. Create a Stop Button control, and also unbundle the error wire to stop the
loop if an error is detected.
b. Replace the tunnels with shift registers

8. Clear the task and place a simple error handler which is located under Programming »
Dialog & User Interface.

9. This VI will now output an 800Hz tone continuously until the Stop button is pressed.
Run the VI to test it out.
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4+ Sine Wave 7|

frequency |800

signal type

amplitude [0.005

sampling infe |[40000

40000

Analog Wfm
1Chan NSamp

Stop
[ =@
——

Part B 1. To update the output waveform while running, you will need to change the default
behavior of allowing regeneration.

a. Right-click the DAQmx Write VI and navigate to DAQmx — Data Acquisition
Palette » DAQmx Write Property Node and place this property node in-
between the Sample Clock and DAQmx Write Vls

b. Connect the Task and Error wires accordingly

c. For the property node, select Regeneration Mode for the property of interest
and create a constant. Select Do Not Allow Regeneration.

|C0ntinu0us Samples =

|Do Mot Allow Regeneration |
Default ~| 40000 ‘ E

& =% DAQmx Write ,

mrl' RegenMode Pemrrrred AN b,
|AO‘u’oItage 'ﬂ |SampIeCIock *H 1Pér;floil‘.;‘.ffm -
an NSamp

2. Increase the size of the While Loop to allow for a copy of the Basic Function Generator
VI and all constants.

% Voltage_out/aod |=j-~1."

a. Copy and paste within the while loop the Function Generator.

b. Change the Frequency constant to a Control.

c. Navigate to the Front Panel and change the numeric control with a Silver
numeric horizontal pointer slide control.

d. Set the limits for the control at 1 to 20k.

3. Copy and Paste the DAQmx Write into the While Loop and wire accordingly to the Task
and Error wires.

a. Set auto-start to F if it is not already

b. Wire the Signal out of the Function Generator inside the loop to the data in
of the DAQmx Read VI.
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# Sine Wave |

D]

d% ey &

Analog Wfm b statush

1Chan N5amp Stop

n

4. Run the VI and modify the frequency during run time while listening to the output
waveform.

Part C 1. To use the analog output code to play back the processed audio input, you will need to
add your new analog output code to the existing VI that you created to read sound in.

a. Copy the entire Block Diagram Code of your analog output VI and paste into
the Block Diagram of the Analog output as seen in the figure below. You
can also select the code from one Block Diagram and drag-and-drop onto the
other.

4 Sine Wave 7|

frequency
0,005

40000
40000
Do Not Allow Regeneration ~|

signal type

amplitude

sampling info

Continuous Samples |

=

e o3 = DAQm: Write 5[ T :l ¥
_______________ HY )
A Analog Wim - b status
1Chan NSamp Stop
[maf20
4000
40000
& OnboardClock [7]
data
P )
i Voltage_in/ail [ 5] E =
Fe & Pl L 2 ; e
AlVoltage || [Sample Clock * Analog Wfm Bass [T517,
1Chan NSamp Mid-tone [Z51 ¥ Stop Button
Treble D5 ¥ frequency § [CTER-
T
0

2. The goal is to now merge the two while loops together. Because the acquisition and
generation are linked together and data needs to be shared from one to the other, they
must be in the same while loop.
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a. You have two options: remove one loop and add code into the other, or
remove both and draw a new while loop.

b. The result is the same, and it is only a matter of preference. You will also
need to remove one Stop button as you no longer need both.

c. Your block diagram should appear as follows.

4000
Continuous Samples |

s OnboardClock [+]
data
|
5 Voltage_in/ail [R>S = T~ b I e :
,,,,,,,,,, 1
Analog Wim | Bass o5 |
LChan NSamp Mid-tone (050 ¥ Stop Button
Treble (o5t ¢ frequency
=
" DEmeey
frequency BT
amplitude |0.005
sampling info [[35000
40000
- 1
TR~T8 5 DA Qmx Write 5|
. 7 s L"’% ¥
Analog Wm ] Analog Wim _
1Chan NSamp o 1Chan NSamp

3. Remove the Function Generator VI and all of its connected constants and controls
inside of the While Loop.

4. Wire the Output Waveform terminal of the Signal Processing subVI to the data input
terminal of the DAQmx Write VI.
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data
| |

GO
TS
Analog Wfm Bass:@ 4
1Chan NSamp Mid-tone [[DEL ¥ Stop Button
Tl'eb|E||E ’ frequency
s}

DL
Analog Wfm
1Chan NSamp

@

5. Change the amplitude on the Function Generator before the while loop to zero (0) so
that it is a 1 second delay with no sound as opposed to a 1 second tone at the
beginning of the initial output.

6. Delete one of the Simple Error Handler Vis as it is a best practice to only have one error
handler per VI.

a. Place a Merge Errors function to merge the two error wires together by
navigating to Programming » Dialog & User Interface

b. Connect the Error output from each DAQmx Clear Task into the inputs of the
merge error function, and wire the output of this function to the input of the
Simple Error Handler.

7. Save the VI.
8. Run the VI with your MP3 source playing. Toggle the attenuation and filter frequencies.

Can you hear the effect?

<End of Exercise>
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Measuring Vibration from an Accelerometer
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Goals

Part A

ni.com/daq

e In the first part of this exercise, you will write a program to control the speed of a fan
and acquire data from accelerometers attached to the fan

e For the second part, you will add code analyze the vibration signal in both LabVIEW and
MathScript

e Key concepts include —

Accelerometer measurements

Using the NI-DAQmx API

Using SubVls

Combining measurement and control tasks
Processing data with LabVIEW and MathScript

©O O 0O o0 O

Measuring Vibration From an Accelerometer
Estimated time: 60 minutes

Many sensors for measuring acceleration and pressure are based on the principle of
piezoelectric generation. The piezoelectric effect denotes the ability of ceramic or quartz
crystals to generate electric potential upon experiencing compressive stresses. These
mechanical stresses are triggered by forces such as acceleration, strain, or pressure.

Seismic mass

Piezoelectric crystal

Sensor housing

Test structure
Figure 1. An accelerometer uses a seismic mass to create a small electrical signal based on
piezoelectric generation.

In the case of microphones, acoustic pressure waves cause a diaphragm, or thin membrane, to
vibrate and transfer stresses into the surrounding piezoelectric crystals. Accelerometers, on the
other hand, contain a seismic mass that directly applies forces to the surrounding crystals in
response to shock and vibrations. The voltage generated is proportional to the internal stresses
in the crystals.

A particular class of piezoelectric sensors, known by the term integrated electronic piezoelectric
(IEPE), incorporates an amplifier in its design next to the piezoelectric crystals. Because the
charge produced by a piezoelectric transducer is very small, the electrical signal produced by
the sensor is susceptible to noise, and you must use sensitive electronics to amplify and
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condition the signal and reduce the outout impedance. IEPE therefore makes the logical step of
integrating the sensitive electronics as close as possible to the transducer to ensure better
noise immunity and more convenient packaging. A typical IEPE sensor is powered by an
external constant current source and moaulates jts output voltage with respect to the varying
charge on the piezoelectric crystal. The IEPE sensor uses only one or two wires for both sensor
excitation (current) and signal output (voltage). The NI 9234 C Series moadule in your NI
CompactDAQ chassis provides this constant current source to |EPE accelerometers and
microphones.

In this exercise, you will measure the vibration of a fan using the accelerometers on the Sound
and Vibration Signal Simulator. The NI 9234 features four simultaneously sampled channels
and can measure signals from both I1EPE and non-1EPE accelerometers and microphones.

Before you start this exercise, confirm that the accelerometer is properly connected and you are
able to acquire basic data from the channel connected to the accelerometer.

1. Ensure that the green Power LED and amber Ready LED are lit to confirm that the
chassis is connected over USB and powered on.

2. Examine the wiring into the NI 9234 to confirm that the BNC cables are connected to
the X Acceleration, Y Acceleration and Tach Out on the Sound and Vibration Signal
Simulator.

3. Open Measurement and Automation Explorer by selecting Start » All Programs»
National Instruments » Measurement and Automation Explorer or double-click the icon
on your desktop.

4. Right click on the NI 9234 and select Test Panels.

T 62 N19234 “Sound_Vibration” - Measurement & Automation Fxplarer ==}

File Edit View Tools Help

- B My System H #¥ Refresh | + Reset [EYSelf-Test [ TestPanels.. | {8 Create Task.. -l Device Pinouts <& Configure TEDS_ 37 Hide Help
[ Data Neighborhood - | @Back f=]
4 @ Devices and Interfaces ;
= Integrated Webcam “cam(” Settings NI-DAQmx Device Basics
& ASRLLANSTR "COML Vehat da you vant to do?
= ASRLI0CINGTR “LPT1Y Mame Sound_Vibration :

& fy | cDAG-9178 “cDAQL” MRun the NI-DAQmx Test Panel:
— . : ‘ender Mational Instruments B
I 1: NI9211 "Temperature FRemove the device

0 2 NI9237 "Strain” Model MI9234
i 3 NI9472 “Digital _out wiew or change device conflguration
@ - iy . Senal Number D14A5998 =
I 4 NI 9263 "Veltage_out” -
I 6: NI 9234 "Sound_Vibration” Slet Number [
o & Vi in"~ |+ Reset
8: NI9215 "Veltage_in' latus Present
& Network Devices [ Self-Test
Il NI Switch Executive Virtual De (M Create Task..
8 Histoncal Data & Configure TEDS.. |
“d Scales xternal Calibration
&1 sottware Rename
il V1 Drivers alibration Dare 1/26/2010 3:15:55 PM
B Remote Syste ] Test Panels...
ot systems F Device Pinouts_ feemmended Next 1/26/2011 315:55 BM
plibration
Help »

—~errehiys M Device Routes

Figure 2. Select Test Panels to open a simple utility for checking signal connectivity.
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5. When the test panel opens, change the Samples to Read to 2560, change the Mode to
Continuous, select the button next to IEPE Enable, and change the Coupling type to AC,
as shown in Figure 3.

6. Press the Start Button.

Test Panels: 7: NI9234: "Sound_Vibration”

Analog Input

2 Amplitude vs. Samples Chart Auto-scale chart [V
- 2 .06 =
0.05-]

0.04-]

0.03-

. 0.02-

| i‘h’l‘xll:’r\m \J“{H’L _"”\iﬁ"i'%fwh_#ﬂumﬁm ‘!“*

|
319999

1.48m
Start | . Stop |
Close | Help

Figure 3. The test panel is used to confirm electrical connections.
7. Gently tap the side of the box to ensure that your sensor reacts to your input.
8. Press the Stop button and close the Test Panel.

Every time you set up a new measurement or measurement system, it is a good idea to
confirm that the wiring is correct and that all software is installed and working correctly. MAX
provides the insight into your system and setup to help you eliminate mistakes early in your
development process.

9. After confirming that your sensors are working, minimize MAX and select Start » All
Programs » National Instruments » LabVIEW <Year> to open LabVIEW.

10. Select File » Open and navigate to the hands-on directory. The starting point for this
exercise is located at Hands-On Exercises\Vibration\Vibration Project.

11. Double click Vibration Exploration.lvproj to open the accelerometer measurement
project. You should see the following screen:
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{3 vibration Exploration.lvproj - Project Explorer

o) o=

File Edit View Project Operate Tools

EEY=1: IR

EL YRR

Window Help

Items | Files

= i}g. Project: Vibration Exploration.vprej
= B My Computer
& [ Exercises
#-[@ Solutions
B[ Support Vs
o . mscript text.bd
+ T‘E‘ Dependencies
‘% Build Specifications

Figure 4. Use the LabVIEW Project to

organize all your Vls.

With the LabVIEW Project you can easily organize and visualize all the files that are important to
your application. In this particular project, the folders like Exercises, Solutions, and Supporting
Vs, have been set to auto-populate with the files within them.

12. Expand the folders to view the file within them. You should see the following Vls:

13 vibration Exploration.vproj - Project Explorer

=)

File Edit View Project Operate Tools

=1 I

IECTER Y

Window Help

Ttems | Files |

= iT_:ﬂ, Project: Vibration Expleration.vproj
£ B My Computer
B[@ Exercises
'gg. Vibration main_exercise.vi
B@ Solutions
i;ﬂ, Vibration main_solution.vi
- [ Support VIs
P | mscript text.bd
_‘;" Dependencies
'% Build Specifications

Figure 5. The VIs used in your project can be found in the auto-populating folders.

138



ni.com/daq

13. Start by opening the solution — expand My Computer » Solutions and double click
Vibration main_solution.vi.

14. Through the rest of this exercise you will build the VI in Figure 6. Ensure that the switch
on the Sound and Vibration Signal Simulator is flipped to BNC. Press the run button.

A3 Vibration men_sohution.n [ Ty s |
File Edit View Project Operste Tock Window Help m
=8
B2 @n | P
Sound_Vibration/ai) [/ LabVIEWPS | psthcrpt PS5
Tirne Domain | = LSS
035 |
02~
L 0018
015 o016
L 0014
005+ y 0012
: i
4 0 —g 001~
< a5 = Doos
b 0006
015 oo
0.002-
2
L |
025, . (] 110
1341 1341 ey ()
Time | *
Vibration Channel Fan Speed Channel Y
B Suund_Vibrston/a |- Voltsge_outracl [ | I v CHECKEAN
” - - o I 9234 Module with :f' N e
Sampies Per Channel . IEPE Canditiening :F :
1000 i 5 ;"- — |5z 1
— — s h st
Sample Rate s 4 - i;'_ MaxVib Level
Eee———] i~ | | -8 ~L— = A1)
1| 10000 | J =~ bt . =002 1}
— ) 1= J =0 ~ L i
N : — h ¥ Datected Ampstude
) 0 it B TP . - = —
B Stop | Fan Speed . 0153018 1]
Vibeatinn Explortion vpraj/by Computer] « i

Figure 6. This VI will acquire a time-domain vibration signal and calculate the frequency content
using both LabVIEW VlIs and MathScript.

15. Using the knob in the center of the screen, adjust the speed of the fan and notice the
reaction in both the time domain and frequency domain. Frequency domain analysis is
crucial to many types of monitoring applications.

16. Click the MathScript PS tab and notice that the frequency domain information is exactly
the same.

17. Press Stop and close the solution without saving.

18. To start the exercise, double-click Vibration main_exercise.vi. The Front Panel has
already been built for you.

When starting a new program, beginning with the Front Panel design is a good way to organize
your thoughts around the inputs and outputs that you expect. Once you understand how you
want a user to interact with the code, then you can begin writing the VI to support that
functionality.

Throughout this exercise, you will complete this VI to control the speed of a fan and acquire
data from an accelerometer in the Sound and Vibration Signal Simulator. Additionally, you will
use both LabVIEW and MathScript to calculate the frequency components of the acquired
signal.
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Figure 7. Beginning with the Front Panel design is a good way to organize your thoughts around

19. Notice that the run arrow in the top right corner is broken (E). This is because the
code contains errors, or in this case, is not in a running state. LabVIEW continuously
compiles in the edit environment, so you will always know if your code is able to run.
Pressing the arrow when it is broken will show a list of errors. Try pressing the run

20.

T3 Vibration men_exercsei Front Parel on Vibration Explorabon hepray My Compules

;

A=)

['File Edit View Project Operate Tock Window Help

o G0 1Sptiegront |+ |[To [ | |20 |

=

K] .

Sound_Vibration/al) [,/
Timé Gorrsin | Ve |

Vibsation Exploration hopray by Computer] «

LabVIFW PS | MathSerpt B5

0.4~ |
| 1+
0.03 |
| -7 -]
002~
SE-7-|
L 00l .
| )
i | E
- | ¥
4] Earr
A1 1
| 274
.02
| 167+
03| |
| 0-, g
0.04- . | ] 10
1800 18:00 | T
Time £ J
Vibratien Channel Fan Speed Channel -
| B sound Vibration/an | (= ¥ Valtage_out/anl e System UK
i 0 B R O S S S SRS R NI 9234 Modulewith |
i Detected Tone
Samples Per Channel - IEPE Conditiening . s
[= ? 0 ]
[ 1000 i PRI i
R . / 1 =
Sample Rate 3 T - : i MaxVibLevel
ah 2= Y -3 LR (o — 3
| = | 10000 | | L hER O Z1{0.03 1
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" o s ] ap—— ittt
L stop Fan Speed e .. VI 0

the inputs and outputs that you expect.

arrow. |f your code compiles with no errors, the run arrow will no longer be broken (

).

Close the Error Dialog and select Window » Show Block Diagram. The keyboard
shortcut for this is Ctrl + E. Use this shortcut to toggle back and forth between the
Front Panel and Block Diagram. When the Block Diagram opens, you will see the

following code:
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Figure 8. The Block Diagram does the work of your program. This is where you will write the
code to control the Front Panel.

Because the code has been started, this Block Diagram includes some basic elements already.
Each element on the Front Panel has a corresponding element on the Block Diagram. To find
the corresponding Front Panel element, you can double click the element on the block diagram
to highlight it. Try double-clicking on the LabVIEW PS icon. Then double click on the same item
on the Front Panel. This is a convenient way to find items on either the Front Panel or Block
Diagram.

The light yellow boxes are annotations. You can create notes on the block diagram simply by
double clicking. It's always a good idea to properly document your code so you (if you come
back a week later) or someone else can understand what is going on.

21. Now that you are familiar with the elements of the program, you can start building the
code to acquire strain data. To start, make sure that the Block Diagram is visible.

22. For this exercise, a large part of the coding will come from the DAQmx palette. To
access this palette right click on any white space on the Block Diagram and navigate to
Measurement I/O » NI-DAQmx, like in Figure 9.
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Figure 9. The DAQmx palette includes all the required VIs for communicating with your NI

CompactDAQ chassis.

23. Click on the pin to keep this palette visible (red arrow in Figure 9).

DAQmx - Data Acq

uisition

4+ | Q search

<, Customize® '

&

%&

Timing Triggering Start Stop
B B #H B G
[ &3 | W
Channel Node Timing Node Triggering N... Read Node Write Node
D) o ¥ v ="
o ' 'e:- ot
DAQ Assist Real-Time Dev Config  Task Config/...

Advanced

Figure 10. Pinning a palette enables you to click elsewhere in your code with the palette still

visible.

24. To start, drag the NI-DAQmx Create Channel (red arrow in Figure 10) and place it in the
position shown in Figure 11.

142



Fan Speed Channel

MathSeript P5
s

[ .
[
et Teoe

Detected Ampitude
Samples Per Charenet [TEER Wikt

—
il

Tane Demain Max Vit Level
= i,

g

0] Grop Buteen[TER - B8

Figure 11. The DAQmx Create Channel VI establishes communication with your DAQ device.

25. By default, this VI is configured to create a simple analog input voltage. To configure
this for accelerometer measurements, click on the drop down list underneath the VI and
select Analog Input » Acceleration » Accelerometer.

=

Analog Output  » Voltage RMS
Digital Input Temperature »
Digital Qutput Current
Counterlnput  » Current RMS
Counter Qutput » Resistance
T Strain
Force
Pressure

Frequency
Position

hcceerometer |

Velocity »
Sound Pressure  p
»
»

4
»
»
Torque >
»
4
»

More
TEDS

Figure 12. The DAQmx Create Channel VI is called polymorphic because it changes to adapt to
the selected measurement type.

26. To find out more about this VI, bring up the Context Help by pressing Ctrl+H.

The Context Help gives you a brief description of anything you hover over with your cursor.
Hover over the DAQmx Create Channel VI to see the inputs and outputs of the VI.

For an accelerometer channel, we need to provide the channel list you are measuring from and
the sensor specific information. To provide these inputs, wire up the VI as shown in Figure 13.
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Context Help
DAQmx Create Channel (Al-Acceleration-Accelerometerlvi

current excitation value
current excitation source
input terminal configuration

Vibration Channel minimum value
maximum value
task in : [T task out
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sensitivity |AI Accelerometer "ﬂ name to i
uniks

1 |
ﬂ'— SOTOT i —

o x custom scale name
sensitivity units sensitivty
senstity s ————
Creates channel(s) that use an accelerometer to measure acceleration,

Detailed help .

Figure 13. Wire the inputs to the DAQmx Create Channel VI.

27. Drag the following VIs from the DAQmx palette and place them as shown in Figure 14.
a) DAQmx Timing
b) DAQmx Start Task
c) DAQmx Read
d) DAQmx Stop Task

e) DAQmx Clear Task

FanSpeed
i
Fan Speed Channal
&
MlatheriptPS_
O
Tab Contrel e
Lt LsbMIEW PS.
The 125 cenrol i ordy used on the freet (]
Loanel & & wiry to organe multipls Samples Per Channel [Fectangie -] Detected Tone
raphs.. £ changing the tab will ot o3 oo
hange amyshing i cod. the tab eontrol Detected amplitiude
[ net wired ta aeything. || e Fan Warning
i)
Sample Rate Time Domain Max Vil Lewel ¢
= = Cl
[Sample Clock =
stop Bunon T} 18

Figure 14. The flow of DAQmx code almost always follows the same pattern

If you recall from the example programs you examined in the earlier exercises, the DAQmx
pattern almost always follows the same flow. A channel is created, settings like timing and
triggering are configured, the task is started, the channel is read then the task is stopped and
the channel is cleared.
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28. The DAQmx Timing VI configures the sample rate, sample mode, and clock source for
your task. You are going to be sampling continuously, using the on-board clock source.
Wire the DAQmx Timing VI as follows:

Context Help [z}

Samples Per Channel

@_ DAQmx Timing (Sample Cleck).vi

samples per channel
sample mode sample mode
task/channels in
rate

FEUrce

active edge i

EITOF I =eemmnd

task out

[Continuous Samples

s SO OUE

Sample Rate

DEL K

Sets the source of the Sample Clock, the rate of the
Sample Clock, and the number of samples to acquire
of generate.

|Sarnple Clock ‘*ﬂ Detailed help
‘ -

Figure 15. The DAQmx Timing VI configures your clock parameters.

29. The DAQmx Start Task VI transitions the code to the running state. Once your code is
past this VI, you are ready to read or write data. To learn more about this VI, make sure
the Context Help is still visible (Ctrl+H) and hover over the DAQmx Start VI.

30. After the task is started, the DAQmx Read VI pulls data off the DAQ device buffer. Like
the DAQOmx Create Channel VI, the DAQmx Read VI is polymorphic. To configure this VI
to read a data from the strain gage, click the drop-down arrow and select Analog »
Single Channel » Multiple Samples » Waveform.

&
O
J SingleSomple v |

Digital » Multiple Channels » 1D DBL

Counter » Unscaled » m|

More » |

Figure 16. Select a single channel of waveform measurement to read from the supplied
accelerometer.

31. Wire the data output of the DAQmx Read VI to the Time Domain chart. This will enable a
user to visualize the data on the front panel. Also, wire the waveform wire to the Get
Waveform Components — you will use this function in a later part of this exercise.
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Figure 17. Get Waveform Components splits the waveform data into the array of points (Y), the
delta between the points (dt) and the starting time (t0).

32. The DAQmx Stop VI and DAQmx Clear VI ensure that your program properly closes
communication and frees up the hardware before stopping the code. Again, to learn
more about these Vls, hover over them with the Context Help visible.

33. Wire the task and error wires through the code. This will pass the task values and any
errors that may arise through the code.

L e P

Figure 18. The task and errors within your code will flow through the wires to the simple user
dialog at the end of your code.

Because LabVIEW uses dataflow to enforce order of execution, you can visualize the data
traveling across each of the wires, from one VI to the next. Each VI will only execute once all
the wired inputs have been accounted for.

Wiring the error wire thought the code ensures that any errors in the code will pass through the
code and be reported to the user.

34. Wire the error wire from the DAQmx Read VI to the input of the Compound Arithmetic
VI. This VI will OR the inputs to stopping the While Loop from executing. The code you
just wrote will stop if an error occurs or a user stops presses the stop button.
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Stop Button
Figure 19. The Compound Arithmetic ORs the inputs, stopping the While Loop if the code has
an error or the user presses stop.

35. Once you wire the error wire to the Compound Arithmetic, your code should be ready to

run. Check to see that the Run Arrow is intact ().
36. Press Ctrl+E to toggle to the Front Panel.

37. Press the drop-down arrow on the Vibration Channel to select the correct channel. In
this exercise, the accelerometer is attached to channel O or channel 1 of the NI 9234. If
you renamed your modules, select Sound_Vibration/ai1.

Vibration Channel
' .
|I|'i Sound_Vibration/ail

LS

Browse... ~

Sound_Vibration/ail
Sound_Vibration/ai2
Sound_Vibration/ai3
strain/af

Strain/ail

Strain/aid

Strain/ai3 =

Figure 20. Select the channel to which your accelerometer is attached.

38. Set the sample rate to 10000 Hz and the samples per channel to 1000, like in Figure 21.
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Part B
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Vibration Channel

-

" Sound_Vibration/ail |[~]

Samples Per Channel

-

Sample Rate

= [10000 |

- Stop

|
Figure 21. A good rule of thumb is to set the number of samples to 1/10™" of the sample rate.

The sample rate dictates how fast your DAQ device samples the selected channel. The
Samples Per Channel dictates how much data is pulled from the DAQ buffer each time the loop
runs. In the example above, DAQmx Read will wait until there are 1000 samples on the buffer
before it pulls them from the DAQ device. This translates to an update every 1/10" of a
second. If you change the Samples Per Channel to 10000, your code will update once every
second. If you get buffer overflow errors, it usually means that your loop is not executing fast
enough to pull data off the DAQ device before the buffer is full. Try increasing the number of
Samples Per Channel if this is the case. In some cases, you may need to split your code into
parallel loops. For more information about this type of architecture, search Producer Consumer
on ni.com.

39. Press the run button. You are now acquiring vibration data from the accelerometer in the
Sound and Vibration Signal Simulator. Make sure that the switch on the Sound and
Vibration Signal Simulator is set to DIAL and try increasing and decreasing the speed of
the fan. Notice the changing signal on the screen.

Often, time-domain signals of sound or vibration signals cannot tell you what is happening to
the device being monitored. Perhaps the most commmon processing on time domain sound or
vibration signals is an FFT. The next portion of the exercise will step you though adding signal
processing, using both LabVIEW VIs and the MathScript node.

40. Press Stop. Save this VI, as you will use it in the next part of the exercise.

Controlling the Fan Speed with Analog Output
Estimated time. 25 minutes

Many times, data acquisition code needs to do more than simply measure a signal. Adding
control to the code enables an operator to use the software to control something. This could be
a digital outout, like an alarm or PWM speed signal, or an analog outout, like a stimulus
waveform. In this example, you will use a DC voltage signal to control the speed of the fan that
was controlled with an external knob in the first part of the exercise.
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Before you start this exercise, switch the physical Fan Speed Control switch to BNC.
1. To begin this exercise, open the Block Diagram of Vibration main_exercise.vi

2. For this exercise, a large part of the coding will come from the DAQmx palette. To
access this palette right click on any white space on the Block Diagram and navigate to
Measurement I/O » NI-DAQm, like in Figure 22.

35 Functions @ Sowrch]
Programmeng »
| @ %
Structures ety Chastes, Clas.

¥ i ="
B> |[lo] (=
Humenc Boclean String
¥ C =
o 0] E

Compaion  Timing  Dulog & Use

] &

Fite VO Waveform  Application
L . [
W
) % &3
Synchoomicat . Graphacs & 5 Repont Gener

Instrurnent L'0 [l
Vision and Motion i
Mathernatics L
Sigrial Processang L} i
Data Communscatson -0 —
Comectty ! EB = [
Contrel Design & Simulation A Task Const  Chanmel Const Create Chan._ Write Wait
SigralExpress 1 [rse e
Espress L] E E
Addor L} Tamang Trggerng Stop Clear
Favorites L! =]
User Librarsts L] @ m E
Select a VL c:mm-m quﬂ:ﬂ Triggenng M... P-tMNo:e wrmho:r -
| g | a o= |
L]
& o] £ | %
DAG Assit Real-Time DevConfig Task Config/_  Advanced
B
Syster Cond_
==
S
N
MIVO Trace

Figure 22. The DAQmx palette includes all the required Vis for communicating with your NI
CompactDAQ chassis.

3. Click on the pin to keep this palette visible (red arrow in Figure 22).
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DAQmx - Data Acquisition 3

2 | Q search | 2, customize |

rise -} EI3

Channel Node Timing Node Triggering N... Read Node Write Node

Y a » > »
/ '}
Li# b e = 9
DAQ Assist Real-Time Dev Config  Task Config/... Advanced

Figure 23. Pinning a palette enables you to click elsewhere in your code with the palette still
visible.

4. To start, drag the NI-DAQmx Create Channel (red arrow in Figure 23) and place it in the
position shown in Figure 24.

Mashript PS
|

Tab Control
=0 |

[The tab sntrol is oty used on the Front
parsel a1 & wiy to erganze ruiple Samples Pes Channel
graphs. Az changing the tab will nat

sample made
Sample Rate

o nt wired 12 anthing.

[Sample Clock <]

B

Figure 24. The same VI for creating and acquisition channel is used to create a generation
channel, but you can change the polymorphic instance by using the drop down menu.

5. To configure this VI for generation, click on the menu below the VI and select Analog

Output » Voltage.
£l

J Analog Input 3 [ .
Slotage |
Digital Input Current
Digital Output Function Generation
Counterlnput  »
Counter Output p

Figure 25. The polymorphic DAQmx Create Channel VI can be configured to create an analog
output value.
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6. Wire the VI as seen in Figure 26.

Context Help (3]

DAQmx Create Channel (AD-Voltage-Basic).vi

output terminal configuration
minimum value
maximum value

Fan Speed Channel task in T ik sk
physical channels Al
¥ name to assign pres—TOT Qut
= L
AQ Voltage ~ EfTorin

custom scale name
Creates channel(s) to generate voltage.
Detailed help =
[]a[?] - '

Figure 26. In this instance, the only thing you need to wire is the channel input to the physical
channels input.

7. Like in the previous exercise, drag the following VIs onto the block diagram and place
them like you see in Figure 25.

a) DAQmx Create Channel
b) DAQmx Start Task

c) DAQmx Write

d) DAQmx Write

e) DAQmx Stop

f) DAQmx Clear

Ean Speed
o}
Fan Speed Channd
40 Vaitage +] Analog DéL _| Anatoq DEL |
AChan 1 5ar 1Chan §Samp
a b C Mathicript PS € f
| i
- |
= — LagMEW %
[The tab control 5 only used on the fremt (o]
pare 258 iy to crgance multiple Sammpies Per Chanmnel Emmges]  DetetedT o
graphs. & changing the tab will not (e o
change snythins in code. the tab control sirnglemods Detected Arsghbudt
= FonWaening
-
5
2 o e I
Stop Buthon| B &

Figure 27. Again, the DAQmx flow, even for output, follows nearly the same pattern.
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You may have noticed that you placed two DAQmx Write Vls. This is because the last value on
the output buffer will persist even after the task is stopped and cleared. In this example, you
may end up with a running fan after stopping the code, depending on the last value. To make
sure the fan is always stopped when the code is stopped, simply write a value of zero to the
buffer before stopping and clearing the task.

For this exercise, we will be writing a single sample to the analog output channel of the NI 9263
each time the loop runs, so the default instance of DAQmx Write VI will work for your program.

8. Wire the Fan Speed control into the data input of the first DAQmx Write VI.

9. Wire the 0 constant next to the second DAQmx Write VI as seen in Figure 28.

Analog DBL
1Chan15%amp

Figure 28. The second DAQmx Write writes a zero to the buffer to make sure the fan turns off
when the VI is stopped.

10. Pull the Merge Errors VI up to reveal another input. The Merge Errors VI is the second
VI from the end, between the Clear Task and Error Handler.

11. Wire the task and error wire through the code, as seen in Figure 29.

r.nSoud(N = m

im - -
)
| E ggggg Tene

7| sl : 2 e
] !&] Siop ButtcnLER E w
Figure 29. The task and error wire communicate information between each of the Vls in the
code.

12. Switch to the Front Panel.

13. Set the Fan Speed Channe/to Voltage_out/ao1. This is the channel of the voltage output
module connected to the fan control on the Sound and Vibration Signal Simulator.
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Figure 30. Using an analog output, you can control the speed of the fan in the Sounds and
Vibration Signal Simulator.

14. Press the Run button.

15. Adjust the speed of the fan using the Fan Speed control knob. You should notice that
the vibration signal in the time domain increases and decreases with the speed of the
fan.

16. Stop the VI and save your work. You will use it in the next part of this exercise.

Adding Analysis to Your Acquisition Code
Estimated time: 25 minutes

In real applications, the measured voltage signals are complex waveforms that contain multjple
frequency components. Sound and vibration analysis usually involves identifying and examining
these frequency components. To do so, you must convert the signals from the time domain to
the frequency domain mathematically using Laplace, Z-, or Fourier transforms. Fourier analysis
IS the most common for this application because it obtains the magnitude and associated phase
for each frequency component in a signar.

For the next part of the exercise, you will calculate the power spectrum using two methods.
The first method will use built-in LabVIEW Vis and the second will integrate .m script to
calculate the same power spectrum. Using this spectrum, vou will calculate the frequency and
amplitude of the vibration to determine the balance of a fan.
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1. To begin the exercise, open the block diagram of Vibration main_exercise.vi.

2. Right click on the block diagram and select Signal Processing » Waveform
Measurements » FFT Power Spectrum and PSD as seen in Figure 31.

431 Functions Q Search
»

. M eh
] * &
Synchronizat. Graphics & 5.. Report Gener...
Measurement 10 L4
Instrument 1O L
Vision and Maotion L
Mathematics L
Data Communication V45 Signal Precessing
cmm [} Wavelorm Messurements t
Control Design & Simulation =) TI g
SegnalExpress ' v d B | 451 Waveform Measurements
i ) Wim Genera... Wim Conditi.. Wim Measure FFT Powcf Spectrum and PSD.vi
. W . = _ -‘.
e N O B "
Fovorbes ! SigGeneration Sig Operation  Windows Baic DC.AMS Avg DC-RMS cycm-g&n. Wim Monito...
User Libranes | L L o M
Select a VL. M t] Iﬂ E . @
Sound and Yibration L] Filters Spectral Transforms

Eﬂud‘l' ﬁmﬁ Hamw-uDd MM_.
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FRF Mag Pha.. FRF Reallmag CrossMagP.. CrossReall.
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Figure 31. LabVIEW contains many built-in analysis functions and many others are supported
through tool kits and add-ons.

3. Place the FFT Power Spectrum VI in the position shown in Figure 32
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Figure 32. The FFT Power spectrum will calculate the frequency spectrum during the
acquisition.

4. Wire the inputs to the VI as seen in Figure 33.

e
4 T Foac
TR

]m pefPstf  Detected Tone
r Ell

Detected Amplitude
] *Ell

Max Vib Level
[DEL¥

Tirme Domain

Analog Wfm
1Chan M5amp

Figure 33. The power spectrum will be calculated each time the loop in the code runs.

5. To learn more about this VI, press Ctrl+H to bring up the Context Help and hover over
the FFT Power Spectrum. If you want to learn even more about this VI, press the
Detailed Help link.

6. With the FFT Power spectrum wired up, open the front panel and run the VI. You should
now be able to see the frequency information from the on-board accelerometer.

7. Try increasing and decreasing the fan speed. Notice that both the time domain and
frequency domain signal changes. Try changing the switch on the Sound and Vibration
Signal Simulator from the balanced fan to the unbalanced fan. Notice how the signal
changes. Measurements like these are commonly used for machine health diagnosis.

ni.com/daq 155



ni.com/daq

13 vibration main_exercise.vi

= Bl |

File Edit View Project Operate Tools

Window Help

Vibration Exploration.lvproj/My Computer‘ 4

i

#2]®[u]
N
S Sound_Vibration/ai0 [/ LabVIEW PS | MathScript PS
[ 0.03 r
0.00022
0,025
0.0002
0.02- A
0.00018 |
0.015-]
0.00016 -
0.01 -
4 0005 , 0.00014-]
e 3 0.00012-
= 0 £
3 2 0.0001-]
-0.005- <
= 8E-5-
-0.01-|
6E-5-|
-0.015-]
4E-5-
-0.02-
2E-5-|
-0.025
0-, ' =
0.03-, ] 0 5110
17:31 1731 Frequency (Hz)
Time
Vibration Channel Fan Speed Channel
", Sound_Vibration/ai0 m] ) Voltage_out/aol m} System OK
NI 9234 Module with
Samples Per Channel IEPE Conditioning E)etectad Tone
] [2000 1 5 6 DU — 0
z L z H
Sample Rate - /o @ e AE Max Vib Level |
% [20000 2 - s (DER AR A SIE
1- -9 -
. . Detected Amplitude
[ o 10 Recccooas o r
LI ——— v

3

Figure 34. From the frequency domain signal, you can understand more about what is

happening in your system.

While LabVIEW includes extensive analysis functions, sometimes the situation may require
integration with other languages, like .m script. For the next portion of the exercise, you will
perform the same analysis using the MathScript node, which enables you to integrate your
existing .m script files into your LabVIEW program.

8. Stop your VI and open the Block Diagram.

9. Right click on the Block Diagram and select Mathmatics » Scripts and Formulas »
MathScript Node.
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Figure 35. The MathScript Node integrates graphical LabVIEW code with text based .m script.

10. Drag a small box in the position shown in Figure 36.
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Figure 36. When you place the MathScript Node, give yourself enough room to type a few lines
of text.

11. For this exercise, you will need to use the components from the time-domain waveform.
To do this, you will use the Get Waveform Attributes, which is already placed for you on
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the block diagram (red arrow in Figure 36). When you hover over this function, you
should see handles appear. Drag the handle down.

2
IM%
attobutes

Figure 37. Drag the Get Waveform Attributes down to add the dt attribute.

12. Click on the attributes portion and select dt. You are now separating out the Y values of
the time domain waveform and the change in time between each of the sample points.

13. Before you can reference data from your LabVIEW code inside the MathScript Node,
you need to define the values that will be input and output from the node. To do this,
right click on the left edge of the MathScript Node and select Add Input. Call this input
dt.

14. Right click on the left side again, select Add Input and call this one Y.

15. Right click again on the edge and select Add Input. Call this one dt.

Fan Speed

|.[-|3[ ]

Analog DBL
1Chan 15amp

Visible Items
Help
Examples

E Description and Tip...

Structures Palette »

|Eower SEectrum hd Add Input

| ———. r_ Add Output »

Probe
Breakpoint »
Script Highlighting » Fan Warning

Time Import..

Gl | Exporti.,

Clear Script

H 6O
ey Clear Script Breakpoints

Analog Wfm - - ) 1
m 1Chan NSamp roperties Stop Bulton lllll
= |

Figure 38. Add the inputs to the MathScript Node by right-clicking on the edge.

16. Open m script text.txt from the Support Vis directory in the LabVIEW Project Explorer.
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17. When the file opens, press Ctrl+A to select all the text then press Ctrl+C to copy.

I

{3 vibration Exploration.lvproj - Project Explorer EI@

File Edit WView Project Operate Tools Window Help
[T TR =50

Items | Files

= E;l, Project: Vibration Exploration.vproj
= B My Computer
E- [ Exercises
L. |md Vibration main_exercisevi
& [ Solutions
E}ﬁ Support Vls
| moscript test.bd
_'5::" Dependencies
+% Build Specifications

Figure 39. m script text.txt includes the required steps to perform frequency analysis using
MathScript.

18. Navigate to the Block Diagram.

19. Left-click inside the MathScript Node then press Ctrl+v to past the text. Your MathScript
Node should look like Figure 40.

% Calculate data parameters
n = length(¥);

df=1/{dt*n];

% Calculate power spectrum

fftrn = ftv):
freq =real( (2/(n"2))*(fftrm). *conj(fftrm));
freq=freq(l,1:(n/2)):

Figure 40. You can past any .m script functions into the MathScript Node to perform text-based
math in-line with your graphical code.
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20. Once you have the text entered, you can add the outputs to the MathScript Node. To
do this, right-click on the right edge of the MathScript Node and select Add Output»df.

Fan Speed
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Analog DBL Analog DBL
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2 n = length(Y);
3 df=1/(dt"n); PS MS
fy| 4 % Calculate power spectrum Visible Items
| 5  fitm = fft(Y); Help
6 freq =real( (2/(n"2))*(fftm).*conj(fftm)); B
W 17 freqefreq(l, Li(n/2); AmEes
i d Description and Tip...
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Detected Tone Probe Add All Outputs
b DBL | .
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Figure 41. Right click on the edge of the MathScript Node to add outputs.

21. Right click on the right edge again and select Add Output»freq.

By inputting the change in frequency (df) and the power at that frequency (freq), you can build a
graph to visually represent the power spectrum while the data is being acquired.

22. Wire the Outputs of the Get Waveform Components VI into the respective MathScript
Node inputs (left side of the MathScript Node), as shown in Figure 41.

23. To build the graph, you will need to bundle the values into a cluster (a cluster is a way to
group elements of differing data types, which is out of the scope of this lesson, but is
thoroughly covered in the on-demand training). Right click on the Block Diagram and
select Programming»Cluster, Class & Variant»Bundle, like in Figure 42.

ni.com/daq 160



<1 Functions g Search[i

Programming 4

]
&

=
o®

Sfrudures Array Cluster, Clas...

| 44 Cluster, Class, & Variant

1 1 1 e o) =
% D) ) i et M= E'
Numeric Boolean .Stling Unbundle By... BundleBy N..  Unbundle Bundle
[ » [ » e =
B O k B= oL

Comparison Timing Dialog & Use... Build Cluster... Index & Bun... Cluster To Ar... Array To Clu...

=4

File /O .| Cluster Cons...
r %o @ ~ EST
m‘ B *

Synéhranizatﬂ. Grahhi:s & The R,epbrt Gener... Call Parent... ToMore Spe.. To More Gen... Preserve Run...
Measurement /O | % 4
o B O
Instrument [/O

LV Object Co... GetLV Class.. GetLV Class.. Variant

Vision and Motion

Mathematics

Signal Processing

Data Communication
Connectivity

Control Design & Simulation
SignalExpress

Express

Addons

Favorites

* ¥ ¥ ¥ ¥ ¥ ¥ w ¥ ¥

User Libraries
Select a VI...

Sound and Vibration L4

Figure 42. Use the Bundle function to combine the elements you need to create the graph.

24. Place this function in the location shown in Figure 43.
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y % Calculate power spectrum i
| fftm = fit(Y):
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Figure 43. Place the Bundle Function in between the MathScript Node and the PS MS graph
input.

25. To add another input, hover over the Bundle Function, then click and drag the handle

that appears.
PS M5

£ b

]

Figure 44. Drag the input down to add another input.

26. Add a zero constant to the block diagram by right clicking on the block diagram,
selecting Programming»Numeric»DBL Numeric Constant and place it in the same

position as figure 46.
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Figure 45. The DBL Numeric Constant is simply a numeric constant that you can use on the
block diagram without requiring any input from the front panel.

27. Wire the Bundle Function as seen in Figure 46.

1 % Calculate data paramneters
2 n = lengthi(¥);

3 df=1/{dt"n};

4 % Calculate power spectrum
5

6

7

PS5 M5

T

fftrn = F&m_
freq =real( (2/(n"2)) (fftm).* conj(fftrm)];
freq=freq(l,1:(n/2]);

Figure 46. The Bundle Function combines functions that are different data types.

28. Switch to the Front Panel and run the VI.
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29. Try switching between the LabVIEW calculated frequency domain and the MathScript
calculated frequency domain by clicking between the tabs.

LebVIEW PS | MathScript PS |

6E-8-

|

[ LabviEw ps | MathScript PS |

BE-B-
5.5E-8-
5E-8+
4.5E-8-

1
0 5110 |
Frequency (Hz)

Figure 47. Both the MathScript and LabVIEW code calculate and display the exact same
frequency domain.

What you have just seen is the integration of external, text-based code into the graphical
LabVIEW environment. With these tools, you can choose the most effective approach to
attacking a problem, whether text based or graphical, all in the same LabVIEW environment.

30. Stop the VI and save. Keep this VI open for the next exercise.

Part D Alarming Based on Vibration
Estimated time. 20 minutes

Accelerometer measurements can be used for applications like structural test, noise vibration
harshness testing or machine health diagnosis. For the last part of this exercise, you will
measure the magnitude of the vibration and alert a user/operator when that threshold is
exceeded. For more detailed information on machine health and asset monitoring, check out
ni.com/mecm.

1. To begin this part of the exercise, navigate to the block diagram of
Vibration_main_exercise.vi.

2. For this exercise, you will simply be extracting the fundamental frequency and testing
against a limit determined by the user. To extract this tone, right-click on the block
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diagram and navigate to Signal Processing»Waveform Measurements»Extract Tone as
shown in Figure 48.
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Figure 48. Select Extract Tone to measure the amplitude of the highest powered tone in the
frequency domain.

3. Place the VI in the location shown in Figure 49 and wire the inputs and outputs as
shown. If you need help figuring out the different inputs, remember that Ctrl+h will
show the Context Help to provide you with a reminder.
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Fan Speed
[DBL K

7 ]

Analog DBL _
1Chan 1Samp

1 % Calculate data parameters

2 n = length(Y);

3 df=1/(dt™n); PSMS
4 % Calculate power spectrum !
5

6

7

fftm = fft(V):
Y freq =real( (2/(n"2))*(fftm)."conj(fftm));
it dt freq=freq(l,1:(n/2));

PS LsbVIEW

Detected Tone
—{¥DBL]|

Detected Amplitude

POBL ] Fan Warning
- Max Vib Level

Time Domain

[DEL K

- ]

Analog Wfm

m 1Chan NSamp Stop BUHOI"I- Eﬁ
S—

]
Figure 49. Wire the time domain waveform to the Extract Tone VI to pull the frequency and
amplitude of the highest power tone.

4. Switch to the front panel.

5. If you run the VI, you should see the detected tone and amplitude on the front panel
indicators.

6. Stop the VI.

With the tone and frequency information being calculated, all that is left is to add in a
comparison and alarming.

7. Place a Greater? function from the Comparison Palette (Figure 50) in the location show
in Figure 51.
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Figure 50. The Greater? function will compare two numbers and output a Boolean True if the
top number is greater than the

8. Wire the Greater? function as seen in Figure 51.
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Fan Speed
[DBL K~

2

Analog DBL
1Chan 15amp

1 % Calculate data parameters

2 n = length(Y);

3 df=1/(dt*n); PS5 MS
4 % Calculate power spectrum L
5

6

7

fftm = fft(V):
Y freq =real( (2/(n*2))*(fftm).*conj(fftm));
I dt freq=freq(l,1:(n/2));

PS LabVIEW

Detected Tone
r—{20BL]|

g' Detected Amplitude
POBL ] Fan Warning

Time Domain - Max Vib Level
[oBL K-

=

Analog Wfm

[i] |1Chan NSamp Stop Button [(TEX EEE
S

Figure 51. The Greater? comparison compares the amplitude of the largest power tone with a
user specified value.

9. Open the Front Panel and run the VI. Make sure that the switch on the Sound and
Vibration Signal Simulator is set to Unbalanced Fan.

10. Change the speed of the fan by adjusting the knob on the front panel. Notice that at
higher speeds, the Fan Warning will show that there is an issue with the fan.

11. If you cannot get the fan alarm to light, try reducing the Max Vib Level input (shown in
Figure 52).
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Figure 52. This VI should behave just like the solution you opened at the beginning of the
exercise.

12. Stop the VI and save.

<End of Exercise>
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Using Tablets with Measurement Systems
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Goals ¢ In the first part of this exercise, you will write a program to control the speed of a fan
and acquire data from accelerometers attached to the fan.

e For the second part, you will use a tablet to remotely display and control the
measurement system.

e Key concepts include —

Accelerometer measurements

Using the NI DAQ Assistant

Data communication

Combining measurement and control tasks
Integrating tablets for visualization and control

©O O 0O o0 O

Part A Measuring Vibration From an Accelerometer and Alarming on Limits
Estimated time: 20 minutes

In this exercise, you will measure the vibration of a fan using the accelerometers on the Sound
and Vibration Signal Simulator. The NI 9234 features four simultaneously sampled channels and
can measure signals from both IEPE and non-IEPE accelerometers and microphones.

1. If it is not already open, select Start » All Programs » National Instruments » LabVIEW
<Year> to open LabVIEW.

2. From the Getting Started window, select the Create Project button or use the menu to
select File » Create Project.

3. From the Create Project dialog, select Blank Project and choose Finish to create a new,
blank project. You should see the following window:

43 Untitled Project 1 - Project Explorer lilﬂléj

File Edit View Project Operate Tools Window He

|hee s RO X BRI &

Items | Files |

= ng, Project: Untitled Project 1
= B My Computer
H =] T
¢ 5 Dependencies
i % Build Specifications

Figure 1. ULse the LabVIEW Project to organize éII your Vls.

With the LabVIEW Project you can easily organize and visualize all the files that are important to
your application including VIs, documentation, support files, and deployment targets.
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4. Within the Project Explorer window, select File » New VI.

5. Within the Front Panel window, right-click anywhere in the blank space to access the
Controls Palette.

6. Within the Controls Palette, select Silver » Graph » Waveform Graph.

<] Controls q Search {
’

Sihver

0o
(=)
v
L
a
=4
A
-

W = [
Bl \EI i i 431 Graph
MArray, Matrix... List, Table & ... Graph Waveform Graph (Silver)

» » F e

= =

- H s
Ring & Enum o Waveform C... Waveform G... XY Graph (Sil...
System P4 i 43 o 4, *iin A
Classic Intensity Cha... Intensity Gra.. Mixed Signal... Digital Wave...
Express
Control Design & Simulation
JNET & ActiveX

Signal Processing
Addons

User Contrels

- v v v v ¥

Select a Control...

Figure 2. The Controls Palette contains all of the control and indicator elements used to
populate a VI's user interface.

7. Leftclick to place the Waveform Graph near the top of your Front Panel.

8. Using your mouse cursor, hover over the Waveform Graph until the resizing handles
appear.

9. Click-and-drag a resizing handle to expand the horizontal size of the Waveform Graph.

=
¥
g o
L ] . . s =
10-, {
o 0 @ &0 L] 100
Time
T N it T SN Y e R S N ¥ e W

Figure 3. Use the resizing handles to customize the size of the Waveform Graph.

10. Right-click anywhere on the Waveform Graph and use the context menu to deselect the
Y Scale » AutoScale Y option.

11. Double-click on the maximum value of the Y-Axis (+10 by default) and use the keyboard
to change the value t0 0.1.
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12. Double-click on the minimum value of the Y-Axis (-10 by default) and use the keyboard
to change the value to -0.1.

3 Untitled 1 Front Panel on Untitled Project 1/My Computer *

File Edit View Project Operate Tools Window Help i

OE | 15pt Application Font |+ H e ”TDT:v HQ- |

| | | |
0 35 40 45 e

SRR

Figure 4. Re-scale the Y-Axis to better fit the signal that will be acquired.

Waveform-Graph

Amplitude

13. Within the Front Panel window, right-click anywhere in the blank space to access the
Controls Palette and select Silver » Boolean » Stop Button.

14. Left-click to place the Stop Button below the Waveform Graph.

15. Within the Front Panel window, right-click anywhere in the blank space to access the
Controls Palette and select Silver » Numeric » Numeric Indicator.

16. Left-click to place the Numeric Indicator below the Waveform Graph.

17. Double-click the label of the Numeric Indicator and use the keyboard to rename the
indicator RMS Value. The Front Panel should look something like the following image:

I3 Untitled 1 Front Panel on Untitled Project 1/My Computer * SRRER X
File Edit View Project Operate Tools Window Help
OE | 15pt Application Font |~ H N ”-7];' Hg' | +| Search 4 W‘%

[ pato [~ |

Waveform Graph
0.1+

0,05

04

Amplitude

-0.05-

01- | | ' ! ' | | | | ' ' ' i ' ' ! ! | | ]
0 5 10 15 20 25 30 35 40 45 50 55 60 65 0 75 80 85 90 95 100
Time

RMS Value Stop Button

] (]

[Ontitled Project 1/My Computer] < o 3
Figure b. The completed LabVIEW Front Panel with all user interface elements.

18. Switch from the Front Panel to the Block Diagram window using your mouse or by
pressing the keyboard shortcut <Ctrl + E>.
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19. Within the Block Diagram window, right-click anywhere in the blank space to access the
Functions Palette and select Programming » Structures » While Loop.
20. Left-click-and-drag a rectangle around (and encompassing) all three Block Diagram

terminals and then release the mouse button in order to place the While Loop.

{3 untitled 1 Black Diagram on Untitled Project 1/My Computer *

= | B |,
File Edit View Project Operate Tools Window Help ‘@
[>[@] & (][9] 2]l > [T5pt Appication Fon |~ | S | v [~ o o oy

Step Button

A
Figure 6. Draw a While Loop that encompasses all three Block Diagram terminals.

21. Left-click-and-drag the Stop Button terminal near the While Loop Stop Condition
terminal.

22. Using the mouse, hover the cursor over the output of the Stop Button terminal.

23. Left-click on the output of the Stop Button terminal. Left-click again on the input of the
While Loop Stop Condition terminal.

This will wire the terminals together so that the While Loop will stop executing when the user
presses the Stop Button on the Front Panel.

RMS Value
L3

Stop Button
-------- @

Figure 7. Wire the Stop Button to the While Loop Stop Condition terminal.

24. Within the Block Diagram window, right-click anywhere in the blank space to access the
Functions Palette and select Measurement 1/O » NI-DAQmx » DAQ Assistant.

25. Left-click to place the DAQ Assistant inside and near the left-edge of the While Loop.
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26. When the Create New... dialog appears, select Acquire Signals » Analog Input »
Acceleration.

27. Select the ai1 physical channel of the Sound_Vibration (NI 9234) module and select
Finish.

This channel is physically wired to the Y Acceleration of the accelerometer mounted within the
NI Sound and Vibration Signal Simulator.

28. Within the DAQ Assistant configuration dialog, change the Sensitivity to 175.

29. Within the DAQ Assistant configuration dialog, change the Acquisition Mode to
Continuous Samples.

30. Within the DAQ Assistant configuration dialog, change the Samples to Read to 1k.

31. Within the DAQ Assistant configuration dialog, change the Rate (Hz) to 10k.

Canfiguration | Triggering | Advanced Timing | Logging |

Detais * | Acceleration Setup

" Settings | W Device | ﬁkCaIibration |

nal Input Ranges
Maix 5 ——
g [=]
Min 5
o .
Sensitivity ¥ Source Iex Value (A)
175 Internal [ m
™N Sensitivity Unifs~ Terminal Configuration
Click the Add Ch & button mVoltsfa EI Pseudodifferential El
(#) to add more channeis fo dB Reference Custom Scaling
the task. 1 <Mo Scale > E| /®

Timing Setting

Acquisition Mode
Continuous Samples

Samples to Read

Figure 8. Customize the timing and sensitivity properties of the acquisition.

32. Select the OK button to close the dialog.

33. Using the mouse, left-click the Data output of the DAQ Assistant. Left-click again on the
input of the Waveform Graph in order to wire the acquired data to the graph.

34. Right-click on the Block Diagram to access the Functions Palette and select Express »
Signal Analysis » Amplitude & Level Measurements.

35. Left-click to place the Express VI to the right of the DAQ Assistant in the While Loop.
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36. Within the Configure Amplitude and Level Measurements configuration dialog, check
the box for RMS Amplitude Measurements.

EE Configure Amplitude and Level Measurements [Amplitude and Level Measurements] LJ
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Time
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Figure 9. Add an RMS Amplitude calculation.

37. Select the OK button to close the dialog.

38. Using the mouse, left-click the Data output of the DAQ Assistant. Left-click again on the
Signals input of the Amplitude and Level Measurements Express VI in order to wire the
acquired data to the analysis calculation.

39. Using the mouse, left-click the RMS output of the Amplitude and Level Measurements
Express VI. Left-click again on the input of the RMS Value indicator terminal in order to
wire the calculated RMS value to the Front Panel indicator.

40. At this point, the Block Diagram should look something like the following image:

3 Untitled 1 Block Diagram on Untitled Project 1/My Computer * = | B [t
File Edit View Project Operate Tools Window Help ‘m
[ ][G][5][wale 2 |[156t Aplication Font |~ |- |[fa~ | [5B~ [ *| search 4, 2=
Waveform Graph
Amplitude and
v il Level

DAQ Assistant | | Measurements

data Signals RMS Value =
- RMS [(E———
Stop Button
|

Untitled Project 1/My Computer ¢ i v

Figure 10. The Block Diagram for basic accelerometer acquisition and RMS analysis.

41. Right-click on the Block Diagram to access the Functions Palette and select
Measurement I/O » NI-DAQmx » DAQ Assistant.
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42. Left-click to place the DAQ Assistant2 to the right of the Amplitude and Level
Measurements Express VI in the While Loop.

43. When the Create New... dialog appears, select Generate Signals » Digital Output » Line
Output.

44. Select the port0/line7 physical channel of the Digital_out (Nl 9472) module and select
Finish.

This channel is physically wired to the red LED marked LED7 on the NI CompactDAQ
Measurements Demo Box.

45. Within the DAQ Assistant configuration window, leave everything default and select OK.

46. Right-click on the Block Diagram to access the Functions Palette and select
Programming » Comparison » Greater?.

47. Left-click to place the Greater? Function to the left of the DAQ Assistant2 Express V.

48. Left-click the RMS output of the Amplitude and Level Measurements Express VI. Left-
click again on the X input of the Greater? function in order to wire the calculated RMS
value to the comparison calculation.

49. Right-click on the Y input of the Greater? function and select Create » Constant from the
context menu.

50. Using the keyboard, change the value of the numeric constant to 0.015.

51. Left-click the X > Y? output of the Greater? function. Left-click again on the Data input
of the DAQ Assistant2 Express VI in order to wire the Boolean result of the comparison
operation to the digital output.

{3 Untitled 1 Block Diagram on Untitled Project 1/My Computer * = | B |t
File Edit View Project Operate Tools Window Help
B3] 5 el [t o - o T | Tl ETa— )
5
:
4 i
DAQ Assistant2
data
Stop Button
o
Untitled Project 1/My Computer « i

Figure 11. If the RMS Value is greater than 0.015, a True value will be digitally output.

52. Switch from the Block Diagram to the Front Panel window using your mouse or by
pressing the keyboard shortcut <Ctrl + E>.
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53. On the NI CompactDAQ Measurements Demo Box hardware, ensure that the Fan
Speed Control switch on the Sound and Vibration Signal Simulator is set to Dial.

54. On the NI CompactDAQ Measurements Demo Box hardware, ensure that the Fan
Selection switch is set to Unbalanced Fan.

55. Select the Run Arrow () to test the VI's functionality. While the VI is running, adjust
the fan speed using the Sound and Vibration Signal Simulator fan speed control dial.

When the fan rotates at low speeds, notice how the detected Y Acceleration signal exhibits no
noticeable pattern, and the signal is mostly lost in noise. When the fan rotates at high speeds,
the amplitude of the acceleration should rise along with the calculated RMS Value, and the Y
Acceleration signal should resemble a “noisy” sinusoidal wave. Additionally, the hardware
LED7 should indicate a high level of measured vibration.

In reality, the “noisy” signal being detected is comprised of two sine waves — one representing
the revolution of the fan, and one representing the five blades of the fan.
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Figure 12. The Y Acceleration is clearly sinusoidal when rotating at maximum RPM.

56. Select the Stop button on the Front Panel to stop execution of the VI.
57. From the Front Panel window, select File » Save All.

58. When prompted to provide a name for the project, use the Windows Explorer dialog to
create a new subdirectory called 8 - Tablets located within the directory C:\Seminars\LV

HO\Exercises.

59. Save the project as Tablets.lvproj within the C:\Seminars\LV HO\Exercises\8 - Tablets
directory.
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60. When prompted to provide a name for the VI, save the VI as Tablets.vi within the
C:\Seminars\LV HO\Exercises\8 - Tablets directory. Keep the VI open — you will need it
for the next part of the exercise.

Part B Integrating Mobile Visualization with Tablets
Estimated time. 20 minutes

In this exercise, yvou will integrate a tablet for visualization of the Y Acceleration data and Alarm
LED. Though this exercise is written using imagery taken from an iPad, functionality will be the
same with an Android tablet. However, the applications will look visually different due to
differences in the native controls and themes between iOS and Android operating systems.

This exercise assumes that your tablet is already operating the Data Dashboard for LabVIEW
app, version 2.2 or later. If it is not already installed, download it for free from the iOS App
Store or from Google Play.

1. To begin this section of the exercise, ensure that the Tablets.lvproj project is still open
from the previous section. If it is not, locate and open it from disk at C:\Seminars\LV
HO\Exercises\8 — Tablets.

2. Using the mouse, switch to the Project Explorer window of Tablets.lvproj.

3. Right-click on the My Computer entry within the Tablets project hierarchy tree and select
New » Variable from the context menu.

3 Tabletslvproj - Project Explorer [E=REn =
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Figure 13. Add a new Variable to the Tablets project.
4. In the Shared Variable Properties dialog, enter Fan Vibration in the Name field.
5. Change the Data Type to Array of Double.

6. Select the OK button to close the Shared Variable Properties dialog, which will add the
Fan Vibration shared variable to the project.
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Figure 14. The Fan Vibration variable will send vibration data over the network.

7. Right-click on the Untitled Library entry within the Tablets project hierarchy tree and
select New » Variable from the context menu.

8. In the Shared Variable Properties dialog, enter Alert in the Name field.
9. Change the Data Type to Boolean.

10. Select the OK button to close the Shared Variable Properties dialog, which will add the
Alert shared variable to the project.

11. Right-click on the Untitled Library entry within the Tablets project hierarchy tree and
select New » Variable from the context menu.

12. In the Shared Variable Properties dialog, enter Fan Speed in the Name field.
13. Change the Data Type to Double.

14. Select the OK button to close the Shared Variable Properties dialog, which will add the
Fan Speed variable to the project. The project should now contain the following:

) ~
Tablets.vproj * - Project Explorer EIE—J

File Edit View Project Operate Teols Window H
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ltems | Files |
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el My Cornputer
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=] L; Untitled Library
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!a Fan Speed
: - ®4 Fan Vibration
%' Dependencies
‘fﬁ; Build Specifications

Figure 15. The Tablets project now contains three shared variables.

15. Using the mouse, switch from the Project Window to the Block Diagram of Tablets.vi. If
it is no longer open, double-click Tablets.vi in the Project Window to open the VI and
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toggle between the Front Panel and Block Diagram windows by pressing the keyboard
shortcut <Ctrl + E>.

16. Arrange the LabVIEW Project Explorer and Block Diagram windows so that you can see
both windows on the screen at the same time.

17. Within the Project Explorer window of the Tablets project, left-click-and-drag the Alert
variable and drop it on the Block Diagram underneath the DAQ Assistant2 within the

While Loop.
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Figure 16. Drag and drop the Alert variable onto the Block Diagram.

18. After placing the terminal, right-click on the Alert shared variable terminal on the Block
Diagram and select Access Mode » Write from the context menu.
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Figure 17. Changing the Access Mode to Write allows you to send data to the shared variable
through the network.

ni.com/daq

181



19. Left-click the X>Y? output of the Greater? function. Left-click again on the input of the
Alert shared variable terminal to wire the Boolean result of the Greater? function to the
shared variable in order to communicate the data over the network.

20. Within the Project Explorer window of the Tablets project, left-click-and-drag the Fan
Vibration variable and drop it on the Block Diagram underneath the Amplitude and Level
Measurements Express VI within the While Loop.

21. After placing the terminal, right-click on the Fan Vibration shared variable terminal on the
Block Diagram and select Access Mode » Write from the context menu.

22. Left-click the Data output of the DAQ Assistant. Left-click again on the input of the Fan
Vibration shared variable terminal to wire the acquired vibration data to the shared
variable in order to communicate the data over the network.

23. At this point, the Block Diagram should look something like the following:
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Figure 18. In addition to acquiring vibration data and alerting after a threshold is exceeded,
pertinent data is being published over the network.

24. Within either the Block Diagram or Project Explorer windows, select File » Save All.

25. When prompted to provide a name for the Variable Library, save the library as Fan
Variables.Ivlib within the C:\Seminars\LV HO\Exercises\8 - Tablets directory.

26. Using your laptop’s network settings functionality, ensure that you are connected to this
seminar’s ad-hoc WiFi network. If you are unsure how to complete this step, please
alert your instructor.

27. Using the iPad or Android tablet device's settings functionality, ensure that you are
connected to this seminar’s ad-hoc WiFi network. If you are unsure how to complete
this step, please alert your instructor.

If no ad-hoc network is available, ensure both devices connect to the same VWiFi network.
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28. On the iPad or Android tablet device, open the Data Dashboard for LabVIEW app.

29. From the Dashboards Overview screen, select the Add () button and choose New
Dashboard. When prompted, select the Landscape layout.

Dashboards (6 of 6)

DASHBOARDS EXCHANGE DATA WITH APPLICATIONS
¥YOU DEPLOY AS LABVIEW WEB SERVICES.

POpR— T —
New Dashboard
Duplicate Dashboard
= fﬁu 12§

Figure 19. With the Data Dashboard for LabVIEW app, you can create, manage and share
multiple Dashboards at one time.

30. From the menu bar in the upper-right corner of the new Untitled 1 Dashboard, select the

Controls and Indicators (g) button to add a new display element to the Dashboard.
31. From the Controls and Indicators dialog, select Indicators.

32. From the Indicators dialog, drag-and-drop a Graph onto the top left portion of the blank
Dashboard canvas.

[ oo R | | Untitied 1 @ &) »
-
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Figure 20. With the Data Dashboard for LabVIEW app, you can create your own custom layouts
for data visualization.

33. Using the resizing handles on the Graph Indicator, drag to expand the size of the
Waveform Graph to occupy approximately the top half of the Dashboard canvas.
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34. Using your finger, tap once to select the Graph Indicator.

35. Select the Properties (ﬁ!) button and choose Graph Axes.
36. Change the Y Scale » Y Minimum to -0.1 and the Y Scale » Y Maximum to 0.1.
37. Change the Y Scale » Y Autoscale toggle switch to the Off position.

38. From the menu bar in the upper-right corner of the Untitled 1 Dashboard, select the

. [ .
Controls and Indicators (24) button to add a new display element to the Dashboard.
39. From the Controls and Indicators dialog, select Indicators.

40. From the Indicators dialog, drag-and-drop an LED onto the bottom left portion of the
Dashboard canvas.

41. Using the resizing handles on the LED Indicator, drag to expand the size of the LED.

[P > aaem o
=2 Untitled 1 Zabal»

trots and Indicators  Indicators

Figure 21. Add and resize an LED Indicator to the bottom-left portion of the canvas.

42. From the menu bar in the upper-right corner of the Untitled 1 Dashboard, select the
Image (B3) button to add a new picture element to the Dashboard.

43. From the Photo dialog, select Take Photo.
44. Using the tablet’s camera, take a photo of the physical hardware setup.

45. From the Preview dialog, select Retake if you're unsatisfied with your photo. When
you're satisfied, select Use.

46. Using the resizing handles on the new photo element, drag to contract the size of the
photo.
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47. Drag the photo element to rearrange it on the Dashboard canvas so that it occupies the
lower-right corner of the Dashboard.

48. At this point, your Dashboard should look something like the following image:

paa > wew o
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Figure 22. Including a photo of a physical hardware setup is a nice way to remember how
things have been wired when you're using a tablet to remotely monitor a system.

49. Using your finger, tap once to select the Graph Indicator.

50. Select the Data Link Adorner (#*) that appears immediately below the Graph Indicator.

51. From the Connect dialog, select Shared Variables.

52. On the computer, use the mouse to select the LabVIEW Project Explorer window for

the Tablets project.

53. Right-click on the Fan Variables.Ivlib shared variable library and select Deploy All from

the context menu.
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Figure 23. Deploying the library publishes the shared variables for access on the network.

54. When the Deployment Progress dialog appears, allow the shared variable library to fully
deploy.

55. Within the Deployment Progress dialog, take note of the IP Address listed. This is the
IP address of the computer you are working on, which will serve as the host for the
shared variables. Note: the IP address will differ from that shown in Figure 24.

IS ™
i3 Deployment Progress EIEIQ

Deployment Status

5] R e e

Preparing items for downlead. This eperation could take a while... i
Deploying My Computer
Deploying Fan Variables.lvlib 3
Deploying Fan Variables.Ivlibflert\\10.0.146 184\Fan Variables\Blert deployed. H

Deploying Fan Variables.lvlip:Fan Speed\\10.0.146.184\Fan Variables\Fan Speed |
deployed. 3
Deploying Fan Variables.lvlib®
Vibration deployed.

Deployment completed successfully

an Vibration\110.0.146.184\Fan Ydriables\Fan

Deployment Progress

[C] Close on successful completion o G

Figure 24. Your computer ié represented by the IP address listed iﬁ the Deployment Progress
dialog, and will serve as the host of the shared variables on the network.

If the Deployment Progress dialog is displayed but quickly disappears, it is possible that the
“Close on Successful Completion” checkbox is selected. If that is the case, determine your

computer’s IP address by typing the command ipconfig within the Windows Command Prompt
located at Start » All Programs » Command Prompt.

56. On the tablet device, type the IP address of your computer into the New Server field
within the Shared Variables dialog.

57. Select the Connect button to connect to the shared variable host on the server.

&3 Shared Variables

Current Connection

New Sew;r\

Not Connected

10.0.146.184

110.0.146.227
110.0.146.216

\110.0.146.200

Figure 25. Ensure that you type in the IP address of your computer exactly as it appeared in the
Deployment Progress dialog in LabVIEW.
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58. When the Data Dashboard for LabVIEW app successfully connects to the shared
variable host on your computer, select the Fan Variables shared variable library.

59. Within the Fan Variables shared variable library, select the Fan Vibration variable.

The app automatically filters available variables within the library to show only the variables
whose data types match the control or indicator element you are attempting to link with a
source of data. Even though there are three variables deployed in your Fan Variables shared
variable library, only the Fan Vibration variable — an Array of Numeric data type — can be
displayed on a Graph Indicator.

60. The Shared Variables dialog will close and the Data Link Adorner of the Graph Indicator
will be green in color, indicating a successful link with a source of data, as show in
Figure 26.

ﬁ ? r. Untitled 1 _ﬂ.. ‘i Q »

NS

Figure 26. Once a display element is successfully linked with a data source, its Data Link
Adorner will become green in color.

61. Using your finger, tap once to select the LED Indicator.
62. Select the Data Link Adorner (W) that appears immediately below the LED Indicator.
63. From the Connect dialog, select Shared Variables.

64. From the Shared Variables dialog, select the IP address of your computer.

65. When the Data Dashboard for LabVIEW app successfully connects to the shared
variable host on your computer, select the Fan Variables shared variable library.

66. Within the Fan Variables shared variable library, select the Alert variable.

67. Select the Run Dashboard button (®) to start the Dashboard.
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68. Notice that no data is being displayed — the Tablets application is not currently running.

69. On the computer, open the Tablets.vi application and select the Run Arrow () to test
the VI's functionality. When the Deploy Progress dialog appears, select Close.

70. Notice that while the application is running, data successfully appears on the tablet.

71. While the VI is running, adjust the fan speed using the Sound and Vibration Signal
Simulator hardware’s fan speed control dial.

72. Notice that while the fan is oscillating at low speeds, the Alert LED is off. When the fan
is oscillating at high speeds, the calculated RMS Value exceeds the set threshold (0.015)
and turns the Alert LED on, as shown in Figure 27.

Figure 27. When the fan is oscillating at a high RPM, the signal exhibits a noticeable pattern
and the Alert LED is turned on.

73. Press the Stop (©) button to stop the running Dashboard.

74. On the computer, use the mouse to select the Stop button on the Front Panel to stop
execution of the VI.

75. From the Front Panel window, select File » Save All. Leave the LabVIEW VI and Data
Dashboard for LabVIEW app open — you will need both for the next part of the exercise.

The Data Dashboard for LabVIEW app features several additional opportunities for
customization. If you'd like to explore the app, feel free to try customizing things like the
Dashboard layout and appearance or Indicator properties and themes.
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Part C Using a Tablet to Remotely Control a Measurement System
Estimated time. 10 minutes

In this exercise, you will augment your application to use the tablet device for remote control of
the data acquisition system. Though this exercise is written using imagery taken from an iPad,
functionality will be the same with an Android tablet. However, the applications will look
visually different due to differences in the native controls and themes between 10S and Android
operating systems.

This exercise assumes that your tablet is already operating the Data Dashboard for LabVIEW
app, version 2.2 or later. If it is not already installed, download it for free from the iOS App
Store or from Google Flay.

1. To begin this section of the exercise, ensure that the Tablets.lvproj project is still open
from the previous section. If it is not, locate and open it from disk at C:\Seminars\LV
HO\Exercises\8 — Tablets.

2. Using the mouse, switch to the Project Explorer window of Tablets.lvproj.

3. Arrange the LabVIEW Project Explorer and Block Diagram windows so that you can see
both windows on the screen at the same time.

4. Within the Project Explorer window of the Tablets project, left-click-and-drag the Fan
Speed variable and drop it on the Block Diagram in the upper-right hand corner within
the While Loop.

13 TabletsIvproj - Project Explorer o =[S | (3 Tabletsvi Block Diagram on TabletsIvpraj/y Computer = | B |
File Edit View Project Operate Tools Window H{ || [File Edit View Project Operste Teols Window Help
= . - = ]
[heal%hox]sR ¢ 1] e VA1 e [Erhrmmiontor T o [ |+ [l AT ]
Items | Files
£ & Project: Tablets.lvproj
Z B My Computer Waveform Graph
ariabl
C 3 s
b i P - |
b ) Level :
DAQ Assistant Measurements Y
data Signals RMS Value [/
= RMS [ a—— v )
— i DAQ Assistant2

- - op Button
M

Tablets.lvproj/My Computer i

Figure 28. Drag and drop the Alert variable onto the Block Diagram.

5. Right-click on the Block Diagram to access the Functions Palette and select
Measurement I/O » NI-DAQmx » DAQ Assistant.

6. Left-click to place the DAQ Assistant3 in the upper-right hand corner within the While
Loop, to the right of the Fan Speed shared variable terminal.

7. When the Create New... dialog appears, select Generate Signals » Analog Output »
Voltage.
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8. Select the ao1 physical channel of the Voltage_out (NI 9263) module and select Finish.

This channel is physically wired to the fan speed control BNC of the NI Sound and Vibration
Signal Simulator hardware within the NI CompactDAQ Measurements Demo Box.

9. Within the DAQ Assistant configuration window, change the Timing Settings Generation
Mode to 1 Sample (On Demand) and select OK to dismiss the dialog.

10. Left-click the output of the Fan Speed shared variable terminal. Left-click again on the
input of the DAQ Assistant3 Express VI to wire the data from the shared variable to the
analog output in order to control the speed of the fan.

11. At this point, the completed Block Diagram should look something like the following:
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12. Within either the Block Diagram or Project Explorer windows, select File » Save All.
13. On the iPad or Android tablet device, switch to the Data Dashboard for LabVIEW app.

14. From the menu bar in the upper-right corner of the Untitled 1 Dashboard, select the
Controls and Indicators (_EI_) button to add a new display element to the Dashboard.

15. From the Controls and Indicators dialog, select Controls.

16. From the Controls dialog, drag-and-drop a Slider onto the bottom-left portion of the
Dashboard canvas.

17. Using the resizing handles on the Slider control, drag to expand the size of the Slider to
occupy the space in the bottom-left corner of the Dashboard canvas.

18. At this point, your Dashboard should look something like the following image:
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19.

20.

21.
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23.
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27.
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31.

32.
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Figure 30. Drag, drop, and resize a Slider control on the Dashboard.

Using your finger, tap once to select the Slider Control.

Select the Properties ({9‘) button.
Switch the Update While Dragging toggle switch to the On position.
Select Data Range.

Change the Maximum to 5.

Select the Data Link Adorner (W) that appears immediately below the Slider Control.
From the Connect dialog, select Shared Variables.
From the Shared Variables dialog, select the IP address of your computer.

When the Data Dashboard for LabVIEW app successfully connects to the shared
variable host on your computer, select the Fan Variables shared variable library.

Within the Fan Variables shared variable library, select the Fan Speed variable.
Select the Run Dashboard button (®) to start the Dashboard.

Notice that no data is being displayed — the Tablets application is not currently running.

On the computer, open the Tablets.vi application and select the Run Arrow () to test
the VI's functionality. When the Deploy Progress dialog appears, select Close.

Notice that while the application is running, data successfully appears on the tablet.
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33.

34.

35.

36.

37.

38.

While the VI is running, adjust the fan speed using the Sound and Vibration Signal
Simulator hardware’s fan speed control dial. Notice that the Dashboard still displays
data on the Graph Indicator and the LED Indicator.

On the NI CompactDAQ Measurements Demo Box hardware, ensure that the Fan
Speed Control switch on the Sound and Vibration Signal Simulator is set to BNC.

Using the Slider Control on the Data Dashboard, remotely adjust the speed of the fan.
Notice that the fan speed reacts accordingly.

Press the Stop () button to stop the running Dashboard.

On the computer, use the mouse to select the Stop button on the Front Panel to stop
execution of the VI.

From the Front Panel window, select File » Save All. Close the LabVIEW VI and the
Data Dashboard for LabVIEW application.

<End of Exercise>
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