
Measurement & Automation Explorer™, NI-VXI™, NI-VISA™, National Instruments™, and ni.com™ are trademarks of National Instruments Corporation. Product and company
names mentioned herein are trademarks or trade names of their respective companies.

370341A-01 © Copyright 2000 National Instruments Corp. All rights reserved. December 2000

Using Measurement &
Automation Explorer™ (MAX)
with VXI

Introduction
Measurement & Automation Explorer (MAX) provides access to all your
National Instruments DAQ, GPIB, IMAQ, IVI, Motion, VISA, and VXI
devices. With MAX, you can configure your National Instruments hardware
and software, add new channels, interfaces, and virtual instruments, execute
system diagnostics, and view the devices and instruments connected to your
system.

MAX installs automatically with NI-VISA version 2.5 or higher or NI-VXI
version 3.0 or higher. MAX is available only for Win32-based operating
systems.

In this course manual addendum, you will examine MAX and use it to
configure a VXI system.
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Exercise 1
Objective: To examine MAX.

1. Launch MAX by double-clicking on the desktop icon or selecting
Start»Programs»National Instruments»Measurement &
Automation.

2. After launching, MAX displays the dialog box shown below. You can
use this dialog to configure MAX to search for new devices each time
you launch it or only when you refresh (<F5> or View»Refresh).
Also, you can configure the dialog box to appear the next time you
launch MAX.

Do not change the settings and click on OK.

Figure 1. MAX User Preferences

Note You selected not to search for new devices when MAX launches, so MAX will not
show the updated system view if there are any changes to it. Remember to refresh after
making any changes. To change these preferences, you can access this dialog box by
selecting Tools»User Preferences....

MAX icon
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3. Expand the Devices and Interfaces folder by clicking on the plus (+)
sign next to it. Select VXI System 0 and expand it also. Expand
Frame 0. The MAX interface should appear as shown below.

Figure 2. The MAX Interface

Configuration Tree
The configuration tree shows a hierarchical view of the instruments in your
system. In the setup shown in Figure 2, MAX shows a VXI system with one
VXI chassis (Frame 0), a National Instruments VXIpc-870 embedded
controller, a Wavetek 1375 arbitrary waveform generator, and a National
Instruments MIO-64E-1 multifunction data acquisition board.

1 Configuration Tree 2 Configuration View 3 Task List

1 2 3
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The following MAX toolbar appears when you select the VXI system in the
Configuration Tree:

Properties—Displays properties of the selected VXI system.

Run VXI Resource Manager—Runs VXI Resource Manager (Resman)
for the selected VXI system.

Note Because NI-VXI 3.0 or higher supports multiple VXI systems, properties apply to
the currently selected VXI system. Resman also runs for only the selected VXI system.
To run Resman for all VXI systems, select Tools»NI-VXI»VXI Resource Manager.

System Properties
You can examine the properties for the selected VXI system by clicking on
the Properties button from the toolbar or right-clicking on the particular
VXI system and selecting Properties, as shown below.

Figure 3. System Properties for VXI System 0

In addition to viewing the properties, you can also launch Resman for
this VXI system, access the hardware configuration for the system
controller, and create a new VME device.
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4. Examine the VXI System 0 properties. Right-click on VXI System 0
and select Properties. The properties dialog box appears as shown
below.

Figure 4. Properties Dialog for VXI System 0

This dialog box reports the device status. If there is a problem with this
system, you can access online help by clicking on the Troubleshoot…
button. The properties dialog box also shows you the device type and
whether the device is enabled.
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5. Select the Settings tab, shown below.

Figure 5. VXI System 0 Settings

You can use this tab to change the VXI system number and Resman
delay for this specific VXI system. (In this exercise, do not change the
settings.)
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6. Select the Interrupt Levels tab, shown below.

Figure 6. VXI System 0 Interrupt Levels

You can use this tab to assign interrupts to specific controllers and set
the mapping for each interrupt level. (In this exercise, do not change the
settings.)

In the Assignment field, you can select four options from the pull-down
menu:

• Auto—Automatically assign to a programmable handler, usually the
local controller.

• Local—Assign the interrupt level to the local controller.

• Choose LA—Choose the Logical Address of the controller that will
handle this interrupt.

• None—Do not assign the interrupt level to any controller.

In the Mapping field, you can select three options for mapping the
interrupts:

• Auto—Auto mapping (maps toward root if root is the handler;
otherwise, does not map).

• Source—Map away from the root (source the interrupt).

• None—Do not map.
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7. Click on the Assist Me… button. The Interrupt Levels dialog box
appears, as shown below.

Figure 7. VXI System 0 Interrupt Assistant

If you are not sure how to set the interrupt assignments and mapping,
you can use this dialog box for detailed descriptions of all the settings
and to set the options separately for each interrupt. (In this exercise, do
not change the settings.)

8. Close the Interrupt Levels and VXI System 0 Properties dialog boxes.
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Configuration View

Figure 8. VXI Address Map View—System Resources Window

The configuration view (the center window) shows the registers/address
space requested by various devices in A16, A24, and A32 space. In this
particular setup, the two devices have registers in A16 and A24 address
space, and the system controller (VXIpc-870) has registers in A16 and
A32 address space.

9. Look carefully at the ranges being used in A16 address space by each
instrument. Recall the formula for the base of these 64 byte (0x40)
windows:

base address = 0xC000 + (logical address * 0x40)

Task List
The task list (the right window) includes an interactive task list to guide you
through VXI system configuration and other basic tasks.

10. Select various items in the configuration tree and review the information
in the task list. Notice that the task list contents change according to the
interface and device you select.
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Device Properties in MAX
11. Select the Wavetek 1375 in the configuration tree. Notice that MAX

displays the information about the device in the Attributes tab of the
configuration view. Here you can see that the Wavetek 1375 is at Logical
Address 1, the manufacturer ID is 4094, and the device resides in slot 2
in your VXI chassis. Also, this window shows the resources used by the
Wavetek 1375. The A16 space for this device contains the Configuration
Registers. The A24 space is scratch pad RAM for storing waveforms.

Figure 9. Right-Clicking on a Device to Examine Its Properties

12. You can examine properties of devices in the system by right-clicking
on a device and selecting Properties or highlighting the device and
clicking on the Properties button on the toolbar. Right-click on the
Wavetek 1375, as shown above. Review the properties information and
close the dialog box.
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Configuring Devices in MAX
You can configure some VXI devices (for example, all National Instruments
MITE-based controllers) through software. You can use MAX to configure
these devices.

13. Right-click on the VXIpc-870 controller in the Configuration Tree and
select Hardware Configuration. The dialog box shown below appears.

Figure 10. VXIpc-870 Hardware Configuration through MAX

General—Use this tab to load and save configurations from file. This is
useful when backing up your system.

Device—Use this tab to configure the MITE-based device logical
address and interrupt configuration.

Shared Memory—Use this tab to set up the shared memory. For more
details on shared memory, see the online help or visit the National
Instruments Web site to download the shared memory application note.

VXI Bus—Use this tab to configure how MITE-based controllers
interface to the VXI bus (timeout, etc.).

PCI—Use this tab to configure the MITE chip (which resides on the
PCI bus, hence the tab name).

Watchdog—Use this tab to enable the watchdog timer.

SMB—Use this tab to configure the front panel SMB connectors to
provide or source clocks and triggers.

14. Close the hardware configuration dialog box.
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Configuring MAX
15. You can customize MAX to meet your system needs. Select

Tools»NI-VXI»VXI Options to get the VXI options dialog box
shown below. Review the options and close the dialog box.

Figure 11. VXI Options
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16. To set the NI-VISA options, select Tools»NI-VISA»VISA Options.

Use this dialog box to tell the driver to run Resman on startup. You can
also set the VISA options shown below.

Review the options and close the dialog box.

Figure 12. VISA Options

Help in MAX
MAX brings online support to a new level. The MAX help files feature
common questions gathered from several years of technical support calls,
as well as helpful hints, references to application notes, and procedures for
setting up a large variety of systems. If MAX resides on a networked
computer, you have a Web link from MAX to the National Instruments
Technical Support home page and the NI-VISA and NI-VXI home pages.
You can access the following help resources through links in MAX.

Online Problem Solving and Diagnostic Resources
• KnowledgeBase—A searchable database containing thousands of

frequently asked questions (FAQs) and their corresponding answers or
solutions, including special sections devoted to our newest products.
The database is updated daily in response to new customer experiences
and feedback.

• Troubleshooting Wizards—Step-by-step guides lead you through
common problems and answer questions about our entire product line.
Wizards include screen shots that illustrate the steps being described and
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provide detailed information ranging from simple getting started
instructions to advanced topics.

• Product Manuals—A comprehensive, searchable library of the latest
editions of National Instruments hardware and software product
manuals.

• Hardware Reference Database—A searchable database containing brief
hardware descriptions, mechanical drawings, and helpful images of
jumper settings and connector pinouts.

• Application Notes—A library of more than 100 short papers addressing
specific topics such as creating and calling DLLs, developing your own
instrument driver software, and porting applications between platforms
and operating systems.

Software-Related Resources
• Instrument Driver Network—A library of hundreds of instrument drivers

for control of standalone instruments via GPIB, VXI, or serial
interfaces. You also can submit a request for a particular instrument
driver if it is not in the library.

• Example Programs Database—A database with numerous example
programs for National Instruments programming environments. You can
use them to complement the example programs already included with
National Instruments products.

• Software Library—A library with updates and patches to application
software, links to the latest versions of driver software for National
Instruments hardware products, and utility routines.

17. Examine some of the help resources available in MAX. Open
Help»HelpTopics»NI-VXI. Suppose you want to configure a
multimainframe VXI system. From the Contents tab, select How
Do I…?»Configuration»Configure a multiple-mainframe system.
You can resize this window and read about the issues involved with this
type of configuration. Notice the reference to an application note
available from the National Instruments Web site. You can easily
download this application note by returning to the MAX interface and
selecting Help»National Instruments on the Web»VXI Home Page
to launch your browser. On this page is a link to the Support Resources
page, where you can download application notes.

18. Close the MAX help.
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Software Information
19. Another helpful MAX feature is its ability to gather and display

information about your system for your reference. Expand the Software
folder in the configuration tree. Expand the NI-VISA icon and select
visa32.dll. The window should appear as shown below.

Figure 13. The MAX Software Information

In this window, you can view the versions of all pertinent National
Instruments drivers in your system. This information is very important
when troubleshooting a system.

End of Exercise 1
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Exercise 2
Objective: To add a fictitious VME device to your system.

It is often necessary to use a VME device in a VXI system. Because the
VME specification does not implement configuration registers, if you want
to use VME devices in your VXI system, you must tell the NI-VXI driver
what resources a particular VME device uses.

In a VXI system, Resman uses the VXI configuration registers to identify
each VXI device, its device class, model and manufacturer, and address
space requirements. Because VME devices do not have the standardized
VXI register set, you must manually enter the information (normally
encoded in this VXI-defined register set) for your VME device before
Resman can properly configure it. You can use MAX to add a VME device
to your system manually.

1. Launch MAX if it is not already running. Expand the Devices and
Interfaces folder in the configuration tree and right-click on VXI
System 0. From the pop-up menu, select Create new VME device….
The Create New… window appears as shown below.

Figure 14. Create New VME Device Window
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Because you can have multiple VXI systems in the same configuration,
there is a System Number pull-down menu. Because there is currently
only one VXI system, keep the VXI System 0 selection. Next, assign
this device a pseudo logical address between 255 and 512. (Select any
number in this range.) Finally, specify the frame and the slot within the
frame where this device resides. The only frame in your system is Frame
0, so keep this selection. Because this VME device does not really exist,
you may select any slot you want.

2. Click on the Next > button to continue. In the next window (shown
below), you can create a new VME profile.

Figure 15. Create a New Profile Window
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3. You can use the pull-down menu in this window to select previously
created VME profiles or create a new one. A profile describes the
manufacturer ID, model code, and resources that this VME device
requires. No VME profiles are created yet, so click on Next > to create
one.

Name your VME device My VME Device, as shown below.

Figure 16. Profile Name, Manufacturer ID, and Model Code

4. In the Manufacturer pull-down menu, select Act Tech as the
manufacturer for this fictitious device.
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5. Select the Model Name pull-down menu for a list of known VME
devices manufactured by Act Tech. This list is empty, so you need to add
this new device yourself. Click on the ... button next to the Model Name
pull-down menu. The dialog box shown below appears.

Figure 17. Adding a New Act Tech VME Device

6. Click on New… and fill in the parameters shown below. Click on OK.

Figure 18. The New VME Model From Act Tech

7. The new VME device appears in the Model Name Editor window. Click
on OK again to confirm the change and return to the Device Wizard.
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8. Select the device you just added in the Model Name menu. Your screen
should appear as shown below.

Figure 19. Device Wizard Showing New VME Model and Manufacturer

9. Click on the Next > button to add resources used by this device.
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10. Click on the Add… button and select Address Range»A24. In the
Setting column, you can enter the range of registers this device uses.
Type in the value 0x0 - 0x100000 and press <Enter>.

Figure 20. Requested Address Space for the New VME Device

11. Click on Next > and Finish to complete the process of adding a VME
device. Notice that in the MAX configuration tree, your VME device
has an exclamation point. This means you need to run Resman again to
reconfigure the system.
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12. Run Resman and notice that the VME device remains in the system and
the exclamation point disappears, as shown below. You can edit the
configuration parameters of this fictitious VME device through its
properties. You can access the Properties menu by right-clicking on the
VME device or selecting Tools»NI-VXI»VME Profiles. In the VME
Profiles window, you can manipulate the profiles you created. You can
remove them, add a new one, or change their properties.

Figure 21. MAX Showing VME Device in Configuration Tree

13. To remove the VME device, right-click on it and select Delete. The
device disappears, but its profile is still available for future use.

End of Exercise 2
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