
Getting Started with the 
LabVIEW  PDA Module
Version 8.0 

The LabVIEW PDA Module extends the LabVIEW graphical development 
environment to PDA devices so you can create PDA applications that run 
on Palm OS and Pocket PC devices, emulators, and simulators. Use the 
PDA Module to build applications that run in the smaller memory space 
common to PDA devices. You can create portable solutions for a wide 
spectrum of applications, such as field test systems, remote control and 
monitoring systems, and portable data acquisition systems.

This manual contains system requirements; installation instructions; new 
features for 8.0; and a tutorial that guides you through creating a LabVIEW 
project, adding a target and a PDA VI to the project, building, downloading, 
running, and debugging a PDA application.
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System Requirements
The PDA Module has the following requirements:

• A desktop computer with Windows 2000 with Service Pack 4 or later 
or Windows XP.

• LabVIEW 8.0 Full or Professional Edition.

• 2.5 GB available disk space.

• One of the following PDA devices:

– A Palm OS device with Palm OS 4.0 or later.

– A Pocket PC 2003 device. The PDA Module does not support 
Pocket PC 2002 devices.

• PDA synchronization software. For Palm OS devices, the PDA 
software is Palm Desktop and HotSync. For Pocket PC devices, the 
PDA software is ActiveSync.
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• (Pocket PC) Microsoft eMbedded Visual Tools—Refer to the 
National Instruments KnowledgeBase at ni.com/info and enter the 
info code pdaevc for the most recent information about downloading 
and installing the Microsoft eMbedded Visual Tools.

• To debug a PDA application on a Palm OS device, you must have 
a serial cable or serial cradle. To debug a PDA application on a 
Pocket PC 2003 device, the device must be connected to ActiveSync 
on the host computer.

Refer to the LabVIEW Release Notes, available by selecting Start»All 
Programs»National Instruments»LabVIEW 8.0»LabVIEW Manuals 
and opening LV_Release_Notes.pdf for standard LabVIEW 
development system requirements.

Installing the PDA Module
Complete the following steps to install the PDA Module.

1. On Windows 2000/XP, log in as an administrator or as a user with 
administrator privileges.

2. Install the PDA software provided with the PDA device, if it is not 
already installed, on the host computer. For Palm OS devices, the PDA 
software is Palm Desktop and HotSync, which is in a single installer. 
For Pocket PC 2003 devices, the PDA software is ActiveSync.

3. Install LabVIEW 8.0. Refer to the LabVIEW Release Notes, available 
by selecting Start»All Programs»National Instruments» 
LabVIEW 8.0»LabVIEW Manuals and opening 
LV_Release_Notes.pdf for standard LabVIEW installation 
instructions.

4. (Pocket PC 2003) Download and install the Microsoft eMbedded 
Visual Tools. Refer to the National Instruments KnowledgeBase at 
ni.com/info and enter the info code pdaevc for the most recent 
information about downloading and installing the Microsoft 
eMbedded Visual Tools.

5. Install the PDA Module software.

You must activate the PDA Module before you can build PDA VIs into 
PDA applications. The PDA Module runs in evaluation mode if you do 
not activate it, which means you can create PDA VIs, but you cannot 
build the PDA VIs into PDA applications. Use the NI License 
Manager, available by selecting Start»All Programs»National 
Instruments»NI License Manager, to activate National Instruments 
products. Refer to the National Instruments License Manager help, 
available by selecting Help»Contents in the NI License Manager, for 
more information about activating National Instruments products.
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6. Restart the computer when the installer completes.

7. Install the additional tools you need, which depend on the platform you 
are using and the functionality you need. Refer to the Installing the 
Additional Tools section for more information about the additional 
tools.

Installing the Additional Tools
You must install additional tools depending on which platform you are 
using and the functionality you need.

Pocket PC

WIDCOMM Bluetooth DLLs
You must install the WIDCOMM Bluetooth DLLs on the Pocket PC 2003 
device to build and run PDA applications that use Bluetooth 
communication.

Note The PDA Module supports the WIDCOMM BTW-CE 1.4 or later driver.

Complete the following steps to install the WIDCOMM Bluetooth DLLs.

1. Place the Pocket PC 2003 device in the cradle.

2. On the host computer, run LabVIEW 8.0\PDA\Utilities\ 
Bluetooth\setup.exe to install the DLLs on the Pocket PC 2003 
device.

You also can manually install the WIDCOMM Bluetooth DLLs by copying 
the following DLLs to the \Windows directory on the Pocket PC device:

• BtCoreIf.dll

• BtSdkCE30.dll

• LVBtw.dll

LabVIEW SMS Client
You must install and run the LabVIEW SMS Client, which is located in 
Labview 8.0\PDA\Utilities\SMS\Pocket PC\Setup.exe, on the 
host computer to receive Short Message Service (SMS) messages or to use 
the Request Make Call VI. The LabVIEW SMS Client notifies the PDA 
application if there is an incoming SMS message and stores the incoming 
message in LVSMSClient.dat, which is located in the \Program 
Files\National Instruments\labview\SMS directory on the 
Pocket PC target.
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Complete the following steps to install or uninstall the 
LabVIEW SMS Client on a Pocket PC target.

1. Perform a soft reset on the Pocket PC device. Refer to your Pocket PC 
device documentation for information about performing soft resets.

2. Connect the Pocket PC device to ActiveSync on the host computer.

3. Run Setup.exe on the host computer to install or uninstall the 
required DLLs.

Pocket PC Emulators
Emulators are useful tools you can use during development to quickly 
run and test PDA VIs without having to download the PDA application to 
the PDA device.

The Microsoft eMbedded Visual Tools you install in step 4 in the Installing 
the PDA Module section installs the Pocket PC 2003 emulator. The 
Pocket PC 2003 emulator launches automatically when you download a 
PDA application to the Pocket PC 2003 emulator from LabVIEW.

Select Start»All Programs»Microsoft Pocket PC 2003 SDK» 
Pocket PC 2003 Emulator to launch the Pocket PC 2003 emulator when 
LabVIEW is not running.

Palm OS

DatalogMgr.prc and Mathlib.prc
You must install DatalogMgr.prc and Mathlib.prc, located in the 
LabVIEW 8.0\PDA\Utilities directory, on the PDA device. 
DatalogMgr.prc is required to sync files between the host PC and the 
Palm OS target. Mathlib.prc is required to run PDA applications on a 
Palm OS target. Use the Palm Desktop and HotSync software to install 
these applications.

LabVIEW SMS Client
You must install and run the LabVIEW SMS Client, which is located 
in Labview 8.0\PDA\Utilities\SMS\Treo 600\LV SMS 
Client.prc, on the Palm OS target to receive Short Message Service 
(SMS) messages. The LabVIEW SMS Client notifies the PDA application 
if there is an incoming SMS message and stores the incoming message in 
the LVSMSClientDAT database.
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Use HotSync to install LV SMS Client.prc on the PDA target. After you 
install the application, run LV SMS Client.prc on the PDA target to 
enable SMS support. If the Palm OS target does not support SMS, you 
receive an error. The LabVIEW SMS Client On/Off LED control in the 
PDA application is lit if the Palm OS target supports SMS.

Palm OS Emulators and Simulators
Emulators and simulators are useful tools you can use during development 
to quickly run and test PDA VIs without having to download the 
PDA application to the PDA device. Refer to the PalmSource Web site at 
www.palmsource.com for information about the differences between the 
Palm OS emulator and Palm OS simulator.

Palm OS Emulator and ROM Image
(Palm OS 4.x) Palm OS emulators use ROM images to enable the emulator 
to behave like a specific Palm OS device. You must have a ROM image to 
run the Palm OS emulator. You can transfer the ROM image from a 
Palm OS device or download ROM images from the PalmSource Web site 
at www.palmsource.com.

Note You must register with PalmSource to download Palm OS emulators and ROM 
images.

Refer to the documentation on the PalmSource Web site for information 
about installing Palm OS emulators and ROM images.

Palm OS Simulator
(Palm OS 5.0 and later) If you are using a Palm OS simulator, you must 
configure the simulator to communicate over a serial port if you want to use 
LabVIEW to deploy PDA applications to a Palm OS simulator. Refer to the 
Using a Palm OS Simulator with LabVIEW topic in the LabVIEW Help, 
available by selecting Help»Search the LabVIEW Help.
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PDA Module for Pocket PC Tutorial
Use this tutorial to learn how to create a LabVIEW project and build, run, 
and debug a Pocket PC application.

Tip You also can use the PDA Project Wizard to create the project, the Pocket PC target, 
and the Pocket PC build specification. Refer to the Creating a Project Using the PDA 
Project Wizard topic in the LabVIEW Help, available by selecting Help»Search the 
LabVIEW Help, for information about the PDA Project Wizard.

Creating the LabVIEW Project
Use LabVIEW projects to group together LabVIEW files and 
non-LabVIEW files, create build specifications for building a Pocket PC 
VI into a Pocket PC application, and deploy the Pocket PC application to 
a Pocket PC device or emulator. You must use a project to build a 
Pocket PC VI into a Pocket PC application.

Complete the following steps to create a LabVIEW project, add a Pocket 
PC target, and add a Pocket PC VI to the project.

1. Launch LabVIEW. In the Getting Started window, select Empty 
Project to open an empty LabVIEW project in the Project Explorer 
window as shown in Figure 1. LabVIEW creates an empty project with 
a Windows target, shown in Figure 1 as My Computer.

Figure 1.  Project Explorer Window
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2. Right-click the project, which is Project:Untitled Project 1 in 
Figure 1, in the Project Explorer window and select New»Targets 
and Devices from the shortcut menu to open the Add Targets 
and Devices dialog box as shown in Figure 2.

Figure 2.  Add Targets and Devices Dialog Box

3. Expand the PDA folder and select either Pocket PC 2003 Device or 
Pocket PC 2003 Emulator as shown in Figure 3.

Note You might see additional Pocket PC targets if you configure additional devices 
through the Microsoft Windows CE Platform Manager.
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Figure 3.  Adding a New Device

4. Click the OK button to add the target to the project. The target appears 
in the Project Explorer window as shown in Figure 4.

Figure 4.  Adding the Pocket PC 2003 Emulator to the Project Explorer Window
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5. Expand the Pocket PC target. In Figure 5, the Pocket PC target is 
Pocket PC 2003 Emulator. LabVIEW automatically adds 
Dependencies and Build Specifications under the target. SubVIs 
appear under Dependencies when you add a VI that contains subVIs 
to a project. Build specifications you create for a target in a project 
appear under Build Specifications in the Project Explorer window. 
Refer to the Creating the Pocket PC Build Specification section for 
more information about how to create a build specification.

Figure 5.  Expanding the Pocket PC Target in the Project Explorer Window

6. Right-click the Pocket PC target and select Add File from the shortcut 
menu to open a file dialog box.

7. Add the PDA Tutorial - Pocket PC VI to the project by navigating to 
LabVIEW 8.0\examples\PDA\PocketPC\tutorial and selecting 
PDA Tutorial - Pocket PC.vi. Click the Add File button to add 
the VI to the project. The VI appears in the Project Explorer window 
under the Pocket PC target as shown in Figure 6.

Figure 6.  Adding a VI to the Project

8. Double-click the VI in the Project Explorer window to open the VI.



© National Instruments Corporation 11 Getting Started with the LabVIEW PDA Module

Creating the Pocket PC Build Specification
Build specifications contain the build settings and code generation options 
to use when you build a Pocket PC VI into a Pocket PC application. You 
can create the build specification when you create a project or wait until 
you are ready to build the Pocket PC VI into a Pocket PC application.

You can have multiple build specifications for the same target. For example, 
you might want one build specification that generates debugging 
information and another build specification that does not generate this extra 
information.

Complete the following steps to create a build specification.

1. Right-click Build Specifications under the Pocket PC target and select 
New»Pocket PC Application from the shortcut menu.

2. LabVIEW prompts you to save the project. Click the Save button when 
prompted and save the project as PDA Tutorial - Pocket PC.

3. Click the Help button to open the LabVIEW Help and read a 
description of each build setting.
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4. Enter PDA Tutorial - Pocket PC in the Build specification name 
text box as shown in Figure 7.

Figure 7.  Creating the Build Specification

5. Select Source Files from the Category list and select 
PDA Tutorial - Pocket PC.vi in the source files list. Click the blue 
right arrow button, shown at left, to move the VI from the source files 
list to the Top-level VI text box as shown in Figure 8.
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Figure 8.  Selecting the Top-Level VI for the Build Specification

6. Click the OK button. The build specification you just created appears 
in the Project Explorer window under the Pocket PC target as shown 
in Figure 9.

Figure 9.  PDA Build Specification in the Project Explorer Window

7. Select Save»Save Project in the Project Explorer window to save the 
project. Build specifications are saved with the project.
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Building the Pocket PC VI into a Pocket PC Application and Deploying
After you develop the VI on the host computer, you build the Pocket PC VI 
into an executable Pocket PC application that you can run on a Pocket PC 
target. Pick one of the options in the Using the Shortcut Menu section or the 
Using the Run Button section to build, run, and deploy a Pocket PC 
application.

Using the Shortcut Menu
Right-click the build specification and select one of the following from the 
shortcut menu:

• Deploy—Builds the Pocket PC VI into a Pocket PC application, if 
necessary, and deploys the application to the Pocket PC target. This 
option does not automatically run the Pocket PC application.

• Run—Builds the Pocket PC VI into a Pocket PC application, if 
necessary; deploys the application to the Pocket PC target, if 
necessary; and automatically runs the Pocket PC application.

• Build—Builds the Pocket PC VI into a Pocket PC application. This 
option does not deploy or automatically run the Pocket PC application.

Using the Run Button
The behavior of the Run button differs from LabVIEW for Windows:

• If you want to build, run, and deploy—Click the Run button in a 
Pocket PC VI to build the Pocket PC VI into a Pocket PC application, 
deploy the Pocket PC application to the Pocket PC target, and run the 
Pocket PC application on the Pocket PC target. LabVIEW prompts you 
to create a build specification if you do not have an existing build 
specification for the Pocket PC VI. If you have multiple build 
specifications, the PDA Module uses the default build specification, 
which the PDA Module indicates with a green square around the PDA 
build specification glyph in the Project Explorer window.

• If you want to build without deploying or running—Press the 
<Ctrl> key while you click the Run button in a Pocket PC VI to build 
the Pocket PC VI into a Pocket PC application without deploying or 
running the Pocket PC application. LabVIEW prompts you to create a 
build specification if you do not have an existing build specification for 
the Pocket PC VI. If you have multiple build specifications, the 
PDA Module uses the default build specification, which the 
PDA Module indicates with a green square around the PDA build 
specification glyph in the Project Explorer window.
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Closing the Pocket PC Application
Tap the Exit button in the Pocket PC application on the Pocket PC target to 
close the Pocket PC application.

Debugging a Pocket PC Application
You must create a build specification that enables debugging before you 
can debug a Pocket PC application. Enabling debugging generates extra 
debugging information and can significantly increase the size of the 
Pocket PC application.

Creating a Debug Build Specification
Complete the following steps to create a debug build specification.

1. Right-click Build Specifications under the Pocket PC target and select 
New»Pocket PC Application from the shortcut menu.

2. Enter (Debug) PDA Tutorial - Pocket PC in the Build 
specification name text box.

3. Remove the checkmark from the Same as top-level VI checkbox so 
you can change the Pocket PC application name.

4. Enter (Debug) PDA Tutorial - Pocket PC.exe in the 
Target filename text box.
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5. Place a checkmark in the Enable debugging checkbox to generate 
debugging information when you build the Pocket PC VI into a 
Pocket PC application as shown in Figure 10.

Figure 10.  Creating the Debug Build Specification

6. Select Source Files from the Category list and select 
PDA Tutorial - Pocket PC.vi in the source files list. Click the blue 
right arrow button, shown at left, to move the VI from the source files 
list to the Top-level VI text box.
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7. Click the OK button. The build specification you just created appears 
in the Project Explorer window as shown in Figure 11.

Figure 11.  Two Pocket PC Build Specifications in the Project Explorer Window

Adding a Probe to the Pocket PC VI
Probes display information about the data that passes through a wire. As 
you interact with the Pocket PC application on the Pocket PC device, you 
can see the data passing through the wire in the Pocket PC VI on the host 
computer.

Complete the following steps to add a probe to the Pocket PC VI.

1. Select Window»Show Block Diagram in the VI to open the block 
diagram if it is not visible.

The block diagram acts as a conduit between the Pocket PC application 
running on the Pocket PC target and the Pocket PC VI running on the 
host computer.

2. Change the event case in the Event structure to 
“Frequency”: Value Change.
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3. Right-click the wire flowing into the frequency input of the Sine 
Waveform VI and select Probe from the shortcut menu.

A floating Probe window appears after you create a probe. LabVIEW 
numbers the Probe windows automatically and displays the same 
number in a glyph on the wire you probe as shown in Figure 12.

Figure 12.  Adding a Probe to the Block Diagram

Deploying and Debugging the Pocket PC Application
You must deploy the Pocket PC VI, which contains debugging information, 
to the Pocket PC device before the probe in the Pocket PC VI on the host 
computer can update the values passing through the wire.

Complete the following steps to deploy and debug the Pocket PC 
application.

1. Right-click the build specification for the Pocket PC VI you want to 
build and deploy, which is (Debug) PDA Tutorial - Pocket PC in 
Figure 11, and select Debug from the shortcut menu. Save any VIs if 
prompted.
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The PDA Module builds the Pocket PC VI into a Pocket PC 
application, deploys the Pocket PC application to the Pocket PC target, 
and runs the Pocket PC application on the Pocket PC target as shown 
in Figure 13.

Tip You also can start a debugging session by clicking the Step Over or Step Into buttons 
or by clicking the Pause button and then clicking the Run button on the block diagram 
toolbar.

Figure 13.  Running the Pocket PC Application on the Pocket PC Emulator

2. Move the Frequency slider in the Pocket PC application running on 
the Pocket PC target. The value in the Probe window on the block 
diagram updates as you move the slider in the Pocket PC application.
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Note Any changes you make on the front panel of the Pocket PC VI have no effect on the 
Pocket PC application running on the Pocket PC target.

3. Tap the Exit button in the Pocket PC application on the Pocket PC 
target to stop the Pocket PC application and end the debugging session.

PDA Module for Palm OS Tutorial
Use this tutorial to learn how to create a LabVIEW project and build, run, 
and debug a Palm OS application.

Tip You also can use the PDA Project Wizard to create the project, the Palm OS target, 
and the Palm OS build specification. Refer to Creating a Project Using the PDA Project 
Wizard topic in the LabVIEW Help, available by selecting Help»Search the LabVIEW 
Help, for information about the PDA Project Wizard.

Creating the LabVIEW Project
Use LabVIEW projects to group together LabVIEW files and 
non-LabVIEW files, create build specifications for building a Palm OS VI 
into a Palm OS application, and deploy the Palm OS application to a Palm 
OS device or emulator. You must use a project to build a Palm OS VI into 
a Palm OS application.

Complete the following steps to create a LabVIEW project, add a Palm OS 
target, and add a Palm OS VI to the project.

1. Launch LabVIEW. In the Getting Started window, select Empty 
Project to open an empty LabVIEW project in the Project Explorer 
window as shown in Figure 14. LabVIEW creates an empty project 
with a Windows target, shown in Figure 14 as My Computer.

Figure 14.  Project Explorer Window
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2. Right-click the project, which is Project: Untitled Project 1 in 
Figure 14, in the Project Explorer window and select New»Targets 
and Devices from the shortcut menu to open the Add Targets 
and Devices dialog box as shown in Figure 15.

Figure 15.  Add Targets and Devices Dialog Box
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3. Expand the PDA folder and select either Palm OS Device or 
Palm OS Emulator as shown in Figure 16.

Figure 16.  Adding a New Device

4. Click the OK button to add the target to the project. The target appears 
in the Project Explorer window as shown in Figure 17.

Figure 17.  Adding the Palm OS Emulator to the Project Explorer Window

5. Expand the Palm OS target. In Figure 18, the Palm OS target is 
Palm OS Emulator. LabVIEW automatically adds Dependencies 
and Build Specifications under the target. SubVIs appear under 
Dependencies when you add a VI that contains subVIs to a project. 
Build specifications you create for a target in a project appear under 
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Build Specifications in the Project Explorer window. Refer to 
Creating the Palm OS Build Specification section for more 
information about how to create a build specification.

Figure 18.  Expanding the Palm OS Target in the Project Explorer Window

6. Right-click the Palm OS target and select Add File from the shortcut 
menu to open a file dialog box.

7. Add the PDA Tutorial - Palm OS VI to the project by navigating to 
LabVIEW 8.0\examples\PDA\PalmOS\tutorial and selecting 
PDA Tutorial - Palm OS.vi. Click the Add File button to add the 
VI to the project. The VI appears in the Project Explorer window 
under the Palm OS target as shown in Figure 19.

Figure 19.  Adding a VI to the Project

8. Double-click the VI in the Project Explorer window to open the VI.
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Creating the Palm OS Build Specification
Build specifications contain the build settings and code generation options 
to use when you build a Palm OS VI into a Palm OS application. You can 
create the build specification when you create a project or wait until you are 
ready to build the Palm OS VI into a Palm OS application.

You can have multiple build specifications for the same target. For example, 
you might want one build specification that generates debugging 
information and another build specification that does not generate this extra 
information.

Complete the following steps to create a build specification.

1. Right-click Build Specifications under the Palm OS target and select 
New»Palm OS Application from the shortcut menu.

2. LabVIEW prompts you to save the project. Click the Save button when 
prompted and save the project as PDA Tutorial - Palm OS.

3. Click the Help button to open the LabVIEW Help and read a 
description of each build setting.
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4. Enter PDA Tutorial - Palm OS in the Build specification name 
text box as shown in Figure 20.

Figure 20.  Creating the Build Specification
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5. Select Source Files from the Category list and select 
PDA Tutorial - Palm OS.vi in the source files list. Click the blue 
right arrow button, shown at left, to move the VI from the source files 
list to the Top-level VI text box as shown in Figure 21.

Figure 21.  Selecting the Top-Level VI for the Build Specification

6. Click the OK button. The build specification you just created appears 
in the Project Explorer window under the Palm OS target as shown in 
Figure 22.
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Figure 22.  Palm OS Build Specification in the Project Explorer Window

7. Select Save»Save Project in the Project Explorer window to save the 
project. Build specifications are saved with the project.

Starting the Palm OS Emulator
The Palm OS emulator must be running before you can build and deploy a 
Palm OS application to a Palm OS target.

Complete the following steps to start the Palm OS emulator.

1. Right-click the Palm OS target, which is Palm OS Emulator in 
Figure 23, and select Properties from the shortcut menu.

Figure 23.  Selecting the Palm OS Target

2. Browse to or enter the path to the emulator in the Emulator Path path 
control.
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3. Click the Launch Emulator button to start the Palm OS emulator as 
shown in Figure 24.

Figure 24.  Starting the Palm OS Emulator

Building the Palm OS VI into a Palm OS Application and Deploying
After you develop the VI on the host computer, you build the Palm OS VI 
into an executable Palm OS application that you can run on a Palm OS 
target. Pick one of the options in the Using the Shortcut Menu section or the 
Using the Run Button section to build, run, and deploy a Pocket PC 
application.

Using the Shortcut Menu
Right-click the build specification and select one of the following from the 
shortcut menu:

• Deploy—Builds the Palm OS VI into a Palm OS application, if 
necessary, and deploys the application to the Palm OS target. This 
option does not automatically run the Palm OS application.
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• Run—Builds the Palm OS VI into a Palm OS application, if 
necessary; deploys the application to the Palm OS target, if necessary; 
and automatically runs the Palm OS application.

• Build—Builds the Palm OS VI into a Palm OS application. This 
option does not deploy or automatically run the Palm OS application.

Using the Run Button
The behavior of the Run button differs from LabVIEW for Windows.

• If you want to build, run, and deploy—Click the Run button in a 
Palm OS VI to build the Palm OS VI into a Palm OS application, 
deploy the Palm OS application to the Palm OS target, and run the 
Palm OS application on the Palm OS target. LabVIEW prompts you to 
create a build specification if you do not have an existing build 
specification for the Palm OS VI. If you have multiple build 
specifications, the PDA Module uses the default build specification, 
which the PDA Module indicates with a green square around the PDA 
build specification glyph in the Project Explorer window.

• If you want to build without deploying or running—Press the 
<Ctrl> key while you click the Run button in a Palm OS VI to build 
the Palm OS VI into a Palm OS application without deploying or 
running the Palm OS application. LabVIEW prompts you to create a 
build specification if you do not have an existing build specification for 
the Palm OS VI. If you have multiple build specifications, the PDA 
Module uses the default build specification, which the PDA Module 
indicates with a green square around the PDA build specification glyph 
in the Project Explorer window.

Closing the Palm OS Application
Tap the Exit button in the Palm OS application on the Palm OS target to 
close the Palm OS application.

Debugging a Palm OS Application
You must create a build specification that enables debugging before you 
can debug a Palm OS application. Enabling debugging generates extra 
debugging information and can significantly increase the size of the Palm 
OS application.
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Creating a Debug Build Specification
Complete the following steps to create a debug build specification.

1. Right-click Build Specifications under the Palm OS target and select 
New»Palm OS Application from the shortcut menu.

2. Enter (Debug) PDA Tutorial - Palm OS in the Build 
specification name text box.

3. Remove the checkmark from the Same as top-level VI checkbox so 
you can change the Palm OS application name.

4. Enter (Debug) PDA Tutorial - Palm OS.prc in the Target 
filename text box.

5. Place a checkmark in the Enable debugging checkbox to generate 
debugging information when you build the Palm OS VI into a Palm OS 
application as shown in Figure 25.

Figure 25.  Creating the Debug Build Specification

6. Select Source Files from the Category list and select 
PDA Tutorial - Palm OS.vi in the source files list. Click the blue 
arrow button, shown at left, to move the VI from the source files list to 
the Top-level VI text box.



© National Instruments Corporation 31 Getting Started with the LabVIEW PDA Module

7. Click the OK button. The build specification you just created appears 
in the Project Explorer window as shown in Figure 26.

Figure 26.  Two Palm OS Build Specifications in the Project Explorer Window

Adding a Probe to the PDA VI
Probes display information about the data that passes through a wire. As 
you interact with the Palm OS application on the Palm OS device, you can 
see the data passing through the wire in the Palm OS VI on the host 
computer.

Complete the following steps to add a probe to the Palm OS VI.

1. Select Window»Show Block Diagram in the VI to open the block 
diagram if it is not visible.

The block diagram acts as a conduit between the PDA application 
running on the Palm OS target and the Palm OS VI running on the host 
computer.

2. Right-click the wire connecting the number (0-1) output of the 
Random Number (0-1) function to the x input of the Multiply function 
and select Probe from the shortcut menu.
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A floating Probe window appears after you create a probe. LabVIEW 
numbers the Probe windows automatically and displays the same 
number in a glyph on the wire you probe as the portion of the block 
diagram in Figure 27 shows.

Figure 27.  Adding a Probe to the Block Diagram

Deploying and Debugging the Palm OS Application
You must deploy the Palm OS VI, which contains debugging information, 
to the Palm OS device before the probe in the Palm OS VI on the host 
computer can update the values passing through the wire.

Complete the following steps to deploy and debug the Palm OS application.

1. Right-click the build specification for the Palm OS VI you want to 
build and deploy, which is (Debug) PDA Tutorial - Palm OS in 
Figure 26, and select Debug from the shortcut menu. Save any VIs if 
prompted.

The PDA Module builds the Palm OS VI into a Palm OS application, 
deploys the Palm OS application to the Palm OS target, and runs the 
Palm OS application on the Palm OS target.

Tip You also can start a debugging session by clicking the Step Over or Step Into buttons 
or by clicking the Pause button and then clicking the Run button on the block diagram 
toolbar.

2. Tap the Collect button in the Palm OS application running on the Palm 
OS target. The Palm OS application begins updating the graph on the 
PDA target, shown in Figure 28, and the value in the Probe window on 
the block diagram updates.
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Figure 28.  Running the Palm OS Application on the Palm OS Emulator

3. Tap the Exit button in the Palm OS application on the Palm OS target 
to stop the Palm OS application and end the debugging session.

What’s New in LabVIEW 8.0 PDA Module
Refer to the PDA Module book on the Contents tab of the LabVIEW Help, 
available by selecting Help»Search the LabVIEW Help in LabVIEW, for 
more information specific to the PDA Module and PDA applications.

Front Panel Controls and Indicators
You now can use the following front panel controls and indicators 
functionality in PDA VIs:

• 3D front panel controls and indicators.

• Multiple needles on dials and meters.



Getting Started with the LabVIEW PDA Module 34 ni.com

• Visible front panel array controls and indicators and cluster controls 
and indicators.

• Time stamp controls and indicators.

• More numeric and Boolean controls.

• Multiple cursors on a graph.

Newly Supported Data Types
You now can use the following data types in PDA VIs:

• Dynamic

• Time Stamp

• Variant

• Waveform

New VIs
The PDA Module now includes the following new VIs:

• Phone VIs

• Short Message Service VIs

• (Pocket PC) PDA Pick Color

• (Pocket PC) PDA Read BMP File

• (Pocket PC) PDA Write BMP File

• (Pocket PC) Set Help File Path

• (Pocket PC) PDA Load Image File

Newly Supported VIs and Functions
You now can use the following LabVIEW VIs and functions in PDA VIs:

• Analog Waveform VIs and functions

• Digital Waveform VIs and functions

• Most Express VIs

• Property Node

• SMTP Email Send Message (Small)

• SMTP Email Send Multiple Attachments

• Variant functions
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Newly Supported Events
You now can use the following VI events in PDA VIs:

• Key Down

• Key Up

• Menu Selection

Deprecated VIs
Because the PDA Module now supports the time stamp data type, the 
following VIs have been deprecated in version 8.0 of the PDA Module:

• PDA Date Time To Seconds—Use the Date/Time To Seconds 
function instead.

• PDA Get Date Time In Seconds—Use the Get Date/Time In Seconds 
function instead.

Note Deprecating these two VIs does not break existing PDA VIs that use them.

General Changes
• PDA VIs now support a select collection of properties in Property 

Nodes.

• The remote path for a Pocket PC application has changed from 
\Windows\Start Menu\Programs to \My Documents.

• The PDA Module now includes a Pocket PC Landscape Screen 
template.

• The Palm OS Build Specification Properties dialog box and the 
Pocket PC Build Specification Properties dialog box replace the 
PDA Build Settings dialog box.

• PDA VIs now support 16-bit and (Pocket PC) 24-bit bitmaps.

• Palette items are now organized according to categories. Custom 
palette views are no longer supported.

• The PDA Module now supports the LabVIEW Internet Toolkit.

• Graphs and charts in PDA VIs now support time stamps on the x-scale.

• The PDA Module no longer supports Sony Clié devices.

• (Pocket PC) The PDA Module now supports the ability to include an 
HTML file as help for a Pocket PC PDA application. Use the Set Help 
File Path VI to set the path to the HTML file you create.
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Related Documentation
LabVIEW includes extensive online and print documentation for new and 
experienced LabVIEW users. The following documents contain 
information that you might find helpful:

• LabVIEW Help—Refer to the LabVIEW Help, available by selecting 
Help»Search the LabVIEW Help in LabVIEW, for information 
about LabVIEW programming concepts, step-by-step instructions for 
using LabVIEW, and reference information about LabVIEW VIs, 
functions, palettes, menus, and tools. Refer to the PDA Module book 
on the Contents tab of the LabVIEW Help, for information specific to 
the PDA Module and PDA applications.

• PDA Module Readme—Refer to the PDA Readme file, available 
by selecting Start»All Programs»National Instruments» 
LabVIEW 8.0»Readme.

• LabVIEW PDFs—In addition to this document, the Getting Started 
with LabVIEW manual, LabVIEW Quick Reference Card, LabVIEW 
Fundamentals manual, LabVIEW Release Notes, and LabVIEW 
Upgrade Notes are available as PDFs by selecting Start»All 
Programs»National Instruments»LabVIEW 8.0»LabVIEW 
Manuals.

Note You must have Adobe Reader with Search and Accessibility 5.0.5 or later installed 
to view the PDFs. You must have Adobe Reader with Search and Accessibility 6.x or later 
installed to search PDF versions of these manuals. Refer to the Adobe Systems 
Incorporated Web site at www.adobe.com to download Adobe Reader. Refer to the 
National Instruments Product Manuals Library at ni.com/manuals for updated 
documentation resources.

• Documentation for the PDA target you use.

Where to Go for Support
The National Instruments Web site is your complete resource for technical 
support. At ni.com/support you have access to everything from 
troubleshooting and application development self-help resources to email 
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 
11500 North Mopac Expressway, Austin, Texas, 78759-3504. 
National Instruments also has offices located around the world to help 
address your support needs. For telephone support in the United States, 
create your service request at ni.com/support and follow the calling 
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instructions or dial 512 795 8248. For telephone support outside the United 
States, contact your local branch office: 

Australia 1800 300 800, Austria 43 0 662 45 79 90 0, 
Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599, 
Canada 800 433 3488, China 86 21 6555 7838, 
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 
Finland 385 0 9 725 725 11, France 33 0 1 48 14 24 24, 
Germany 49 0 89 741 31 30, India 91 80 51190000, 
Israel 972 0 3 6393737, Italy 39 02 413091, Japan 81 3 5472 2970, 
Korea 82 02 3451 3400, Lebanon 961 0 1 33 28 28, 
Malaysia 1800 887710, Mexico 01 800 010 0793, 
Netherlands 31 0 348 433 466, New Zealand 0800 553 322, 
Norway 47 0 66 90 76 60, Poland 48 22 3390150, 
Portugal 351 210 311 210, Russia 7 095 783 68 51, 
Singapore 1800 226 5886, Slovenia 386 3 425 4200, 
South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 
Sweden 46 0 8 587 895 00, Switzerland 41 56 200 51 51, 
Taiwan 886 02 2377 2222, Thailand 662 278 6777, 
United Kingdom 44 0 1635 523545
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