
Getting Started Manual
LabVIEW  LEGO® MINDSTORMS® NXT Module

The LabVIEW LEGO® MINDSTORMS® NXT Module enables you to 
perform the following tasks:

• Develop LabVIEW VIs that run on a host computer and communicate 
with an NXT brick. These programs also can run directly on the NXT 
brick.

• Create and configure LabVIEW controls to represent TETRIX motors 
and servos connected to the NXT brick. You then can wire these 
LabVIEW controls to the NXT VIs to specify the motors and servos 
you want to control.

This document contains exercises you can use to learn how to develop VIs 
that run on a host computer or on an NXT brick. These exercises require a 
basic understanding of the LabVIEW development environment. Refer to the 
Getting Started with LabVIEW document, accessible by navigating to the 
labview\manuals directory and opening LV_Getting_Started.pdf, 
for an introduction to LabVIEW.
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Building a VI that Communicates with the NXT Brick
In this exercise, you will build a VI that runs on the host computer and 
communicates with the NXT brick. This VI measures the brightness of an 
LED light sensor and displays the value on the screen of the NXT brick.

Building the VI
Complete the following steps to build a VI that communicates with the 
NXT brick.

1. In the Getting Started window, click the Blank VI link to create a new 
VI. 

2. Select Window»Show Block Diagram to display the block diagram 
window. 

3. If the Functions palette does not appear, select View»Functions 
Palette to display the Functions palette.

4. Select NXT Robotics»NXT I/O from the Functions palette. The 
NXT I/O palette contains a library of VIs you can use to communicate 
with an NXT brick. 

5. Add the Read Sensor VI, shown at left, to the block diagram window.

Tip Select Help»Show Context Help to display the Context Help window. Hover over 
an object on the palette or block diagram window to view information about that object in 
the Context Help window.

6. Select Read Light»LED On from the polymorphic VI selector on the 
Read Sensor VI. This option specifies that this VI turns the LED light 
on and reads the light sensor.

7. Right-click the Port input of the Read Sensor VI and select 
Create»Constant from the shortcut menu. Port 3 is the default port. 

8. Add the Display Control VI to the block diagram window to the right 
of the Read Sensor VI.

9. Select Write»Integer from the polymorphic VI selector on the 
Display Control VI. This option specifies that the NXT brick displays 
an integer on the screen. You can use this VI to display the value of the 
light sensor.

10. Wire the NXT output of the Read Sensor VI to the NXT input of the 
Display Control VI.

11. To display the scaled value of the light sensor on the NXT brick, wire 
the Scaled Value output of the Read Sensor VI to the number input 
of the Display Control VI.
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After you complete this step, the block diagram window should appear 
similar to the following figure.

12. Add a Wait For VI to the right of the Display Control VI. The Wait For 
VI specifies that this VI waits the number of seconds you specify or 
until the action you specify occurs. By default, this VI waits for one 
second.

13. Wire the NXT output of the Display Control VI to the NXT input of 
the Wait For VI.

14. Add a Read Sensor VI to the right of the Wait For VI.

15. Wire the NXT output of the Wait For VI to the NXT input of the Read 
Sensor VI.

16. Select Read NXT Btns from the polymorphic VI selector on the Read 
Sensor VI. By default, this option specifies that this VI returns the 
value of the orange button on the NXT brick. If the button is pressed, 
this VI returns TRUE. If the button is not pressed, this VI returns 
FALSE. You then can wire this value to another object to perform an 
action based on whether the button is pressed.

In the current state, this VI runs once and then stops. To configure the VI to 
run continuously, you can use a While Loop. A While Loop specifies that 
a VI runs until you stop it. Complete the following steps to configure the 
VI to run continuously.

1. Add a While Loop, located on the NXT Robotics»NXT 
Programming»Structures palette, to the block diagram window. 
Make sure that you include all the objects on the block diagram inside 
the While Loop.

2. Wire the Yes/No output of the last Read Sensor VI to the conditional 
terminal of the While Loop. When you press the orange button on the 
NXT brick, the Yes/No output returns TRUE, and the VI stops 
running.

3. Save the VI as Read Light Sensor.vi in an easily accessible 
location on the host computer.
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After you complete this step, the block diagram window should appear 
similar to the following figure.

This VI reads the light sensor connected to the NXT brick and displays the 
scaled value of the light sensor on the screen of the NXT brick.

Understanding How the VI Works
You can use the LabVIEW execution highlighting tool to see how a VI works.

Use execution highlighting to view an animation of the execution of the block 
diagram. Execution highlighting shows the movement of data on the block 
diagram from one node to another using bubbles that move along the wires. 

Complete the following steps to use execution highlighting for the Read 
Light Sensor VI.

1. Connect the NXT brick to the host computer through a USB 
connection.

2. Press the orange button on the NXT brick to power on the NXT brick.

3. Connect the light sensor to port 3 of the NXT brick.

4. In LabVIEW, click the Highlight Execution button, shown at left, on 
the block diagram toolbar of the Read Light Sensor VI to enable 
execution highlighting.

5. Click the Run button, shown at left, and view the block diagram as the 
VI runs. Notice that with execution highlighting, bubbles move along 
the wires to mark the movement of data from one node to another, and 
the values at each terminal are displayed.

6. Cover the light sensor to see the scaled value on the screen of the NXT 
brick change.

7. Click the Highlight Execution button again to disable execution 
highlighting.

8. Click the Abort Execution button on the block diagram window to 
stop the VI.



© National Instruments Corporation 5 Getting Started with the LabVIEW NXT Module

Deploying and Running the VI on the NXT Brick
After you see how the Read Light Sensor VI works, you are ready to run 
the Read Light Sensor VI directly on the NXT brick. Complete the 
following steps to deploy and run the Read Light Sensor VI on the NXT 
brick.

1. Select File»Target to NXT to open the Read Light Sensor VI in the 
NXT application instance. LabVIEW targets the VI to the NXT brick 
connected to the host computer. Notice that the application instance 
shortcut menu in the bottom left corner of the block diagram window 
turns orange and displays the name of the NXT brick to which the VI 
is targeted.

2. Click the Run button on the front panel window or block diagram 
window to run the VI on the NXT brick.

3. Cover the light sensor to see the scaled value change on the screen of 
the NXT brick.

4. Press the orange button on the NXT brick to stop the VI.

5. Save and close the VI.

Refer to the labview\examples\NXT Robotics directory for more 
examples of VIs you can develop with the NXT Module. 

Creating Controls for Motors and Servos
Some VIs you use to program the NXT brick require that you specify which 
motors and servos you want to control. If you build a robot using TETRIX 
motors or servos, you can use the TETRIX Motor Configurator to create 
controls that specify the names and configurations for the TETRIX motors 
and servos. You then can wire these controls to the VIs you build in 
LabVIEW to specify the motors and servos you want to control. 

You can use the TETRIX Motor Configurator, available by selecting 
Tools»NXT Tools»TETRIX Motor Configurator, to create new 
LabVIEW controls or to update the configuration of existing controls.

Creating New Controls for Motors and Servos
Use the TETRIX Motor Configurator, shown as follows, to create controls 
that contain the names and configurations for motors and servos before you 
begin to program a robot.
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Complete the following steps to create a new motor control.

1. In the Getting Started window, click the Blank VI link to create a new 
VI.

2. Select Tools»NXT Tools»TETRIX Motor Configurator to display 
the TETRIX Motor Configurator.

3. Click the Browse button to specify where you want to save the new 
motor control. Save the control in the default data directory so that the 
control appears on the Functions palette in the block diagram window 
and the Controls palette in the front panel window.

4. Specify a unique file name for the control and click the OK button to 
close the file dialog box.

5. On the DC Motors page of the TETRIX Motor Configurator, enter 
Left Drive in the first Motor Name text box to specify the name of 
the first motor.

6. Place a checkmark in the Reverse checkbox for Left Drive. This 
option specifies that Left Drive will move in the opposite direction of 
the command you send to it.

7. Click the Add Motor button to add a second motor to the motor list.

8. Name the second motor Right Drive.
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9. Select Motor 2 from the corresponding Motor pull-down menu to 
specify that Right Drive connects to the Motor 2 terminals on the 
HiTechnic Motor Controller.

10. Click the Save button to save the motor names and configurations.

11. Click the OK button to close the TETRIX Motor Configurator.

After you create and save the motor control, the control appears on the 
Functions»NXT Robotics»TETRIX»Motor Configurations palette and 
the Controls»NXT Robotics»Motor Configurations palette, shown as 
follows.

You can add the motor control to the block diagram and wire the control to 
the DC Motor input of the TETRIX VIs, located on the TETRIX palette, 
to begin programming a robot. An example program might appear similar 
to the following figure.

You can create and use servo controls similarly to how you create and use 
motor controls.
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Editing Existing Motor and Servo Controls
You also can open an existing motor or servo control in the TETRIX Motor 
Configurator to edit that control. After you save the new configurations for 
the control, the TETRIX Motor Configurator prompts you to update the VIs 
in which you use the control. 

Where to Go from Here
The following documents contain information about programming 
concepts and provide step-by-step instructions for using LabVIEW and the 
NXT Module.

• LabVIEW NXT Module Help—Use the LabVIEW NXT Module Help to 
access information about NXT Module programming concepts, 
step-by-step instructions for using the NXT Module, and reference 
information about NXT Module VIs, functions, palettes, menus, tools, 
dialog boxes, and so on. Access the LabVIEW NXT Module Help by 
selecting Help»NXT Module Help in LabVIEW.

• LabVIEW LEGO® MINDSTORMS® NXT Module Programming 
Guide—Use the LabVIEW LEGO® MINDSTORMS® NXT Module 
Programming Guide to access information about advanced 
programming in the LabVIEW NXT Module. The LabVIEW LEGO® 
MINDSTORMS® NXT Module Programming Guide details the 
NXT-specific modifications and extensions to LabVIEW provided by 
the NXT Module. Access this guide by navigating to the 
labview\manuals directory and opening 
NXT_Advanced_Programming_Guide.pdf.

• LabVIEW Help—Use the LabVIEW Help to access information about 
LabVIEW programming concepts, step-by-step instructions for using 
LabVIEW, and reference information about LabVIEW VIs, functions, 
palettes, menus, tools, properties, methods, events, dialog boxes, and 
so on. The LabVIEW Help also lists the LabVIEW documentation 
resources available from National Instruments. Access the LabVIEW 
Help by selecting Help»Search the LabVIEW Help in LabVIEW.

• LabVIEW Quick Reference Card—Use this card as a reference for 
information about documentation resources, keyboard shortcuts, data 
type terminals, and tools for editing, execution, and debugging. Access 
this manual by navigating to the labview\manuals directory and 
opening LV_Quick_Reference.pdf.
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