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1
Introduction to NI Circuit 
Design Suite

Some of the described features may not be available in your edition of Circuit Design Suite. 

Refer to ni.com for a list of the features available in your edition. 

NI Circuit Design Suite Product Line 
National Instruments Circuit Design Suite is a suite of EDA (Electronics Design Automation) 
tools that assists you in carrying out the major steps in the circuit design flow. 

Multisim is the schematic capture and simulation program designed for schematic entry, 
simulation, and feeding to downstage steps, such as PCB layout. It also includes mixed 
analog/digital simulation capability, and microcontroller co-simulation. 

Ultiboard is used to design printed circuit boards, perform certain basic mechanical CAD 
operations, and prepare them for manufacturing. It also provides automated parts placement and 
layout. 

The Tutorials 
This book contains the following step-by-step tutorials: 

• Multisim Tutorial—Introduces you to Multisim and its many functions. 

• Ultiboard Tutorial—Shows you how to place the components and traces for the design 
described in the Multisim Tutorial chapter. You will also learn how to autoplace parts and 
then autoroute them. 

For more detailed information on the features discussed in these chapters, refer to the Multisim 
Help or the Ultiboard Help. 
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2
Multisim Tutorial

This chapter contains a tutorial that introduces you to Multisim and its many functions. 

Some of the described features may not be available in your edition of Circuit Design Suite. 

Refer to ni.com for a list of the features available in your edition. 

Introduction to the Multisim Interface 
Multisim is the schematic capture and simulation application of National Instruments Circuit 
Design Suite, a suite of EDA (Electronics Design Automation) tools that helps you carry out the 
major steps in the circuit design flow. 

Multisim is designed for schematic entry, simulation, and exporting to downstage steps, such as 
PCB layout. 
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Multisim User Interface  
Multisim’s user interface includes the following elements: 

1 Menu Bar
2 Design Toolbox
3 Component Toolbar
4 Standard Toolbar

5 View Toolbar
6 Simulation Toolbar
7 Main Toolbar
8 In Use List

9 Instruments Toolbar
10 Workspace
11 Spreadsheet View
12 Active Tab
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Refer to the table below as needed: 

Overview 
This tutorial leads you through the circuit design flow, from schematic capture, through 
simulation and analysis. After following the steps outlined on the following pages, you will have 
designed a circuit that samples a small analog signal, amplifies it and then counts the cycles on 
a simple digital counter. 

Helpful tips are indicated by an icon in the left column, as in the tip below: 

Tip You can access the online help at any time by pressing F1 on your keyboard, or 
by clicking the Help button in a dialog box. 

 Element  Description

1 Menu Bar Contains the commands for all functions. 

2 Design 
Toolbox 

Use to navigate through the different types of files in a project 
(schematics, PCBs, reports), view a schematic’s hierarchy and 
show or hide different layers. 

3 Component 
toolbar 

Contains buttons that you use to select components from the 
Multisim databases for placement in your schematic. 

4 Standard 
toolbar 

Contains buttons for commonly-performed functions such as Save, 
Print, Cut, and Paste. 

5 View toolbar Contains buttons for modifying the way the screen is displayed. 

6 Simulation 
toolbar 

Contains buttons for starting, stopping, and other simulation 
functions. 

7 Main toolbar Contains buttons for common Multisim functions. 

8 In Use List Contains a list of all components used in the design. 

9 Instruments 
toolbar 

Contains buttons for each instrument. 

10 Workspace This is where you build your designs. 

11 Spreadsheet 
View 

Use for fast advanced viewing and editing of parameters including 
component details such as footprints, RefDes, attributes and design 
constraints. 

12 Active tab Indicates the design you are working on. Click another tab to 
switch. 
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Schematic Capture 
In the following sections, you will place and wire the components in the design shown below. 

 

Creating the File 
Complete the following steps to create the design file: 

1. Launch Multisim. 

A blank file called Design1 opens on the workspace. 

2. Select File»Save as to display a standard Windows Save dialog. 

3. Navigate to the location where you wish to save the file, enter MyGettingStarted as the 
File name, and click the Save button. 

Tip To guard against accidental loss of data, set up a timed Auto-backup of the file 
in the Save tab of the Global Options dialog box. 
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Placing the Components 
Complete the following steps to place the components on MyGettingStarted: 

1. Select Place»Component to display the Select a Component dialog box. 

2. Select the Indicators component Group and the HEX_DISPLAY component Family. 

3. Type seven_seg_decimal_com_a_blue in the Component field. 

As you type, the string appears in the Searching field at the bottom of the browser. Matches 
display in the Component list. 

4. Click OK when the desired component displays as shown below. 

The component appears as a “ghost” on the cursor. 
 

5. Move the cursor to the bottom-right of the workspace and click to place the component. 

Note that the Reference Designator for this component is U1. 
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6. Place the remaining components in the Digital Counter area as shown below. 

Tip The Group and Family location of each component is listed in Component 
Locations. 

 

Tip While placing the 200 Ω resistor, press <Ctrl-R> to rotate it to a vertical 
orientation. 

7. Place the components in the Counter Control section as shown below. 
 

8. Right-click on each SPDT switch and select Flip horizontally. 
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9. Place the components in the Analog Amplifier section as shown below, rotating as needed. 
 

10. Double-click on the AC voltage source (V1), change Voltage (Pk) to 200 mV and click OK 
to close the dialog. 

11. Place the components in the Bypass Capacitors section as shown below. 
 

12. Place the header and associated components as shown below. 
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Component Locations 
The following shows you where to locate all components for this design in the Select a 
Component dialog box. 

Tip Reference Designators (for example, U1, U2) are assigned in the order the 
components are placed. If you place components in a different order than in the 
original design, the numbering will differ. This will not affect the operation of the 
design in any way. 

Component Group Family

VCC

GND - DGND

GROUND

Sources POWER_SOURCES

LED1 - LED_blue Diodes DIODES_VIRTUAL

U1 - 7-segment display Indicators HEX_DISPLAY

U2 - 74LS190N

U3 - 74LS47N

TTL 74LS

R1 - 200 Ω Basic RESISTOR

R2 - 1 k potentiometer Basic POTENTIOMETER

R3 - 1 k Basic RESISTOR

R4 - 10Line_Bussed Basic RPACK

J1, J2 - SPDT Basic SWITCH

U4 - 741 Analog OPAMP

V1 - AC_VOLTAGE Sources SIGNAL_VOLTAGE_SOURCES

C1 - 1 μF

C2 - 10 nF

C3 - 100 μF

Basic CAP_ELECTROLIT

J3 - HDR1X4 Connectors HEADERS_TEST
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Note When placing resistors, inductors, or capacitors, the Select a Component 
dialog box has slightly different fields than for other components. When placing 
these, you can choose any combination of the component’s value (for example, the 
resistance value), type (for example, carbon film), and so on. If you are placing a 
component that will be exported to PCB layout, the combination of values that you 
select must be available in a commercially available component. 

Wiring the Design 
All components have pins that you use to wire them to other components or instruments. As soon 
as your cursor is over a pin, the pointer changes to a crosshair, indicating you can start wiring. 

Tip You can wire the design that you placed on the workspace or you can use 
Getting Started 1 from the Getting Started folder (found inside the 
samples folder). 

Complete the following steps to wire the design: 

1. Click on a pin on a component to start the connection (your pointer turns into a crosshair) 
and move the mouse. 

A wire appears, attached to your cursor. 

2. Click on a pin on the second component to finish the connection. 

Multisim automatically places the wire, which conveniently snaps to an appropriate 
configuration, as shown below. 

 

Tip You can also control the flow of the wire by clicking on points as you move the 
mouse. Each click “fixes” the wire to that point. 
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3. Finish wiring the Digital Counter section as shown below. 
 

Tip Use Bus Vector Connect to wire multi-pinned devices like U3 and R4 together 
in a bus. Refer to the Multisim Help for details. 

Tip Virtual Wiring—To avoid clutter, you can use virtual connections between the 
Counter Control and Digital Counter sections using on-page connectors. Refer to the 
Multisim Help for details.
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4. Finish wiring the design as shown below. 
 

Simulation 
Simulating your designs with Multisim catches errors early in the design flow, saving time and 
money. 

Virtual Instrumentation 
In this section, you will simulate the design and view the results with the virtual oscilloscope. 

Tip You can also use Getting Started 2 from the Getting Started folder 
(found in the samples folder). 

1. Set up the interactive keys for J1, J2 and R2: 

a. Double-click on each and select the Value tab. 

b. Select “E” for J1 and “L” for J2 in the Key for toggle field. 

c. Select “A” in the Key field for R2. 

Note J1, J2 and R2 are interactive components. 

2. Press <E> to enable the counter. 

Or 

Click on the widened switch arm that appears when you hover the cursor over J1. 

Enable is Active Low. 

3. Select Simulate»Instruments»Oscilloscope to place the oscilloscope on the workspace. 
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4. Wire the instrument as shown in step 7. 

Tip To differentiate between traces on the oscilloscope, right-click on the wire 
connected to the scope’s B input and select Segment color from the context menu 
that displays. Select a color that differs from the wire connected to the A input, for 
example blue. (Changing wire color or performing other editing functions cannot be 
done while simulation is running). 

5. Double-click on the oscilloscope icon to show its instrument face. 

6. Select Simulate»Run. 

The output of the op-amp appears on the scope.  

7. Adjust the Timebase to 2 ms/Div and Channel A’s Scale to 500 mV/Div. 

The following displays on the oscilloscope: 
 

As the design simulates, the 7-segment display counts up and the LED flashes at the end of 
each count cycle. 

8. Do the following: 

a. Press <E> while the simulation is running to enable or disable the counter. Enable is 
Active Low. 

b. Press <L> to load zeros into the counter. Load is Active Low. 

c. Press <Shift-A> to observe the effect of decreasing the potentiometer’s setting. 
Repeat, pressing <A> to increase. 
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Tip Instead of pressing the above-mentioned keys, you can directly manipulate the 
interactive components on the schematic with your mouse. 

Analysis 
In this section, you will use AC Analysis to verify the frequency response of the amplifier. 

Complete the following steps to perform an AC Analysis at the output of the op-amp: 

1. Double-click on the wire that is attached to pin 6 of the op-amp. 

The Net Properties dialog box displays. 

2. Change the Preferred net name to analog_out. 

3. Select Simulate»Analyses»AC analysis»Output tab. 

4. Highlight V(analog_out) in the Variables in circuit (left) column and click Add. 

V(analog_out) moves to the Selected variables for analysis (right) column. 

This indicates that the voltage at node V(analog_out) will be displayed after simulation. 

5. Click Simulate. 

The results of the analysis appear in the Grapher. 

The Grapher 
The Grapher is a multi-purpose display tool that lets you view, adjust, save and export graphs 
and charts. It is used to display the results of all Multisim analyses in graphs and charts, and 
graphs of traces for some instruments (for example, the oscilloscope). 

Complete the following steps to view results of a simulation on the Grapher: 

1. Run the simulation with the oscilloscope as described earlier. 

2. Select View»Grapher. 
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The Postprocessor 
Use the Postprocessor to manipulate the output from analyses and plot the results on a graph or 
chart. Types of mathematical operations that can be performed on analysis results include 
arithmetic, trigonometric, exponential, logarithmic, complex, vector and logic. 

Reports 
You can generate a number of reports in Multisim: Bill of Materials (BOM), Component 
Detail Report, Netlist Report, Schematic Statistics, Spare Gates and the Cross Reference 
Report. 

The following section uses the BOM as an example for the tutorial design. 

Bill of Materials 
A bill of materials lists the components used in a design, providing a summary of the 
components needed to manufacture the circuit board.

Information provided for each component includes: 

• quantity required. 

• description, including the type of component (example: resistor) and value
(example: 5.1 kΩ). 

• Reference Designator. 

• package or footprint name. 
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Complete the following steps to create a BOM (bill of materials) for your design: 

1. Select Reports»Bill of Materials. 

The report appears, similar to this: 

Click the Send to printer button to print the Bill of Materials. A standard Print dialog box 
appears, where you choose the printer, number of copies, and so on.  

Click the Save to text file button to save the Bill of Materials. A standard Windows file save 
dialog box appears, where you specify the path and file name.  

Because the Bill of Materials is primarily intended to assist in procurement and manufacturing, 
it includes only “real” components—it excludes components that are not real or available for 
purchase, such as sources or virtual components. Components without assigned footprints do not 
appear in the Bill of Materials. 
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To see a list of components in your design that are not “real” components, click the Show virtual 
components button. A separate view appears, showing these components only.  

Refer to the Multisim Help for detailed information on this and other reports. 
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3
Ultiboard Tutorial

The tutorial in this chapter places the parts and traces for the circuit described in the Multisim 
Tutorial chapter. 

Some of the described features may not be available in your edition of Ultiboard. 

Refer to ni.com for a list of the features available in your edition. 

Introduction to the Ultiboard Interface 
Ultiboard is the PCB layout application of National Instruments Circuit Design Suite, a suite of 
EDA (Electronics Design Automation) tools that assists you in carrying out the major steps in 
the design flow. 

Ultiboard is used to lay out and route printed circuit boards, perform certain basic mechanical 
CAD operations, and prepare boards for manufacturing. It also provides automated parts 
placement and wire routing. 
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Ultiboard User Interface  
Ultiboard’s user interface is made up of several elements. 

 

1 Menu Bar
2 Standard Toolbar
3 Select Toolbar
4 Draw Settings Toolbar

5 View Toolbar
6 Main Toolbar
7 Autoroute Toolbar

8 Status Bar
9 Workspace
10 Spreadsheet View

11 Design Toolbox
12 3D Preview
13 Birds Eye View
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Refer to the table below as needed: 

Opening the Tutorial  
Complete the following steps to open the tutorial file: 

1. Launch Ultiboard, select File»Open samples and double-click on the GettingStarted 
folder to open it. 

2. Select GettingStarted and click Open. 

The project file is loaded into Ultiboard. 

Element  Description

1 Menu Bar Contains the commands for all functions. 

2 Standard toolbar Contains buttons for commonly-performed functions such as 
Save, Print, Cut, and Paste. 

3 Select toolbar As you add more parts and traces to a board, it can become 
difficult to select only those which you want to use. This toolbar 
contains buttons used to control selections. 

4 Draw Settings 
toolbar

This is where you select the layer, thickness and unit of measure 
of a line or object that is being drawn. It also contains buttons 
for functions that control the appearance of lines and shapes 
drawn on a layer. 

5 View toolbar Contains buttons for modifying the way the screen is displayed. 

6 Main toolbar Contains buttons for common board design functions. 

7 Autoroute toolbar Contains autorouting and part placement functions. 

8 Status Bar Displays useful and important information. 

9 Workspace This is where you lay out the PCB. 

10 Spreadsheet View This allows fast advanced viewing and editing of parameters 
including part details such as shapes, Reference Designators, 
attributes and design constraints. 

11 Design Toolbox Use to navigate through project files and show, hide or dim 
different elements of the design. 

12 3D Preview Displays a three-dimensional preview of the board. 

13 Birds Eye View Displays an “aerial view” of the design and lets you easily 
navigate around the workspace. 
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Tip For instructions on exporting a design from Multisim to Ultiboard, refer to the 
Multisim Help and the Ultiboard Help. 

3. Select design GS1. 

Tip To select a design from the project (for example, GS1), click on its tab, or click 
on its name in the Projects tab of the Design Toolbox. 

Creating a Board Outline  
There is already a board outline, however, you can create one that is a more suitable size for the 
parts in this design in one of the following ways: 

• Draw a board outline using the drawing tools. 

• Import a DXF file. 

• Use the Board Wizard. 

Complete the following steps to experiment with the Board Wizard: 

1. Double-click on Board Outline in the Layers tab to make it the active layer.

2. Click on the existing board outline in the GS1 design and press Delete on the keyboard. 
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3. Choose Tools»Board wizard. 
 

4. Select Change the layer technology to make the Technology options available. 

5. Choose Multi-layers constructed with double-sided boards and single layer stack-ups, 
and click Next. 

The next dialog box (Copper Layers) is where you define the Lamination settings for the 
board. (For this tutorial you will not change settings). 
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6. Click Next. 

In the Board Wizard - Shape of Board dialog box: 

a. Confirm that Units is set to mil. 

b. Confirm that the Reference point is set to Bottom-left for Alignment. 

c. Confirm that the Rectangular option is selected in Board shape and size. 

d. Set the Width to 3000 and the Height to 2000.

e. Set the Clearance to 5.00000. 

This is the distance from the edge of the board that is to be kept free of parts or any 
other elements. 

7. Click Finish. 

The board outline is placed on your design. 

Note For complete details on the Board Wizard, refer to the Ultiboard Help. 

Complete the following steps to move the board outline:

1. Double-click on Board Outline in the Layers tab.

2. Click anywhere on the board outline in the workspace and drag the board to a location just 
below the row of parts.

Complete the following steps to change the reference point:

1. Select Design»Set reference point. 

The reference point is attached to your cursor. 

2. Move the cursor the the lower-left corner of the board outline and click to place it. 
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Placing Parts  
You can place parts on your GS1 design in several different ways: 

• Select one or more parts from outside the board outline and drag them into place. 

• Use the Parts tab in the Spreadsheet View to locate parts and place them. 

• Select and place parts from the database. 

Tip Use the Place»Unplace parts command to remove all non-locked parts from 
the PCB and experiment with a different placement technique. 

Dragging Parts from Outside the Board Outline 
By default, parts are placed outside the board outline when you open a netlist from Multisim or 
another schematic capture program. 

Complete the following steps to drag U1 from outside the board outline: 

1. Double-click the Copper Top layer in the Design Toolbox to make it the active layer. 

2. Find U1 in the collection of parts outside the board outline. To make this easier, use the 
mouse wheel to zoom in until you can see U1. 

Tip You can also search for a part with the Edit»Find command. While this 
command works much like a Find function in other applications, it also allows you 
to search for a part by name, number, shape, value, or by all variables. Refer to the 
Ultiboard Help for details. 
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3. Click on U1 (the 7-segment display) and drag it to the location shown in the figure below. 
 

U1 remains selected. This is an important point for Ultiboard that holds throughout the 
application—you need to explicitly end any particular action. 

Click elsewhere on the workspace to de-select the part. Right-clicking also ends the current 
action. 

4. Go to the Parts tab in the Spreadsheet View and scroll to U1. 

Notice that the green light beside the part is slightly brighter—this indicates that the part 
has been placed. 

Dragging Parts from the Parts Tab 
Complete the following steps to drag parts from the Parts tab: 

1. In the Parts tab, scroll down to J3. 
 

1 Force Vector (orange line) 2 Ratsnest (yellow line)
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2. Click on J3 in the table and drag it from the Parts tab onto the workspace. 

J3 is attached to the mouse pointer. 

3. Drop J3 on the left edge of the board, approximately in the middle. 

In the Parts tab J3’s green light is slightly brighter, indicating that the part has been placed. 

Placing the Tutorial Parts
Using any method or combination of methods, lay out the design like the illustration below. 

Tip You can open the next design file in the project, GS2, which has already been 
set up this way. 

The design should look like this: 
 

Placing Parts from the Database 
In addition to placing parts imported as part of your design, you can place parts directly from the 
database. The following uses this method to place the mounting holes. 

Complete the following steps to place parts from the database: 

1. Choose Place»From database. 

The Get a Part From the Database dialog box opens.  

2. In the Database panel, expand the Ultiboard Master»Through Hole Technology Parts 
category and navigate to the Holes category. 
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The parts appear in the Available parts panel. 

3. In the Available parts panel, select the HOLE35 part. 

The part displays in the Preview panel. 
 

4. Click OK. 

The Get a Part From the Database dialog box disappears, and the Enter Reference 
Designation for Part dialog box displays. 

5. Enter the RefDes for shape HOLE35 (H1) and Value (HOLE) and click OK. 

6. Move the pointer over the board. 

The part is attached to the pointer. 

7. Move the hole to the top-left corner, and click to drop it on the board. 

The Enter Reference Designation for Part dialog box reappears, with the RefDes for 
shape HOLE35 automatically incremented to H2. 

8. Enter the value (HOLE) and click OK to place the next mounting hole in the top right 
corner. 

9. Repeat to place H3 in the bottom right corner, and H4 in the bottom left corner. 
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10. Click Cancel to stop, and click Cancel again. 

The Get a Part From the Database dialog box closes. 
 

Moving Parts
You can use the same methods for moving parts as you do for placing them. 

To select a part already on the board, click on it. 

To specify the X/Y coordinates to where the selected part is to move, press * on the numeric 
keypad. 

Or, select a placed part in the Parts tab (indicated by a bright green light beside it) and drag it to 
a new location. 

Tip A part’s label and pads are separate elements from its shape. When selecting a 
part on the board, be sure to select the whole part, not just the label or pads. Use the 
Selection Filters to assist with this. Refer to the Ultiboard Help for more 
information. 

Tip Once a part is selected, you can also move it around on the board by pressing 
the arrow keys on your keyboard. 

To select a group of parts and move them together, do one of the following: 

• Hold <Shift> and click on more than one part. 

• Drag a box around several parts. 

All the selected parts will move together when you drag the pointer. 
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Tip These are temporary groups—once you select another part, the group 
connection is lost. To make a group that remains until you remove it, you can use the 
Group Editor. Refer to the Ultiboard Help for details. 

You can use the Edit»Align commands to align the edges of selected parts or to space them 
relative to each other. 

Use the Edit»Align commands to align the mounting holes you just placed: 

1. Select H1 and hold <Shift> to select H2. 

2. Choose Edit»Align»Align top. 

If H2 was not originally placed exactly in line with H1, you will see it move. 

3. Click on an empty space on the board, then select H2 and H3. 

4. Choose Edit»Align»Align right. 

5. Continue in this manner to align the bottoms of H3 and H4, and the left sides of H1 and H4. 

Placing Traces 
You have the following options for placing traces: 

• Manual trace. 

• Follow-me trace. 

• Connection machine trace. 

A manual trace is placed exactly as you specify, even running through a component or trace if 
that is the path you set. 

A follow-me trace automatically draws a valid trace between the pins you select with your 
mouse movements—you can move from pin to pin, leaving a valid trace. 

A connection machine trace automatically joins two pins by the most efficient route, though you 
have the option of changing it. 

As you place a trace, and before you click to fix it in place, you can always remove a segment 
by backing up over it. 

Each time you click while placing a manual trace, or each time a follow-me trace or connection 
machine trace changes direction, a separate segment of that trace is created. 

Tip When performing operations on traces, be sure to select either the appropriate 
segment or the whole trace. 
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Placing a Manual Trace 
You can continue with the design you have been working on, or open GS3. 

Be sure you are on the Copper Top layer before beginning—Copper Top must be highlighted 
in red in the Layers tab of the Design Toolbox. 

Tip If necessary, press <F7> to show the whole design. 

Complete the following steps to place a trace manually: 

1. Choose Place»Line. 

Tip The Line command creates a line on any layer. The results differ depending on 
the layer selected. For example, if the selected layer is silkscreen, a line is created on 
the silkscreen layer of the PCB. If the selected layer is a copper layer, then the “line” 
is actually a trace. 

2. Locate J3, toward the left-hand part of the board and find the start pin shown below: 
 

Tip You can turn off or dim the Force Vectors to see the nets more clearly. Do this 
using the Force Vectors checkbox and color chooser in the Layers tab of the Design 
Toolbox. Refer to the Ultiboard Help for more information about Force Vectors. 

Tip If you have trouble locating the part, use the Find function of the Parts tab. 
Select the part in the Parts tab, then click the Find and select the part button. The 
part is shown in the workspace. If necessary, zoom in further using the mouse wheel. 

1 Part J3 2 Start Pin
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3. Click on the pin specified in the above step. 

Ultiboard highlights all the pins that are part of the same net as the pin you clicked on with 
an X. These indicate which pins to connect to match the connectivity from your schematic. 

 

4. Move the cursor in any direction. 

A green line (the trace) is attached to the selected pin. Each time you click, you anchor the 
trace segment, as shown in the figure below (2). 

5. Click to anchor the trace and on the destination pin as shown below. 
 

6. Right-click and choose Cancel to stop placing traces. 

7. Click the Select button on the Main toolbar to exit line-placing mode.  

1  Pins in the Same Net  

1 Trace 2 Click to anchor trace 3 Destination Pin



© National Instruments | 3-15

Getting Started with NI Circuit Design Suite

Placing a Follow-me Trace 
Complete the following steps to place a follow-me trace: 

1. Choose Place»Follow-me.  

2. Click on the top pin of J3. 

3. Click on the pin indicated by the “X” on U4. 

Ultiboard draws the trace for you. 

Placing a Connection Machine Trace 
Complete the following steps to place a Connection Machine trace: 

1. Choose Place»Connection Machine.  

2. Click on the segment of the ratsnest indicated below. 
 

3. Move your cursor. 

As the cursor moves, Ultiboard displays various trace placement options. 

1 Click Ratsnest  
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4. Click to fix the trace when you see the route you want. There is no need to click on the 
ratsnest or the destination pin. 

 

5. Right-click to end trace placement. 

Auto Part Placement 
As well as placing parts as described earlier in this chapter, you can use Ultiboard’s advanced 
automatic part placement functionality. 

Tip Before autoplacing parts, pre-place and lock any parts that you do not wish to 
be moved during the autoplacement process. (The mounting holes, and U1, J1, J2, J3, 
and LED 1 in GS5 have been pre-placed and locked). For details on locking parts, 
refer to the Ultiboard Help. 

Complete the following steps to autoplace the parts in Getting Started: 

1. Open the GS5 design in Ultiboard. 

2. Select Autoroute»Autoplace parts. 

The parts are placed on the circuit board. 

1 Trace Segments Appear Between Pins  
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Autorouting Traces 
You can place traces in Ultiboard using the methods described earlier in this chapter, or 
automatically route the traces as described below. 

Complete the following steps to autoroute the traces in Getting Started: 

1. Open the GS3 design in Ultiboard. 

2. Select Autoroute»Start/resume autorouter. 

The workspace switches to Autorouter Mode and trace autorouting begins. 

As autorouting proceeds, you will see traces being placed on the board. When autorouting 
is complete, Autorouter Mode closes and you are returned to the workspace. 

3. Select Autoroute»Optimize routing to optimize trace placement. 
 

The autorouter can be stopped at any time and you can make manual changes as desired. When 
you restart the autorouter, it will continue with the changes you made. Remember to lock any 
traces that you have placed manually and do not wish to be moved by the autorouter. 

Tip Use the Routing Options dialog box to modify autoplacement and autorouting 
options. Refer to the Ultiboard Help for details. 

Preparing for Manufacturing/Assembly 
Ultiboard can produce many different output formats to support your production and 
manufacturing needs. The following sections explain the functions performed to output your 
board for production and documentation purposes. 
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Cleaning up the Board 
Before sending the board for manufacturing, you should clean up any open trace ends (trace 
segments that do not have any terminating connections in the design) and unused vias. 

To delete any open trace ends, open the GS4 design and choose Edit»Copper delete»Open 
trace ends. 

To delete any unused vias, select Design»Remove unused vias. This deletes all vias that do not 
have any trace segments or copper areas connected to them. 

Adding Comments 
Comments can be used to show engineering change orders, to facilitate collaborative work 
among team members, or to allow background information to be attached to a design. 

You can pin a comment to the workspace, or directly to a part. When a part with an attached 
comment is moved, the comment also moves. 

Refer to the Ultiboard Help for details. 

Exporting a File 
You can export a number of file types, including Gerber. An exported file contains complete 
information describing how a finished board is to be manufactured. 

Refer to the Ultiboard Help for details.

Viewing Designs in 3D 
You can use the 3D View to see what the board looks like in three dimensions at any time during 
the design. 

Refer to the Ultiboard Help for details. 
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Technical Support and 
Professional Services

Log in to your National Instruments ni.com User Profile to get personalized access to your 
services. Visit the following sections of ni.com for technical support and professional services:

• Support—Technical support at ni.com/support includes the following resources:

– Self-Help Technical Resources—For answers and solutions, visit ni.com/
support for software drivers and updates, a searchable KnowledgeBase, product 
manuals, step-by-step troubleshooting wizards, thousands of example programs, 
tutorials, application notes, instrument drivers, and so on. Registered users also 
receive access to the NI Discussion Forums at ni.com/forums. NI Applications 
Engineers make sure every question submitted online receives an answer.

– Standard Service Program Membership—This program entitles members to direct 
access to NI Applications Engineers via phone and email for one-to-one technical 
support, as well as exclusive access to self-paced online training modules at ni.com/
self-paced-training. All customers automatically receive a one-year 
membership in the Standard Service Program (SSP) with the purchase of most 
software products and bundles including NI Developer Suite. NI also offers flexible 
extended contract options that guarantee your SSP benefits are available without 
interruption for as long as you need them. Visit ni.com/ssp for more information.

For information about other technical support options in your area, visit ni.com/
services, or contact your local office at ni.com/contact. 

• Training and Certification—Visit ni.com/training for training and certification 
program information. You can also register for instructor-led, hands-on courses at locations 
around the world.

• System Integration—If you have time constraints, limited in-house technical resources, or 
other project challenges, National Instruments Alliance Partner members can help. To learn 
more, call your local NI office or visit ni.com/alliance.

You also can visit the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support phone numbers, email 
addresses, and current events.
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